Menu Déroulant dont les Liens ne fonctionnent plus

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Menu Déroulant dont les Liens ne fonctionnent plus

Message par NonamCrevette le Dim 23 Fév 2014 - 20:41

Bonjour, Bonsoir,

Après avoir longuement cherché solution à mon problème et parcouru autant de sujets sur la question que je pouvais trouver, j'ai fini par me décider à créer mon propre sujet pour exposer mon problème.

Le fait est que, en septembre dernier quand j'ai créé le graphisme de mon forum, mon code de menu déroulant fait avec l'aide de ce sujet : Installation d'un menu déroulant, marchait parfaitement. Mais depuis peu, au moment où j'ai voulu modifier une partie de ma page d'accueil pour dire vrai, il ne marche plus. Le déroulement s'effectue parfaitement, mais les liens n'existent plus. Impossible de cliquer sur les mots comme "contexte" ou "règlement", et donc de rediriger vers ces messages du forum. Pourtant, je ne vois aucune erreur dans mon CSS ou mon HTML, le javascript étant conforme à celui du tutoriel de forumactif.

Le lien du forum est le suivant : Dark London. Le forum est en PHBB2 et j'ai accès au compte fondateur si besoin. Si j'ai principalement codé sur chrome, le problème est néanmoins le même sur mozilla, et présent sur les ordinateurs d'autres des membres du forum.

Voici mon code CSS :
Code:
/*liste des menus*/
#menu ul{
  padding: 0px;
  list-style-type: none;
  margin: 0px;}
 
/*positionnement des menus*/
#menu dl {
  float: left;
  width: 160px;}
 
/*menus*/
#menu dt {
  color: #0c0a0b;
  text-align: center;
  cursor: pointer;
  background: #766656;
  margin: 0px;
  font-size: 13px;}
 
/*menus au survol*/
#menu dt:hover{
  border-bottom: none!important;}
 
/*liste des sous-menus*/
#menu dd {
  display: none;
  border-top: none!important;
  background: #766656;
  margin: 0px;
  padding: 0px;
  list-style-type: none;}
 
#menu li {
  text-align: center;
  background: #766656;
  margin: 0px;
  padding: 0px;
  list-style-type: none;}
 
/* liens des sous-menus*/
#menu li a, #menu dt a {
  color: #0c0a0b;
  background: #766656;
  text-decoration: none;
  display: block;
  height: 100%;
  border: 0 none;
  margin: 0px;
  padding: 0px;
  list-style-type: none;}
 
/*liens des sous-menus au survol*/
#menu li a:hover, #menu li a:focus, #menu dt a:hover, #menu dt a:focus {
  color: #0c0a0b;
  text-align: center;
  width: 160px;
  cursor: pointer;
  font-weight: bold;
  background: #766656;
  margin: 0px;
  padding: 0px;
  list-style-type: none;}

Et mon code HTML :
Code:
<div id="menu" style="margin-right: -3px; margin-left: -3px; margin-top: -12px; background-color: #766656;"><dl>       
<dt>Administration</dt>
<dd>
<ul>
<li><a href="http://dark-london.forumactif.org/t2-le-reglement">Règlement</a></li>
<li><a href="http://dark-london.forumactif.org/t80-credits">Crédits</a></li>
</ul>
</dd>
</dl>
<dl>       
<dt>Contexte</dt>
<dd>
<ul>
<li><a href="http://dark-london.forumactif.org/t3-le-contexte">Contexte</a></li>
<li><a href="http://dark-london.forumactif.org/t78-premiere-intrigue">Intrigue</a></li>
<li><a href="http://dark-london.forumactif.org/t1-pactes-liens">Pactes & Liens</a></li>
<li><a href="http://dark-london.forumactif.org/t4-les-groupes">Groupes</a></li>
</ul>
</dd>
</dl>
<dl>       
<dt>Partenariat</dt>
<dd>
<ul>
<li><a href="http://dark-london.forumactif.org/t20-demande-de-partenariat">Devenir Partenaire ?</a></li>
<li><a href="http://dark-london.forumactif.org/t79-nos-boutons-fiches">Nos Fiches & Boutons</a></li>
<li><a href="http://dark-london.forumactif.org/f51-nos-amis">Nos Amis</a></li>
</ul>
</dd>
</dl>
<dl>       
<dt>Recensements</dt>
<dd>
<ul>
<li><a href="http://dark-london.forumactif.org/t5-les-avatars-pris">Avatars Pris</a></li>
<li><a href="http://dark-london.forumactif.org/f7-les-predefinis">Prédéfinis</a></li>
</ul>
</dd>
</dl>
<dl>       
<dt>Questions</dt>
<dd>
<ul>
<li><a href="http://dark-london.forumactif.org/t8-questions-reponses">FAQ</a></li>
<li><a href="http://dark-london.forumactif.org/t23-demandes-de-logement">Demandes de Lieux</a></li>
<li><a href="http://dark-london.forumactif.org/f63-coin-invite">Coin Invité</a></li>
</ul>
</dd>
</dl></div>

Et s'il manque une information pour résoudre le problème, n'hésitez pas à me le signaler. Je tâcherai d'y remédier au plus vite ^^

Merci d'avance à celui ou celle qui pourra m'aider à enfin régler ce problème ><


Dernière édition par NonamCrevette le Dim 2 Mar 2014 - 19:39, édité 1 fois

NonamCrevette
Nouveau membre

Féminin
Messages : 2
Inscrit(e) le : 28/06/2013

http://dark-london.forumactif.org/
NonamCrevette a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Menu Déroulant dont les Liens ne fonctionnent plus

Message par Neptunia le Dim 23 Fév 2014 - 21:53

Bonjour, et bienvenue sur le Forum des Forums ForumActif

Je vais commencer par une excellente nouvelle.

Il n'y a aucun souci ni dans le javascript, ni dans le HTML, ni dans le CSS.
Je viens d'installer ces éléments sur un forum vierge et ça fonctionne impec.

Il va donc falloir chercher le souci ailleurs.
En commençant par forcer les templates par défaut. Ca va exclure d'un coup d'un seul une mise en cause des overall_header, overall_footer_begin, overall_footer_end, index_body et index_box.

Et ensuite il faudra désactiver un par un tout .js actif sur l'accueil.




Edité à 21h55

Suis allé un peu vite, en fait nous faudrait l'intégralité du message d'accueil, pas uniquement la portion Menu déroulant.

Neptunia
+ Hyperactif +

Féminin
Messages : 10395
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Menu Déroulant dont les Liens ne fonctionnent plus

Message par MasDan le Mar 25 Fév 2014 - 5:21

Bonjour,


Ce sont les attributs  HREF des balises A qui cause problème.  Le code ne correspond plus au code que vous nous avez fourni.

MasDan
*****

Masculin
Messages : 797
Inscrit(e) le : 24/05/2011

http://projetaum2.forumactif.com/
MasDan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Menu Déroulant dont les Liens ne fonctionnent plus

Message par Milouze14 le Mar 25 Fév 2014 - 8:50

Salut à toutes et à tous,

j'apporte aussi ma petite participation ,

comme le souligne MasDan le code HTML est erroné et ensuite il doit y avoir un conflit avec un javascript car le lien
change comme le montre la capture de MasDan



et le code que tu nous donnes :
Code:
<li><a href="http://dark-london.forumactif.org/t2-le-reglement">Règlement</a></li>

devient dark-butler


a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4565
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Menu Déroulant dont les Liens ne fonctionnent plus

Message par Scoubifitz le Mar 25 Fév 2014 - 17:43

bonjour,

même souci qu'ici :

http://forum.forumactif.com/t364567-message-sur-la-page-d-accueil#3091454

il y a modification du code html à l'édition .

il devient urgent de voir avec un devactif ...

édit : 26.02.2014 à 07:31:02

il suffit de copier/coller le code original de l'astuce dans la page d'accueil :

Code:
       <div id="menu">
        <dl>
        <dt>Replier</dt>
        </dl>
        
       <dl>
        <dt>Menu 1</dt>
        <dd  style="display:none;">
        <ul>
        <li><a href="url-de-renvoi">Sous-Menu 1.1</a></li>
        <li><a href="url-de-renvoi">Sous-Menu 1.2</a></li>
        <li><a href="url-de-renvoi">Sous-Menu 1.3</a></li>
        </ul>
        </dd>  
       </dl>
        
       <dl>
        <dt>Menu 2</dt>
        <dd  style="display:none;">
        <ul>
        <li><a href="url-de-renvoi">Sous-Menu 2.1</a></li>
        <li><a href="url-de-renvoi">Sous-Menu 2.2</a></li>
        <li><a href="url-de-renvoi">Sous-Menu 2.3</a></li>
        <li><a href="url-de-renvoi">Sous-Menu 2.4</a></li>
        <li><a href="url-de-renvoi">Sous-Menu 2.5</a></li>
        <li><a href="url-de-renvoi">Sous-Menu 2.6</a></li>
        </ul>
        </dd>
        </dl>
        
       <dl>
        <dt>Menu 3</dt>
        <dd  style="display:none;">
        <ul>
        <li><a href="url-de-renvoi">Sous-Menu 3.1</a></li>
        <li><a href="url-de-renvoi">Sous-Menu 3.2</a></li>
        </ul>
        </dd>  
       </dl>
        </div>

... et de l'éditer (ou de basculer de mode d'édition) pour voir que des balises supplémentaires se sont rajoutées , et que le display:none n'est plus pris en compte parce que la balise "dd" a été refermée juste après l'ouverture .
______________________________________________________

Pour votre bug , il provient d'une balise <a> non fermée dans les top sites .

<a href="http://en.root-top.com/toplist/horsevalleys/in.php?ID=1793"><img src="http://img15.hostingpics.net/pics/328958top3.png" border="0" width="50" height="50" alt="" /><a>

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Menu Déroulant dont les Liens ne fonctionnent plus

Message par NonamCrevette le Dim 2 Mar 2014 - 17:13

Merci pour toutes vos réponses ! Smile

Pour les liens, c'est un simple oubli de ma part. Il se trouve que le forum a changé de nom très récemment, passant de dark-butler à dark-london. J'ai juste oublié de changer cela dans la page d'accueil. En revanche, le problème était déjà présent avant le changement de lien.

Je vais donc de ce pas regarder de plus près toutes vos solutions et je vous tiens au courant \o

EDIT [02/03/2014 à 19:35]
Merci beaucoup, Scoubifitz. Avec l'aide de ton lien, j'ai réussi à résoudre le problème. Du coup, l'édition ne dérange plus sur la PA. Tout fonctionne parfaitement !

Encore merci à vous tous pour l'aide apportée ! Je mets le sujet en résolu.

NonamCrevette
Nouveau membre

Féminin
Messages : 2
Inscrit(e) le : 28/06/2013

http://dark-london.forumactif.org/
NonamCrevette a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum