Problèmes chargement du forum

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problèmes chargement du forum

Message par Citura le Sam 8 Mar 2014 - 20:15

Bonjour,

Je l'ai déjà signalé plusieurs fois, et je le signale encore ...Depuis quelques mois déjà, très régulièrement, je ne peux plus accéder à mon forum, ni à l'espace d'administration. Le temps de chargement est très long ( Je précise que mes pages internet s'ouvrent rapidement avec le haut débit ).
Lorsque que le chargement du forum est passé, cela m'affiche une page blanche sans inscriptions ( s'écoule parfois 2 minutes ! ) Ou lorsque le forum est affiché correctement, c'est pour naviguer dans chaque rubrique qui est problématique...Absence de smileys dans les réponses, chargement des liens longs. L'accès à la messagerie privée est laborieux ! Dés que le clique sur un message, le chargement est tellement long, qu'une page blanche apparait. Ou lorsque ce que je veux formuler une réponse, impossible de l'envoyer, car temps de chargement long, et au final, page blanche ...Et message non envoyé même après des centaines de Ctrl-F5 ..

Cela ce produit par intermittence, le forum à ce bug assez régulièrement quand même  ( Parfois tous fonctionne très très bien )

Voici les deux screens montrant deux problèmes différent ( parmi tant d'autre )





Lien du forum : http://www.aufildeslignes.net/
Version du forum : Invision
Fondateur : Oui
Templates modifiées : Non
Autres : Deux modifications Javascript
Internet : Haut débit SFR
Moteur de recherche : Mozilla Firefox dernière version.

Merci à vous pour votre réponse Wink


Dernière édition par Citura le Sam 15 Mar 2014 - 11:33, édité 1 fois

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par FANCH 56 le Sam 8 Mar 2014 - 20:30

Bonsoir

Le sujet après RVipr 118 s'ouvre instantanément................. et le chargement est complet en 2.44 secondes.

FANCH 56
+ Hyperactif +

Masculin
Messages : 13260
Inscrit(e) le : 25/07/2005

http://www.anciens-cols-bleus.net/
FANCH 56 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Sam 8 Mar 2014 - 20:45

Bonsoir ^^

Moi non plus je n'ai constaté aucun ralentissement sur ce beau forum que j'avais connu en phpBB3.

- Ce ralentissement touche t'il également la clientèle de ton réseau ?
- Y a t'il des créneaux horaires où ça bouchonne plus (genre 17-22h) ?
- En cas de difficulté à tenir l'horaire as tu déjà tenté le haut le pied avec un autre navigateur ?

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Citura le Sam 8 Mar 2014 - 21:15

@FANCH 56 a écrit:Bonsoir

Le sujet après RVipr 118 s'ouvre instantanément................. et le chargement est complet en 2.44 secondes.

Il y à pas que se sujet là ...

AoF-Neptune a écrit:Bonsoir ^^

Moi non plus je n'ai constaté aucun ralentissement sur ce beau forum que j'avais connu en phpBB3.

- Ce ralentissement touche t'il également la clientèle de ton réseau ?
- Y a t'il des créneaux horaires où ça bouchonne plus (genre 17-22h) ?
- En cas de difficulté à tenir l'horaire as tu déjà tenté le haut le pied avec un autre navigateur ?

Pour te répondre malgré tout : Non à la première question, non à la seconde et pour la dernière : que sa soit Opéra, Google, ou Mozilla c'est le même bug. J'ai testé également sous plusieurs fournisseurs internet : Bouygues, Sfr et Numéricable ( Auquel j'étais auparavant )

Je re-précise que ce ralentissement n'intervient pas en continue, mais par intermittence.

Bien cordialement.


PS : Questionnement limite moqueur, j'apprécie ...On va dire moyennement.

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Sam 8 Mar 2014 - 21:40

@Citura a écrit:PS : Questionnement limite moqueur, j'apprécie ...On va dire moyennement.

C'était pas moqueur mais de multiples clins d’œil à une passion commune, je suis aussi dans le métier Wink
Désolé si ça a été mal perçu

Donc en résumé souci indépendant du navigateur, du FAI et des créneaux horaires où certains hébergeurs sont à la limite de la surcharge et ne touche que toi. Et souci intermittent.

- As tu un autre administrateur sur ton forum ?
- As tu essayé de te connecter avec un autre ordinateur quand le souci se produit ?

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problèmes chargement du forum

Message par Citura le Sam 8 Mar 2014 - 21:46

AoF-Neptune a écrit:

C'était pas moqueur mais de multiples clins d’œil à une passion commune, je suis aussi dans le métier Wink
Désolé si ça a été mal perçu

Autant pour moi alors  Embarassed 

AoF-Neptune a écrit:Donc en résumé souci indépendant du navigateur, du FAI et des créneaux horaires où certains hébergeurs sont à la limite de la surcharge et ne touche que toi. Et souci intermittent.

- As tu un autre administrateur sur ton forum ?
- As tu essayé de te connecter avec un autre ordinateur quand le souci se produit ?

Pas d'autres administrateurs, et oui déjà essayer sur d'autre ordinateurs  Wink  Personnellement, je me demande si le passage du PhpBB3 au Invision aurait une incidence ?

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Sam 8 Mar 2014 - 22:09

Donc on a exclu un problème provoqué par une configuration particulière de l'ordinateur.

Right Il faudrait voir quand ça se reproduira si tu as le même souci avec un compte membre "standard" quitte à en créer un pour l'occasion. En cas de reproduction du souci sur un compte "normal" ça exclurait également un problème lié à ton statut sur ton forum.

Niveau javascript j'ai détecté :
- Un script qui rajoute un copyright dans le footer
- Un script qui est sensé modifier la présentation des annonces et Note (j'ai l'impression que ce script ne sert plus actuellement)

Right Y a t'il d'autres javascripts, et dans l'affirmative y en a t'il un ou plusieurs qui réagissent uniquement si le connecté est administrateur ?

@Citura a écrit:Personnellement,  je me demande si le passage du PhpBB3 au Invision aurait une incidence ?
Oui ! Vu que le problème semble assez ancien, je comptais te demander s'il existait déjà en phpBB3.
Toutefois je vois ni pourquoi Invision serait un souci, ni pourquoi il ne toucherait que toi.

Dernière question qui risque de sembler bête, as tu demandé à tes membres s'il leur arrivait de rencontrer le souci ? Parfois les membres sont trop timides pour faire remonter d'eux même un souci qu'ils pensent dû à leur matériel/connexion ou comme c'est aléatoire le jugent non significatif.

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Citura le Sam 8 Mar 2014 - 22:21

Effectivement, compte standard, cela le fait également et d'autres membres sont impacté par ce bug. Tu m'as énoncé le code Javascript pour les annonces et Note qui ne sert à rien ...Je pense donc que tu as surement trouver l'origine du problème ! Un codage qui ne sert à rien plombe le fonctionnement d'un forum ! Et j'ai ce codage depuis PhpBB3 cela pourrait donc expliquer ceci  Laughing 


Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Sam 8 Mar 2014 - 22:32

Le javascript en question ne devrait pas poser souci, son code est correct mais il semble se référer à des images qui ne sont plus utilisées, donc n'ajoutera plus les class correspondantes. Par ailleurs il me semble aussi que tu as viré le css correspondant.

Je pense qu'il faut chercher ailleurs, si c'était ce javascript, le souci devrait être permanent. Mais piste tout de même à garder sous la main. A ta place j'attendrais que le problème se reproduise avant de désactiver ou supprimer ce javascript.

@Citura a écrit:Effectivement, compte standard, cela le fait également et d'autres membres sont impacté par ce bug.

Ah bah j'avais compris le contraire  lol!  ça m'apprendra à faire des jeux de mots membres/clientèle.

Ya aussi un autre truc qui me chiffonne. C'est que ça touche même ta navigation sur le panneau admin.

Là je suis à court d'idées, j'espère que d'autres aideurs auront d'autres pistes à explorer.




Edité à 22h40

Je viens de regarder de plus près le javascript en question
Right Coloriser les cases des Note et des annonces
Le script que tu avais mis est spécifique à phpBB3, donc oui, il n'est pas correct vu qu'il se base sur des identifiants inexistants sous Invision. Autre anomalie sans conséquence, celui ci est placé sur toutes les pages alors qu'il devrait être placé sur les sous-forums.

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Citura le Sam 8 Mar 2014 - 23:03

Oui effectivement ce code ne s'activait que sous PhpBB3. Je crois que tu as trouver le problème. Very Happy 

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Sam 8 Mar 2014 - 23:15

Je n'en suis pas certain parce que si on part de l'idée qu'un appel a des class inexistantes posent souci, il en serait de même de l'autre javascript qui inclut
("#page-footer,#gfooter,#pun-foot")

Le vert est un identifiant spécifique PunBB (étant sous cette version, j'avais trouvé curieux la présence d'un tel code sur ton forum)
Le rouge, l'identifiant Invision, et le dernier en bleu doit concerner phpBB2 et 3.

Et le tuto est fait comme cela et posté ici même. Donc il ne devrait pas poser souci.

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problèmes chargement du forum

Message par Citura le Sam 8 Mar 2014 - 23:47

AoF-Neptune a écrit:Je n'en suis pas certain parce que si on part de l'idée qu'un appel a des class inexistantes posent souci, il en serait de même de l'autre javascript qui inclut
("#page-footer,#gfooter,#pun-foot")

Le vert est un identifiant spécifique PunBB (étant sous cette version, j'avais trouvé curieux la présence d'un tel code sur ton forum)
Le rouge, l'identifiant Invision, et le dernier en bleu doit concerner phpBB2 et 3.

Et le tuto est fait comme cela et posté ici même. Donc il ne devrait pas poser souci.

Je viens de modifier cela à l'instant ( Mais comment fait tu pour voir  Mr. Green ), je vais bien voir, mais cela semble avoir une coïncidence ...J'ai mis ces codes en place l'été dernier, et ces bugs étaient existant ensuite. Très sporadiquement sous phpBB3 puis régulier voir journalier sous Invision, depuis Décembre. Mais effectivement je n'ai jamais pensé au codage javascript .. Non ! 

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Dim 9 Mar 2014 - 0:32

@Citura a écrit:Je viens de modifier cela à l'instant ( Mais comment fait tu pour voir  Mr. Green )

Ah bah ya des choses qu'il vaut mieux ne pas dire tout haut, du coup je t'ai envoyé un MP.

J'avais également appelé du renfort qui aurait pu avoir d'autres pistes de recherche et comme je ne sais pas s'il s'exprimera sur ce sujet, j'ai profité du MP pour te communiquer sa réponse.

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problèmes chargement du forum

Message par Citura le Dim 9 Mar 2014 - 9:39

Merci pour ton MP fort utile  Very Happy Je vais m'attacher à corriger le problème dés cette après-midi  Very Happy 

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Citura le Lun 10 Mar 2014 - 18:50

Bonsoir à tous,

Finalement, même avec les arrangements fait, le ralentissement est toujours de mise ..

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Lun 10 Mar 2014 - 19:05

C'est effectivement ce que je craignais.

Que tes codes Javascript pointent sur des class inexistantes sous Invision, passe.
Que tes pages HTML comportent quelques erreurs, passe encore.

Mais que le problème soit intermittent était à mes yeux incompatible avec un souci de codage.

Pour ma part j'ai fait le tour des idées auxquelles je pensais.

Dernier point à vérifier.
Right Au moment ou cela se produit, y a t'il des choses qui sont fort gourmandes en bande passante genre téléchargement, la TV sur ADSL, le fiston qui joue en ligne à OMSI (enfin nan, ça c'est pas un jeu pour les gosses mais pour nous  lol!  )
Je suis certain à 99% de ta réponse, mais autant ne pas exclure cette hypothèse.

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Citura le Lun 10 Mar 2014 - 19:26

Oui la télé est souvent allumé pendant que je suis sur ordinateur, mais cela peut aussi ce passer hors télé allumé. Quand au fiston ... d'abord, faut avoir la fille et après j'aurai le fiston  lol! 

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Citura le Lun 10 Mar 2014 - 21:10

De nouveau, impossible de pouvoir se rendre sur le forum ...Et ni sur mon panneau d'administration ! Je pense de plus en plus alors à mon internet !

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Lun 10 Mar 2014 - 21:22

Quand ça se produit as tu un message en bas à gauche du genre :
En attente de site.com ?

Pour ma part j'ai vidé mon cache avant de repasser sur ta page d'accueil ainsi que celle du parc au complet sans le moindre ralentissement Sad

@Citura a écrit:Je pense de plus en plus alors à mon internet !
Tu nous a dit plus haut que tu n'étais pas le seul impacté, donc je doute que le souci vienne de chez toi.

J'ai aussi songé à des extensions de ton navigateur, mais dans ce cas, le souci serait permanent.

Deux conseils :
- Noter dans un coin l'heure où ça se produit pour chaque ralentissement constaté.
- Faire des ups réguliers de ce sujet sans toutefois avoir moins de 24h entre deux de tes messages consécutifs.

Je pense avoir fait un tour assez complet des possibilités et du coup la seule solution que je propose, c'est de ne pas lâcher l'affaire en faisant des ups réguliers jusqu'à ce qu'on trouve enfin l'origine du souci.

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Citura le Lun 10 Mar 2014 - 21:32

AoF-Neptune a écrit:Quand ça se produit as tu un message en bas à gauche du genre :
En attente de site.com ?

Pour ma part j'ai vidé mon cache avant de repasser sur ta page d'accueil ainsi que celle du parc au complet sans le moindre ralentissement Sad

@Citura a écrit:Je pense de plus en plus alors à mon internet !
Tu nous a dit plus haut que tu n'étais pas le seul impacté, donc je doute que le souci vienne de chez toi.

J'ai aussi songé à des extensions de ton navigateur, mais dans ce cas, le souci serait permanent.

Deux conseils :
- Noter dans un coin l'heure où ça se produit pour chaque ralentissement constaté.
- Faire des ups réguliers de ce sujet sans toutefois avoir moins de 24h entre deux de tes messages consécutifs.

Je pense avoir fait un tour assez complet des possibilités et du coup la seule solution que je propose, c'est de ne pas lâcher l'affaire en faisant des ups réguliers jusqu'à ce qu'on trouve enfin l'origine du souci.

Ca me marque juste " en attente de Au Fil Des Lignes ...." Et même en vidant le cache, rien à faire !
En fait, la dernière fois qu'ils été impacté, c'était lors d'un bug général...Au final personne n'est impacté par ce bug, sauf moi apparemment !
Le chargement du forum est toujours mauvais à 21h28 ( Oui ca concerne pas que la rubrique, mais TOUT le forum ainsi que le panel admin Laughing )

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Lun 10 Mar 2014 - 21:57

En résumé

- Le problème est récurrent depuis plusieurs mois tout en restant intermittent.
- Lien possible mais non démontré avec le changement de moteur phpBB3 > Invision
- Pas de créneau horaire où le souci est plus fréquent.
- N'impacte que l'administrateur du forum aussi bien avec le compte fondateur qu'avec un compte "membre"
- Souci présent sur Google Chrome, Mozilla Firefox et Opera
- Souci présent avec d'autres ordinateurs
- Souci présent chez plusieurs FAI (Bouygues, Numericable, SFR)
- Pas de message en attente d'un hébergeur type servimg où d'un site externe comme Google Analytics ( juste en attente de nomdedomaineperso.net )
- Le problème se produit sur toutes les pages (index, sous-forums, sujets)
- Le problème impacte également le panneau admin
- Le souci est indépendant de l'utilisation de la bande passante de la connexion.




La configuration du forum

- Version Invision
- Pas de templates modifiés (Invision)
- Un seul javascript injectant une mention supplémentaire dans le footer
- Nom de domaine personnalisé acquis chez ForumActif
- Redirection auto de l'url de base vers le domaine
Feuille de style CSS:
       a.forumlink span, a.forumtitle span { display: none; }
       a.forumlink img, a.forumtitle img { display: inline!important; }




Je pense avoir fait le tour
Ton javascript restant contient ("#gfooter,"), à ma connaissance cete virgule est superflue. -> Corrigé

Pourrais tu nous fournir le contenu de ta feuille CSS afin d'avoir un bilan exhaustif ?
Ainsi que rappeler les éléments qui m'auraient échappé dans mon récapitulatif ?


Dernière édition par AoF-Neptune le Lun 10 Mar 2014 - 23:39, édité 1 fois (Raison : Ajout de la feuille CSS au récapitulatif)

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Citura le Lun 10 Mar 2014 - 22:15

Tu as résumé fortement bien !
Rien ne t'as échappé effectivement mais je pense Laughing 

J'ai enlevé la virgule superflue, mais je doute qu'elle ait eu un grand impact sur le forum. Quand à la feuille CSS je ne sais pas comment pouvoir te la fournir !

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Neptunia le Lun 10 Mar 2014 - 22:33

Pour le CSS

PA / Affichage / Couleurs / Onglet Feuille CSS

Et tu nous copie son contenu entre balises code ou spoiler.

Neptunia
+ Hyperactif +

Féminin
Messages : 10969
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problèmes chargement du forum

Message par Citura le Lun 10 Mar 2014 - 23:24

AoF-Neptune a écrit:Pour le CSS

PA / Affichage / Couleurs / Onglet Feuille CSS

Et tu nous copie son contenu entre balises code ou spoiler.

Ah bah oui quel c** je fais  Razz 

Et voici :
CSS:
a.forumlink span, a.forumtitle span { display: none; }
a.forumlink img, a.forumtitle img { display: inline!important; }

Citura
**

Masculin
Messages : 65
Inscrit(e) le : 25/07/2010

http://aufildeslignes.forumactif.org
Citura a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum