Problème avec les sous forums

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec les sous forums

Message par Wenn le Jeu 10 Avr 2014 - 5:19

Bonsoir bonsoir !
Alors voilà je me présente avec un problème qui doit sans doute paraitre un peu bête, mais a chaque sous forum que j'ajoute se met automatiquement un retour à la ligne que je ne m'explique pas, au lieu de les mettre simplement à la suite. De même, j'ai visiblement un sérieux problème avec le placement de mes sous forums...
Voyez vous même ;

http://image.noelshack.com/fichiers/2014/15/1397099762-screen.png

Je suppose que vous aurez besoin du template ainsi que du CSS pour pourvoir m'aider alors je vous les mets également :

Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
 <tr>
 <td valign="bottom">
 <!-- BEGIN switch_user_logged_in -->
 <span class="gensmall">{LAST_VISIT_DATE}<br />
 {CURRENT_TIME}<br />
 </span>
 <!-- END switch_user_logged_in -->
 <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
 </td>
 <td class="gensmall" align="right" valign="bottom">
 <!-- BEGIN switch_user_logged_in -->
 <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
 <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
 <!-- END switch_user_logged_in -->
 <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
 </td>
 </tr>
</table>
        <!-- BEGIN catrow --><!-- BEGIN tablehead -->
<div class="TitreCategorie">{catrow.tablehead.L_FORUM}</div>
<div class="categorie">
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
 <!-- END tablehead -->
 <!-- BEGIN cathead -->
 <tr>
 <!-- BEGIN inc -->
 <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
 <!-- END inc -->
 
<td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right"> </td>
 </tr>
 <!-- END cathead -->
 
<!-- BEGIN forumrow -->
 <tr>
          
         <!-- BEGIN inc -->
 <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
 <!-- END inc -->

        
          <td colspan="{catrow.tablehead.INC_SPAN}" width="100%" >
        
           <div class="ensemble">
 <h{catrow.forumrow.LEVEL} class="hierarchy">
 <span class="forumlink">
 <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br /><div class="spaceTitreForum"></div>
 </span>
 </h{catrow.forumrow.LEVEL}>
 <div class="forumCentrer">
   <div id="Description">
   <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
   </div>
 <div class="ImageMessage">
           <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" ></img>
   </div><br>
          
          
       
  <div class="LastMess">
 <span class="gensmall"><table width="100%" height="100%" border="0" ><tr><td align="center" valign="middle">
                      <div class="SujetMessage">
             {catrow.forumrow.TOPICS} Partie(s) • {catrow.forumrow.POSTS} Joueur(s)
 </div>
 {catrow.forumrow.LAST_POST}
                                  </td></tr></table></span>
                
         <div id="Categorie">
 <span class="gensmall">
 <!-- BEGIN switch_moderators_links -->
 {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
 <!-- END switch_moderators_links -->
                  <div class="forum-sousforum">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</div>
 </span>
 </div>
</div>
          <div class="spaceForumTitre"></div></td>
          
 <!-- END forumrow -->
 <!-- BEGIN catfoot -->
 <tr>
 <!-- BEGIN inc -->
 <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
 <!-- END inc -->
          <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
        </tr>
 <!-- END catfoot -->
 <!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --></div><!-- END catrow -->

Code:
.ensemble {
  height: 100px;
  width: 750px;
  position: relative;
  top: 0px;
  bottom: -40px;}

.hierarchy{
  height: 15px;
  display:block !important;}

.forumCentrer{
  position:relative;}

.forumlink{
  font-family: Time New Roman;
        letter-spacing: -1px;
        font-size: 25px;
        position:relative;
        margin-left: 10px;
        margin-top: -25px;
z-index:999;}

.forum-description{
        font-size: 14px;
        letter-spacing: -1px;
        height : 100px;
        width: 750px;
        padding: 2px;
        Position:relative;
        left:10px;
        top: 10px;
        background-color: #a7c9d4}

.forum-image{
  border: 4px double #B5A27D;
        border-radius: 15px;
        height: 86px;
        width: 90px;
        opacity: 0.7;
}

.forum-sousforum{
  position:relative;
  font-size: 25px;
  text-transform : uppercase;
  letter-spacing:0.8px;
  left: -600px;
  top:-70px;}

.LastMess {
        height: 86px;
        width: 140px;
        border: 4px double #B5A27D;
        background-color: #E6E2D8;
        border-radius: 20px;
        text-align: center;
        position: relative;
        left: 602px;
        top: -125px;}

.SujetMessage {
       font-size: 13px;
  font-weight: bold;  
  top:-15px;
  left: 15px;
  letter-spacing: -1px;
  color: #b5a27d;
  text-shadow: 0px 0px 3px white;}

.ImageMessage {
        position: relative;
        position: absolute;
        top:-1px;
        left:-10px;
border-radius: 0px 0px 20px 20px;}

Je débute pour ce qui est de coder les templates, alors ça doit être très brouillon ^^"
Merci d'avance à celui ou celle qui saura m'aider ! ♥


Dernière édition par Wenn le Dim 13 Avr 2014 - 11:47, édité 1 fois

Wenn
Nouveau membre

Messages : 7
Inscrit(e) le : 10/04/2014

http://omnos-pathos.azureforum.com/
Wenn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Wenn le Ven 11 Avr 2014 - 10:44

Petit up

Wenn
Nouveau membre

Messages : 7
Inscrit(e) le : 10/04/2014

http://omnos-pathos.azureforum.com/
Wenn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Kinotto le Ven 11 Avr 2014 - 17:53

Bonjour,

Remplacez
Code:
<div class="forum-sousforum">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</div>
par
Code:
<span class="forum-sousforum">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span>

Cordialement.

Kinotto
+ Hyperactif +

Masculin
Messages : 2177
Inscrit(e) le : 12/09/2012

http://test-nightmare.superforum.fr/
Kinotto a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Wenn le Sam 12 Avr 2014 - 12:06

Grand merci pour votre réponse !
Hélas, le problème persiste..

Wenn
Nouveau membre

Messages : 7
Inscrit(e) le : 10/04/2014

http://omnos-pathos.azureforum.com/
Wenn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Kinotto le Sam 12 Avr 2014 - 12:18

Bonjour,

Et en modifiant la classe .forum-sousforum par :
Code:
.forum-sousforum{
  z-index:99;
  position:relative;
  font-size: 25px;
  text-transform : uppercase;
  letter-spacing:0.8px;
  top:60px;
  left:20px;
}
?

Avec une reproduction j'obtiens :



Cordialement.

Kinotto
+ Hyperactif +

Masculin
Messages : 2177
Inscrit(e) le : 12/09/2012

http://test-nightmare.superforum.fr/
Kinotto a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Wenn le Sam 12 Avr 2014 - 13:21

Étrange, car chez moi le problème persiste..
Voyez vous même ;
http://omnos-pathos.azureforum.com/

Wenn
Nouveau membre

Messages : 7
Inscrit(e) le : 10/04/2014

http://omnos-pathos.azureforum.com/
Wenn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Kinotto le Sam 12 Avr 2014 - 13:29

Re,

Et en élargissant avec :
Code:
width:Xpx !important;
?

NB : pensez à remettre la balise div pour .forum-sousforum dans ce cas.

Cordialement.

Kinotto
+ Hyperactif +

Masculin
Messages : 2177
Inscrit(e) le : 12/09/2012

http://test-nightmare.superforum.fr/
Kinotto a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Wenn le Sam 12 Avr 2014 - 14:59

Cela a réglé le problème en effet !
En revanche à présent, lorsque j'ajoute des sous forums la ligne s'affiche de plus en plus bas..

Wenn
Nouveau membre

Messages : 7
Inscrit(e) le : 10/04/2014

http://omnos-pathos.azureforum.com/
Wenn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Kinotto le Sam 12 Avr 2014 - 16:09

Il ne faut pas mettre une taille trop grande !

Kinotto
+ Hyperactif +

Masculin
Messages : 2177
Inscrit(e) le : 12/09/2012

http://test-nightmare.superforum.fr/
Kinotto a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Wenn le Dim 13 Avr 2014 - 10:24

Au niveau de la largeur ?
Même en modifiant cela ne change rien :/

Wenn
Nouveau membre

Messages : 7
Inscrit(e) le : 10/04/2014

http://omnos-pathos.azureforum.com/
Wenn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Kinotto le Dim 13 Avr 2014 - 10:34

Bonjour,

Voici ce que je vois personnellement :


Le problème du retour à la ligne étant réglé, il ne vous resterait plus qu'à régler le positionnement, je me trompe ? J'entends par là modifier :
Code:
[...]
  top:60px;
  left:20px;
[...]

Cordialement.

Kinotto
+ Hyperactif +

Masculin
Messages : 2177
Inscrit(e) le : 12/09/2012

http://test-nightmare.superforum.fr/
Kinotto a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Wenn le Dim 13 Avr 2014 - 11:47

Ah en effet !
Merci beaucoup, le problème est résolu !

Wenn
Nouveau membre

Messages : 7
Inscrit(e) le : 10/04/2014

http://omnos-pathos.azureforum.com/
Wenn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec les sous forums

Message par Kinotto le Dim 13 Avr 2014 - 11:53

Je vous en prie, bonne journée Smile

Kinotto
+ Hyperactif +

Masculin
Messages : 2177
Inscrit(e) le : 12/09/2012

http://test-nightmare.superforum.fr/
Kinotto a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum