Le CSS ne marche pas sur Chrome

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Le CSS ne marche pas sur Chrome

Message par Aliichaa le Jeu 19 Juin 2014 - 11:44

Bonjours,
hier j'avais un soucis de .div, aujourd'hui c'est de CSS...



Comme le montre le Screen, le "border-radius" ne s'applique pas correctement, le "width" et le " padding" ne fonctionne pas non plus ...

Mon CSS:
Code:


.categorie  { background-color : #c1c1c1 ;
border-radius:10px ;
}

.description  { background-color : #fff ; width:560px ;
padding: 8px; overflow:hidden ;
  -moz-border-radius: 10px;
    -webkit-border-radius: 10px;
    border-radius: 10px;
}

 .forum { background-color : #ffffff0;
width:100%; }



.sousforum { background-color : #000 ;
 position:relative; }

.stats {background-color : #fff ;
 position:relative; 
  padding: 20px;
border-radius : 30px}


.bouton { background-color : #ffffff0 ;
 position:relative; }
 

.messagesujet {font-size: 7px;}


a.forumlink{ background-color : #fff ;
  padding: 15px;
  display: block;
  text-align: center;
  border-bottom: 0px solid #000;
  margin: 5px;
  border-radius : 20px ;
 
}

Quelque chose ne vas pas dans mon CSS?
D'habitude, ces codes s'applique très bien sur Chrome... Merci et bonne journée ><


Dernière édition par Aliichaa le Jeu 19 Juin 2014 - 17:38, édité 1 fois

Aliichaa
****

Féminin
Messages : 329
Inscrit(e) le : 13/12/2010

http://touhoudessin.forumactif.com/
Aliichaa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Le CSS ne marche pas sur Chrome

Message par demeter1 le Jeu 19 Juin 2014 - 13:33

Pour les bords arrondis, ce css est correct

Code:
.description  { background-color : #fff ; width:560px ;
padding: 8px; overflow:hidden ;
  -moz-border-radius: 10px;
    -webkit-border-radius: 10px;
    border-radius: 10px;
}

Pour le reste, vous ne mettez que border-radius

Pour le padding, il me semble qu'il faut rajouter -webkit-padding pour que cela marche sur chrome.
La syntaxe en fonctions de l'attribution de l'arrondi
(haut) -webkit-padding-before

(doite) -webkit-padding-end

(bas) -webkit-padding-after

(gauche) -webkit-padding-start



demeter1
+ Hyperactif +

Masculin
Messages : 8221
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Le CSS ne marche pas sur Chrome

Message par Aliichaa le Jeu 19 Juin 2014 - 16:23

Re-bonjours

Ca ne marche toujours pas ...

Aliichaa
****

Féminin
Messages : 329
Inscrit(e) le : 13/12/2010

http://touhoudessin.forumactif.com/
Aliichaa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Le CSS ne marche pas sur Chrome

Message par demeter1 le Jeu 19 Juin 2014 - 16:25

1 on pourrait avoir le nouveau css
2 vous avez pensé à vider les caches de votre navigateur ??

demeter1
+ Hyperactif +

Masculin
Messages : 8221
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Le CSS ne marche pas sur Chrome

Message par Aliichaa le Jeu 19 Juin 2014 - 16:53

CSS:
Code:
.categorie  { background-color : #c1c1c1 ;
border-radius:10px ;
}

.description  { background-color : #fff ; width:560px ;
-webkit-padding: 8px; overflow:hidden ;
  -moz-border-radius: 10px;
    -webkit-border-radius: 10px;
    border-radius: 10px;
}

 .forum { background-color : #ffffff0;
width:100%; }



.sousforum { background-color : #000 ;
 position:relative; }

.stats {background-color : #fff ;
 position:relative; 
  -webkit-padding: 20px;
  -moz-border-radius: 30px;
    -webkit-border-radius: 30px;
    border-radius: 30px;}

.bouton { background-color : #ffffff0 ;
 position:relative; }
 

.messagesujet {font-size: 7px;}


a.forumlink{ background-color : #fff ;
  -webkit-padding: 15px;
  display: block;
  text-align: center;
  border-bottom: 0px solid #000;
  margin: 5px;
  border-radius : 20px ;
 
}



Et je n'ai pas vider le cache vu que j'ai tester sur 2 ordinateurs différents et c'st le même soucis : les codes ne s'appliquent pas sur Chrome

Aliichaa
****

Féminin
Messages : 329
Inscrit(e) le : 13/12/2010

http://touhoudessin.forumactif.com/
Aliichaa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Le CSS ne marche pas sur Chrome

Message par Scoubifitz le Jeu 19 Juin 2014 - 17:19

bonjour,

on reprend depuis le début ?

vous avez mis la class "description" à une balise "span" , qui n'accepte le width et le padding que si on définit la balise comme un block :

.description {
display:block;
background-color : #fff ;
width:560px ;
padding: 8px;
overflow:hidden ;
-moz-border-radius: 10px;
-webkit-border-radius: 10px;
border-radius: 10px;
}

passons à la class "stats" qui est intégrée à une cellule (td) ...
cette cellule a son propre padding , il faut donc forcer le padding de cette class par un !important :


.stats {background-color : #fff ;
position:relative;
padding: 20px!important;
border-radius : 30px}

en rajoutant ces 2 attributs à votre CSS de départ , vous résoudrez votre souci .

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Le CSS ne marche pas sur Chrome

Message par Aliichaa le Jeu 19 Juin 2014 - 17:36

Effectivement, ça marche nettement mieux comme ça ... Merci de votre aide. ^^

Et désolé du dérangement, problème résolu ^^ .

Aliichaa
****

Féminin
Messages : 329
Inscrit(e) le : 13/12/2010

http://touhoudessin.forumactif.com/
Aliichaa a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum