repeat-y ne fonctionne pas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu repeat-y ne fonctionne pas

Message par Takoda le Dim 12 Oct 2014 - 14:24

Détails techniques


Version du forum : phpBB3
Poste occupé : Administrateur
Navigateur(s) concerné(s) : Google Chrome
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : 12/10/14
Lien du forum : http://archeagerp.forumgratuit.org/

Description du problème

Bonjour,
actuellement, je tente de faire un fond de page qui a une forme particulière.
Il se compose d'une tête, d'un corps et d'un pied.

Je n'ai pas de soucis avec la tête et le pied, mais le corps refuse de se répéter en verticalement, fonction de la taille des page.

Voici le code css utilisé :

Code:
#page-header{
background-color: transparent;
background-image: url('http://i39.servimg.com/u/f39/11/54/97/73/header11.jpg');
background-repeat: no-repeat;
height: 952px;
width: 1328px;
margin: 0px;
padding: 0px;
}

.search-box { display: none; }
#search-box { display: none; }

#page-header .navbar{
background-color: transparent !important;
margin-top: 0px;
}
.navbar{
background-color: transparent !important;
}
ul.navlinks{
border: none;
}
#fa_ticker_block{
background-color: transparent !important;
border: none;
padding: 0px 263px 0px 263px;
margin-bottom: 30px !important;
margin-top : 30px !important;
}
#fa_ticker_block .module{
background-color: transparent !important;
border: none;
padding: 0px;
}

#fa_ticker{
background-image: none !important;
}
#page-body{
background-color: transparent !important;
background-image: url('http://i39.servimg.com/u/f39/11/54/97/73/body11.jpg');
background-repeat: repeat-y !important;
margin: 0px;
padding: 100px;
}

#main-content{
background-color: transparent !important;
margin: 0px 3px;
padding-top: 3px;
padding-bottom: 3px;
}


#tabs{
margin-top: 0px !important;
}
#page-footer{
background-color: transparent !important;
font-size : 1.0em !important;
color: #000 !important;
background-image: url('http://i39.servimg.com/u/f39/11/54/97/73/footer10.jpg');
background-repeat: no-repeat;
width:1328px;
height:838px;
padding: 0px;
margin: 0px;
}

#page-footer ul.linklist{
display: block !important;
margin: -20px 284px 0px 284px;
}


.panel{
background-color: transparent !important;
margin-bottom: 0px;
}
h1.page-title{
margin-top: 0px !important;
padding-top: 0px;
}

.row{
background-image: url('http://i39.servimg.com/u/f39/11/54/97/73/row12.jpg');
background-repeat: repeat;
}

a.button1, input.button1, a.button2, input.button2, button.button2 {
background-image: url("http://i80.servimg.com/u/f80/13/60/55/30/oo10.jpg");
background-repeat: repeat;
background-position: top left;
border: 3px double #000;
}


a.button1:hover, input.button1:hover, a.button2:hover, input.button2:hover, button.button2:hover {
background-image: url("http://i80.servimg.com/u/f80/13/60/55/30/tex110.jpg");
background-repeat: repeat;
background-position: top left;
border: 3px double #000;
}
#page-footer span.corners-top { background-image: none; }

#page-footer span.corners-top span { background-image: none; }

#page-footer span.corners-bottom { background-image: none; }

#page-footer span.corners-bottom span { background-image: none; }

#headerbar span.corners-top { background-image: none; }

#headerbar span.corners-top span { background-image: none; }

#headerbar span.corners-bottom { background-image: none; }

#headerbar span.corners-bottom span { background-image: none; }



#page-header span.corners-top { background-image: none; }

#page-header span.corners-top span { background-image: none; }

#page-header span.corners-bottom { background-image: none; }

#page-header span.corners-bottom span { background-image: none; }

Voici le lien du forum :
Vox Populi
pour palier à cela, j'ai pour l'heure mis en body de 1500px de haut. Mais dans "Membres" par exemple, ou une page relativement haute, on voit bien que le body ne se répète pas.

Merci par avance pour votre aide.


Dernière édition par Takoda le Lun 13 Oct 2014 - 11:41, édité 1 fois

Takoda
Nouveau membre

Messages : 10
Inscrit(e) le : 12/10/2014

http://archeagerp.forumgratuit.org/
Takoda a été remercié(e) par l'auteur de ce sujet.

Résolu Re: repeat-y ne fonctionne pas

Message par Self le Dim 12 Oct 2014 - 20:04

..
Bonjour et Bienvenue
sur le Forum des Forums ForumActif
Vu que vous êtes nouveau, voici quelques sujets importants :
Sécurité : mail de fondation - Ce qu'il ne faut pas faire
N'hésitez pas à ouvrir un nouveau sujet si vous ne trouvez pas votre réponse Wink

Localisez dans votre CSS le passage :
Code:
#content-container div#container {
   margin-right: -403px;
   width: 100%;
   float: left;
}

Et remplacez le par :
Code:
#content-container div#container {
   margin-right: -403px;
   width: 100%;
   display: inline-block;
}

Self
+ Hyperactif +

Masculin
Messages : 3710
Inscrit(e) le : 13/06/2013

Self a été remercié(e) par l'auteur de ce sujet.

Résolu Re: repeat-y ne fonctionne pas

Message par Takoda le Lun 13 Oct 2014 - 11:12

Bonjour, et merci pour votre réponse.
J'ai pu localiser dans le CSS de base ce passage. Mais malheureusement je ne sais pas comment l'éditer.

J'ai essayé de désactiver le CSS de base, en le recopiant dans ma page CSS, mais apparemment, cela ne marche pas.

Pourriez vous m'éclairer sur la marche à suivre ?

Merci par avance.

Takoda
Nouveau membre

Messages : 10
Inscrit(e) le : 12/10/2014

http://archeagerp.forumgratuit.org/
Takoda a été remercié(e) par l'auteur de ce sujet.

Résolu Re: repeat-y ne fonctionne pas

Message par Self le Lun 13 Oct 2014 - 11:22

Si ce passage se trouve dans le CSS de base, collez plutôt dans votre feuille de style CSS :
Code:
#content-container div#container {
   float: none;
   display: inline-block;
}

Self
+ Hyperactif +

Masculin
Messages : 3710
Inscrit(e) le : 13/06/2013

Self a été remercié(e) par l'auteur de ce sujet.

Résolu Re: repeat-y ne fonctionne pas

Message par Takoda le Lun 13 Oct 2014 - 11:26

Cela fonctionne !
Merci beaucoup pour votre aide. Smile

Takoda
Nouveau membre

Messages : 10
Inscrit(e) le : 12/10/2014

http://archeagerp.forumgratuit.org/
Takoda a été remercié(e) par l'auteur de ce sujet.

Résolu Re: repeat-y ne fonctionne pas

Message par Self le Lun 13 Oct 2014 - 11:28

..Bonjour,

Afin de faciliter la gestion des problèmes, si votre problème est résolu, pensez à :
  • éditer votre premier message,
  • cocher l'icône résolu
  • Et enregistrer en cliquant sur


Vous pouvez également remercier les personnes qui vous ont aidé, en cliquant sur le bouton

A bientôt sur ForumActif Smile

Self
+ Hyperactif +

Masculin
Messages : 3710
Inscrit(e) le : 13/06/2013

Self a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum