Problème d'écriture personnalisée

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème d'écriture personnalisée

Message par LilianaGCF le Dim 26 Oct 2014 - 10:29

Bonjour,

J'ai installé un sélecteur de thème sur mon forum et tout fonctionne, sauf l'écriture personnalisée sur les profils, qui marchait très bien avant. Le souci est que quand on arrive sur le forum, on ne voit pas l'écriture personnalisée mais celle par défaut : georgia (exemple ici). Il faut aller choisir un autre thème avec le sélecteur pour voir l'écriture apparaître (exemple ici). L'écriture personnalisée (IndieStar) fonctionne sur les trois thèmes de couleurs, mais pas quand on arrive sur le forum. Pourtant, le CSS de base est le même que le CSS de la couleur "rouge" (ça n'est pas très clair mais il faut voir sur le forum xD)

Le forum concerné : http://www.become-an-idol.com/
Un lien vers le souci : n'importe quel message du forum

A savoir que l'écriture personnalisée n'est pas une écriture Google Font, qu'elle est appelée via un script qui fonctionnait très bien jusqu'à maintenant.



Dernière édition par LilianaGCF le Mer 19 Nov 2014 - 16:08, édité 1 fois

LilianaGCF
*****

Féminin
Messages : 992
Inscrit(e) le : 11/05/2007

http://sos-rpg.com
LilianaGCF a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par LilianaGCF le Lun 27 Oct 2014 - 18:46

Je me permets un petit "up". Le problème persiste toujours Wink

LilianaGCF
*****

Féminin
Messages : 992
Inscrit(e) le : 11/05/2007

http://sos-rpg.com
LilianaGCF a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par LilianaGCF le Mer 29 Oct 2014 - 15:47

Je fais remonter ^^
Le souci est toujours là

LilianaGCF
*****

Féminin
Messages : 992
Inscrit(e) le : 11/05/2007

http://sos-rpg.com
LilianaGCF a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par LilianaGCF le Dim 2 Nov 2014 - 17:10

Coucou !

Le problème est toujours là. Quelqu'un a t-il une solution ?

LilianaGCF
*****

Féminin
Messages : 992
Inscrit(e) le : 11/05/2007

http://sos-rpg.com
LilianaGCF a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par LilianaGCF le Jeu 6 Nov 2014 - 17:57

@LilianaGCF a écrit:Coucou !

Le problème est toujours là. Quelqu'un a t-il une solution ?

LilianaGCF
*****

Féminin
Messages : 992
Inscrit(e) le : 11/05/2007

http://sos-rpg.com
LilianaGCF a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par LilianaGCF le Jeu 13 Nov 2014 - 22:11

"Up" à nouveau, c'est toujours d'actualité =)
Merci ^^

LilianaGCF
*****

Féminin
Messages : 992
Inscrit(e) le : 11/05/2007

http://sos-rpg.com
LilianaGCF a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par LilianaGCF le Mar 18 Nov 2014 - 16:27

@LilianaGCF a écrit:"Up" à nouveau, c'est toujours d'actualité =)
Merci ^^

LilianaGCF
*****

Féminin
Messages : 992
Inscrit(e) le : 11/05/2007

http://sos-rpg.com
LilianaGCF a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par Ea le Mer 19 Nov 2014 - 9:37

Bonjour,


Difficile à dire, il faudrait voir Cufon en détail j'imagine.

La seule différence entre avoir sélectionné un thème ou pas, c'est que si on en a pas sélectionné, une balise <link> qui ne sert à rien est présente :

Code:
// ajoute une balise <link> "vide"
$("head").append('<link rel="stylesheet" type="text/css" id="tstyle" />');

if (my_getcookie("sstyle")) {
    // on est ici seulement si on a sélectionné un thème, donc le sélecteur de style affiche juste la feuille CSS de base si on a pas sélectionné de style, ou le CSS de base + la feuille de CSS personnalisée si style sélectionné
    $("#tstyle").attr("href", my_getcookie('sstyle'))
}

peut-être que Cufon scanne juste la dernière balise <link> et vu que quand on a pas sélectionné de thème cette balise est factice il n'agit pas.

Enfin il faudrait le comprendre mieux que je le fais pour le savoir vraiment, vous pourriez déjà essayer de mettre la feuille CSS que vous souhaitez par défaut en remplaçant :

Code:
if (my_getcookie("sstyle")) {
    $("#tstyle").attr("href", my_getcookie('sstyle'))
}

par :

Code:
$("#tstyle").attr("href", my_getcookie('sstyle')||"http://sd-2.archive-host.com/membres/up/190331098933529247/BAI/CSS_Rouge.css");

à ce moment là il y aura toujours un thème sélectionné donc il n'y aurait pas de raison que le comportement diffère.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par LilianaGCF le Mer 19 Nov 2014 - 15:52

Bonjour,

Merci pour ta réponse ^^
Alors, au niveau des codes, j'ai un javascript qui appelle les trois feuilles CSS déjà : rouge, bleu et vert :



Dernière édition par LilianaGCF le Mer 19 Nov 2014 - 16:08, édité 1 fois

LilianaGCF
*****

Féminin
Messages : 992
Inscrit(e) le : 11/05/2007

http://sos-rpg.com
LilianaGCF a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par Ea le Mer 19 Nov 2014 - 16:02

Oui c'est ce que j'avais compris.

Et la raison qui entraîne le problème, comme je l'ai indiqué c'est ( à mon avis ) que le script de police Cufon à un problème avec une balise <link> sans attribut href.

Donc il faudrait remplacer :

Code:
if(my_getcookie("sstyle")) { $("#tstyle").attr("href", my_getcookie('sstyle')); }

par :

Code:
$("#tstyle").attr("href", my_getcookie('sstyle')||"http://sd-2.archive-host.com/membres/up/190331098933529247/BAI/CSS_Rouge.css");

de manière à avoir le thème rouge sélectionné par défaut ( et avoir toujours un attribut href à la balise <link /> ) et voir ce que ça donne.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23417
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par LilianaGCF le Mer 19 Nov 2014 - 16:08

Apparemment, ça semble fonctionner \o/
Je te remercie, je pense que je n'aurais jamais trouvé toute seule Laughing

LilianaGCF
*****

Féminin
Messages : 992
Inscrit(e) le : 11/05/2007

http://sos-rpg.com
LilianaGCF a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème d'écriture personnalisée

Message par Chacha le Mer 19 Nov 2014 - 20:13

..Bonjour,

Afin de faciliter la gestion des problèmes, si votre problème est résolu, pensez à :
  • éditer votre premier message,
  • cocher l'icône résolu
  • Et enregistrer en cliquant sur


Vous pouvez également remercier les personnes qui vous ont aidé, en cliquant sur le bouton

A bientôt sur ForumActif Smile


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Chacha
Modéractif
Modéractif

Masculin
Messages : 49718
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum