Tableau décalé sans raison dans les posts

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Tableau décalé sans raison dans les posts

Message par Romann le Jeu 1 Jan 2015 - 19:34

Détails techniques


Version du forum : PunBB
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Moi uniquement
Lien du forum : (lien masqué, vous devez poster pour le voir)

Description du problème

Bonsoir,

Voila, mon problème est assez simple, je voulais faire un tableau html tout ce qu'il y a de plus banal dans un post ordinaire, mais voila il s'affiche avec une énorme marge au dessus ! D:

Je ne comprend pas pourquoi car tous mes autres posts sont nickels (ils sont quant à eux sous forme de "<div>" et non en "<table>"), je n'ai pas très envie de faire mon tableau sous forme de <div> ... Si quelqu'un pouvait m'éclairer sur le problème...

Voila le codage que j'ai utilisé :

Code:
<table style="width:500px;border:1px solid #68609a;background-color:#ebe8ff;">
   <tr>
       <td colspan="5">img</td>
   </tr>
   <tr>
       <td rowspan="4">contexte</td>
       <td>reglement</td>
       <td>staff</td>
       <td colspan="2">une question ?</td>
   </tr>
   <tr>
       <td>contexte</td>
       <td>nos groupes</td>
       <td colspan="2">nos amis</td>
   </tr>
   <tr>
       <td colspan="4">fonda</td>
   </tr>
   <tr>
       <td>admin 1</td>
       <td>admin 2</td>
       <td>admin 3</td>
       <td>admin 4</td>
   </tr>
</table>

Je précise bien que le soucis ne vient sans doute pas du css ou du template puisque mes autres posts sont normaux.

Merci à vous !


Dernière édition par Romann le Jeu 1 Jan 2015 - 22:53, édité 1 fois

Romann
Nouveau membre

Messages : 29
Inscrit(e) le : 19/12/2014

http://alpha-centauri.forumactif.fr/
Romann a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Tableau décalé sans raison dans les posts

Message par Scoubifitz le Jeu 1 Jan 2015 - 22:09

bonjour,

ce n'est pas un problème , mais le comportement normal et attendu de l'éditeur de texte ...

quand vous mettez un retour à la ligne au code , l'éditeur place aussi un retour à la ligne ...

deux solutions :
mettre tout le code sur une seule ligne :

Code:
<table style="width:500px;border:1px solid #68609a;background-color:#ebe8ff;"> <tr> <td colspan="5">img</td> </tr> <tr> <td rowspan="4">contexte</td> <td>reglement</td> <td>staff</td> <td colspan="2">une question ?</td> </tr> <tr> <td>contexte</td> <td>nos groupes</td> <td colspan="2">nos amis</td> </tr> <tr> <td colspan="4">fonda</td> </tr> <tr> <td>admin 1</td> <td>admin 2</td> <td>admin 3</td> <td>admin 4</td> </tr> </table>

ou mettre le code en BBcode :

Code:
[table style="width:500px;border:1px solid #68609a;background-color:#ebe8ff;"][tr]
[td colspan="5"]img[/td]
[/tr][tr]
[td rowspan="4"]contexte[/td]
[td]reglement[/td]
[td]staff[/td]
[td colspan="2"]une question ?[/td]
[/tr][tr]
[td]contexte[/td]
[td]nos groupes[/td]
[td colspan="2"]nos amis[/td]
[/tr][tr]
[td colspan="4"]fonda[/td]
[/tr][tr]
[td]admin 1[/td]
[td]admin 2[/td]
[td]admin 3[/td]
[td]admin 4[/td]
[/tr]
[/table]
img
contextereglementstaffune question ?
contextenos groupesnos amis
fonda
admin 1admin 2admin 3admin 4

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Tableau décalé sans raison dans les posts

Message par Romann le Jeu 1 Jan 2015 - 22:51

oki je teste et j'éditerai pour vous tenir au courant Very Happy merci ^^

EDIT : Merci beaucoup ! ça marche nickel ! je garde l'astuce, je ne savais pas ^^ encore merci !! Very Happy

Romann
Nouveau membre

Messages : 29
Inscrit(e) le : 19/12/2014

http://alpha-centauri.forumactif.fr/
Romann a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum