Bouton survol BUG

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Bouton survol BUG

Message par Gregoryen le Lun 19 Jan 2015 - 1:01

Détails techniques


Version du forum : Invision
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome, Safari, Autre
Personnes concernées par le problème : Moi uniquement
Lien du forum : http://www.gtaforum.fr

Description du problème

Bonsoir tout le monde !

J'ai recherché la solution à mon problème mais rien ne marche et la ça me prend la tête j'ai besoin d'une aide personnalisé.

Voilà, dans ma barre de menu, j'ai créer un bouton " Forum " et un bouton " Accueil ", pour que le bouton accueil tombe sur le portail, et le forum sur le forum, car de base c'est mal redirigé et on ne peux pas modifier.

Donc j'ai créé ces deux menu supplémentaires dans l'entête de navigation puis barre de navigation.

J'ai crée des icônes pour ma barre de menu. De base ils sont grisés, puis quand on survole ils se mettent en couleur.

J'ai regardé plusieurs forum, j'y suis arrivé à la moitié mais j'ai du loupé un truc.

Dans " entête et navigation ", dans mon menu " forum ", dans URL j'ai mis :

Code:
http://illiweb.com/fa/empty.gif" id="forum

On ma dit de mettre une image transparente ( cette image GIF ) le guillemet, espace, id=" Le nom de mon ID

Dans le css j'ai mis :

Code:
#forum {
background-image: url('http://image.noelshack.com/fichiers/2015/03/1421616075-2nbforum.png');
width: 150px;
height: 96px;
}
#forum:hover{
background-image: url('http://image.noelshack.com/fichiers/2015/03/1421616066-2couleurforum.png');
width: 150px;
height: 96px;
}

Mon image fait 150*96 donc j'ai mis la bonne taille, l'image noir et blanc en premier lien, celle qui n'est pas survollé, et la deuxième est en couleur quand on survole.

Quand je vais sur mon forum, apparemment l'id à bien marché. Sauf que je n'ai aucune image, celle en noir et blanc quand on ne survole pas. Par contre si je passe la souris, l'image couleur marche.

Qu'est ce que j'ai loupé ? J'ai lu qu'il fallait mettre " class=Nom de l'id" mais cela ne marche pas.

Que faire ? Ou suis-je ? Quel est le sens de la vie ?

Je suis perdu je craque ça fait plusieurs jours que je cherche mais je ne trouve pas.

Help me :'(

Merci pour ceux qui prennent le temps de lire et de répondre, et bonne journée et encore bonne année car on est encore en janvier ^^


Dernière édition par Gregoryen le Lun 19 Jan 2015 - 18:51, édité 1 fois

Gregoryen
Nouveau membre

Messages : 4
Inscrit(e) le : 19/01/2015

http://www.gtaforum.fr
Gregoryen a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bouton survol BUG

Message par Milouze14 le Lun 19 Jan 2015 - 4:12

Salut Gregoryen ,

tu as être dirigé vers le portail ici:
Affichage/Page d'acceuil/
Généralités
/Général

L'adresse de votre forum dirige vers :
Cocher ==> L'index du forum

Pour le reste, non l'image n'a rien a voir, il faut un lien avec un ID,
on voit tout çà dès mon retour ou si une âme charitable passe avant Very Happy .

a++


Milouze14
+ Hyperactif +

Masculin
Messages : 4563
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bouton survol BUG

Message par Gregoryen le Lun 19 Jan 2015 - 9:09

Bonjour, merci de tes conseils.

En effet j'avais déjà activé le bouton pour rediriger vers le portail, j'ai même réussi à modifier le fait que quand on clique sur le logo, ça redirige vers le portail.

En fait j'ai refait les bouton menu, car ceux de base ne peuvent pas se modifier. Et pour le forum, quand on survolais il y avait marqué accueil, et on ne peux pas l'enlever dans la config.

Encore ça, j'ai trouvé la solution j'ai crée mes boutons donc ça va, c'est surtout les images et le css.

Mais j'avais réussis avec un bouton auparavant mais j'avais fait un copié collé en remplaçant les images d'un ancien bouton. Je vais essayer de le refaire et je vous tiens au courant :-)

Gregoryen
Nouveau membre

Messages : 4
Inscrit(e) le : 19/01/2015

http://www.gtaforum.fr
Gregoryen a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bouton survol BUG

Message par Gregoryen le Lun 19 Jan 2015 - 12:43

Bon j'ai récupéré le code du bouton que j'avais réussis maintenant tout marche !

Ceci est un bouton que j'ai personnalisé voici le code pour ceux qui tomberont sur ce topic et qui sont dans la même situation.

Code:
 #forum { width: 150px; height: 96px; background: url(http://image.noelshack.com/fichiers/2015/04/1421667552-2nbforum.png) no-repeat 0 0; } #forum:hover { background: url(http://image.noelshack.com/fichiers/2015/04/1421667543-2couleurforum.png ) no-repeat 0 0px; }

Merci encore de ta réponse Milouze14.

J'ai une dernière question :

Savez vous, quel site ou quel logiciel sur mac/pc, ou je peux faire des GIF avec des images PNG, sans perdre de qualité ? Car tout les logiciel que je dispose, me mettent des pixel dégeu sur mes images et je perd la qualité.

J'ai un gif avec 200 images PNG, et je ne sait pas comment faire.

Cordialement Smile

Gregoryen
Nouveau membre

Messages : 4
Inscrit(e) le : 19/01/2015

http://www.gtaforum.fr
Gregoryen a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bouton survol BUG

Message par Milouze14 le Lun 19 Jan 2015 - 18:07

Re,
désolé mais le graphisme et moi cela fait deux,
tu peux toujours aller voir ce forum:
http://forum.forumactif.com/f53-service-de-creation-graphique

a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4563
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Bouton survol BUG

Message par Gregoryen le Lun 19 Jan 2015 - 18:50

Merci beaucoup ^^
Bonne journée ! sunny

Gregoryen
Nouveau membre

Messages : 4
Inscrit(e) le : 19/01/2015

http://www.gtaforum.fr
Gregoryen a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum