Problème avec bannière défilante...

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec bannière défilante...

Message par badibou le Mer 28 Jan 2015 - 8:12

Détails techniques


Version du forum : phpBB3
Poste occupé : Administrateur
Navigateur(s) concerné(s) : Google Chrome
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : 5 jours
Lien du forum : http://www.forumdessports.com

Description du problème

Bonjour, depuis environs 5 jours les bannière défilante de mon forum ont le ''Parkinson'' au-lieu de défiler elle ''shake''.. sur Google Chrome(mais c'est normal sur Firefox) dur à expliquer comme ça.. le mieux si bien sur vous voulez m'aider... serait d'aller voir sur mon site...

Merci d'avance !!

Cdt, Badi


Dernière édition par badibou le Jeu 29 Jan 2015 - 20:14, édité 1 fois

badibou
*****

Masculin
Messages : 544
Inscrit(e) le : 14/02/2013

http://www.forumdessports.com
badibou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par Shadow le Mer 28 Jan 2015 - 9:57

Bonjour badibou,

Des sujets similaires ont été ouverts sur notre support ces derniers jours et ce problème d'affichage est lié à l'utilisation de la balise <marquee>.

Je vous invite à consulter celui-ci par exemple, où une explication et une solution y est proposé. Wink

Problème d'affichage sous Chrome.

Cordialement,
Vivi.


Règles Générales du Forum - Le Staff de ForumActif
Questions & Réponses Fréquentes - Trucs & Astuces
Outils Fondateurs - Perte de Mot de Passe

Shadow
Adminactive
Adminactive

Féminin
Messages : 23787
Inscrit(e) le : 30/03/2007

http://forum.forumactif.com
Shadow a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par badibou le Mer 28 Jan 2015 - 18:43

Bonjour Vivi et merci pour ta réponse !! ::pourtoi::

Malheureusement le code ne semble pas avoir d'effet sur mon problème...

J'ai fais un changement dans la balise ''marque'' en enlevant: BEHAVIOR=alternate dans le titre de mon index cela à enlever le tremblement de la bannière mais maintenant ma bannière de l'index se répète sur un seul sous-forum(tous les autres sont OK) !!

Si toi ou quelqu'un d'autre a une idée elle est la bienvenue !! Yes

Merci encore !

Cdt, Badi !

badibou
*****

Masculin
Messages : 544
Inscrit(e) le : 14/02/2013

http://www.forumdessports.com
badibou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par Milouze14 le Mer 28 Jan 2015 - 19:41

Salut badibou,

Ta balise <marquee> a telle un style ?

Si oui il faut supprimer ce dernier , c'est à dire:

Comme la souligné EA dans son astuce ,
il faut que cette balise n'est pas de style dans le cas contraire il faut attribuer la class.


Code:

<marquee style="LE STYLE APPLIQUE"behavior="scroll" direction="left" scrollamount="3" scrolldelay="60" onmouseover="this.stop()" onmouseout="this.start()">

deviendra
Code:
<marquee behavior="scroll" direction="right" scrollamount="2" scrolldelay="30" onmouseover="this.stop()" onmouseout="this.start()">

Si cela est trop compliqué pour toi , donne le code html ici Wink .

a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4565
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par badibou le Mer 28 Jan 2015 - 21:52

Bonjour Milouze et merci de vouloir m'aider(encore une fois lol) mon code ne contient pas de style mais il fonctionne avec un JS puisque j'ai mis des bannières différentes sur d'autres pages...

Code:
<A href=http://www.forumdessports.com><marquee align=center height=100 scrolldelay=1 scrollamount=2><p><img border=10 src=http://i39.servimg.com/u/f39/18/10/14/65/bannie11.jpg alt=hspace=0 id=banniere_defilante></p></marquee></A


Et voici le SUJET avec les codes que j'ai pris pour le faire.. ce sera surement plus clair comme ça pour toi !


Cdt, Badi

EDIT: J'ai enlevé ''ALTERNATE'' du code ça règle le problème de tremblement mais l'image ''scroll'' vers la gauche ce qui n'est pas vraiment beau.. mais c'est temporaire !



badibou
*****

Masculin
Messages : 544
Inscrit(e) le : 14/02/2013

http://www.forumdessports.com
badibou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par Milouze14 le Jeu 29 Jan 2015 - 4:08

Salut badibou,

je n'ai pas de soucis avec chrome avec ce code html,

mais tu peux mettre ce dernier avec la class
Code:
    <A href=http://www.forumdessports.com><marquee class=autowidv align=center height=100 scrolldelay=1 scrollamount=2><p><img border=10 src=http://i39.servimg.com/u/f39/18/10/14/65/bannie11.jpg alt=hspace=0 id=banniere_defilante></p></marquee></A>

et
le script donné par EA:
http://forum.forumactif.com/t375571-regler-le-probleme-des-pages-elargies-a-cause-d-un-defilement-sous-google-chrome#3169782


a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4565
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par badibou le Jeu 29 Jan 2015 - 17:40

Bonjour MIlouze !!

J'ai mis ce code:

Code:
<A href=http://www.forumdessports.com><marquee class=autowidv BEHAVIOR=alternate align=center height=100 scrolldelay=1 scrollamount=2><p><img border="10" src="http://i58.servimg.com/u/f58/18/12/26/07/bannie13.jpg" alt="hspace=0" id="banniere_defilante"></p></marquee></A>


Sauf que là c'est tout le forum qui alterne de gauche à droite lol

Merci encore !!

Cdt, Badi

badibou
*****

Masculin
Messages : 544
Inscrit(e) le : 14/02/2013

http://www.forumdessports.com
badibou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par Milouze14 le Jeu 29 Jan 2015 - 17:47

Re,
ben tu as déposé le code html dans quelle partie stp ?

a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4565
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par badibou le Jeu 29 Jan 2015 - 18:02

Bonjour Milouze !

Ce code va dans ''description du site''..

Cdt, Badi

badibou
*****

Masculin
Messages : 544
Inscrit(e) le : 14/02/2013

http://www.forumdessports.com
badibou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par Milouze14 le Jeu 29 Jan 2015 - 18:08

Re,
supprimes le et dépose le dans la page d’accueil Wink .

a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4565
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par badibou le Jeu 29 Jan 2015 - 18:13

Re, si je fais ceci la bannière apparait pas au bon endroit...

@+

badibou
*****

Masculin
Messages : 544
Inscrit(e) le : 14/02/2013

http://www.forumdessports.com
badibou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par Milouze14 le Jeu 29 Jan 2015 - 18:16

Re,

elle doit être positionnée à quel endroit , sois explicite stp Wink .

a++

Milouze14
+ Hyperactif +

Masculin
Messages : 4565
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par badibou le Jeu 29 Jan 2015 - 18:23

Re, elle est dans le haut du forum là ou va le logo.. si tu regarde mon site c'est ou il y a la bande bleu en haut...

Merci encore !!


badibou
*****

Masculin
Messages : 544
Inscrit(e) le : 14/02/2013

http://www.forumdessports.com
badibou a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par Milouze14 le Jeu 29 Jan 2015 - 18:35

Re,
on va passer par le template :
Dans le template overall_header:
Affichage/Templates/Général/ overall_header

Cherches ceci ligne 51 environ
Code:
<div id="logo-desc">
juste après colles ceci;
Code:

<div style="height:100px;">                         
<a href="http://www.forumdessports.com">
<marquee class="autowidv" BEHAVIOR="alternate"scrolldelay="1" scrollamount="2"><p>
<img border="10" src="http://i58.servimg.com/u/f58/18/12/26/07/bannie13.jpg" alt="hspace=0" id="banniere_defilante"/>
</p></marquee></a>
</div>
Vu que c'est ta bannière qui remplace le logo tu peux supprimer ce qui suit
En dessous supprimes ceci:
Code:

<a href="{U_INDEX}" id="logo"><img src="{LOGO}" alt="{L_INDEX}" /></a>

Penses a enregistrer les modifications en cliquant respectivement sur et
a++


Milouze14
+ Hyperactif +

Masculin
Messages : 4565
Inscrit(e) le : 18/04/2005

http://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec bannière défilante...

Message par badibou le Jeu 29 Jan 2015 - 20:14

PERFECT !! Yes

Merci encore Milouze !!

badibou
*****

Masculin
Messages : 544
Inscrit(e) le : 14/02/2013

http://www.forumdessports.com
badibou a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum