Les Scripts ChatBox ne fonctionnent pas

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Les Scripts ChatBox ne fonctionnent pas

Message par Arcaëlle le Lun 23 Fév 2015 - 16:23

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome, Internet Explorer, Opera, Safari, Autre
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : 23/02/15
Lien du forum : http://arcaellev4.lebonforum.com/

Description du problème

Bonjour,

Je rencontre des soucis lors de la mise en place des script de ce tuto : http://forum.forumactif.com/t376202-codes10-pour-la-chatbox#change_title

En effet, les scripts ne fonctionnent pas sur mon forum. Je vous joins ci-dessous les codes utilisés.

Titre de la CB (ne s'affiche pas)

Code:
$(window).load(function() {
  var chatbox_script = function() {
    $("a.chat-title").text("L'auberge de la licorne");
  };
  var s=document.createElement('script');s.text="("+chatbox_script.toString()+")();";$('object[data^="/chatbox/index.forum"],iframe[src^="/chatbox/index.forum"]').each(function(){try{$(this.contentDocument||this.contentWindow.document).find("#chatbox").closest("html").find("head").first().each(function(){this.appendChild(s)})}catch(a){}})
});

Son de la CB à la réception d'un message

Code:
window.localStorage && $(window).load(function() {
  var chatbox_script = function() {
    var sounds = {
      'future': 'http://s301826463.onlinehome.fr/f/future.mp3',
      'hal': 'http://s301826463.onlinehome.fr/f/hal.mp3',
      'secret': 'http://s301826463.onlinehome.fr/f/secret.mp3',
      'zelda': 'http://s301826463.onlinehome.fr/f/zelda.mp3',
      'mozart': 'http://s301826463.onlinehome.fr/f/mozart.mp3'
    };
    var default_sound = sounds['future'];
    var default_freq = 'new';
    var default_when = 'once';
    var default_volume = 100;

 
    if(localStorage.cb_sound && !localStorage.cb_sound.indexOf('https://dl.dropboxusercontent.com/u/181621985/')) localStorage.removeItem('cb_sound');
    var a = document.createElement('audio');
    if(!a.canPlayType) return;
    a.volume = Math.min(1, Math.max(0, localStorage.cb_volume||(default_volume/100)));
   
    var origin_send = Chatbox.prototype.send;
    Chatbox.prototype.send = function(params) {
      var m = $.trim($("#message").val());
      if(m.indexOf('/sound')&&m.indexOf('/soudn'))
        return origin_send.call(this, params);
      m = $.trim(m.substr(6)).split(/\s+/,3);
      var bad_apple = false;
      switch(m[0].toLowerCase()) {
        case "":
          if(!a.src) a.src = localStorage.cb_sound||default_sound;
          a.load();
          a.play();
          break;
        case "all":
        case "new":
          localStorage.cb_freq = m[0]; break;
        case "always":
        case "off":
        case "on":
        case "once":
        case "never":
          localStorage.cb_when = m[0]; break;
        case "stop":
          if(!a.paused) a.pause();
          if(!a.ended) a.currentTime = 0;
          break;
        case "pause":
          if(!a.paused) a.pause();
          break;
        case "volume":
          if(m.length>1) {
            localStorage.cb_volume = Math.min(1, Math.max(0, parseFloat(m[1].replace(',','.'))/100));
            a.volume = localStorage.cb_volume;
            break
          }
        default:
          bad_apple = true;
      };
      if(bad_apple) {
        if(m[0] in sounds) {
          m[0]= sounds[m[0]];
        }
        if(m[0]=="default") {
          m[0]=default_sound; 
          localStorage.removeItem('cb_sound');
          localStorage.removeItem('cb_freq');
          localStorage.removeItem('cb_volume');
          localStorage.removeItem('cb_when');
          a.volume = Math.min(1, Math.max(0, default_volume/100));
        }
        if(/^https?:\/\/.+/.test(m[0])) {
          localStorage.cb_sound = m[0];
          a.pause();
          a.src = m[0];
          a.load();
          a.play();
        } else {
          var message = $('#message').val();
          alert('/sound [all | new]\n/sound [always | off | on | once | never]\n/sound [stop | pause]\n/sound default\n/sound volume 0-100\n/sound ['+$.map(sounds,function(_,k){return k}).join(' | ')+']\n/sound [http://* | https://*]');
          setTimeout(function(){ $("#message").val(message).select().focus(); }, 100);
          return;
        }
      }
      return $("#message").val('').focus();
    };

    $(window).on("focus", function(){ localStorage.removeItem('cb_once'); localStorage.removeItem('cb_blurred') }).on("blur", function(){ localStorage.cb_blurred=1; });

    var play_sound = function(){
      if(a.paused || a.ended) {
        a.currentTime=0;
        if(!a.src) a.src = localStorage.cb_sound||default_sound;
        a.load();
        a.play()
      }
    };
    var overrided = Chatbox.prototype.refresh;
    Chatbox.prototype.refresh = function(data) {
      if (data.messages) {
        var lm = data.messages.slice(-1)[0];
        var last_message = lm.time+','+lm.action+','+lm.msg;
        if(this.last_message_sound != last_message) {
          var user = $.grep(data.users, function(v){return v.id==chatbox.userId});
          user = user.length ? user[0] : [{}];
          if(this.last_message_sound!==undefined) {
            var freq = (localStorage.cb_freq||default_freq);
            var when = (localStorage.cb_when||default_when);
            console.log([when, freq, localStorage.cb_blurred, localStorage.cb_once]);
            if(when != "never" && (when != "off" || localStorage.cb_blurred) && (when != "on" || !localStorage.cb_blurred) && (when != "once" || (localStorage.cb_blurred && !localStorage.cb_once))) {
              console.log([when, freq, localStorage.cb_blurred, localStorage.cb_once]);
              if(freq =="all" || (lm.userId!=chatbox.userId && user.username!=lm.username)) {
                if(when!="once" || !localStorage.cb_once) {
                  play_sound();
                  localStorage.cb_once = 1;
                }
              }
            }
          }
          this.last_message_sound = lm;
        }
      }
      overrided.call(this, data);
    };
  };
  var s=document.createElement('script');s.text="("+chatbox_script.toString()+")();";$('object[data^="/chatbox/index.forum"],iframe[src^="/chatbox/index.forum"]').each(function(){try{$(this.contentDocument||this.contentWindow.document).find("#chatbox").closest("html").find("head").first().each(function(){this.appendChild(s)})}catch(a){}})
});

CB clignotement

Code:
window.localStorage && $(window).load(function() {
  var chatbox_script = function() {
    var t_icon = window.top.$.find('link[rel="shortcut icon"]')[0];
    var t_doc = window.top.document;
    var title = t_doc.title;
    var icon = t_icon.getAttribute('href');
 
    var rep_title = '!! Nouveau message !! '+title;
    var rep_icon = 'https://dl.dropboxusercontent.com/u/181621985/al.ico';
 
    $(window).on("focus", function(){ localStorage.cb_blurred='' }).on("blur", function(){ localStorage.cb_blurred=1; });
    var overrided = Chatbox.prototype.refresh;
    Chatbox.prototype.refresh = function(data) {
      if (data.messages) {
        var lm = data.messages.slice(-1)[0];
        var last_message = lm.time+','+lm.action+','+lm.msg;
        if(this.last_message != last_message) {
          var user = $.grep(data.users, function(v){return v.id==chatbox.userId});
          user = user.length ? user[0] : [{}];
          if(this.last_message!==undefined) {
            if(lm.userId!=chatbox.userId && user.username!=lm.username) {
              if(localStorage.cb_blurred) (function(){
                var blink = function(){
                  if(title == t_doc.title) {
                    if(!localStorage.cb_blurred) return;
                    var new_title = rep_title;
                    var new_icon = rep_icon;
                  } else {
                    var new_title = title;
                    var new_icon = icon;
                  }
                  t_doc.title = new_title;
                  var new_t_icon = t_icon.cloneNode(true);
                  new_t_icon.setAttribute('href', new_icon);
                  var t_icon_parent = t_icon.parentNode;
                  t_icon_parent.removeChild(t_icon);
                  t_icon_parent.appendChild(new_t_icon);
                  t_icon = new_t_icon;
                  setTimeout(blink, 500);
                };
                blink();
              })();
            } else {
              localStorage.cb_blurred='';
            }
          }
          this.last_message = lm;
        }
      }
      overrided.call(this, data);
    };
  };
  var s=document.createElement('script');s.text="("+chatbox_script.toString()+")();";$('object[data^="/chatbox/index.forum"],iframe[src^="/chatbox/index.forum"]').each(function(){try{$(this.contentDocument||this.contentWindow.document).find("#chatbox").closest("html").find("head").first().each(function(){this.appendChild(s)})}catch(a){}})
});


J'ai coché : Sur l'index.

Merci à celle ou celui qui répondra =)

Bonne fin de journée

Arcaëlle
Nouveau membre

Féminin
Messages : 20
Inscrit(e) le : 16/12/2013

http://aubedesmondes.rpgistes.com/
Arcaëlle a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Ea le Lun 23 Fév 2015 - 17:09

Bonjour,


Chez moi ils fonctionnent : http://demo.fra.co/?demo

Il y a moyen d'avoir un couple "mot de passe/pseudo" d'un compte de test ?

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Lun 23 Fév 2015 - 18:07

@Ea a écrit:Bonjour,


Chez moi ils fonctionnent : http://demo.fra.co/?demo

Il y a moyen d'avoir un couple "mot de passe/pseudo" d'un compte de test ?

Cordialement.
Bonjour,

J'ai le même problème


Bonne soirée !

Edit : Ca marche dans le widget portail mais pas sur la page d'accueil (voir le titre de la chatbox).
L'url de la chatbox chargée sur la page d'accueil (réglable via les options du PA) est
Code:
URL DU FORUM/chatbox/index.forum?page=front&
Par contre, le script pour enlever les lignes "a rejoint le chat" ne marche pas même en actualisant la page et en étant connecté (en fait, il faut envoyer un message pour que ça marche) ...
Je n'ai aucun template de modifié et je regarde du côté des autres scripts (qui ont, soit dit en passant, la case "Galerie" de cochée pour leur placement alors que je n'ai rien modifié ...).
Aussi, quand on met en place le script de notification visuelle ou auditive, la chatbox a un problème d'affichage. Il faut faire CTRL+F5 pour que ça marche Wink
J'espère que ça aide ...

Merci !


Dernière édition par kiwi14637 le Mar 24 Fév 2015 - 15:52, édité 1 fois

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Ea le Lun 23 Fév 2015 - 18:42

Ce problème là devrait être résolu, je pensais avoir simplifié le code pour un point, mais ça causait un problème dans le cas de plus d'une chatbox sur une page.

Le problème est résolu dans les codes ( on pourrait même mettre à jour à la main en ajoutant les .cloneNode(true) à chaque .appendChild(s

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Lun 23 Fév 2015 - 18:48

@Ea a écrit:Ce problème là devrait être résolu, je pensais avoir simplifié le code pour un point, mais ça causait un problème dans le cas de plus d'une chatbox sur une page.

Le problème est résolu dans les codes ( on pourrait même mettre à jour à la main en ajoutant les .cloneNode(true) à chaque .appendChild(s
Merci ! Smile Ca marche !

Toutefois, le code pour enlever les lignes rouge et verte ne marche que quand on entre un message ... Wink


Dernière édition par kiwi14637 le Sam 7 Mar 2015 - 20:33, édité 2 fois

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Ea le Lun 23 Fév 2015 - 19:05

Moi ça arrive parfois aussi mais rarement, comme je l'ai indiqué ici à mon avis ça dépend du temps de chargement et d'exécution de tout les éléments : si les messages ont déjà été chargés avant l'exécution du script, il n'a pas pu agir dessus ( et il faut attendre un autre message pour que ça se mette à jour ).

La solution ce serait faire un cas spéciale pour ce cas, j'ai modifié le code dans ce sens.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Lun 23 Fév 2015 - 19:41

@Ea a écrit:Moi ça arrive parfois aussi mais rarement, comme je l'ai indiqué ici à mon avis ça dépend du temps de chargement et d'exécution de tout les éléments : si les messages ont déjà été chargés avant l'exécution du script, il n'a pas pu agir dessus ( et il faut attendre un autre message pour que ça se mette à jour ).

La solution ce serait faire un cas spéciale pour ce cas, j'ai modifié le code dans ce sens.
Merci encore ! Je me demande si
Code:
$('#chatbox > p > .msg > span').filter('[style="color:green"],[style="color:red"]').closest('p').remove();
ne permettrait pas de passer par le CSS
Edit :
Code:
#chatbox > p > .msg > span[style="color:green"] {display:none}
pourrait être un début de piste mais je ne suis pas assez bon pour savoir comment cacher le p

Seul problème sinon, c'est que j'ai une chatbox qui marche et l'autre qui apparaît comme ceci (parfois) :


Merci !


Dernière édition par kiwi14637 le Mar 24 Fév 2015 - 15:28, édité 1 fois

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par bfrag le Mar 24 Fév 2015 - 12:16

Moi j'ai le même souci, pouvez vous me dire ce qui a été corrigé exactement car je ne comprend plus rien...

En clair dans le script, il avait que la connexion en automatique qui fonctionne pour moi.

L'historique de la conversation avant le pb de chatbox s'affiché dans la chatbox mais la ce n'est plus le cas..
avait aussi ce problème ?

Cordialement.

bfrag
Nouveau membre

Messages : 10
Inscrit(e) le : 02/01/2015

http://frenchalliancegaming.forumactif.org/
bfrag a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Mar 24 Fév 2015 - 15:51

@bfrag a écrit:Moi j'ai le même souci, pouvez vous me dire ce qui a été corrigé exactement car je ne comprend plus rien...

En clair dans le script, il avait que la connexion en automatique qui fonctionne pour moi.

L'historique de la conversation avant le pb de chatbox s'affiché dans la chatbox mais la ce n'est plus le cas..
avait aussi ce problème ?

Cordialement.
Bonjour,

Mettez les nouveaux codes à la place des anciens. Certains ont été en effet modifiés.

L'historique de la conversation avant le pb de chatbox s'affiché dans la chatbox mais la ce n'est plus le cas..
avait aussi ce problème ? --> Les archives ont été modifiées depuis la nouvelle chatbox.

Bonne journée ! Wink

Edit : Les scripts pour cacher les lignes rouge et verte et activer les notifications auditives d'arrivée d'un nouveau message ne s'aiment pas. Impossible de cliquer sur le lien de connexion pour se connecter à la chatbox.
Firefox dit "TypeError: lm is undefined"

Merci !

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Ea le Mar 24 Fév 2015 - 20:17

Dans le cas où il n'y a aucun message dans la chatbox, ce qui peut-être possible quand on a le script qui retire les (dé/)connexions, le test que j'effectuais if(data.messages) était tout de même vrai alors qu'il aurait du être faux (j'ai du confondre avec python).

Donc j'ai modifié les scripts et ajouté && data.messages.length dans les 3 cas où ça arrivait.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Mer 25 Fév 2015 - 15:22

@Ea a écrit:Dans le cas où il n'y a aucun message dans la chatbox, ce qui peut-être possible quand on a le script qui retire les (dé/)connexions, le test que j'effectuais if(data.messages) était tout de même vrai alors qu'il aurait du être faux (j'ai du confondre avec python).

Donc j'ai modifié les scripts et ajouté && data.messages.length dans les 3 cas où ça arrivait.

Cordialement.
Bonjour,

Merci ! Je n'ai plus le problème décrit précédemment mais j'ai encore un problème avec la notification sonore : sous Firefox 36 et IE11 (Windows 7), quand je tape la commande /sound je n'entends pas les sons.
En outre, le son zelda ne semble pas marcher sur Firefox.
Egalement, il y a toujours le problème des archives qui font que les scripts ne s'appliquent plus (les réexcuter après avoir cliqué sur "Archives" ?).

Sinon, c'est très bien ! Smile

Merci et bon après-midi !

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Ea le Mer 25 Fév 2015 - 19:33

Le support dépend du navigateur, c'est pour ça que j'ai en partie mis les options pour l'écouter en faisant/sound ou /sound [raccourci]. De cette manière si ça fonctionne on le sait directement.

Justement le zelda il me semble était le seul en .wav, si j'en crois le tableau de compatibilité firefox devrait les supporter depuis la version 3.5 ( par contre IE ne le supporte pas ).

Enfin depuis le ré-hébergement des fichiers audio, il me semble que tout est en .mp3 également donc étrange.

Egalement, il y a toujours le problème des archives qui font que les scripts ne s'appliquent plus (les réexcuter après avoir cliqué sur "Archives" ?).

Ce n'est pas si simple mais j'imagine qu'on pourrait au clic prévenir la fenêtre parente, qui ré-exécutera le script au clic.

Cordialement.


Dernière édition par Ea le Mer 25 Fév 2015 - 22:53, édité 1 fois

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Mer 25 Fév 2015 - 19:56

@Ea a écrit:Le support dépend du navigateur, c'est pour ça que j'ai en partie mis les options pour l'écouter en faisant/sound ou /sound [raccourci]. De cette manière si ça fonctionne on le sait directement.

Justement le zelda il me semble était le seul en .wav, si j'en crois le tableau de compatibilité firefox devrait les supporter depuis la version 3.5 ( par contre IE ne le supporte pas ).

Enfin depuis le ré-hébergement des fichiers audio, il me semble que tout est en .mp3 également donc étrange.

Egalement, il y a toujours le problème des archives qui font que les scripts ne s'appliquent plus (les réexcuter après avoir cliqué sur "Archives" ?).

Ce n'est pas si simple mais j'imagine qu'on pourrait au clic prévenir la fenêtre parente, qui ré-exécutera le script au clic. Vu que ça complique un peu les choses, il faudrait refactorer un peu tout les scripts ( pour avoir une partie commune ).

Cordialement.
Rebonjour Smile

Je viens de tester avec "future" et ça marche Smile
Pour "zelda", je n'y arrive toujours pas, même en collant le lien dans la barre d'adresses de Firefox. En fait, Firefox semble ne pas le supporter et ce n'est pas la première fois Wink Je pense qu'il faudrait l'enlever pour éviter aux gens de se demander pourquoi ça ne marche pas ...

Aussi :
Code:
if(localStorage.cb_sound && !localStorage.cb_sound.indexOf('https://dl.dropboxusercontent.com/u/181621985/')) localStorage.removeItem('cb_sound');

Merci ! Smile

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Invité le Jeu 26 Fév 2015 - 17:58

moi ça fonctionne pas je suis obligé de faire /sound pour que le son se lance apres les messages a la suite marche et dec que je me deco ça re-fonctionne pas

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Ea le Jeu 26 Fév 2015 - 19:42

@kiwi14637 a écrit:Je viens de tester avec "future" et ça marche Smile
Pour "zelda", je n'y arrive toujours pas, même en collant le lien dans la barre d'adresses de Firefox. En fait, Firefox semble ne pas le supporter...

dans ce cas qu'en est-il de zelda.mono.mp3 et zelda.stereo.mp3 dans ce dossier : http://s301826463.onlinehome.fr/f/ ?

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Peggy06 le Jeu 26 Fév 2015 - 20:03

Bonsoir à tous,
Je voudrais savoir si chaque utilisateur doit mettre /sound default à chaque fois qu'il se connecte à la chatbox.
Par avance, merci

Peggy06
****

Messages : 261
Inscrit(e) le : 24/10/2014

http://evasionentrenous.forumactif.org/
Peggy06 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Ea le Jeu 26 Fév 2015 - 20:24

Bonjour,


Il n'y a jamais besoin de le mettre, la seule action engendrée par l'utilisation de :

Code:
/sound

c'est de tester si on entend bien le son.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Peggy06 le Jeu 26 Fév 2015 - 20:33

Pour l'instant j'ai testé et je l'entendais mais comme je suis seule, entre-temps le son ne marche plus ou bien mettre / sound à chaque fois et mes messages n'apparaissent pas tout le temps j'ai des bugs, Changer le préfixe de modérateur, Ajouter les avatars où ils ne sont pas et Notification nouveau message visuelle ne fonctionnent pas.
Merci beaucoup pour votre réponse rapide

Peggy06
****

Messages : 261
Inscrit(e) le : 24/10/2014

http://evasionentrenous.forumactif.org/
Peggy06 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Ven 27 Fév 2015 - 12:20

Bonjour,

@Ea a écrit:
@kiwi14637 a écrit:Je viens de tester avec "future" et ça marche Smile
Pour "zelda", je n'y arrive toujours pas, même en collant le lien dans la barre d'adresses de Firefox. En fait, Firefox semble ne pas le supporter...

dans ce cas qu'en est-il de zelda.mono.mp3 et zelda.stereo.mp3 dans ce dossier : http://s301826463.onlinehome.fr/f/ ?
Ils marchent parfaitement ! Smile
@Peggy06 a écrit:Pour l'instant j'ai testé et je l'entendais mais comme je suis seule, entre-temps le son ne marche plus ou bien mettre / sound à chaque fois et mes messages n'apparaissent pas tout le temps j'ai des bugs, Changer le préfixe de modérateur, Ajouter les avatars où ils ne sont pas et Notification nouveau message visuelle ne fonctionnent pas.
Merci beaucoup pour votre réponse rapide
Avez-vous essayé de mettre les nouveaux scripts http://forum.forumactif.com/t376250-codes10-pour-la-chatbox car ils ont été mis à jour entre temps ...

Bonne journée !

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Invité le Ven 27 Fév 2015 - 13:20

c'est pareil pour moi a chaque fois que je suis connecter /sound et sa remarche le son

Merci beaucoup pour résoudre mon problème le plus rapidement Very Happy Smile

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Ven 27 Fév 2015 - 13:31

Bonjour,

Je viens de tester avec les paramètres
Code:
        var default_sound = sounds['zelda'];
        var default_freq = 'all';
        var default_when = 'always';
        var default_volume = 100;
pour le script de notification sonore et quand j'envoie un message, il n'apparaît pas sur la chatbox.
La console de Firefox dit :
Code:
InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable
Quand j'actualise, les messages que j'ai écrits apparaissent.

Merci ! Il y a effectivement un problème avec ce script !

Bonne journée !

@pt55 : A l'ouverture de la chatbox, faites F12 puis écrivez un message (pour que le problème apparaisse). Quel message apparaît dans la console ?

Edit : Le script qui change le titre de la page marche mais sous IE11 (Windows 7), l'icône n'est pas changée (je suppose que c'est normal) et sur Firefox, j'ai une erreur dans la console qui apparaît :
Code:
TypeError: t_icon_parent is null
Wink


Dernière édition par kiwi14637 le Sam 28 Fév 2015 - 17:21, édité 1 fois

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Invité le Ven 27 Fév 2015 - 18:12

c'est peut etre normal se probleme a pres tous le java scripts c'est dur mais l'ancien

code marcher pas mal


Code:
$(document).ready(function(){
  urlForum = "http://ashoka-reiki.forumactif.org";
  urlSound = "http://ashoka.reiki.free.fr/FORUM/son.wav";
  urlTchat = urlForum+"/chatbox/index.forum";
  titlePage = document.title;
  $.get(urlTchat, function(resultat){
      nbCaracteres = resultat.length;
  });
  nbMsgNonLu = 0;
  $('body').attr('onclick', 'resetTitlePage();');
  $('body').append('<audio style="display:none" id="tchat-notif-sonore"><source src="'+urlSound+'" type="audio/wav" /></audio>');
});
function testLongeur()
{
  $.get(urlTchat, function(resultat){
      var nbCaracteresRefresh = resultat.length;
      if(nbCaracteresRefresh > nbCaracteres)
      {
        nbMsgNonLu = nbMsgNonLu + 1;
        document.title = titlePage+" - ( "+nbMsgNonLu+" ) Nouveaux messages";
        nbCaracteres = nbCaracteresRefresh;
        $('#tchat-notif-sonore').trigger("play");
      }
      else
      {
        nbCaracteres = resultat.length;
      }
  });
}
function resetTitlePage()
{
  document.title = titlePage;
  nbMsgNonLu = 0;
}
setInterval(testLongeur, 400);


mes bon les teste son abandonner ou pas Ea

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Dim 1 Mar 2015 - 13:00

UP (Peut-être transformer un des topics en "topic unique" ?)

PS : @Ea : Bien reçu mon MP ?

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Peggy06 le Dim 1 Mar 2015 - 14:03

Bonjour à tous,
Je reviens, car le son ne fonctionne que si à chaque message on remet /sound sinon rien et de plus les messages ne s'affichent plus tout le temps, il faut faire f5, sans compter les autres codes qui ne marchent pas non plus, va -t-il y avoir une rectification ?
Je souhaiterais savoir aussi, si chaque membre doit activer /sound default car j'ai l'impression qu'ils n'entendent pas celui-ci.
Par avance, merci pour votre réponse.

Peggy06
****

Messages : 261
Inscrit(e) le : 24/10/2014

http://evasionentrenous.forumactif.org/
Peggy06 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Ea le Dim 1 Mar 2015 - 15:49

@Peggy06 a écrit:Bonjour à tous,
Je reviens, car le son ne fonctionne que si à chaque message on remet /sound sinon rien et de plus les messages ne s'affichent plus tout le temps, il faut faire f5, sans compter les autres codes qui ne marchent pas non plus, va -t-il y avoir une rectification ?
Je souhaiterais savoir aussi, si chaque membre doit activer /sound default car j'ai l'impression qu'ils n'entendent pas celui-ci.
Par avance, merci pour votre réponse.

L'utilité de :

Code:
/sound default

c'est de remettre la configuration par défaut c'est à dire, annuler ce que l'utilisateur a pu faire, et remettre la configuration des 4 lignes :

Code:
    var default_sound = sounds['zelda'];
    var default_freq = 'new';
    var default_when = 'once';
    var default_volume = 100;

de plus les messages ne s'affichent plus tout le temps, il faut faire f5

cela c'est étrange. vous parlez bien de messages envoyés de comptes différents ? si vous ouvrez plusieurs fois la chatbox avec le même compte et que vous envoyez un message dans une, vous ne verrez directement ce message que dans la chatbox où vous l'avez envoyer.

Si vous voulez tester l'envoie de message avec plusieurs comptes, à ma connaissances les seuls moyens sont :

  • Soit se connecter à des comptes différents sur des ordinateurs différents,
  • Soit se connecter à des comptes différents sur des navigateurs différents,
  • Soit se connecter à un compte différent en ouvrant un onglet en navigation privée.


Et google chrome a aussi un outils de gestion d'utilisateurs ( voici un lien d'une vidéo concernant la fonction ) qui permet également de faire ces tests avec plusieurs comptes.

@Plümpheit a écrit:Comme je n'ai rien compris à ce qui a été dit avant et que je n'ai pas le sentiment que cela concernait ce script là... Je préfère redemander Smile

Que faut il que je fasse?

Je ne sais pas, jusqu'à présent le script m'a semblé toujours fonctionné à part :

  • Si on avait une chatbox modifiée pour afficher les archives à l'ouverture de la page, dans ce cas il faut retirer le ?archives=1 comme mentionné dans le tutoriel,

  • Si on a plusieurs chatbox sur la même page : cela a été résolu dans les scripts présent dans le tutoriel il y a plusieurs jours,

  • Si on avait les urls de sons "dl.dropboxusercontent.com" qui ont été bloquées par dropbox, dans ce cas il fallait mettre à jour avec le script contenant les nouvelles urls sur illiweb.com

  • Quelqu'un signalait un problème avec le fichier zelda.mp3 sur certains versions/configurations de firefox, un fichier ( qui lui semble fonctionner ) devrait remplacer le zelda.mp3 vers lundi. Pour tester si on a le problème juste avec zelda.mp3 il suffit de tester un autre /sound {raccourci} ( de base il y a également secret, hal et future)

  • Certains scripts utilisent des fonctionnalités qui ne sont pas apparus dans internet explorer avant le 9, donc si il y a un script qui ne fonctionne pas avec IE8-7-ou plus bas c'est normal.

  • Si on a un erreur dans un autre script, suivant où est le problème il peut causer le non-fonctionnement d'un script de chatbox. Dans ce cas il faudrait le corriger pour résoudre le non-fonctionnement du script de chatbox.


@kiwi14637 a écrit:PS : @Ea : Bien reçu mon MP ?

Non, et vu que mes MPs sont actuellement désactivés ( je crois ) ce n'est pas possible à ma connaissance.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Peggy06 le Dim 1 Mar 2015 - 16:35

Code:
L'utilité de :
/sound default
c'est de remettre la configuration par défaut c'est à dire, annuler ce que l'utilisateur a pu faire, et remettre la configuration des 4 lignes :
si j'ai bien compris c'est lorsqu'il y a plusieurs utilisateurs, mais il n'y qu'un utilisateur sur mon pc.
Ensuite pour
Code:
de plus les messages ne s'affichent plus tout le temps, il faut faire f5
vous me répondez
Code:
cela c'est étrange. vous parlez bien de "messages envoyés de comptes différents" ? si vous ouvrez plusieurs fois la chatbox avec le même compte et que vous envoyez un message dans une, vous ne verrez directement ce message que dans la chatbox où vous l'avez envoyer.
je ne comprends pas bien, excusez-moi je suis assez novice, pour l'instant je fais des tests seule c'est pourquoi j'ai mis "all" et "always" car de toute manière nous n'arrivons plus à nous joindre avec les membres. Qu'entendez-vous par :
Code:
Si vous voulez tester l'envoie de message avec plusieurs comptes, à ma connaissances les seuls moyens sont :

    Soit se connecter à des comptes différents sur des ordinateurs différents,
    Soit se connecter à des comptes différents sur des navigateurs différents,
    Soit se connecter à un compte différent en ouvrant un onglet en navigation privée.
. Désolé pour mon ignorance, mais je me soigne, et pour le "roman" que je vous ai fait.
Merci pour votre rapidité à répondre.

Peggy06
****

Messages : 261
Inscrit(e) le : 24/10/2014

http://evasionentrenous.forumactif.org/
Peggy06 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Dim 1 Mar 2015 - 16:58

@Peggy06 a écrit:
Code:
L'utilité de :
/sound default
c'est de remettre la configuration par défaut c'est à dire, annuler ce que l'utilisateur a pu faire, et remettre la configuration des 4 lignes :
si j'ai bien compris c'est lorsqu'il y a plusieurs utilisateurs, mais il n'y qu'un utilisateur sur mon pc.
Ensuite pour
Code:
de plus les messages ne s'affichent plus tout le temps, il faut faire f5
vous me répondez
Code:
cela c'est étrange. vous parlez bien de "messages envoyés de comptes différents" ? si vous ouvrez plusieurs fois la chatbox avec le même compte et que vous envoyez un message dans une, vous ne verrez directement ce message que dans la chatbox où vous l'avez envoyer.
je ne comprends pas bien, excusez-moi je suis assez novice, pour l'instant je fais des tests seule c'est pourquoi j'ai mis "all" et "always" car de toute manière nous n'arrivons plus à nous joindre avec les membres. Qu'entendez-vous par :
Code:
Si vous voulez tester l'envoie de message avec plusieurs comptes, à ma connaissances les seuls moyens sont :

    Soit se connecter à des comptes différents sur des ordinateurs différents,
    Soit se connecter à des comptes différents sur des navigateurs différents,
    Soit se connecter à un compte différent en ouvrant un onglet en navigation privée.
. Désolé pour mon ignorance, mais je me soigne, et pour le "roman" que je vous ai fait.
Merci pour votre rapidité à répondre.
Bonjour,

Pour faire des tests, vous pourriez essayer de donner le forum, le pseudo et le mot de passe d'un compte test, sous balise hide ! Wink

Bonne fin d'après-midi !

Edit : Pour Ea :
- j'ai en fait demandé à Chacha de vous faire passer un message Wink
-
Code:
        if(localStorage.cb_sound && !localStorage.cb_sound.indexOf('https://dl.dropboxusercontent.com/u/181621985/')) localStorage.removeItem('cb_sound');
Le lien dropbox est toujours dans le code même s'il ne l'empêche pas de tourner
- Je viens de tester avec les paramètres
Code:
        var default_sound = sounds['zelda'];
        var default_freq = 'all';
        var default_when = 'always';
        var default_volume = 100;
pour le script de notification sonore et quand j'envoie un message, il n'apparaît pas sur la chatbox.
La console de Firefox dit :
Code:
InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable
Quand j'actualise, les messages que j'ai écrits apparaissent.
- Le script qui change le titre de la page marche mais sous IE11 (Windows 7), l'icône n'est pas changée (je suppose que c'est normal) et sur Firefox, j'ai une erreur dans la console qui apparaît :
Code:
TypeError: t_icon_parent is null

Merci encore pour ces scripts !

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par Ea le Dim 1 Mar 2015 - 17:22

@kiwi14637 a écrit:-
Code:
        if(localStorage.cb_sound && !localStorage.cb_sound.indexOf('https://dl.dropboxusercontent.com/u/181621985/')) localStorage.removeItem('cb_sound');
Le lien dropbox est toujours dans le code même s'il ne l'empêche pas de tourner

ce code a pour but de remplacer le son par le son par celui par defaut dans le cas où il aurait un son contenant https://dl.dropboxusercontent.com/u/181621985/

Pour le reste étrange, la dernière erreur me ferait penser qu'il n'y a pas de tag du style :

Code:
<link rel="shortcut icon" type="image/x-icon" href="http://illiweb.com/fa/favicon/discussion.ico" />

dans la page parente.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Dim 1 Mar 2015 - 17:53

@Ea a écrit:
@kiwi14637 a écrit:-
Code:
        if(localStorage.cb_sound && !localStorage.cb_sound.indexOf('https://dl.dropboxusercontent.com/u/181621985/')) localStorage.removeItem('cb_sound');
Le lien dropbox est toujours dans le code même s'il ne l'empêche pas de tourner

ce code a pour but de remplacer le son par le son par celui par defaut dans le cas où il aurait un son contenant https://dl.dropboxusercontent.com/u/181621985/

Pour le reste étrange, la dernière erreur me ferait penser qu'il n'y a pas de tag du style :

Code:
<link rel="shortcut icon" type="image/x-icon" href="http://illiweb.com/fa/favicon/discussion.ico" />

dans la page parente.
Ok

Pour le dernier code, vous voulez parler du favicon ? En fait, je viens de remarquer que sur mon IE, les favicons ne sont plus pris en compte et comme j'ai testé à partir de là vers Firefox.
Edit : Il semble que je n'ai plus le problème ...

Le script de notification visuelle marche aussi quand le message * a été déconnecté de la chatbox s'affiche. Quand on utilise le script pour cacher cette ligne, ça fait un peu bizarre et j'ai mis un peu de temps à comprendre ...

Pour le MP, je vous le mets sous spoiler et balise hide dans ce topic ?

Pour "InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable", Firefox me dit en détail
Code:
InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable index.forum:1:0
Array [ "always", "all", "", undefined ] index.forum:1:2921
Array [ "always", "all", "", undefined ] index.forum:1:3155

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Les Scripts ChatBox ne fonctionnent pas

Message par kiwi14637 le Jeu 5 Mar 2015 - 14:55

UP

kiwi14637
# Tropactif #

Masculin
Messages : 1388
Inscrit(e) le : 19/05/2010

kiwi14637 a été remercié(e) par l'auteur de ce sujet.

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum