Lien dans iframe qui ne charge pas toute la page

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Lien dans iframe qui ne charge pas toute la page

Message par Eiffel01 le Dim 13 Déc 2015 - 20:29

Bonsoir,
Oui, c'est dur à expliquer...
J'ai une page HTML où est seulement une barre de navigation.
Lorsque je mets l'iframe menant vers la barre de navigation, tout fonctionne correctement.
Mais lorsque je veux cliquer sur un lien, seulement la partie de la barre de navigation change de page, effet à voir ici : http://onapprendlesmaths.forumactif.org/h2-accueil
Quelqu'un aurait-il la solution ?

Autre problème, comment puis-je créer une base de donnée des class utiles pour le CSS ? Je m'explique : je ne veux pas copier / coller à chaque fois les mêmes classes, au cas où je veuille la modifier ; puisque cela ne fonctionne pas si je place mes class dans la feuille de style.

Quelqu'un aurait-il la réponse à mes questions ?

Passez de merveilleuses fêtes de fin d'année
Merci


Dernière édition par Eiffel01 le Ven 18 Déc 2015 - 22:45, édité 1 fois

Eiffel01
***

Masculin
Messages : 192
Inscrit(e) le : 10/03/2014

http://maths-laboisse.forumactif.org
Eiffel01 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Lien dans iframe qui ne charge pas toute la page

Message par Eiffel01 le Mar 15 Déc 2015 - 21:07

UP

Bonne soirée

Eiffel01
***

Masculin
Messages : 192
Inscrit(e) le : 10/03/2014

http://maths-laboisse.forumactif.org
Eiffel01 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Lien dans iframe qui ne charge pas toute la page

Message par Eiffel01 le Mer 16 Déc 2015 - 21:03

UP
Si quelqu'un a une réponse....
Bonne soirée

Eiffel01
***

Masculin
Messages : 192
Inscrit(e) le : 10/03/2014

http://maths-laboisse.forumactif.org
Eiffel01 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Lien dans iframe qui ne charge pas toute la page

Message par Eiffel01 le Ven 18 Déc 2015 - 18:54

Bonsoir,
UP

Eiffel01
***

Masculin
Messages : 192
Inscrit(e) le : 10/03/2014

http://maths-laboisse.forumactif.org
Eiffel01 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Lien dans iframe qui ne charge pas toute la page

Message par Tite-May le Ven 18 Déc 2015 - 20:30

Bonsoir,

Pour que le lien s'ouvre dans la page et non dans l'iframe, rajoute ce code dans le head de l'iframe :

Code:
<base target="_parent" />

Pour ton autre soucis, je ne comprends pas réellement ce que tu veux dire...
Tu pourrais être plus claire ?

Tite-May
Nouveau membre

Féminin
Messages : 29
Inscrit(e) le : 13/08/2012

http://templactif.forumactif.org/
Tite-May a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Lien dans iframe qui ne charge pas toute la page

Message par Eiffel01 le Ven 18 Déc 2015 - 20:34

Bonsoir,
Depuis le temps que je cherchais :O

Merci infiniment Tite-May

Pour mon autre problème, c'est que je souhaiterais créer une page HTML qui regroupe toutes mes propriétés CSS (afin de ne les modifier qu'une seule fois et qu'elle s'applique à toutes les pages où elles sont utilisées), je ne sais pas si je suis guère explicite.

Passez de bonnes fêtes

Eiffel01
***

Masculin
Messages : 192
Inscrit(e) le : 10/03/2014

http://maths-laboisse.forumactif.org
Eiffel01 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Lien dans iframe qui ne charge pas toute la page

Message par Tite-May le Ven 18 Déc 2015 - 20:40

Bonsoir,
il ne faut pas mettre sur une page HTML en fait, il faut créer une page CSS que vous hébergez quelque part et que vous appelez sur chacune de vos pages HTML. Mais avez-vous essayé en mettant sur le CSS du forum ? (j'essaye après avoir réglé votre autre soucis)

Bises

Tite-May
Nouveau membre

Féminin
Messages : 29
Inscrit(e) le : 13/08/2012

http://templactif.forumactif.org/
Tite-May a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Lien dans iframe qui ne charge pas toute la page

Message par Eiffel01 le Ven 18 Déc 2015 - 20:45

Bonsoir,
Je vous remercie de vous occuper de tous mes problèmes
Cela ne fonctionne pas avec le CSS du forum, je pense puisque je n'inclus pas le haut et le bas du forum.
Il faut utiliser quelle propriété pour inclure un fichier de la sorte ?
link et @link n'ont pas fonctionné sur Internet Explorer 11 (je me mets sur le navigateur à mon sens le moins facile pour coder).

Cordialement

Eiffel01
***

Masculin
Messages : 192
Inscrit(e) le : 10/03/2014

http://maths-laboisse.forumactif.org
Eiffel01 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Lien dans iframe qui ne charge pas toute la page

Message par Tite-May le Ven 18 Déc 2015 - 21:04

Certains choses sont OK sur IE et pas sur d'autres navigateurs et inversement. Donc il faut tester tous les navigateurs. C'est long et chi**t mais c'est comme ça Wink

En fait pour insérer une feuille de style CSS externe, il faut ajouter ceci dans le head :
Code:
<link rel="stylesheet" type="text/css" href="lien_de_la_page.css"  />

Sur le PA, dans la feuille de style CSS, il y a un lien "voir la feuille de style de base...". Cliquez dessus, et récupérez le lien en retirant tout ce qu'il y a après .css.
Mettez ce lien dans le code donné juste au dessus. Est-ce que ça fonctionne ?

Tite-May
Nouveau membre

Féminin
Messages : 29
Inscrit(e) le : 13/08/2012

http://templactif.forumactif.org/
Tite-May a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Lien dans iframe qui ne charge pas toute la page

Message par Eiffel01 le Ven 18 Déc 2015 - 22:44

Bonsoir,
Ca fonctionne !
Je vous remercie infiniment, je passe ce sujet en résolu.

Passez de bonnes fêtes

Eiffel01
***

Masculin
Messages : 192
Inscrit(e) le : 10/03/2014

http://maths-laboisse.forumactif.org
Eiffel01 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum