Crochet "sauvage" présent sur le forum

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Crochet "sauvage" présent sur le forum

Message par TYL le Ven 22 Jan 2016 - 22:39

Détails techniques


Version du forum : phpBB2
Poste occupé : Membre
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome, Internet Explorer
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Moi uniquement
Problème apparu depuis : il y a environs un mois
Lien du forum : http://www.the-hundred.org/

Description du problème

Bonsoir,
Depuis quelques temps, sur le RPG où je joue, je vois des crochets qui sont assez gênants puisqu'ils décalent la barre de navigation et que c'est usant à force. Ils sont en haut à gauche de l'écran. Je suis la seule à les voir après avoir demandé au staff, et je les vois depuis mon ordinateur ainsi que celui de ma mère (windows 10 tous les deux), cependant une membre sous ce même système d'exploitation n'a pas le soucis. J'aimerais donc savoir comme régler ce soucis, sachant que les templates du forum sont modifiés et qu'il y a un script actif (la neige)
Après avoir fait "examiner l'élément" avec mozilla, j'obtiens ceci: https://i68.servimg.com/u/f68/19/24/57/47/2016-011.jpg
J'aimerais donc savoir d'où vient ce crochet et quelle manipulation indiquer à leur codeuse qui ne trouve pas, ne voyant pas ce soucis elle non plus.
Je précise que j'ai nettoyé, redémarré mon ordinateur avant de poster ce message et que je n'ai ce soucis que sur la page principale du forum.
Merci d'avance,


Dernière édition par TYL le Sam 23 Jan 2016 - 23:34, édité 1 fois

TYL
**

Féminin
Messages : 65
Inscrit(e) le : 30/06/2011

http://love-runs-out.forumactif.org/
TYL a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par R-max le Ven 22 Jan 2016 - 23:30

bonsoir , c'est une bannière aléatoire ??

surement sur un lien image qu'il y a un soucie ,(sur la fin du code)
Code:
<img src="lien de l'image"/>"/>

surement ceci a écrit:<img src="lien de l'image"/>"/>

la partie en noir qui est en trop.

R-max
# Tropactif #

Masculin
Messages : 1522
Inscrit(e) le : 08/01/2015

http://graphcode.forumactif.org/
R-max a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par TYL le Ven 22 Jan 2016 - 23:39

Bonsoir, c'est en effet une bannière aléatoire mais l'ancienne (de la première capture d'écran) ne l'était pas... Je transmets néanmoins et je vous tiens au courant, merci de la réponse. I love you

TYL
**

Féminin
Messages : 65
Inscrit(e) le : 30/06/2011

http://love-runs-out.forumactif.org/
TYL a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par TYL le Sam 23 Jan 2016 - 13:49

Elle n'a pas réussi, je suis toujours la seule à le voir; mais ej ne le vois que sur la première page, quand je navigue sur le forum, je ne le vois pas. I love you

TYL
**

Féminin
Messages : 65
Inscrit(e) le : 30/06/2011

http://love-runs-out.forumactif.org/
TYL a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par Hellandra le Sam 23 Jan 2016 - 14:25

Bonjour Smile

Je me permets de venir poster ici, ayant cherché le souci absolument partout sur le forum. Aucun des membres du forum ni du staff ne voit la même chose. De plus, après avoir fouillé en vain via les screens (puisque je ne vois moi-même pas d'erreur ou de balise comme celle décrite non fermée), il est évident que le problème ne vient pas de notre côté. Sur son téléphone, le forum s'affiche bien sans aucun bug apparent.

Nous en sommes donc venus à la conclusion que l'erreur venait de son ordinateur. En revanche, aucune idée de comment réparer le souci de ce côté-là. Souci d'antivirus? De navigateur (mais le problème persiste apparemment de son côté sous Chrome et Firefox)?

En espérant que vous puissiez lui venir en aide. Au moins maintenant nous savons de quel côté chercher. I love you

Cordialement,
Alex, The Hundred

Hellandra
Nouveau membre

Féminin
Messages : 11
Inscrit(e) le : 20/09/2014

http://www.the-hundred.org/
Hellandra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par Scoubifitz le Sam 23 Jan 2016 - 21:40

@Hellandra a écrit:
Bonjour Smile

Je me permets de venir poster ici, ayant cherché le souci absolument partout sur le forum. Aucun des membres du forum ni du staff ne voit la même chose. De plus, après avoir fouillé en vain via les screens (puisque je ne vois moi-même pas d'erreur ou de balise comme celle décrite non fermée), il est évident que le problème ne vient pas de notre côté. Sur son téléphone, le forum s'affiche bien sans aucun bug apparent.

Nous en sommes donc venus à la conclusion que l'erreur venait de son ordinateur. En revanche, aucune idée de comment réparer le souci de ce côté-là. Souci d'antivirus? De navigateur (mais le problème persiste apparemment de son côté sous Chrome et Firefox)?

En espérant que vous puissiez lui venir en aide. Au moins maintenant nous savons de quel côté chercher. I love you

Cordialement,
Alex, The Hundred

Bonjour,

Vraiment partout ? D'après cet extrait du code source de votre page d'accueil , il y a un bug dans une balise meta ... balise dans laquelle le script a été incrusté ... Regardez bien la fin de cet extrait ...

Code:
<meta property="og:description" content="Forum RPG inspiré de la série the 100 <script type=text/javascript> var banListe=['1','2']; document.write('<body class=ban' + banListe[Math.floor(Math.random()*banListe.length)] +'>'); </script>"/>

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par Hellandra le Sam 23 Jan 2016 - 22:08

@Scoubifitz a écrit:Bonjour,

Vraiment partout ? D'après cet extrait du code source de votre page d'accueil , il y a un bug dans une balise meta ... balise dans laquelle le script a été incrusté ... Regardez bien la fin de cet extrait ...

Code:
<meta property="og:description" content="Forum RPG inspiré de la série the 100 <script type=text/javascript> var banListe=['1','2']; document.write('<body class=ban' + banListe[Math.floor(Math.random()*banListe.length)] +'>'); </script>"/>
Effectivement, j'ai bien regardé partout. La preuve avec ce screen de l'endroit qui semblerait gêner (le curseur montre bien qu'il n'y a rien derrière): https://i68.servimg.com/u/f68/17/91/78/58/script11.png

Encore une fois s'il y avait une balise "sauvage" de ce type, ne devrait-elle pas être visible d'autres membres?

Cordialement

Hellandra
Nouveau membre

Féminin
Messages : 11
Inscrit(e) le : 20/09/2014

http://www.the-hundred.org/
Hellandra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par Scoubifitz le Sam 23 Jan 2016 - 22:45

Ce n'est pas parce que le navigateur ne l'interprète pas , que cette balise n'existe pas ...

Cependant , la description du site ne doit comporter que du texte , pas des balises de script ...

Par exemple , si vous mettez : bla bla bla dans la description , le code source sera comme ça :
Code:
<meta property="og:description" content="bla bla bla" />
ça sert à décrire le forum , et à être référencé par les moteurs de recherche ...

Supprimez cette balise de la description :
Code:
<script type=text/javascript> var banListe=['1','2']; document.write('<body class=ban' + banListe[Math.floor(Math.random()*banListe.length)] +'>'); </script>

puis placez le contenu de cette balise dans une page Javascript , en cochant sur toutes les pages :
Code:
var banListe=['1','2'];
document.write('<body class=ban' + banListe[Math.floor(Math.random()*banListe.length)] +'>');

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Crochet "sauvage" présent sur le forum

Message par Hellandra le Sam 23 Jan 2016 - 23:27

Je n'ai jamais dit que la balise n'existait pas, sinon je ne serais pas ici. J'ai seulement dit que la balise n'était pas visible du reste des membres.

Pour la description du forum contenant le script, cela ne date pas d'hier donc c'est étrange que le problème survienne uniquement maintenant, j'avoue être curieuse si vous avez l'explication. Neutral Concernant la méthode, à vrai dire nous l'avions trouvée ici sur FA bien que pas en tutoriel, mais si celle-ci n'est plus à l'ordre du jour nous nous mettons à la page, même si cela crée un script de plus.

J'ai transféré dans un module Javascript du coup, je n'ai pas regardé mais je pense qu'on doit avoir la même chose...surtout pour 2 lignes. Apparemment le bug n'apparaît plus chez elle, donc c'est tant mieux!

Merci du coup de main Smile

Hellandra
Nouveau membre

Féminin
Messages : 11
Inscrit(e) le : 20/09/2014

http://www.the-hundred.org/
Hellandra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par TYL le Sam 23 Jan 2016 - 23:33

En effet le soucis est maintenant résolu, merci beaucoup! I love you

TYL
**

Féminin
Messages : 65
Inscrit(e) le : 30/06/2011

http://love-runs-out.forumactif.org/
TYL a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par Scoubifitz le Sam 23 Jan 2016 - 23:36

Avant , on pouvait le placer dans les balises méta (un peu plus bas dans la description du forum) , mais depuis , Forumactif a rajouté des modules JS pour augmenter le nombre de scripts ...


Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par Hellandra le Sam 23 Jan 2016 - 23:40

D'accord, c'est donc une mise à jour FA récente qui aurait entravé la fonctionnalité de cette méthode... On prendra désormais l'habitude de segmenter tout ça pour plus de clarté (et limiter les bugs).

Merci à toi

Hellandra
Nouveau membre

Féminin
Messages : 11
Inscrit(e) le : 20/09/2014

http://www.the-hundred.org/
Hellandra a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Crochet "sauvage" présent sur le forum

Message par Scoubifitz le Dim 24 Jan 2016 - 0:00

En fait , cette méthode fonctionne si on ne met que le script , sans la description ...

Mais comme on a pu le constater , sur internet explorer (version 10 , avec le même système d'exploitation ) , les balises meta sont lues sans correction ...

Fa n'a rien entravé ... il se trouve que cette méthode a ses limites , et un de vos membres a trouvé ces limites !^^

Mieux vaut utiliser les outils mis a disposition (modules JS) ...

D'ailleurs , le tuto originel ( http://forum.forumactif.com/t223082-banniere-aleatoire-ou-defilante ) préconise de passer par les modules .

Avant les modules , on prenait l'habitude (mauvaise habitude) de passer par les balises meta pour les scripts ... au dépend des moteurs de recherches .

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum