problème infobulle

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu problème infobulle

Message par Loü le Mar 26 Jan 2016 - 20:27

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome, Internet Explorer, Opera, Safari, Autre
Personnes concernées par le problème : Tous les utilisateurs
Lien du forum : http://scarymovie.forumactif.org

Description du problème

Bonsoir Very Happy

Encore une fois je viens quémander votre aide pour un problème de codage sur mon forum. J'ai voulu mettre le nombre de sujets et messages en infobulle sur l'avatar du dernier posteur... Globalement j'ai trouvé comment faire mais je n'arrive pas à enlever une petite barre noire qui s'affiche au dessus de mon texte (dans l'infobulle).

Ci dessous mon template modifié + css associé :

Spoiler:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
<tr>
<td valign="bottom">
<!-- BEGIN switch_user_logged_in -->

<!-- END switch_user_logged_in -->
<div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
</td>

</tr>
</table>
<!-- BEGIN catrow --><table class="forumline" width="100%" border="0" cellspacing="7" cellpadding="5" id="categories">
<!-- BEGIN cathead -->
<tr>
<td class="{catrow.cathead.CLASS_CAT}" colspan="3" width="100%">
<h{catrow.cathead.LEVEL} class="hierarchy">
<span class="cattitle">
<a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
</span>
</h{catrow.cathead.LEVEL}>
</td>
</tr>
<!-- END cathead -->
<!-- BEGIN forumrow -->
<tr>
<td class="newpost" align="center" valign="middle">
<img class="imgnewpost" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
<span id="lastpost" class="gensmall"><br /><br />{catrow.forumrow.LAST_POST}</span>
</td>

<td valign="top" width="100%" class="descriptions">
<div class="forumlink"><a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a></div>
<div class="description"><span class="genmed">{catrow.forumrow.FORUM_DESC}</span></div><div id="details" class="gensmall">
<div id="details" class="gensmall">
<span id="lienssousforums"><div style="font-size:9px;text-transform:uppercase;color:#000000;">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</div>
<script type="text/javascript">
jQuery('#lienssousforums').html(jQuery('#lienssousforums').html().replace(/, /g,' ☠ ')).removeAttr('id');
</script>
</span>
</div>
</div>


</td><td align="center" valign="middle"><div class="infobulle"> <div class="lastpost-avatar"><!-- BEGIN avatar -->{catrow.forumrow.avatar.LAST_POST_AVATAR}<!-- END avatar --></div>
<span><div class="messages"><span id="nbposts" class="gensmall"><b>{catrow.forumrow.POSTS}</b> messages → <b>{catrow.forumrow.TOPICS}</b> sujets</span></div></span></div>

</td>
</tr>
<!-- END forumrow -->
<!-- BEGIN catfoot -->
<tr>
<!-- BEGIN inc -->
<td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
<!-- END inc -->
<td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
</tr>
<!-- END catfoot -->
<!-- BEGIN tablefoot -->
</table><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->

Spoiler:
/*infobulles nombre de messages et sujets*/
.infobulle{position: relative;z-index: 0;}

.infobulle:hover{background-color: transparent;z-index: 50;}

.infobulle span{
position: absolute;
background-color: #000000;
padding: 5px;
left: -1000px;
visibility: hidden;
color: #D1815B;}

.infobulle span img{
border: 0px;
padding: 0px;}

.infobulle:hover span{
visibility: visible;
top: 30px;
left: 3px;
width: 60px ;
color:#D1815B;
border: 1px solid #000000;}

Merci beaucoup à tous ceux qui tenteront de m'éclairer Razz


Dernière édition par Loü le Ven 5 Fév 2016 - 0:51, édité 1 fois

Loü
***

Messages : 126
Inscrit(e) le : 28/01/2010

Loü a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème infobulle

Message par demeter1 le Mar 26 Jan 2016 - 20:43

Lou, sous opera il n'y a aucune infobulle sur l'avatar du dernier posteur. j'ai voulu aller analyser la séquence mais n'ayant rien vu.....

demeter1
+ Hyperactif +

Masculin
Messages : 8107
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème infobulle

Message par Loü le Mar 26 Jan 2016 - 20:51

Ah bon ? Pourtant je suis sur Opera et ça fonctionne bien chez moi...

Loü
***

Messages : 126
Inscrit(e) le : 28/01/2010

Loü a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème infobulle

Message par demeter1 le Mar 26 Jan 2016 - 20:57

strange !!!! en allant par exemple sur ce sujet http://scarymovie.forumactif.org/t27-promotion-fiche-de-publicite

voici ce que j'ai en passant sur l'avatar


demeter1
+ Hyperactif +

Masculin
Messages : 8107
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème infobulle

Message par Loü le Mar 26 Jan 2016 - 20:58

Ah non, effectivement. Je parle de l'avatar du dernier poster sur l'index du forum (qui lui même est caché sous une image d'ailleurs xd) Very Happy

Loü
***

Messages : 126
Inscrit(e) le : 28/01/2010

Loü a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème infobulle

Message par Loü le Mar 26 Jan 2016 - 20:58

Ah non, effectivement. Je parle de l'avatar du dernier posteur sur l'index du forum (qui lui même est caché sous une image d'ailleurs xd) Very Happy

Loü
***

Messages : 126
Inscrit(e) le : 28/01/2010

Loü a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème infobulle

Message par Loü le Jeu 28 Jan 2016 - 3:15

UP ? Very Happy

Loü
***

Messages : 126
Inscrit(e) le : 28/01/2010

Loü a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème infobulle

Message par Loü le Lun 1 Fév 2016 - 14:02

UP ?

Loü
***

Messages : 126
Inscrit(e) le : 28/01/2010

Loü a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème infobulle

Message par tupac le Mar 2 Fév 2016 - 1:37

Bonsoir,

Vous avez juste des SPAN en trop dans votre codage.

Il sont indiqués en rouge dans le morceau suivant ,à vous de les retirer.
Spoiler:
<span><div class="messages"><span id="nbposts" class="gensmall"><b>{catrow.forumrow.POSTS}</b> messages → <b>{catrow.forumrow.TOPICS}</b> sujets</span></div></span></div>

tupac
+ Hyperactif +

Masculin
Messages : 2331
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème infobulle

Message par Loü le Ven 5 Fév 2016 - 0:51

Merci beaucoup, le problème est résolu. Very Happy

Loü
***

Messages : 126
Inscrit(e) le : 28/01/2010

Loü a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum