Problème avec des codes sur la chatbox

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec des codes sur la chatbox

Message par Stankiller le Sam 27 Fév 2016 - 23:00

Bonsoir.

J'ai voulu rajouter des codes Javascript/CSS pour la chatbox de mon forum grâce à ce tutoriel >> http://forum.forumactif.com/t376396-codes10-pour-la-chatbox

Cependant, après avoir rajouté tous les codes CSS et Javascript ces codes ne s'effectuent pas, rien ne change sur la chatbox de mon forum. Mon forum est sous invision c'est peut-être la cause mais normalement si j'ai bien compris ces codes devraient s'appliquer pour n'importe quelle version. Voici les codes que j'ai dans ma feuille CSS >>

http://image.noelshack.com/fichiers/2016/08/1456610217-panneau.png

Code:
body.chatbox img { vertical-align: 0px; }
    /* invision : mis à la ligne de base */
   
    .post-entry img { vertical-align: baseline; }
    .msg img {
    vertical-align: middle;
    }
/*Trait sous pseudo*/
a:link, a:visited, a:hover, a:active, a:focus {
 
  text-decoration: none;
}
 
a:hover {
 
  font-style:italic;
}
 
a:hover {
 
  text-decoration: none !important;
}
/*Fin trait*/

                  #chatbox .user-msg .user, #chatbox .user-msg .msg {
        display: inline;
    }

    #chatbox .cb-avatar > img{ border-radius: 50% !important; }

    #chatbox .cb-avatar { background: transparent !important; box-shadow: none !important; }
    body #chatbox .cb-avatar { border: none !important; /*retirer la bordure*/ }

    #chatbox .cb-avatar, #chatbox .cb-avatar > img { width: 50px !important; height: 50px !important; }

Voici désormais le code que j'ai inséré dans ma page javascript :

http://image.noelshack.com/fichiers/2016/08/1456610332-chatbox.png

Code:
$(window).load(function() {
  var chatbox_script = function() {
 
    var default_avatar = '';
    var ava_in_member_list = true;
    var ava_in_indirect_message = true;
 
    var avatars = {};
    var d;
    var set_avatar = function(pseudo, elem_to_prepend){

    #chatbox_members .cb-avatar > img {
      height:30px;width:30px;
      vertical-align: middle;
    }

Je ne vois vraiment pas ce qu'il manque.
Merci de m'éclairer là-dessus, je vous remercie de votre compréhension.
Bonne soirée.


Dernière édition par Stankiller le Lun 29 Fév 2016 - 16:33, édité 1 fois

Stankiller
**

Messages : 63
Inscrit(e) le : 14/06/2011

http://royal-universe.forum-gratuit.net/
Stankiller a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec des codes sur la chatbox

Message par Stankiller le Sam 27 Fév 2016 - 23:29

J'ai réussi à exécuter tous les codes.
Cependant, un trait blanc assez horrible s'affiche que faire pour le supprimer ?
http://image.noelshack.com/fichiers/2016/08/1456612070-bug.png
En plus de cela les avatars ont du mal à s'afficher.

Stankiller
**

Messages : 63
Inscrit(e) le : 14/06/2011

http://royal-universe.forum-gratuit.net/
Stankiller a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec des codes sur la chatbox

Message par winatickets le Dim 28 Fév 2016 - 21:22

Bonsoir

Pour commencer pour enlever ce trait blanc il faudrai limite que tu mette image de fon toutes noirs tu n'aurai plus le soucis des traits, de plus demain je passerai par la pour te mettre le code si tu ne la pas, par contre en ce quoi concerne code tchatbox ou autre j'ai besoin :

Fait une capture de tout ton css, ensuite donne moi les code javascript que tu a activer et présise si tu les a activer sur toutes les pages ou non

amicalement serge
( ps : jsuis pas fan du tout d'un tchat noir car pour moi cela ne rend en aucun cas un forum esthétique, évidement ci celui ci est noir cela reste logique mais moi sa me fait peur mdr) voila
Je re demain pour t'aider si tu a mis les codes demandé .....

winatickets
****

Messages : 221
Inscrit(e) le : 20/02/2015

http://winatickets.forumactif.org
winatickets a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec des codes sur la chatbox

Message par Stankiller le Lun 29 Fév 2016 - 5:44

Voici les codes de la feuille CSS :

Code:
body.chatbox img { vertical-align: 0px; }
    /* invision : mis à la ligne de base */
   
    .post-entry img { vertical-align: baseline; }
    .msg img {
    vertical-align: middle;
    }
/*Trait sous pseudo*/
a:link, a:visited, a:hover, a:active, a:focus {
 
  text-decoration: none;
}
 
a:hover {
 
  font-style:italic;
}
 
a:hover {
 
  text-decoration: none !important;
}
/*Fin trait*/

                  #chatbox .user-msg .user, #chatbox .user-msg .msg {
        display: inline;
    }

    #chatbox .cb-avatar > img{ border-radius: 50% !important; }

    #chatbox .cb-avatar { background: transparent !important; box-shadow: none !important; }
    body #chatbox .cb-avatar { border: none !important; /*retirer la bordure*/ }

    #chatbox .cb-avatar, #chatbox .cb-avatar > img { width: 50px !important; height: 50px !important; }
/* Ligne de séparation */
#chatbox > p {
  border-bottom: 1px solid #010101;
}
/* Calque des avatars */
 
#chatbox .cb-avatar {
  float: left;
  margin-right: 4px;
  background: none repeat scroll 0 0 #fff;
  border: 1px solid #d5d5d5 !important; /* Bordure */
  box-shadow: 0 2px 2px rgba(0, 0, 0, 0.1);
  height: 30px;
  padding: 1px;
  vertical-align: middle;
  width: 30px;
}

Le code Javascript :

Code:
$(window).load(function() {
  var chatbox_script = function() {
 
    var default_avatar = 'http://imagerespawn.jeuxvideo.com/avatars/default.jpg';
    var ava_in_member_list = true;
    var ava_in_indirect_message = true;
 
    var avatars = {};
    var d;
    var set_avatar = function(pseudo, elem_to_prepend){

    #chatbox_members .cb-avatar > img {
      height:30px;width:30px;
      vertical-align: middle;
    }

Je l'ai activé sur toute les pages et c'est le seul qu'il y a sur mon forum.

Le lien de mon forum : http://royal-universe.forum-gratuit.net/

Stankiller
**

Messages : 63
Inscrit(e) le : 14/06/2011

http://royal-universe.forum-gratuit.net/
Stankiller a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec des codes sur la chatbox

Message par Stankiller le Lun 29 Fév 2016 - 16:33

C'est bon j'ai trouvé la solution à mon problème !
Le code qu'il fallait insérer est celui-là :

Code:
#chatbox > p {
      border: none !important;
    }

Je fais passer le topic en résolu.

Stankiller
**

Messages : 63
Inscrit(e) le : 14/06/2011

http://royal-universe.forum-gratuit.net/
Stankiller a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum