Précharger images de fond de tableaux "display: none"

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Précharger images de fond de tableaux "display: none"

Message par alv le Ven 25 Mar 2016 - 12:01

Rappel du premier message :

Bonjour,
Sur mon forum, j'ai fait un bandeau avec des liens à survoler. Au survol de chaque lien, un tableau apparaît. Chaque tableau a 2 colonnes qui ont chacune leur image de fond.
Par défaut, les tableaux sont en "display: none". Au survol d'un lien, le tableau devient "display: table". Le problème est que le "display: none" fait que les images de fond ne se chargent que quand les tableaux apparaissent (avec un délai de quelques millisecondes pour que les images de fond apparaissent), alors que je souhaiterais que les images de fond apparaissent immédiatement, sans délai de chargement.

Comment précharger les images de fond contenu dans un tableau en "display: none" ? Ou il faut ne pas utiliser de display ?
Merci d'avance.

Voici mon code (template overall_header) :
Spoiler:
CSS :
Spoiler:

J'ai essayé de précharger comme ceci (mais ça n'a rien changé) :
Spoiler:


Dernière édition par alv le Lun 18 Avr 2016 - 18:05, édité 1 fois

alv
# Tropactif #

Messages : 1080
Inscrit(e) le : 09/07/2012

http://urlz.fr/2OYC
alv a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Précharger images de fond de tableaux "display: none"

Message par alv le Lun 18 Avr 2016 - 11:51

Up

alv
# Tropactif #

Messages : 1080
Inscrit(e) le : 09/07/2012

http://urlz.fr/2OYC
alv a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Précharger images de fond de tableaux "display: none"

Message par MlleAlys le Lun 18 Avr 2016 - 16:50

rebonjour,
et en passant par la propriété visibility plutôt que display, ça devrait fonctionner non ?

MlleAlys
+ Hyperactif +

Messages : 4340
Inscrit(e) le : 12/09/2012

MlleAlys a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Précharger images de fond de tableaux "display: none"

Message par alv le Lun 18 Avr 2016 - 18:04

Bonjour,
C'est nickel. J'avais testé mais ça mettait quand même du temps à charger les images de fond. Depuis j'avais modifié le template et je n'avais pas réessayé.
Merci MlleAlys.

résolu

alv
# Tropactif #

Messages : 1080
Inscrit(e) le : 09/07/2012

http://urlz.fr/2OYC
alv a été remercié(e) par l'auteur de ce sujet.

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum