Problème de script pour le ''Panneau latéral coulissant''

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème de script pour le ''Panneau latéral coulissant''

Message par Rich Bloodstone le Jeu 9 Juin 2016 - 1:01

Détails techniques


Version du forum : phpBB2
Poste occupé : Administrateur
Navigateur(s) concerné(s) : Mozilla Firefox
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : Aujourd'hui
Lien du forum : (lien masqué, vous devez poster pour le voir)

Description du problème

Bonjour à vous,
En fait j'ai 3 petits problèmes qui sont tous relier. Le premier est au sujet de mes images avec des contour blanc alors qu'elles sont sur font transparent (images en png). J'ai d'abord cru que c'était l'hébergeur Servimg qui en était la cause, mais non. Mon 2ème problème est au sujet du ''Panneau latéral coulissant''. J'ai suivi le tutoriel et il ne fonctionne qu'a moitié puisqu'une foi fermé,je dois toujours actualiser ma page pour qu'il puisse ouvrir à nouveau. Et pout finir,je me retrouve avec 2 Chat Box. Celle activé dans mon panneau de configuration et celle du panneau latéral coulissant.

Voici mon script:

Code:
jQuery(document).ready(function () {
        jQuery('body').append('<table style="position: fixed; bottom: 50px; left: 0px;background-color: #ffffff;z-index:10000;"><tr><td><div id="panneau" scrolling="no" style="width: 800px; height: 400px; display: none;" marginwidth="0" marginheight="0" frameborder="0"><iframe src="/chatbox/index.forum?page=front" style="width: 800px; height: 400px;" ></iframe></div></td><td style="vertical-align: bottom;"><img src="http://i.imgur.com/bxVmNjN.png" onClick="document.getElementById(\'panneau\').style.display=(this.src==\'http://i.imgur.com/bxVmNjN.png\')?\'block\':\'none\';this.src=(this.src==\'http://i.imgur.com/bxVmNjN.png\')?\'http://ahp.li/7227f657ba2edfb09c8c.png\':\'http://ahp.li/7227f657ba2edfb09c8c.png\';"/></td></tr></table>');
    });


J'ai grand besoin d'aide s.v.p! Merci


Dernière édition par Rich Bloodstone le Sam 11 Juin 2016 - 2:24, édité 1 fois

Rich Bloodstone
Nouveau membre

Messages : 26
Inscrit(e) le : 08/06/2016

http://vikings.tropfun.net/
Rich Bloodstone a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script pour le ''Panneau latéral coulissant''

Message par Toryudo le Jeu 9 Juin 2016 - 21:55

Bonjour !

Alors, d'après ce que je vois du code :

1) le fond blanc est là à cause du background-color: #ffffff; présent dans votre code.
Il suffira de le retirer pour que le blanc disparaisse.

2) Modifiez la fin de votre code en :
Code:
this.src=(this.src==\'http://i.imgur.com/bxVmNjN.png\')?\'http://ahp.li/7227f657ba2edfb09c8c.png\':\'http://i.imgur.com/bxVmNjN.png\';
On remet alors l'image en "situation initiale" lorsqu'on referme la chatbox.

3) Je pense qu'il est possible de retirer la chatbox dans le panneau des administrateurs, à voir, je ne sais plus où cette option se trouve.


En résumé, le code final doit donner ça :
Code:
jQuery(document).ready(function(){jQuery('body').append('<table style="position: fixed; bottom: 50px; left: 0px;z-index:10000;"><tr><td><div id="panneau" scrolling="no" style="width: 800px; height: 400px; display: none;" marginwidth="0" marginheight="0" frameborder="0"><iframe src="/chatbox/index.forum?page=front" style="width: 800px; height: 400px;" ></iframe></div></td><td style="vertical-align: bottom;"><img src="http://i.imgur.com/aIZuuVc.png" onClick="document.getElementById(\'panneau\').style.display=(this.src==\'http://i.imgur.com/aIZuuVc.png\')?\'block\':\'none\';this.src=(this.src==\'http://i.imgur.com/aIZuuVc.png\')?\'http://ahp.li/7227f657ba2edfb09c8c.png\':\'http://i.imgur.com/aIZuuVc.png\';"/></td></tr></table>')});

En espérant vous avoir aidé ! Very Happy

Toryudo
**

Masculin
Messages : 53
Inscrit(e) le : 09/06/2016

http://www.deus-academia.com
Toryudo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script pour le ''Panneau latéral coulissant''

Message par Rich Bloodstone le Ven 10 Juin 2016 - 2:41

Bonjour Toryudo,
WoW! 2 sur 3 c'est très bon comme moyenne.
Un gros merci pour ton aide,c'est vraiment aprécié.
J'ai encore tenté de retirer la Chat Box comme tu m'as demandé,
c'est à dire,désactiver la Chat Box dans Modules,Chat Box,configuration,
mais rien à faire. Est-ce que tu as d'autres solutions?

J'attends de tes nouvelles.

Rich Bloodstone
Nouveau membre

Messages : 26
Inscrit(e) le : 08/06/2016

http://vikings.tropfun.net/
Rich Bloodstone a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script pour le ''Panneau latéral coulissant''

Message par Oka.mi le Ven 10 Juin 2016 - 21:50

Hello,

Il ne faut pas désactiver la Chatbox, puisque vous ne l'aurez plus nulle part.
Vous devez seulement régler l'Affichage de la chatbox juste en-dessous -> Ne pas afficher

Oka.mi
# Tropactif #

Féminin
Messages : 1328
Inscrit(e) le : 06/01/2011

http://www.deus-academia.com
Oka.mi a été remercié(e) par l'auteur de ce sujet.

Résolu L'affichage de la Chat Box

Message par Rich Bloodstone le Sam 11 Juin 2016 - 0:22

Bonsoir Oka.mi,
j'ai choisi l'option ne pas afficher comme tu me l'as demandé mais ça ne fonctionne pas Sad
les 2 sont toujours présentes.

Rich Bloodstone
Nouveau membre

Messages : 26
Inscrit(e) le : 08/06/2016

http://vikings.tropfun.net/
Rich Bloodstone a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script pour le ''Panneau latéral coulissant''

Message par Oka.mi le Sam 11 Juin 2016 - 0:43

Je sais que ça peut paraître bête, mais êtes-vous sûr d'avoir cliqué sur "Valider" après votre choix ?
Car sur votre forum, j'aperçois la chatbox comme réglée sur "bottom".

Avez-vous modifié le template index_body ? Si oui, j'aimerais bien y jeter un coup d'œil.

Oka.mi
# Tropactif #

Féminin
Messages : 1328
Inscrit(e) le : 06/01/2011

http://www.deus-academia.com
Oka.mi a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de script pour le ''Panneau latéral coulissant''

Message par Rich Bloodstone le Sam 11 Juin 2016 - 2:23

Bonsoir Oka_mi,
Oui effectivement elle était réglée sur "bottom".
J'avais oublié d'actualiser la page avant d'effectuer la correction.
C'est mon erreur désolé. Un gros MERCI Oka_mi!
Problème résolu.

Rich Bloodstone
Nouveau membre

Messages : 26
Inscrit(e) le : 08/06/2016

http://vikings.tropfun.net/
Rich Bloodstone a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum