Script qui ne marche que pour moi (admin)

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Script qui ne marche que pour moi (admin)

Message par Master Darek le Ven 24 Juin 2016 - 14:44

Détails techniques


Version du forum : phpBB3
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : Depuis insertion du script
Lien du forum : http://rpgo.forumgratuit.org/

Description du problème

Bonjour,

Je suis le fondateur et l'administrateur d'un petit forum de JdR privé sur lequel je joue avec mes amis depuis plusieurs années. Hier j'ai trouvé un script qui me permet de convertir les caractères d'un texte en ceux d'un autre alphabet, grâce à la balise "font". Le script en fait appel à un autre qui se trouve sur un site extérieur et transforme un texte normal en texte écrit en elfique ou en runes, par exemple.

Ce script, qui est comme ceux qu'on peut trouver sur "google fonts" pour importer des polices de caratères, marche très bien chez moi mais aucun de mes quatre joueurs (membres du forum donc) n'en voit les effets : le texte leur apparaît écrit normalement quoi que je fasse.

J'ai commencé par mettre le script à travers les options disponibles sur le panneau d'administration (appliqué "sur toutes les pages"), puis quand j'ai su qu'ils ne voyaient rien je l'ai directement écrit dans le template "overall_header". Je leur ai ensuite demandé de vider leur cache et de redémarrer leur navigateur mais rien n'y fait. Quand j'inspecte le code source de ma page d'accueil je vois bien le script en entier. Il en va de même pour eux, je leur ai demandé de regarder pour moi.

A partir de là je ne sais plus comment faire. Mon forum est en phpBB3, j'utilise Firefox. Eux ont tous Chrome.
(Edit : Une des membres a aussi Firefox, en fait, mais le problème est le même chez elle, bien que cela m'aurait étonné que le problème soit dû au navigateur...)

Merci pour vos réponse !

Master Darek
Nouveau membre

Messages : 3
Inscrit(e) le : 24/06/2016

http://rpgo.forumgratuit.org/
Master Darek a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Script qui ne marche que pour moi (admin)

Message par Master Darek le Mar 28 Juin 2016 - 11:22

Up.

Personne n'aurait un début de réponse, des pistes ? Smile

Master Darek
Nouveau membre

Messages : 3
Inscrit(e) le : 24/06/2016

http://rpgo.forumgratuit.org/
Master Darek a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Script qui ne marche que pour moi (admin)

Message par tupac le Mar 28 Juin 2016 - 17:16

Bonjour,

Avec les codes en nôtre possession on aurait pu y voir un peu plus clair Wink
Bon je n'ai pas vu le code mais je pense que le script contient les polices elfique et runes d'on vous parlez donc ma question est la suivante, les membres ont-ils téléchargés ces fameuses polices sur leurs PC ? si ce n'est pas le cas il faudrait surement le faire.

tupac
+ Hyperactif +

Masculin
Messages : 2334
Inscrit(e) le : 13/10/2010

tupac a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Script qui ne marche que pour moi (admin)

Message par Master Darek le Mar 28 Juin 2016 - 18:14

Mon dieu que je suis stupide. Rolling Eyes

Je comprends ce qui ne va pas à présent, merci. C'était pourtant évident. En effet les polices des scripts qui marchent chez moi sont aussi installées dans mon répertoire fonts de windows, et j'avais oublié ce détail capital... J'étais persuadé que comme pour google fonts c'était la page web qui allait charger les polices d'écriture pour les membres, mais en fait je n'ai qu'un script qui pointe vers un fichier .js extérieur, et non pas vers une feuille de style.

Master Darek
Nouveau membre

Messages : 3
Inscrit(e) le : 24/06/2016

http://rpgo.forumgratuit.org/
Master Darek a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum