L'image ne s'affiche pas dans les MP

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu L'image ne s'affiche pas dans les MP

Message par Elfette7 le Jeu 4 Aoû 2016 - 13:15

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : Je pense que le problème est présent depuis le début du forum, je n'ai pas de souvenir précis d'avant, mais il me semble ne jamais avoir vu les images directement en MP.
Lien du forum : http://lovinghome.bbactif.com/

Description du problème

Bonjour tout le monde Smile

D'avance un tout grand merci à ceux qui liront et accorderont de l'attention à mon message.

Je me tourne vers vous car aujourd'hui je rencontre un problème sur mon forum. Aujourd'hui, ou je pense toujours depuis sa création il y a un peu plus de six mois (dans mes souvenirs, ça n'a jamais fonctionné).

En effet, quand je reçois un message avec une image intégrée (moi ou quelqu'un d'autre, j'ai testé avec ma co-admin qui rencontre le même souci apparemment quand je lui ai envoyé une image) je ne la vois pas, j'ai un espace vide comme l'image que je vous ai jointe ci-dessus. Le code noté est le code qui est repris juste au dessus de la balise code et qui n'est donc pas affiché, comme vous pouvez le constater.

En revanche, lorsque je clique sur répondre ou citer, je vois l'image dans l'historique en dessous :


C'est assez contraignant et je ne parviens pas à comprendre d'où peut venir le problème.
J'ai testé sur Mozilla Firefox, et l'image ne s'affiche pas non plus dans le MP.
J'ai également testé sans AdBlock, le souci reste le même.

Sur l'ensemble du forum, je ne rencontre pas le souci. Si je poste le même lien dans un sujet, ça marche sans problème. Et on voit que le lien est bon, vu qu'il s'affiche une fois qu'on a cliqué sur "répondre" ou sur "citer" :/


D'avance un très grand merci à vous !


Dernière édition par Elfette7 le Jeu 4 Aoû 2016 - 20:03, édité 1 fois

Elfette7
Nouveau membre

Féminin
Messages : 6
Inscrit(e) le : 04/08/2016

http://lovinghome.bbactif.com/
Elfette7 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: L'image ne s'affiche pas dans les MP

Message par Walt le Jeu 4 Aoû 2016 - 17:01

Bonjour,

L'image est bien dans le message mais une instruction CSS la cache. Cette instruction est contenue dans le CSS de base, ce qui signifie que ce n'est pas le comportement normalement attendu. J'ai fait quelques tests (d'où mon inscription), et il s'avère que c'est un script personnalisé qui est à l'origine du problème, a priori c'est le script qui permet de rajouter un enregistrement de messages dans l'éditeur.

Or, puisque sur la page de lecture d'un message il n'y a pas d'éditeur de texte, le script plante avant la fin, et bloque les scripts suivants. Deux solutions : soit vous supprimez ce script, soit il faut le modifier pour le rendre fonctionnel, auquel cas il va m'en falloir copie.

Cordialement,

Walt
Modéractif
Modéractif

Masculin
Messages : 1432
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: L'image ne s'affiche pas dans les MP

Message par Elfette7 le Jeu 4 Aoû 2016 - 18:14

Bonjour Walt et un grand merci pour votre passage, votre test et votre explication.


Effectivement en supprimant le script de sauvegarde du message en cours ça fonctionne (et mille merci d'avoir trouvé ça Smile)

Je peux vous copier le script ici, ce serait super si vous saviez le "réparer", si pas ce n'est pas grave on fera sans ! Smile


En tout cas, un grand merci pour la rapidité Smile


Le script :
Code:
var messageSaver=function(e,t){"use strict";var n=function(t){t=t.replace(/[\[]/,"\\[").replace(/[\]]/,"\\]");var n="[\\?&]"+t+"=([^&#]*)",r=new RegExp(n),i=r.exec(window.location.href),s=e("#text_editor_textarea").siblings('input[name="'+t+'"]').val();return i===null?s:i[1]};var r=function(e,t,n,r){var i={userID:e,topicURL:r,message:t};localStorage.setItem(n,JSON.stringify(i))};var i=function(e,t,n,r){var i,o="\nIl n'y a pas de message à charger.",u=localStorage.getItem(n);if(u!="undefined"){i=JSON.parse(u);s(e,t.val(),n,r)?t.val(i.message):alert("Erreur 1:\nLa vérification du message enregistré a échoué.")}else alert("Erreur 2: Il n'y a aucun message sauvegardé dans le WebStorage")};var s=function(e,t,n,r){var i,s=localStorage.getItem(n);if(s!="undefined"){i=JSON.parse(s);return i.userID===e&&i.topicURL===r&&t===""?true:false}else return false};var o=function(){var t=window.location.host,s=_userdata.user_id,o=n("t"),u=e('form[action="/post"]'),a=u.find('input[name="post"]'),f=e("#text_editor_textarea").sceditor("instance");f.bind("keyup",function(){r(s,f.val(),t,o)});if(localStorage.getItem(t)){a.before('<input type="button" class="mainoption btn-loader" id="ms-loader" value="Charger le message sauvegardé" /> &nbsp;')}u.on("click","#ms-loader",function(){i(s,f,t,o)})};return{init:o}}(jQuery);$(window).load(function(){typeof _userdata=="undefined"?console.log("L'objet \"_userdata\" de forumactif n'a pas été trouvé. Le script de sauvegarde des messages en cours d'écriture ne peut pas fonctionner."):messageSaver.init()})

Elfette7
Nouveau membre

Féminin
Messages : 6
Inscrit(e) le : 04/08/2016

http://lovinghome.bbactif.com/
Elfette7 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: L'image ne s'affiche pas dans les MP

Message par Walt le Jeu 4 Aoû 2016 - 18:19

Essayez de le remplacer par ceci :

Code:
if($("#text_editor_textarea").length > 0) {
    var messageSaver = function(e, t) {
        "use strict";
        var n = function(t) {
            t = t.replace(/[\[]/, "\\[").replace(/[\]]/, "\\]");
            var n = "[\\?&]" + t + "=([^&#]*)",
                r = new RegExp(n),
                i = r.exec(window.location.href),
                s = e("#text_editor_textarea").siblings('input[name="' + t + '"]').val();
            return i === null ? s : i[1]
        };
        var r = function(e, t, n, r) {
            var i = {
                userID: e,
                topicURL: r,
                message: t
            };
            localStorage.setItem(n, JSON.stringify(i))
        };
        var i = function(e, t, n, r) {
            var i, o = "\nIl n'y a pas de message à charger.",
                u = localStorage.getItem(n);
            if (u != "undefined") {
                i = JSON.parse(u);
                s(e, t.val(), n, r) ? t.val(i.message) : alert("Erreur 1:\nLa vérification du message enregistré a échoué.")
            } else alert("Erreur 2: Il n'y a aucun message sauvegardé dans le WebStorage")
        };
        var s = function(e, t, n, r) {
            var i, s = localStorage.getItem(n);
            if (s != "undefined") {
                i = JSON.parse(s);
                return i.userID === e && i.topicURL === r && t === "" ? true : false
            } else return false
        };
        var o = function() {
            var t = window.location.host,
                s = _userdata.user_id,
                o = n("t"),
                u = e('form[action="/post"]'),
                a = u.find('input[name="post"]'),
                f = e("#text_editor_textarea").sceditor("instance");
            f.bind("keyup", function() {
                r(s, f.val(), t, o)
            });
            if (localStorage.getItem(t)) {
                a.before('<input type="button" class="mainoption btn-loader" id="ms-loader" value="Charger le message sauvegardé" /> &nbsp;')
            }
            u.on("click", "#ms-loader", function() {
                i(s, f, t, o)
            })
        };
        return {
            init: o
        }
    }(jQuery);
    $(window).load(function() {
        typeof _userdata == "undefined" ? console.log("L'objet \"_userdata\" de forumactif n'a pas été trouvé. Le script de sauvegarde des messages en cours d'écriture ne peut pas fonctionner.") : messageSaver.init()
    })
}

Walt
Modéractif
Modéractif

Masculin
Messages : 1432
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: L'image ne s'affiche pas dans les MP

Message par Elfette7 le Jeu 4 Aoû 2016 - 18:24

Bonsoir Smile

Je viens d'essayer mais ce n'est pas le même résultat.

Le premier script que j'avais permettait de sauvegarder le message en cours d'écriture, de cette manière, lors d'un retour arrière fait par erreur, lorsqu'on revenait sur l'éditeur de message on avait un bouton "charger le message sauvegarder" et ce qu'on était en train d'écrire revenait Smile

Ici le script que je viens d'installer m'offre un bouton "Brouillon" uniquement au centre, qui permet de sauvegarder en brouillon si on clique sur le bouton "Brouillon" au centre. Rien d'autre :/
Et je crois que le bouton Brouillon est par défaut :/


Bien à vous Smile Merci encore !

Elfette7
Nouveau membre

Féminin
Messages : 6
Inscrit(e) le : 04/08/2016

http://lovinghome.bbactif.com/
Elfette7 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: L'image ne s'affiche pas dans les MP

Message par Walt le Jeu 4 Aoû 2016 - 18:37

Dans ce cas, remettez le script précédent et décochez toutes les cases d'affichage, de sorte que ce script ne soit plus chargé sur aucune page. Une fois enregistré, retenez le lien du script (quelque chose comme adresseduforum.forumactif.com/12000.js)

Ensuite, créez un nouveau javascript en cochant l'affichage sur "Toutes les pages" et insérez-y :
Code:
if($("#text_editor_textarea").length > 0) {
  $.getScript('http://adresseduforum.forumactif.com/12000.js');
}

Et en prenant soin de remplacer le lien dans le script par celui noté précédemment.

Cordialement,

Walt
Modéractif
Modéractif

Masculin
Messages : 1432
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: L'image ne s'affiche pas dans les MP

Message par Elfette7 le Jeu 4 Aoû 2016 - 19:57

Je vais essayer Smile

Hélas, ça ne fonctionne pas non plus Sad
Ce n'est pas grave, ne vous en faites pas Smile Je vais enlever ce script Smile


Merci infiniment pour votre aide !


Bonne soirée Thanks

Elfette7
Nouveau membre

Féminin
Messages : 6
Inscrit(e) le : 04/08/2016

http://lovinghome.bbactif.com/
Elfette7 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum