@font-face ne fonctionne pas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 2:07

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome
Personnes concernées par le problème : Tous les utilisateurs
Lien du forum : http://ac-project.fra.co/

Description du problème

Bonjour,

J'ai actuellement un problème avec le @font-face. J'ai bien-sur suivi tous les tutoriels du forums et ceux aussi des sites externes mais je n'ai pas réussi à implanter ma polices d'écritures.
Je dispose d'un serveur externe ou ce trouve ma police, j'ai inséré ce code .css
Code:
@font-face {
   font-family: 'R&C Demo';
   src: url('R&C-Demo.eot');
   src: url('R&C-Demo.eot?#iefix') format('embedded-opentype'),
      url('R&C-Demo.woff') format('woff'),
      url('R&C-Demo.ttf') format('truetype');
   font-weight: normal;
   font-style: normal;
}

Sauf que celui ne souhaite pas être exécuté sur la page de demo
http://forumressources.hol.es/demo.html

J'ai mis au cas ou le code suivant de le overall_header en dessous de </head>
Code:
  <link rel="stylesheet" href="http://forumressources.hol.es/stylesheet.css" />

Mais hélas sans succès, je ne sais plus quoi faire donc je viens ici pour que l'on puisse m'éclairé Smile

Merci d'avance pour vos réponses !


Dernière édition par Ozsi-sun le Dim 6 Nov 2016 - 15:11, édité 1 fois
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par snakefl1984 le Dim 6 Nov 2016 - 10:32

bonjour , tu nous dit que tu a heberger ta police sur un site externe , d'accord , mais dans ton code CSS , la tu demande a charger la police seulement sur le serveur parent , donc celui de forum actif
ce qui est a modifier
Code:
  src: url('R&C-Demo.eot');
  src: url('*************************R&C-Demo.eot?#iefix') format('embedded-opentype'),
      url('*************************R&C-Demo.woff') format('woff'),
      url('*************************R&C-Demo.ttf') format('truetype');

la ou j'ai rajouter ************************* , tu devra donner un acces a tes police ,

admettons que tu a mis cela sur un site d'hébergement ou même un serveur privee, cela donnerais quelque chose comme cela ,

monserveur/mondossier/mespolices/R&C-Demo/et ici tous les fichier qui sont demandée par le script

monserveur souvent des addresse ip , ou si tu possede un dns un nom simple pour retrouver et acceeder a ton serveur privee disont "192.192.192.192"
mon dossier dossier ou se trouverais toutes amelioration externe a ton forum disont "forum ac-projet"
mespolices dossier ou tu stock dedans toutes tes police differente " police "

donc ton codage devrais ressembler a cela

Code:
src: url('192.192.192.192/forum ac-projet/police/R&C-Demo/R&C-Demo.eot');
  src: url('192.192.192.192/forum ac-projet/police/R&C-Demo/R&C-Demo.eot?#iefix') format('embedded-opentype'),
      url('192.192.192.192/forum ac-projet/police/R&C-Demo/R&C-Demo.woff') format('woff'),
      url('192.192.192.192/forum ac-projet/police/R&C-Demo/R&C-Demo.ttf') format('truetype');

ce n'est qu'un exemple bien sur

avatar

snakefl1984
**

Masculin
Messages : 71
Inscrit(e) le : 05/08/2016

http://test1984.forumactif.org , http://sag-28.forumactif.org/ ,
snakefl1984 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 10:48

Merci pour ta réponse,

Le code CSS est sur le serveur, et les fichiers sont à la racines, je les appeler via le lien <link> que je mets dans le templates.

J'ai essayer ce que tu m'as conseillé avant, et cela ne donne aucuns résultats.
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Neptunia le Dim 6 Nov 2016 - 11:14

Bonjour ^^

Une petite recherche sur le forum et on apprend que @font-face n'est pas utilisable dans la feuille css de nos forums. Il faut donc utiliser cette propriété ailleurs.

Right Recherche interne
avatar

Neptunia
Membre actif

Féminin
Messages : 12683
Inscrit(e) le : 08/08/2010

https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 11:17

Bonjour,

Je précise bien que le CSS du @font-face ce trouve sur un serveur heberger, donc pas dans le CSS du forum, j'utilise "font-family" pour le nom de la police et j'ai mis dans le Template Overall_Header le lien qui appelle le CSS du serveur.
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par snakefl1984 le Dim 6 Nov 2016 - 12:04


ses ton serveur opu tu stock tes police ?

si oui qu'a tu mis comme code pour les police ?
avatar

snakefl1984
**

Masculin
Messages : 71
Inscrit(e) le : 05/08/2016

http://test1984.forumactif.org , http://sag-28.forumactif.org/ ,
snakefl1984 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 12:08

Oui c'est le serveur,

J'ai mis ce code là
Code:
/* This stylesheet generated by Transfonter (http://transfonter.org) on November 6, 2016 1:03 AM */
@font-face {
  font-family: 'R&C Demo';
  src: url('R&C-Demo.eot');
  src: local('☺︎'),
    url("R&C-Demo.woff") format("woff"),
    url("R&C-Demo.otf") format("opentype"),
    url("R&C-Demo.svg#grablau") format("svg");
}
Qui ce trouve dans ce fichier la : http://forumressources.hol.es/stylesheet.css
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par snakefl1984 le Dim 6 Nov 2016 - 12:10

j'ai eu ma reponse , xd , en cliquant sur le lien plus haut

je me suis permis d'extraire tes lien de tes polices qui sont

http://forumressources.hol.es/R&C-Demo.eot
http://forumressources.hol.es/R&C-Demo.ttf
http://forumressources.hol.es/R&C-Demo.woff

Code:
@font-face {
  font-family: 'R&C Demo';
  src: url('forumressources.hol.es/R&C-Demo.eot');
  src: url('forumressources.hol.es/R&C-Demo.eot?#iefix') format('embedded-opentype'),
      url('forumressources.hol.es/R&C-Demo.woff') format('woff'),
      url('forumressources.hol.es/R&C-Demo.ttf') format('truetype');
  font-weight: normal;
  font-style: normal;
}

voila se que devrais donner ton css, normalement
avatar

snakefl1984
**

Masculin
Messages : 71
Inscrit(e) le : 05/08/2016

http://test1984.forumactif.org , http://sag-28.forumactif.org/ ,
snakefl1984 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 12:14

Y'a pas de mal,

Je viens d'injecter le code que tu m'as passer et cela ne marche pas. Mais ou est donc l'erreur (petit... petit... )
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par snakefl1984 le Dim 6 Nov 2016 - 12:20

je vient de charger ton css , et il n'y a eu aucune modif sur celui si , il reste le meme de depart , la tu recharger sur ton serveur ?
avatar

snakefl1984
**

Masculin
Messages : 71
Inscrit(e) le : 05/08/2016

http://test1984.forumactif.org , http://sag-28.forumactif.org/ ,
snakefl1984 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 12:21

Je n'ai touché que au fichiers CSS
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par snakefl1984 le Dim 6 Nov 2016 - 12:24

Code:
/* This stylesheet generated by Transfonter (http://transfonter.org) on November 6, 2016 1:03 AM */
@font-face {
  font-family: 'R&C Demo';
  src: url('R&C-Demo.eot');
  src: local('☺︎'),
    url("R&C-Demo.woff") format("woff"),
    url("R&C-Demo.otf") format("opentype"),
    url("R&C-Demo.svg#grablau") format("svg");
}

voila se que je voie sur ton css dans ton serveur ,
avatar

snakefl1984
**

Masculin
Messages : 71
Inscrit(e) le : 05/08/2016

http://test1984.forumactif.org , http://sag-28.forumactif.org/ ,
snakefl1984 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 12:26

Ah, pour ma part je vois le nouveau, je viens de le remettre.
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par snakefl1984 le Dim 6 Nov 2016 - 12:31

hum peut etre une latence quelque part , est ce que tu vois une difference sur ton forum ? avec la remise en palce du css sur ton serveur ?
avatar

snakefl1984
**

Masculin
Messages : 71
Inscrit(e) le : 05/08/2016

http://test1984.forumactif.org , http://sag-28.forumactif.org/ ,
snakefl1984 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 12:32

Cela la remis en par défauts.
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par snakefl1984 le Dim 6 Nov 2016 - 12:36

hum mes compétence malheureusement s’arrête la , xd , en serveur j'y connais pas grand chose , il te faudra l'aide d'un dev ou d'un modo , qui si connais ,
avatar

snakefl1984
**

Masculin
Messages : 71
Inscrit(e) le : 05/08/2016

http://test1984.forumactif.org , http://sag-28.forumactif.org/ ,
snakefl1984 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 12:37

Merci infiniment pour ton aide Smile
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Walt le Dim 6 Nov 2016 - 12:48

Bonjour,

@snakefl1984 a écrit:
Code:
@font-face {
  font-family: 'R&C Demo';
  src: url('forumressources.hol.es/R&C-Demo.eot');
  src: url('forumressources.hol.es/R&C-Demo.eot?#iefix') format('embedded-opentype'),
      url('forumressources.hol.es/R&C-Demo.woff') format('woff'),
      url('forumressources.hol.es/R&C-Demo.ttf') format('truetype');
  font-weight: normal;
  font-style: normal;
}

voila se que devrais donner ton css, normalement

Ce code ne peut pas fonctionner, car le lien relatif est erroné. Il appelle les fichiers à l'adresse http://forumressources.hol.es/forumressources.hol.es/R&C-Demo.woff ce qui n'existe pas. D'où une 302 redirigeant vers la page d'erreur de votre hébergeur :



Soit vous indiquez un lien absolu (par exemple url('http://forumressources.hol.es/R&C-Demo.woff') et de même pour chaque fichier), soit un chemin relatif correct.

Cordialement,
Walt
avatar

Walt
Modéractif
Modéractif

Masculin
Messages : 3720
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 12:57

Bonjour,

D'accord, et bien j'ai mis un lien absolu. Aucuns résultats.
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Walt le Dim 6 Nov 2016 - 13:03

Alors le problème ne peut venir que du fichier de police. J'ai tenté de l'ouvrir, et voici le résultat :


Cordialement,
Walt


Dernière édition par Pinguino le Dim 6 Nov 2016 - 13:55, édité 2 fois (Raison : édité)
avatar

Walt
Modéractif
Modéractif

Masculin
Messages : 3720
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 13:04

Ah !
Je n'y avais pas pensé à cela :/
Je vais les ré-uploads tout de suite !
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Walt le Dim 6 Nov 2016 - 13:57

Afin de faciliter la gestion des problèmes, si le vôtre est résolu, pensez à :
  • éditer votre premier message,
  • cocher l'icône résolu et enregistrer
Vous pouvez également remercier les personnes qui vous ont aidé, en cliquant sur le bouton
avatar

Walt
Modéractif
Modéractif

Masculin
Messages : 3720
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: @font-face ne fonctionne pas

Message par Ozsi-sun le Dim 6 Nov 2016 - 14:19

Cela ne marche toujours pas :/

On va rectifié, j'ai trouvé la solution sur Never-Utopia
Spoiler:

Et cela fonctionne à merveille Smile Résolu !
avatar

Ozsi-sun
*

Masculin
Messages : 31
Inscrit(e) le : 06/11/2016

http://www.ac-project.fr/
Ozsi-sun a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum