Problème avec la colorisation des cellules "nouveaux messages"

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec la colorisation des cellules "nouveaux messages"

Message par Manu34 le Mer 21 Déc 2016 - 13:17

Détails techniques


Version du forum : phpBB2
Poste occupé : Administrateur
Navigateur(s) concerné(s) : non défini
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : quelques jours
Lien du forum : http://motos-en-v-honda.superforum.fr/index.htm

Description du problème

Bonjour à tous.

Un ptit souci depuis quelques jours, mes cellules de nouveaux messages ne se colorisent que quand ça leur chante.
Même en rafraîchissant la page de lecture, ça vient ou non.
Alors je ne comprends pas. Surprised

Mon Script Java est toujours actif, l'icone de référence est bien présent, mais
je pense que j'ai un problème dans la ligne de code de mon CSS.
J'ai essayé différentes syntaxes, mais ça ne change pas le coté aléatoire de la chose.

Pourriez-vous me dire s'il vous plait, si d'après vous, quelque chose cloche :

Code:
/* colorisation cellule nouveaux messages */
tr.newpost td {
background-color: #FFE35A !important; }

Merci de votre aide et passez de bonne fêtes ! cheers


Dernière édition par Manu34 le Sam 7 Jan 2017 - 1:36, édité 1 fois
avatar

Manu34
****

Masculin
Messages : 201
Inscrit(e) le : 10/09/2008

http://motos-en-v-honda.superforum.fr/index.htm
Manu34 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Manu34 le Ven 23 Déc 2016 - 2:42

Petit Up s'il vous plait. Mr. Green
avatar

Manu34
****

Masculin
Messages : 201
Inscrit(e) le : 10/09/2008

http://motos-en-v-honda.superforum.fr/index.htm
Manu34 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Manu34 le Mar 27 Déc 2016 - 12:02

Un petit coup de main siouplé ?

ça marchait bien jusqu'àlors, pourquoi ça ne marcherait plus d'un coup, alors que je n'ais rien changé ?
avatar

Manu34
****

Masculin
Messages : 201
Inscrit(e) le : 10/09/2008

http://motos-en-v-honda.superforum.fr/index.htm
Manu34 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Manu34 le Jeu 29 Déc 2016 - 2:17

Mon Javascript :

Code:
$(function() {
 $('img[src="http://i18.servimg.com/u/f18/12/89/91/23/folder10.png"]').closest('tr').addClass('newpost');
$('img[src="http://i18.servimg.com/u/f18/12/89/91/23/folder10.png"]').closest('tr').addClass('newpost');
});

Et l'icone de l'image est bien associé aux nouveaux messages Embarassed Crying or Very sad
avatar

Manu34
****

Masculin
Messages : 201
Inscrit(e) le : 10/09/2008

http://motos-en-v-honda.superforum.fr/index.htm
Manu34 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Kumo le Jeu 29 Déc 2016 - 8:13

Je me joins à vous, je rencontre exactement le même problème sur mon forum...
Aucune modification n'a été effectué, j'utilise le même script que Manu34, mais depuis un peu plus d'un mois les cellules des nouveaux messages ne se colorent plus.

Quelqu'un d'autre rencontre ce soucis ? Auriez vous un début de réponse ?
avatar

Kumo
*

Messages : 49
Inscrit(e) le : 11/03/2016

http://encre-seiche.forumactif.org/
Kumo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Milouze14 le Sam 31 Déc 2016 - 8:50

Hello Manu34,


Manu34 a écrit:
Mon Javascript :

Code:

$(function() {
 $('img[src="http://i18.servimg.com/u/f18/12/89/91/23/folder10.png"]').closest('tr').addClass('newpost');
$('img[src="http://i18.servimg.com/u/f18/12/89/91/23/folder10.png"]').closest('tr').addClass('newpost');
});

Et l'icone de l'image est bien associé aux nouveaux messages Embarassed Crying or Very sad



Remplaces le script par:

Code:

$(function() {
 $('img[alt="Nouveaux messages"]').closest('tr').addClass('newpost');

});

a++
avatar

Milouze14
Membre actif

Masculin
Messages : 4806
Inscrit(e) le : 18/04/2005

https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Manu34 le Sam 31 Déc 2016 - 14:57

Bonjour Milouze

J'ai mis le script en place, vous en donnerais des nouvelles dès que ça poste.

Merci et bon réveillon en attendant !
avatar

Manu34
****

Masculin
Messages : 201
Inscrit(e) le : 10/09/2008

http://motos-en-v-honda.superforum.fr/index.htm
Manu34 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Manu34 le Lun 2 Jan 2017 - 9:41

Oui alors, ça fonctionne comme ça, seulement ça me colorise aussi les entêtes de catégories sur l'index !

Avant ça ne suivait que la rubrique du nouveaux sujet.

Donc ça ne va pas, c'est trop chargé. Sad
avatar

Manu34
****

Masculin
Messages : 201
Inscrit(e) le : 10/09/2008

http://motos-en-v-honda.superforum.fr/index.htm
Manu34 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Milouze14 le Lun 2 Jan 2017 - 9:58

Hello Manu34,

essayes avec ce script alors:
Code:
   
$(function() {
    $('img[src="https://i18.servimg.com/u/f18/12/89/91/23/folder10.png"]').closest('tr').addClass('newpost');
    $('img[src="https://i18.servimg.com/u/f18/12/89/91/23/folder10.png"]').closest('tr').addClass('newpost');
    });

En fait il y a eut une mise à jour sur le lien des images (je ne sais pas pourquoi d'ailleurs ) qui transforme
ce dernier:
Regarde dans ton P.A sur le bouton"Sujet - Nouveau :" , le lien doit être:

http://i18.servimg.com/u/f18/12/89/91/23/folder10.png

alors que désormais lorsque je regarde le lien de ton image sur ton fofo j'ai ceci:

https://i18.servimg.com/u/f18/12/89/91/23/folder10.png

il y a https:

a++
avatar

Milouze14
Membre actif

Masculin
Messages : 4806
Inscrit(e) le : 18/04/2005

https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Manu34 le Lun 2 Jan 2017 - 11:58

Bonjour camarade (et bonne année !)

Alors oui, c'est bien vu ! les images servimg sont toutes passées en "https" !
Donc mon ancien script en "Http" ne passait plus !

Fallait avoir l'oeil ou le savoir ! Mr. Green

Bon, je re confirmerai quand ça aura posté sur mon forum mais à priori, ce devait-être bon^^
Merci beaucoup
avatar

Manu34
****

Masculin
Messages : 201
Inscrit(e) le : 10/09/2008

http://motos-en-v-honda.superforum.fr/index.htm
Manu34 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la colorisation des cellules "nouveaux messages"

Message par Manu34 le Sam 7 Jan 2017 - 1:35

Et bien c'est parfait !
Encore merci à Milouze ! Smile
avatar

Manu34
****

Masculin
Messages : 201
Inscrit(e) le : 10/09/2008

http://motos-en-v-honda.superforum.fr/index.htm
Manu34 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum