Questions avant de passer en HTTPS

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Questions avant de passer en HTTPS

Message par Cloo le Sam 11 Fév 2017 - 20:34

Bonjour,

Avant de me lancer dans la dernière étape, soit l'acquisition d'un certificat SSL et de passer mon forum en HTTPS, j'aurais encore quelques petites questions...

J'ai modifié et ré-hébergé pas mal toutes les images statiques du forum pour avoir des liens HTTPS, ça me semble beau. Pour les avatars, j'ai vu qu'ils sont hébergés chez imgfast, donc https, à moins que l'utilisateur n'ait mis un lien vers une image sur un autre hébergeur.
J'ai aussi vérifié les templates et les Javascript (je n'en ai pas, plus facile!).

Premier cas
Nous sommes un forum où nous publions beaucoup de photos... de nos jardins, de nos plantes, etc... voici un exemple assez typique de post:
http://accrosjardin.forumactif.com/t2270-les-orchidees-de-cloo-saison-2017

Sur cet exemple, les photos sont hébergées sur Photobucket, qui n'offre pas pour le moment des liens https (réponse de leur part ce matin même). Bon, c'est un exemple, d'autres utilisent Flickr qui a des liens https, d'autres utilisent l'hébergeur intégré Servimg qui offre aussi des liens https, mais d'autres utilisent des petits hébergeurs, comme Hosting Pics, Tiny Pic ou autres qui n'offrent pas des liens https.

Si je comprends bien... une fois que j'aurais installé le certificat SSL... quelqu'un arrive sur la page d'accueil du forum, ou la page "Voir les nouveaux messages", le petit cadenas sera vert, mais si la personne clique sur le lien d'un post avec des photos comme ci-dessus qui sont sur un hébergeur non-https, le cadenas va passer au jaune ou au rouge? Et revenir au vert dès que la personne va quitter cette page?

C'est juste pour comprendre... car il est bien certain que je ne peux pas demander à tous mes membres d'utiliser un hébergeur de photos qui fournit des liens https.

Deuxième cas
Un index avec des liens comme ceci:
http://accrosjardin.forumactif.com/t677-index-des-experiences-de-semis#10925
Sous le nom de la plante, le lien va vers un post du forum, OK, pas de problème.
Sous le petit appareil photo (dont l'image est sur Servimg, https), le lien mène vers une photo de la plante qui est hébergée sur Photobucket, non-https. Si j'ai bien suivi, comme ce n'est qu'un lien, et pas une ressource affichée sur la page, c'est OK?

Merci de m'aider à comprendre avant d'aller plus loin... si vous pensez que j'oublie des trucs, n'hésitez pas à me le dire!

Mon forum --> http://accrosjardin.forumactif.com/
avatar

Cloo
****

Féminin
Messages : 346
Inscrit(e) le : 09/07/2008

http://accrosjardin.forumactif.com/
Cloo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Questions avant de passer en HTTPS

Message par Walt le Dim 12 Fév 2017 - 11:14

Bonjour,

Vous avez parfaitement saisi pour les deux cas que vous soumettez. Dans le premier cas, effectivement la page du sujet ne sera pas affichée comme "sécurisée" car des éléments sont chargés en HTTP. Sauf si vous cochez sur votre panneau d'administration l'option permettant de forcer le chargement en HTTPS (ce qui aura pour conséquence que les images hébergées sur un hébergeur ne proposant pas le HTTPS ne s'afficheront pas).

Pour le second cas, en effet, les liens ne sont pas une ressource chargée donc pas de souci de ce côté.

Cordialement,
Walt
avatar

Walt
Modéractif
Modéractif

Masculin
Messages : 2182
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Questions avant de passer en HTTPS

Message par Cloo le Dim 12 Fév 2017 - 11:21

Merci pour les confirmations!
avatar

Cloo
****

Féminin
Messages : 346
Inscrit(e) le : 09/07/2008

http://accrosjardin.forumactif.com/
Cloo a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum