Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Message par le Monde d'Ewilan le Mer 5 Avr 2017 - 23:09

Détails techniques


Version du forum : phpBB2
Poste occupé : Administrateur
Navigateur(s) concerné(s) : Mozilla Firefox
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : Hier/Aujourd'hui (le 04/05 Avril 207)
Lien du forum : http://ewilan.forumactif.fr/

Description du problème

Aloooors, je m'excuse d'avance pour le pavé. Je remercie ceux qui me liront. I love you

Bonsoir !
Si je viens vous trouver en cette nuit au beau milieu de la semaine c'est que depuis hier on a des "nouveauté" sur le forum, qui ressemblent à des "mises à jours de ForumActif", sauf que si au début, c'était plutôt cool, maintenant ça l'est beaucoup moins. Et en regardant par chez vous, il semblerait qu'il n'y ait aucune mise à jour, du coup je viens vous en parler directement.

Je vais essayer de lister les différences qui ont été notées depuis hier.

1-Réaménagement des smileys. Maintenant ils sont tous collés ! Il n'y a plus de perte d'espace en fonction des grands/petits smileys, et c'est plutôt cool ! Même si... de notre côté on n'y est absolument pour rien. (avant c'était comme les smileys d'ici, maintenant c'est plus le cas)

2-Barre de navigation allongée. Avant, même en mettant la barre de navigation (là où on peut voir son profil, les membres, la page d'acceuil, se connecter, etc.) en pleine page, il y avait des "trous" sur les côtés, pas beaucoup, mais entre 10-50px. Et depuis hier la barre va jusqu'au bout ! Very Happy
C'est top aussi, même si une fois encore on y est pour rien.

3-On a codé notre forum avec du CSS, un peut de bidouille dans les templates (bon, moi j'ai pas codé, mais quelqu'un l'a fait) de manière à "organiser" les catégories d'une autre manière, avec des petits boites pour que ça fasse plus clean. Depuis hier/aujourd'ui, les "derniers messages postés par" ne sont plus à leur place. Ce n'est pas grand chose, mais ils sont tous remontés de quelques pixels, ce qui rend notre "code" nettement moins esthétique.
Mais le texte s'affiche toujours de la même manière, il a simplement changé un petit peu de place, ce n'est rien de dramatique, c'est juste frustrant de galérer à mettre en place un code qui, sans y toucher, déconne. Tout était bien aligné et là.. c'est plus trop le cas.

4-La CB. Là, on arrive au plus gros bug, celui que j'ai décidé de garder pour la fin. On a un problème "esthétique" qui gène au fonctionnement.
Lorsqu'on se connecte à la ChatBox (qu'elle soit latérale ou ouverte dans une autre fenêtre) les boutons n'appariassent pas, ni les pseudos des membres connectés. U.u Vous pouvez le voir sur la capture d'écran. C'est comme ça depuis aujourd'hui (hier tout au mieux).
Alors mes questions sont.. Est-ce que ForumActif est à l'origine de ces changements ? Si non.. d'où peuvent-ils venir ?! :O Si oui, est-ce que d'autres personnes/forums vous ont fait part de problèmes de leurs côtés, vous avez des solutions à mes problèmes (points 3 et 4) ou êtes en train d'y réfléchir..?

5- Sur le forum, on a installé un code qui fait apparaitre les noms des catégories au survol, et lorsque les bugs sont survenus, on a remarqué que les noms de sous-forums étaient tous collés les uns aux autres... O.o
A quoi est-ce dû ? Comment peut-on rectifier ce soucis ? Parce que pour lire les différents sous-forum ça devient un peu compliqué et pas hyper agréable... :S



Voilà, j'avoue que les soucis ne passant pas, je viens chercher de votre côté, si vous avez des réponses qui pourraient m'être utiles.

Je profite de la création de ce long message pour partager avec vous une découverte qui m'intrigue. Sur la CB (encore), il y a une différence entre le forum officiel et le forum test, bien qu'ils soient supposés être identiques. Sur le forum test, lorsqu'un memrbe poste sur la CB, son avatar apparait à côté de son pseudo ! C'est normal..? Comment est-ce que ça se fait ?
Bon, ce n'est pas un problème ni particulièrement urgent, mais si l'un de vous peu m'éclairer, je me sentirais moins bête Wink


Voilà ! Merci pour vos réponses, et je suis désolée si les questions/problèmes ont déjà été soulevés.
Bonne nuit !

PS : je m'excuse pour les éventuelles fautes, je suis épuisée, j'arrive plus à me relire...


Dernière édition par le Monde d'Ewilan le Ven 21 Avr 2017 - 17:44, édité 2 fois
avatar

le Monde d'Ewilan
Nouveau membre

Messages : 20
Inscrit(e) le : 01/07/2016

http://ewilan.forumactif.fr/
le Monde d'Ewilan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Message par le Monde d'Ewilan le Sam 8 Avr 2017 - 22:20

Bonjour,

je suis toujours en attente d'un petit coup de pouce, ou d'une explication à ces phénomènes...
D'ailleurs, je viens ajouter un autre point problématique, que j'avais oublié dans ma liste (dois-je éditer le premier message pour l'y glisser afin d'avoir toutes mes questions regroupées ? je vais le faire, au cas où...)

5- Sur le forum, on a installé un code qui fait apparaitre les noms des catégories au survol, et lorsque les bugs sont survenus, on a remarqué que les noms de sous-forums étaient tous collés les uns aux autres... O.o
A quoi est-ce dû ? Comment peut-on rectifier ce soucis ? Parce que pour lire les différents sous-forum ça devient un peu compliqué et pas hyper agréable... :S


voilà, merci.
j'attends vos conseils, remarques et tout ce qui pourrait aider. Merci d'avance !
Bonne soirée Like a Star @ heaven
avatar

le Monde d'Ewilan
Nouveau membre

Messages : 20
Inscrit(e) le : 01/07/2016

http://ewilan.forumactif.fr/
le Monde d'Ewilan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Message par Walt le Dim 9 Avr 2017 - 0:00

Bonjour,

En principe une seule question est autorisée par sujet... En outre, ça manque d'illustrations pour vous expliquer. Donc si je comprends bien, le problème n°1 n'en est pas un ? Le 2ème non plus ?

Pour le 3ème, le contenu de la zone "dernier message" était où auparavant ? Plus bas de combien de pixels ?

Pour le 5ème, comment était-ce auparavant ?

Pour le 4ème, êtes-vous l'unique personne à rencontrer ce problème ou tous vos membres l'ont ? Le problème subsiste si la chatbox est en pleine page (http://ewilan.forumactif.fr/chatbox/index.forum) ?

Et enfin, pour le forum de test, c'est une option activable ou désactivable dans la partie liée à la chatbox de votre panneau d'administration.

Cordialement,
Walt
avatar

Walt
Modéractif
Modéractif

Masculin
Messages : 3738
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Message par le Monde d'Ewilan le Dim 9 Avr 2017 - 16:20

Une seule question ? Ah, eh bien je la formulerais ainsi :
ForumActif est-il à l'origine d'une mise à jour le 04 avril ?
Tous mes "problèmes" sont des manifestations d'un changement soudain et inexpliqué. Certains sont biens, d'autres non, mais la question est toujours la même "pourquoi et comment ?"


Donc le point un et deux n'ont pas besoin de "solution" dans le sens où c'est ce qu'on aurait aimé, mais cela n'empêche pas qu'on aimerait connaitre l'origine de ces changements.

Pour le 3 : je ne sais pas, je recherche d'éventuelles captures d'écran qui permettraient de comparer mais... j'avoue que c'est assez léger.
en image:
avant (en cours d'aménagement, les boites sont "actuelles", elle sont juste pas bien alignées entre elles)


Là, c'est une étape encore avant, mais on voit mieux les catégories, et la place qui est occupée...


et là, c'est comme c'est actuellement.

C'est tout ce que j'ai, je suis incapable de vous dire ce qui a vraiment changé, de combien de pixels ça a bougé, qu'est-ce qui a réellement bougé... Je dirais éventuellement que c'est le "bloc" du "dernier message posté par" (avec le pseudo du membre, le titre du post, la date/heure) qui n'est pus collé au bas de sa "boite".
désolé si ça vous semble flou, peu précis et assez confus, ça l'est aussi pour moi. On n'a touché à rien pouvant expliquer ce décalage mystère...

pour le 4 : Tous les membres avec qui j'ai pu en discuter m'ont dit avoir ce problème, oui.
Et oui, même avec la ChatBox en pleine page le problème persiste.
en image:
J'ai essayé de "surligner" au niveau des pseudos, où ils s'affichent en général, dans les connecter, voir si c'était un problème de couleur ou quoi mais.. Rien n’apparait, comme s'il n'y avait personne de connecté sur la CB.
Pour les boutons, ils fonctionnent, on ne sais juste pas ce qu'il font, et lorsqu'ils sont "utilisés", on ne les voit pas non plus. (pourtant l’icône est plus foncée).


le 5e point : Excellente question.. J'ai cherché dans mes captures d'écrans, au moment où on faisait le thème et je n'ai pas trouvé. Du coup de mémoire je dirais qu'il y avait une virgule puis un espace entre les lieux. Mais comme le problème a affecté soudainement le forum, je ne peux pas dire avec certitude. Et j'ai voulu ruser en regardant sur le forum test, mais celui-ci rencontre les même "problèmes".
en image:

Ca donne ça actuellement, lorsqu'on regarde les sous-forum... Tous les noms des lieux sont collés les uns au autres, les seuls espaces sont ceux présents dans le nom du lieu
En faisant la capture d'écran pour vous montrer comment c'était actuellement, j'ai remarqué que si l'on survolait longtemps une sous-catégorie, sa description apparaissait ! J'ignore si on avait ça avant... O.o


Merci pour l'information pour la CB ! Je l'ignorais et j'étais curieuse, j'irais regarder ça alors.

Merci également pour votre temps et pour vous occuper de notre cas ^^'
avatar

le Monde d'Ewilan
Nouveau membre

Messages : 20
Inscrit(e) le : 01/07/2016

http://ewilan.forumactif.fr/
le Monde d'Ewilan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Message par Chacha le Sam 15 Avr 2017 - 9:29

Bonjour,

Attention, cela fait 6 jours que nous n'avons pas de nouvelles concernant votre demande, si vous ne voulez pas voir votre sujet déplacé à la corbeille, merci de poster dans les 24h qui suivent ce message.

Si votre sujet est résolu, merci d'éditer votre premier message et de cocher l'icône « résolu »
avatar

Chacha
Modéractif
Modéractif

Masculin
Messages : 55335
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Message par le Monde d'Ewilan le Sam 15 Avr 2017 - 23:57

Bonjour,
Non, mon problème n'est toujours pas résolu. On m'a demandé plus de détails, j'ai donc expliqué plus clairement et je n'ai eut aucune nouvelles depuis, j'attends patiemment que quelqu'un puisse/sache/veuille/ait le temps de m'aider. Je ne relance pas car je me doute que tout le monde ici à une vie IRL, et qu'en ces périodes de vacances/fêtes vous avez probablement peu de temps à m'accorder. Wink
Mais je reste dans l'attente qu'on vienne m'aider.

(la CB sur le forum est toujours peu praticable...)


Merci, bonne soirée à vous.
Et joyeuses Pâques !
avatar

le Monde d'Ewilan
Nouveau membre

Messages : 20
Inscrit(e) le : 01/07/2016

http://ewilan.forumactif.fr/
le Monde d'Ewilan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Message par Walt le Ven 21 Avr 2017 - 9:59

Bonjour,

Désolé de ce temps de réponse, j'ai eu d'autres priorités par ailleurs...

ForumActif est-il à l'origine d'une mise à jour le 04 avril ?
Non, rien n'ayant pu impacter vos forums n'a été publié à cette date.

Vous avez une instruction un peu surprenante dans votre CSS :
Code:
body {
   background:url(http://i65.tinypic.com/2zpnp6r.jpg) no-repeat top center scroll,url(http://i66.tinypic.com/2m41zia.jpg) no-repeat top center fixed;
   background-color:#f0f0f0;
   color:#464646;
   cursor:default;
   font-family:Arial,sans-serif;
   font-size:0;
   font-style:normal;
   font-variant:normal;
   font-weight:normal;
   height:auto;
   margin:0;
   max-width:100%;
   padding: 0
}

font-size: 0; qui indique donc au navigateur d'afficher l'intégralité de la page dans une taille de police 0. Si vous supprimez cette ligne, tous les problèmes évoqués - même la chatbox - sont résolus.

Cordialement,
Walt
avatar

Walt
Modéractif
Modéractif

Masculin
Messages : 3738
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Message par le Monde d'Ewilan le Ven 21 Avr 2017 - 16:28

Bonjour Walt !
Merci pour ce coup de pouce, ça me fait plaisir qu'une solution aussi simple ait été trouvé ! Par contre... je ne voit pas tout ça dans mon CSS.

Code:
 body {
    background: url('http://i65.tinypic.com/2zpnp6r.jpg') no-repeat top center scroll, url('http://i66.tinypic.com/2m41zia.jpg') no-repeat top center fixed; /* http://i66.tinypic.com/2m41zia.jpg ; https://i58.servimg.com/u/f58/15/92/10/15/test_f12.jpg ; http://i68.tinypic.com/2gxijci.jpg*/
  max-width: 100%;
    height: auto;
}

Je n'ai pas autant de lignes que vous... En espérant pallier à ça, j'ai modifié mon CSS pour y mettre le bout de code que vous donnez, en ôtant la partie concernant la taille d'affichage de la police, ce qui donne ça :

Code:
body {
      background:url(http://i65.tinypic.com/2zpnp6r.jpg) no-repeat top center scroll,url(http://i66.tinypic.com/2m41zia.jpg) no-repeat top center fixed;
      background-color:#f0f0f0;
      color:#464646;
      cursor:default;
      font-family:Arial,sans-serif;
      font-style:normal;
      font-variant:normal;
      font-weight:normal;
      height:auto;
      margin:0;
      max-width:100%;
      padding: 0
    }

Sauf que... rien n'a changé sur le forum.
... Une idée de ce qui cloche ?
avatar

le Monde d'Ewilan
Nouveau membre

Messages : 20
Inscrit(e) le : 01/07/2016

http://ewilan.forumactif.fr/
le Monde d'Ewilan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Changements imprévus sur le forum, dont le staff n'est pas à l'origine (dont un problème avec la CB)

Message par le Monde d'Ewilan le Ven 21 Avr 2017 - 17:44

Bonjour !

Le problème a été résolu ! Disons qu'on a trouvé d'où venait le problème, on avait deux fois "body" dans notre css (on a voulu installé un calendrier en widget), ce qui faisait planter le "body" principal. Donc maintenant tout semble rentré dans l'ordre, on est revenus au point de "départ", avant les changements.

Merci beaucoup pour votre aide. Bonne fin de journée !
avatar

le Monde d'Ewilan
Nouveau membre

Messages : 20
Inscrit(e) le : 01/07/2016

http://ewilan.forumactif.fr/
le Monde d'Ewilan a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum