Problème balises dernier message (Template Général Index_box)

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème balises dernier message (Template Général Index_box)

Message par Yintatsu le Mar 9 Mai 2017 - 19:03

Détails techniques


Version du forum : phpBB3
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome, Internet Explorer, Opera, Safari
Personnes concernées par le problème : Tous les utilisateurs
Lien du forum : http://nephalemschronicles.forumactif.com/

Description du problème

Bonjour,

Je suis actuellement sur la création d'un forum et j'ai un léger souci au niveau d'un bout de mon code, puisque celui-ci à l'état final fait répéter le dernier message du forum sur dans tous les emplacements dédié au dernier message d'une catégorie.

Voici donc le code :

Code:
<!-- BEGIN catrow -->
   <!-- BEGIN tablehead -->
<div class="categorie">
  <table witdh="100%" border=0 cellspacing=0 cellpadding=0>
    <tr>
      <th>
        <div class="categorietitre">
          {catrow.tablehead.L_FORUM}
        </div>
      </th>
    </tr>
       <!-- END tablehead -->
       <!-- BEGIN forumrow -->
    <tr>
      <td>
        <div class="forumensemble">
          <div class="forumhead">
            <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumtitle">{catrow.forumrow.FORUM_NAME}</a>
          </div>
          <table witdh="100%" border=0 cellspacing=0 cellpadding=0>
            <tr>
              <td>
                <div class="sousforum">
                  <div class="sousforumtitre">
                    <span id="subforums">{forumrow.L_SUBFORUM_STR}{catrow.forumrow.LINKS}</span>
                  </div>
                </div>
              </td>
              <td>
                <div class="colonnedivise">
                  <table witdh="100%" border=0 cellspacing=0 cellpadding=0>
                    <tr>
                      <td colspan=2>
                        <div class="forumdescription">
                          {catrow.forumrow.FORUM_DESC}
                        </div>
                      </td>
                    </tr>
                    <tr>
                      <td>
                        <div class="forummessages">
                          {catrow.forumrow.POSTS} MESSAGES
                        </div>
                      </td>
                      <td>
                        <div class="forumsujets">
                          {catrow.forumrow.TOPICS} SUJETS
                        </div>
                      </td>
                    </tr>
                    <tr>
                      <td colspan=2>
                        <div class="forumderniermessage">
                          <!-- BEGIN switch_topic_title -->
                          <a href="{catrow.forumrow.U_LATEST_TOPIC}" title="{catrow.forumrow.LATEST_TOPIC_TITLE}">{catrow.forumrow.LATEST_TOPIC_NAME}</a>
                          <!-- END switch_topic_title -->
                          {catrow.forumrow.USER_LAST_POST}
                        </div>
                      </td>
                    </tr>
                  </table>
                </div>
              </td>
              <td>
                <div class="imagestatut">
                  <img src="{catrow.forumrow.FORUM_FOLDER_IMG}"/>
                </div>
              </td>
            </tr>
          </table>
        </div>
      </td>
    </tr>
  </table>
</div>
<script type="text/javascript">jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'')).removeAttr('id');</script>
<script type="text/javascript">jQuery('.forumderniermessage').html(jQuery('.forumderniermessage').html().replace("<br>",' '));</script>
   <!-- END forumrow -->
<!-- END catrow -->

Et voici le problème que cela engendre :

Lien image:


Dernière édition par Yintatsu le Mer 10 Mai 2017 - 18:56, édité 2 fois
avatar

Yintatsu
Nouveau membre

Messages : 2
Inscrit(e) le : 09/05/2017

http://nephalemschronicles.forumactif.com/
Yintatsu a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème balises dernier message (Template Général Index_box)

Message par MlleAlys le Mar 9 Mai 2017 - 20:13

Bonjour,
Il y a quelques soucis de balises dans votre template, mais le problème semble venir du javascript pour supprimer les retours à la ligne.
Code:
<!-- BEGIN catrow -->

<!-- BEGIN tablehead -->
<div class="categorie">
  <div class="categorietitre">{catrow.tablehead.L_FORUM}</div>
  <!-- END tablehead -->

  <!-- BEGIN forumrow -->
  <div class="forumensemble">
    <div class="forumhead">
      <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumtitle">{catrow.forumrow.FORUM_NAME}</a>
    </div>
    <table witdh="100%" border=0 cellspacing=0 cellpadding=0>
      <tr>
        <td>
          <div class="sousforum">
            <div class="sousforumtitre">
              <span id="subforums">{forumrow.L_SUBFORUM_STR}{catrow.forumrow.LINKS}</span>
            </div>
          </div>
        </td>
        <td>
          <div class="colonnedivise">
            <table witdh="100%" border=0 cellspacing=0 cellpadding=0>
              <tr>
                <td colspan=2>
                  <div class="forumdescription">{catrow.forumrow.FORUM_DESC}</div>
                </td>
              </tr>
              <tr>
                <td>
                  <div class="forummessages">{catrow.forumrow.POSTS} MESSAGES</div>
                </td>
                <td>
                  <div class="forumsujets">{catrow.forumrow.TOPICS} SUJETS</div>
                </td>
              </tr>
              <tr>
                <td colspan=2>
                  <div class="forumderniermessage" id="modif">
                    <!-- BEGIN switch_topic_title -->
                    <a href="{catrow.forumrow.U_LATEST_TOPIC}" title="{catrow.forumrow.LATEST_TOPIC_TITLE}">{catrow.forumrow.LATEST_TOPIC_NAME}</a><br />
                    <!-- END switch_topic_title -->
                    {catrow.forumrow.USER_LAST_POST}
                  </div>
                </td>
              </tr>
            </table>
          </div>
        </td>
        <td>
          <div class="imagestatut"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}"/></div>
        </td>
      </tr>
    </table>
  </div>
  <script type="text/javascript">jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'')).removeAttr('id');</script>
  <script type="text/javascript">jQuery('#modif').html(jQuery('#modif').html().replace("<br>", ' ')).removeAttr('id');</script>
  <!-- END forumrow -->

  <!-- BEGIN tablefoot -->
</div>
<!-- END tablefoot -->
 
<!-- END catrow -->
avatar

MlleAlys
Membre actif

Messages : 4620
Inscrit(e) le : 12/09/2012

MlleAlys a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème balises dernier message (Template Général Index_box)

Message par Yintatsu le Mer 10 Mai 2017 - 18:56

Je te remercie pour cette réponse rapide et précise, ça fonctionne de nouveau Wink
avatar

Yintatsu
Nouveau membre

Messages : 2
Inscrit(e) le : 09/05/2017

http://nephalemschronicles.forumactif.com/
Yintatsu a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum