problème image qui ne s'affiche pas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu problème image qui ne s'affiche pas

Message par chrisnvidia le Mar 6 Juin 2017 - 10:21

Détails techniques


Version du forum : Invision
Poste occupé : Administrateur
Navigateur(s) concerné(s) : Google Chrome
Capture d'écran du problème :
Voir l'image:
[img][/img]

Personnes concernées par le problème : Tous les utilisateurs
Lien du forum : http://sos-pc.forumactif.org/

Description du problème

Bonjour tout le monde

Je voudrais savoir s'il n'y a pas un script pour changer automatiquement
le http en https car c'est très embêtant surtout pour la désinfection



clic sur enregistrer et choisis le bureau comme destination.


[*]Ferme toutes les applications, y compris ton navigateur
[*]Double-clique sur FRST.exe et clique sur Oui pour accepter le Disclaimer
/!\ Sous Vista, Windows 7 et 8, il faut lancer le fichier par clic-droit -> Exécuter en tant qu'administrateur
[*]  Sur le menu principal, clique sur Scan
[*]  patiente le temps de l'analyse



[*]A la fin du scan, un rapport FRST.txt.txt s'ouvre.
[*]A son premier lancement, l'outil va aussi créer un fichier nommé Addition.txt
[*]Pour poster les 2  rapports en lien dans ta réponse utilise cet hébergeur de fichiers : http://cjoint.com/
Les rapports sont enregistrés au même emplacement que l'outil et sous C:\FRST\Logs
[/list]

Merci d'avance pour votre aide Wink


Dernière édition par chrisnvidia le Mar 6 Juin 2017 - 14:26, édité 1 fois
avatar

chrisnvidia
**

Masculin
Messages : 76
Inscrit(e) le : 20/01/2015

http://sos-pc.forumactif.org/
chrisnvidia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème image qui ne s'affiche pas

Message par Neptunia le Mar 6 Juin 2017 - 11:18

Vous avez une option qui permet de forcer le https sur toutes les pages.

Cette option convertit d'office toute ressource http convertible en https et ignore toutes les ressources non convertibles.

Ensuite les rapports ne posent pas de problèmes puisqu'il s'agit de simples liens qui ne sont pas appelés sur la page.
cjoint.com n'est pas compatible https mais vous allez obtenir des liens de type http://www.cjoint.com/nom_de_fichier.txt qui ne posent aucun problème.

En revanche cette image ne s'affichera jamais du fait que pcland.fr n'est pas compatible https.
http://pcland.fr/tuto/migau/Fabar-FRST/frst.jpg

Il faut donc ré-héberger l'image sur un site fournissant des URL en https, servimg par exemple




Si vous ne voulez pas ré-héberger toutes vos images, il suffit dans la configuration du certificat, de choisir Non à "Forcer le https sur toutes les pages"
Toutes les images s'afficheront mais le cadenas vert n'apparaîtra que sur les pages sans ressource http
avatar

Neptunia
Membre actif

Féminin
Messages : 12395
Inscrit(e) le : 08/08/2010

https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème image qui ne s'affiche pas

Message par chrisnvidia le Mar 6 Juin 2017 - 12:20

hello Neptunia

Même si je clic sur non sur " "Forcer le https sur toutes les pages" les images ne s'affichent pas scratch

Ya pas un script pour forcer les images en http ?
avatar

chrisnvidia
**

Masculin
Messages : 76
Inscrit(e) le : 20/01/2015

http://sos-pc.forumactif.org/
chrisnvidia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème image qui ne s'affiche pas

Message par Neptunia le Mar 6 Juin 2017 - 12:40

Forcer les images en http ?

Dans ce cas pourquoi acquérir un certificat SSL puisque du moment que le certificat sera actif sur une page déterminée, toute ressource http ne sera plus disponible.

Si en désactivant le https sur toutes les pages, vous ne voyez toujours pas l'image, le problème ne vient pas de votre forum mais plutôt du navigateur.

Ce que vous pouvez vérifier facilement en choisissant HTTP comme protocole et qui ne fera pas revenir les images que vous ne voyez pas mais que vos membres continuent à voir normalement.

Et au fait ? Voyez vous l'image dans votre premier message ?
avatar

Neptunia
Membre actif

Féminin
Messages : 12395
Inscrit(e) le : 08/08/2010

https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème image qui ne s'affiche pas

Message par chrisnvidia le Mar 6 Juin 2017 - 13:11

Oui la 1 ère image je la vois car je l'ai hébergé en https Wink

Mais les autres non .

J'ai remis le forum en http mais les images apparaissent toujours pas scratch

avatar

chrisnvidia
**

Masculin
Messages : 76
Inscrit(e) le : 20/01/2015

http://sos-pc.forumactif.org/
chrisnvidia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème image qui ne s'affiche pas

Message par Neptunia le Mar 6 Juin 2017 - 13:56

On ne parle visiblement pas de la même image vu que votre premier message n'en comporte qu'une seule et pas en https

Si les images ne s'affichent pas sur votre forum même en http, c'est qu'elles ont été supprimées de chez l'hébergeur, il vous faut donc les ré-héberger ailleurs. Le moment idéal pour les mettre sur un hébergeur supportant le https.




Edité :

Je viens de voir en citant votre message qu'ily avairt d'autres images

Celle ci :
https://img11.imgup.net/pics/366951scan.jpg

Renvoie un message comme quoi la connexion n'est pas sécurisée.

Et si on enlève le s -> http://img11.imgup.net/pics/366951scan.jpg le lien redirige sur l'accueil de l'hébergeur, il s'agit donc d'un lien non valide, normal que rien ne s'affiche.
avatar

Neptunia
Membre actif

Féminin
Messages : 12395
Inscrit(e) le : 08/08/2010

https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: problème image qui ne s'affiche pas

Message par chrisnvidia le Mar 6 Juin 2017 - 14:26

Ok donc plus qu'à re héberger les images sur http://www.servimg.com/

Un grand merci pour tes lumières Neptunia thumright
avatar

chrisnvidia
**

Masculin
Messages : 76
Inscrit(e) le : 20/01/2015

http://sos-pc.forumactif.org/
chrisnvidia a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum