Publications : problème avec les ancres

Voir le sujet précédent Voir le sujet suivant Aller en bas

En cours Publications : problème avec les ancres

Message par papa pig le Dim 4 Fév 2018 - 12:00

Détails techniques

Version du forum : ModernBB
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : 04/02/2018
Lien du forum : http://www.batteriefanfare.com/p1015648-la-charte-du-forum

Description du problème

Bonjour, il est très confortable d'avoir la possibilité de créer des ancres lors de la rédaction de publications, qui permettent de faire un sommaire par exemple.
Ils sont proposés dès lors qu'on veut ajouter un lien, et dès lors qu'on a inséré des balises h2 h3 h4 dans le corps du message.
Or, une fois publiés, ces liens d'ancres sont dysfonctionnels.
Je tenais à vous le faire remonter.
Bien à vous, merci
scratch
avatar

papa pig
***

Masculin
Messages : 106
Inscrit(e) le : 22/01/2017

http://www.batteriefanfare.com
papa pig a été remercié(e) par l'auteur de ce sujet.

En cours Re: Publications : problème avec les ancres

Message par papa pig le Mar 6 Fév 2018 - 14:38

Bonjour!
UP, juste pour savoir si cela a été rajouté dans les bugs à résoudre
Cdt, merci bonne journée à vous
avatar

papa pig
***

Masculin
Messages : 106
Inscrit(e) le : 22/01/2017

http://www.batteriefanfare.com
papa pig a été remercié(e) par l'auteur de ce sujet.

En cours Re: Publications : problème avec les ancres

Message par papa pig le Mer 7 Fév 2018 - 22:14

Bonsoir
Petit up du jour pour savoir si le staff a bien eu l'info
Cdt, merci joker
avatar

papa pig
***

Masculin
Messages : 106
Inscrit(e) le : 22/01/2017

http://www.batteriefanfare.com
papa pig a été remercié(e) par l'auteur de ce sujet.

En cours Re: Publications : problème avec les ancres

Message par Leeloo le Ven 9 Fév 2018 - 11:05

Bonjour @papa pig

Les publications ne donnent pas la possibilité d'injecter du HTML et ne prennent pas en charge nativement les ancres, alors il est normal que ces derniers ne fonctionnent pas. Ce n'est pas un bug ni un oubli mais un comportement voulu.

Si l'utilisation des ancres ou autres attributs vous semble importante dans les publications, je vous suggère de nous en faire par dans ce sujet.

Cordialement,
Leeloo
avatar

Leeloo
Modéractive
Modéractive

Féminin
Messages : 612
Inscrit(e) le : 25/10/2007

http://forum.forumactif.com
Leeloo a été remercié(e) par l'auteur de ce sujet.

En cours Re: Publications : problème avec les ancres

Message par papa pig le Ven 9 Fév 2018 - 12:08

Bonjour, pardonnez-moi par avance d'insister, mais l'éditeur de publications embarque bien nativement un système d'hyper lien par ancrage dès lors qu'on formate des titres H2 H3 H4 dans le contenu d'un article.
Or, il y a bien présence d'un bug sur cet outil.
Cordialement
avatar

papa pig
***

Masculin
Messages : 106
Inscrit(e) le : 22/01/2017

http://www.batteriefanfare.com
papa pig a été remercié(e) par l'auteur de ce sujet.

En cours Re: Publications : problème avec les ancres

Message par papa pig le Lun 12 Fév 2018 - 12:11

Bonjour, je voudrais juste m'assurer que FA a bien noté le bug.
Si toutefois, vous n'êtes pas convaincus, demandez-moi des précisiosn, avez-vous besoin que je fasse une capture, ou autre ..? Je ne sais pas ce qu'il vous faut, mais je suis sûr de moi.
Cordialement.
avatar

papa pig
***

Masculin
Messages : 106
Inscrit(e) le : 22/01/2017

http://www.batteriefanfare.com
papa pig a été remercié(e) par l'auteur de ce sujet.

En cours Re: Publications : problème avec les ancres

Message par Chapo le Mar 20 Fév 2018 - 10:27

Bonjour @papa pig,

Votre remarque est très intéressante, car comme le rappelait @Leeloo il n'y a pas pour moi non plus de système permettant de gérer les ancres.

Pour que l'on soit bien d'accord sur les définitions, une ancre représente une partie d'un document qui est identifiée et à laquelle on peut accéder via un lien (interne ou externe au document), par exemple si je suis le lien http://domain.tld/page.html#anchor mon navigateur va ouvrir la page page.html sur le domaine domain.tld puis va rechercher l'élément d'id anchor pour s'y positionner; dans le code un lien (interne) ressemble à
Code:
<a href="#anchor">Lien vers l'ancre</a>

et l'ancre doit être un élément clairement identifié (lien, conteneur, ...)
Code:
<a id="anchor"></a>
Code:
<div id="anchor">...</div>

Si je me base sur l'éditeur des publications, on peut indiquer des titres (de type h2, h3 ou h4), on peut ajouter des liens (qui peuvent contenir une ancre) mais on ne peut pas ajouter d'ID aux éléments; a priori il n'est donc pas possible de gérer des ancres dans une page de publications.

Dans la mesure où vous nous dites
@papa pig a écrit:mais l'éditeur de publications embarque bien nativement un système d'hyper lien par ancrage
je me doute que vous voyez quelque chose que nous ne voyons pas et potentiellement je peux imaginer 1000 choses mais ne peux pas vous apporter de réponse précise. Afin que nous puissions vous aider et éventuellement prendre en charge ce bug si sa présence est confirmée merci de bien vouloir nous transmettre un maximum d'informations (même des impressions d'écran indiquant de quoi vous parlez si cela vous arrange). Wink

Merci
avatar

Chapo
Dévactif
Dévactif

Masculin
Messages : 5136
Inscrit(e) le : 02/05/2006

http://forum.forumactif.com
Chapo a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum