Problème avec un script

3 participants

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec un script

Message par bertrand_del Jeu 20 Déc 2012 - 8:05

Bonjour,

J'avais le module "partagez" en voulant faire des modifications pour installer des scripts facebook tout a disparu , en parcourant le forum, j'ai trouvé ce tuto https://forum.forumactif.com/t290177-installer-un-module-partager il correspond à ce que j'aimerai avoir , j'ai tout fait comme indiqué , mon css du pa est vide provisoirement pour voir si le problème n'était pas là, j'ai tout copié comme sur le tuto, la partie dans le CSS et l'autre en JS, mais rien ne s'affiche , merci de votre aide .
Bien cordialement

Ne possédant plus le logiciel de copies d'écran je ne peux vous le montrer, mais je doute avoir fait une erreur si vous voulez voir , si cela est lié qu'à mon forum ou mon pc voici mon forum
bertrand_del

bertrand_del
**

Masculin
Messages : 70
Inscrit(e) le : 14/11/2012

Voir le profil de l'utilisateur http://neo-igs-police.1fr1.net
bertrand_del a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par Arlem Jeu 20 Déc 2012 - 10:48

Bonjour,

Vos scripts pour facebook et GeoMap sont mal installés ce qui a pour effet d'annuler l'effet des autres que vous voulez installer. Tant que vous ne les aurez pas bien insérés pas la peine d'essayer d'en ajouter d'autres. Smile
avatar

Arlem
Membre actif

Messages : 2550
Inscrit(e) le : 30/06/2009

Voir le profil de l'utilisateur
Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par bertrand_del Jeu 20 Déc 2012 - 11:07

Arlem a écrit:Bonjour,

Vos scripts pour facebook et GeoMap sont mal installés ce qui a pour effet d'annuler l'effet des autres que vous voulez installer. Tant que vous ne les aurez pas bien insérés pas la peine d'essayer d'en ajouter d'autres. Smile

Bonjour merci de votre réponse, donc cela serait la cause du problème , pourtant il n'y a pas de codes de fb ni de geo loc dans le CSS, je ne savais pas car je ne connais pas trop cela, donc je dois enlever les codes fb et les geo loc ,mais comment faire, il faut dire le geo loc compte que les personnes ''membres pas les visiteurs '' donc je peux m'en passer , quant à fb pas indispensable si on ne peut pas faire autrement, donc votre réponse serait si j'ôte tout ces codes en conflit, mon script de partage que je souhaite fonctionnera,

Je viens d'enlever le widget avec geo loc et fb , ça ne fonctionne toujours pas
Merci pour votre réponse
bertrand_del

bertrand_del
**

Masculin
Messages : 70
Inscrit(e) le : 14/11/2012

Voir le profil de l'utilisateur http://neo-igs-police.1fr1.net
bertrand_del a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par Arlem Jeu 20 Déc 2012 - 11:19

Ils ne posent pas de problème dans le CSS, mais là où vous les avez mis dans la gestion des codes Javascript. Il ne faut pas obligatoirement que vous les retiriez, simplement que vous corrigiez l'endroit où vous les avez mis.

Pour le code de GeoMap et Facebook, étant donné qu'il s'agit de HTML, le code qui vous a été donné est a mettre soit sur la PA soit dans les templates, mais pas dans la gestion des codes Javascript.
avatar

Arlem
Membre actif

Messages : 2550
Inscrit(e) le : 30/06/2009

Voir le profil de l'utilisateur
Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par bertrand_del Jeu 20 Déc 2012 - 12:07

Je comprends de mieux en mieux, car je débute, j'en apprends tous les jours, ce qui est très positif, j'ai vérifié les codes fb sont bien mis dans l' html, le geo loc , je ne le trouve plus, mais c'est pas le plus important , en tout cas le geo visites qui est sur le portail est un js, ceci étant rien ne fonctionne pour ce que je désire à savoir, les icones partages comme indiqué au dessus , que puis je faire, je pense avoir fait une erreur de choix d'avoir pris un forum invision, je n'ai pas d'accès aux templates , je suis donc très limité et trop de travail pour reprendre un autre forum php bb avec accès aux templates, les erreurs des débutants
bertrand_del

bertrand_del
**

Masculin
Messages : 70
Inscrit(e) le : 14/11/2012

Voir le profil de l'utilisateur http://neo-igs-police.1fr1.net
bertrand_del a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par bertrand_del Ven 21 Déc 2012 - 10:15

Bonjour à vous,

Si quelqu'un connait les raisons de mon problème, peut me répondre ça serai gentil , je ne peux plus rien installer dans le CSS depuis ma dernière manip ,

J'ai procédé à ce que l 'on ma dit , mais c'est toujours la même chose, désolé de vous déranger , je vous remercie
bertrand_del

bertrand_del
**

Masculin
Messages : 70
Inscrit(e) le : 14/11/2012

Voir le profil de l'utilisateur http://neo-igs-police.1fr1.net
bertrand_del a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par Arlem Ven 21 Déc 2012 - 12:15

Bonsoir,

Vous n'avez pas enlevé les codes qui posent problème comme je vous l'avais dit.
Dans panneau d'administration => Modules => Gestion des codes Javascript => Cherchez et supprimez ceux qui contiennent les codes suivants :
- Celui-ci est inutile :
Code:
<script type=text/javascript src=http:
- Celui-ci correspond au code GeoMap, il ne doit pas se trouver dans les codes Javascript car il s'agit de HTML, si vous voulez le garder il faut le placer dans le message sur la page d'accueil ou sur une page HTML :
Code:
<!--************CODE GEOMAP************--><script type="text/javascript"src="http://geoloc9.whoaremyfriends.com/private/geomap.js?compte=936546739358"></script><noscript><a href="http://www.geovisites.com/fr/directory/informatique_actualite-et-medias.php?compte=936546739358"target="_blank"><img src="http://geoloc9.whoaremyfriends.com/private/geomap.php?compte=936546739358"border="0"alt="informatique"></a><br>Please do not change this code for a perfect fonctionality of your counter<a href="http://www.geovisites.com/fr/directory/informatique_actualite-et-medias.php">informatique</a></noscript><br><a href="http://www.geovisite.com/en/">web hit counter</a><!--************END CODE GEOMAP************-->
- Pareil que le précédent, ce code correspondant a votre badge facebook ne doit pas se trouver dans les codes Javascript :
Code:
<!--Facebook Badge START--><a href="https://www.facebook.com/harolddanfair"target="_TOP"style="font-family: &quot;lucida grande&quot;,tahoma,verdana,arial,sans-serif; font-size: 11px; font-variant: normal; font-style: normal; font-weight: normal; color: #3B5998; text-decoration: none;"title="Harold Danfair">Harold Danfair</a><br/><a href="https://www.facebook.com/harolddanfair"target="_TOP"title="Harold Danfair"><img src="https://badge.facebook.com/badge/566579555.235.395995138.png"style="border: 0px;"/></a><br/><a href="http://www.facebook.com/badges/"target="_TOP"style="font-family: &quot;lucida grande&quot;,tahoma,verdana,arial,sans-serif; font-size: 11px; font-variant: normal; font-style: normal; font-weight: normal; color: #3B5998; text-decoration: none;"title="Créez votre propre badge !">Cré️ez votre badge</a><!--Facebook Badge END-->

Il existe trois types de "codes" utilisables sur les forums Forumactif :
- Le CSS
- Le HTML
- Le Javascript

Chacun de ces langages à ses particularités et ne peut pas être placé n'importe où, sinon... ça plante. Wink
avatar

Arlem
Membre actif

Messages : 2550
Inscrit(e) le : 30/06/2009

Voir le profil de l'utilisateur
Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par bertrand_del Ven 21 Déc 2012 - 15:08

Bonsoir Arlem,

En effet il restait deux codes dans je JS sauf que je ne sais pas toujours reconnaitre ce qui est HTML ou JS Ce qui me reste en JS sont les décos de noel prises ici, un code de traduction google, si j'ai compris pour le copier ici je vais le mettre, je souhaite qu'après avoir enlevé tout ça , je vais pouvoir remettre des scripts qui vont fonctionner comme précédemment

Spoiler:


bertrand_del

bertrand_del
**

Masculin
Messages : 70
Inscrit(e) le : 14/11/2012

Voir le profil de l'utilisateur http://neo-igs-police.1fr1.net
bertrand_del a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par bertrand_del Ven 21 Déc 2012 - 15:27

Mes codes fb sont dans un widget en HTML , sont ils corrects,

Spoiler:

bertrand_del

bertrand_del
**

Masculin
Messages : 70
Inscrit(e) le : 14/11/2012

Voir le profil de l'utilisateur http://neo-igs-police.1fr1.net
bertrand_del a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par Arlem Ven 21 Déc 2012 - 15:52

Maintenant que vous avez supprimé les scripts qui posaient problème, vous devez pouvoir reprendre l'installation de la barre de partage qui devrait fonctionner normalement.

Pour différencier le HTML des autres différents types de code, vous pouvez le repérer car c'est un langage de balise, il s'utilise sous la forme <balise>contenu</balise>.

Concernant le code de votre widget, vous affiche-t-il ce que vous souhaitez ?
avatar

Arlem
Membre actif

Messages : 2550
Inscrit(e) le : 30/06/2009

Voir le profil de l'utilisateur
Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par bertrand_del Ven 21 Déc 2012 - 17:00

Merci Arlem pour votre aide, je vais essayer de poursuivre ce que je voulais , en espérant que tout marche, dans tous les cas , j'ai procédé comme vous me l'avez indiqué, le widget a tous les FB il a l'air de fonctionner, le seul prbme dans le dernier fb '' like '' la fenêtre ne peut s'ouvrir complètement, c'est la raison pour laquelle je souhaitais la mettre au milieu du forum sous la barre de navigation, puis je me permettre de vous recontacter si mon problème persiste ....

Un grand merci , je vous souhaite une bonne soirée,
bertrand_del

bertrand_del
**

Masculin
Messages : 70
Inscrit(e) le : 14/11/2012

Voir le profil de l'utilisateur http://neo-igs-police.1fr1.net
bertrand_del a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par Arlem Ven 21 Déc 2012 - 17:16

Créez un nouveau sujet si vous avez un nouveau problème, ça permet de simplifier les recherches si quelqu'un a un jour le même problème que vous. Wink
avatar

Arlem
Membre actif

Messages : 2550
Inscrit(e) le : 30/06/2009

Voir le profil de l'utilisateur
Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par bertrand_del Ven 21 Déc 2012 - 17:19

Tout à fait je ferai ainsi, en tout cas j'en ai beaucoup appris,
bertrand_del

bertrand_del
**

Masculin
Messages : 70
Inscrit(e) le : 14/11/2012

Voir le profil de l'utilisateur http://neo-igs-police.1fr1.net
bertrand_del a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec un script

Message par Tech Ven 21 Déc 2012 - 17:21

Problème avec un script Check10Bonjour,

Afin de faciliter la gestion des problèmes, si votre problème est résolu, pensez à :
  • éditer votre premier message,
  • cocher l'icône résolu
  • Et enregistrer en cliquant sur Problème avec un script Envoi10


Vous pouvez également remercier les personnes qui vous ont aidé, en cliquant sur le bouton Problème avec un script 50378

A bientôt sur ForumActif Smile
Tech

Tech
Membre actif

Masculin
Messages : 22683
Inscrit(e) le : 01/12/2007

Voir le profil de l'utilisateur https://forum.forumactif.com/
Tech a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum