Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Problème de code [résolu]

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème de code [résolu]

Message par Shak le Mer 26 Mar 2014 - 19:11

Bonjour, Bonsoir,  Very Happy 

Pour commencer, sachez que mon forum est en phpbb2.
Voilà, mon problème concerne une infobulle. Les images seront surement plus parlantes qu'un long texte:

Lorsqu'on passe la souris sur l'image, l'infobulle s'ouvre de la sorte:


Le soucis c'est que, comme on peut le voir, la seconde bulle dans laquelle est marqué "Valkyrs ; Admin" n'est pas dans son cadre et dépasse de l'infobulle...
J'ai bien réussi à retirer la bulle, ce qui fait que le texte était correctement positionné, seulement j'aimerais garder cette bulle qui s'est ajoutée contre mon gré (bin oui à force de la voir je l'aime bien moi)

Voici mes codages, si un âme charitable parvenait à trouver le soucis (selon moi il faut rajouter un code, mais j'ai beau bidouiller, je n'arrive pas à trouver lequel... donc bon) ça m'aiderait grandement !
Voici mes codes :

Code CSS:



De plus, lorsque je copie/colle plusieurs fois le code (pour avoir plusieurs infobulles, les images sont collées les unes aux autres de la sorte :
Si vous arriviez à mes les séparer d'un retour à la ligne ou deux, ça m'aiderait grandement ! Car à part dérégler tout mon code je n'arrive pas à grand chose (grmbl)


Merci d'avance !  Flowers2


Dernière édition par Shak le Jeu 27 Mar 2014 - 10:47, édité 1 fois

Shak
Nouveau membre

Féminin
Messages : 16
Inscrit(e) le : 19/05/2013

http://universite-les-camel.forumactif.org/
Shak a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code [résolu]

Message par Scoubifitz le Jeu 27 Mar 2014 - 0:43

bonsoir,

Remplacez entièrement le CSS par celui ci :

Code:
.infobulle{
  position: relative;
  margin-bottom:20px;
}

.infobulle>span{
  display:none;
  position: absolute;
  padding: 5px;
  top: 5px;
  left: 15px;
  background-color: #000000;
  color: #ffffff;
  z-index: 1;
}

.infobulle span img{
  border: 1px solid;
  padding: 3px;
}

.infobulle:hover span{
  display:block;
  width: 140px ;
  border: 1px solid #ffffff;
  text-align:center;
  -moz-border-radius: 12px;
  -webkit-border-radius: 12px;
  border-radius: 12px;
}
avatar

Scoubifitz
Membre actif

Masculin
Messages : 3598
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de code [résolu]

Message par Shak le Jeu 27 Mar 2014 - 10:47

C'est merveilleux, c'est ce que je voulais !

Merci beaucoup Very Happy

Shak
Nouveau membre

Féminin
Messages : 16
Inscrit(e) le : 19/05/2013

http://universite-les-camel.forumactif.org/
Shak a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum