Iframes qui ne s'affichent plus sur notre forum, problème SSL

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Mathildenst le Mar 15 Aoû 2017 - 14:06

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome, Internet Explorer, Mozilla Firefox
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : Le problème a lieu depuis plus de deux mois et nous pensons que c'est lié au certificat SSL qu'on a eu récemment, nous avons que des soucis sur le forum depuis...
Lien du forum : https://www.schoolgraph.com/

Description du problème

Bonjour,
Depuis quelques temps nous n'avons que des soucis sur notre forum : les images qui ne s'affichent plus, les codes déformés selon les navigateurs et j'en passe...
Et maintenant voilà qu'on a encore un nouveau soucis lié aux iframes. En effet, depuis un ou deux mois je dirais, quand nous postons les fiches de nos forums partenaires, les fiches (uniquement celles en iframe et hébergées dans les modules forumactif chez nos partenaires) ne s'affichent plus et laissent des sujets vides ! Nous ne trouvons pas d'où vient le problème.
J'ai regardé et pour moi tous ces soucis viennent d'une incompatibilité avec le certificat SSL du forum, en plus de ne pas être marqué sécurisé alors qu'on l'a acheté avec nos crédits, tous les liens http ne fonctionneraient donc plus selon moi sur le forum, mais je ne vois pas comment mettre des liens https alors que nos forums partenaires ne sont pas HTTPS et leurs iframes sont tous en http. il nous est donc impossible de changer quoi que ce soit !
Nous avons aussi eu récemment le soucis d'affichage des images, nous avons du tout réhéberger et plus aucun de nos hébergeurs ne fonctionnaient, nous avions lu le sujet explicatif mais nous ne pouvons pas réhéberger tous les boutons partenaires, ni leurs fiches pub nous n'y sommes bien entendu pas autorisé car ça serait s'approprier leurs codes etc.

Je ne vois pas du tout si c'est lié au certificat SSL, ni pourquoi tous ces problèmes depuis quelques temps ! Si c'est pour avoir autant de soucis et ne même pas avoir mon forum sécurisé je préfère autant cesser ce certificat qui n'a aucun intêret pour le coup j'ai l'impression !

Merci de votre réponse.


Dernière édition par Chacha le Dim 20 Aoû 2017 - 14:53, édité 2 fois (Raison : Sujet déplacé dans la section Problème avec mes crédits, mon nom de domaine, mon certificat SSL ou autres fonctionnalités payantes)
avatar

Mathildenst
*

Féminin
Messages : 30
Inscrit(e) le : 06/12/2015

http://school-graph.forumactif.org/
Mathildenst a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Neptunia le Mar 15 Aoû 2017 - 15:06

Bonjour ^^


Comme indiqué sur votre panneau d'administration :
Le passage en HTTPS de votre forum nécessite que toutes les ressources externes (images, JavaScripts, CSS, ...) soient appelées en HTTPS. Pour plus d’informations, lire ce tutoriel.

Les iframes sont des ressources externes qui doivent elles aussi être appelées en https.
Si vous n'en avez pas la possibilité, il reste une option permettant de ménager la chèvre https et les choux http. Option disponible uniquement au fondateur du forum
Right PA > Divers > Gestion des crédits > Résumé / Synthèse > Activation du certificat SSL > Modifier

-> Forcer la compatibilité HTTPS (label "Sécurisé") : Non :enreg:

Sur une page donnée il y aura deux cas de figure
- Si une ou des ressources sont encore appelées en http elles seront affichées mais le cadenas ne sera pas présent. La page sera en http avec toutes ses ressources.
- Si toutes les ressources de la page sont en https, la connexion (sur cette page) sera sécurisée et le cadenas présent.

Cette option permettra d'afficher n'importe quelle ressource comme sur un forum http mais se fera au détriment du cadenas dès qu'il y aura au moins une ressource appelée en http.
avatar

Neptunia
Membre actif

Féminin
Messages : 12200
Inscrit(e) le : 08/08/2010

https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Mathildenst le Mar 15 Aoû 2017 - 15:14

Bonjour,
Merci pour votre réponse.
Ca a en effet réglé le soucis d'affichage de certaines images mais les iframes de nos partenaires ne s'affichent toujours pas !
avatar

Mathildenst
*

Féminin
Messages : 30
Inscrit(e) le : 06/12/2015

http://school-graph.forumactif.org/
Mathildenst a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Mathildenst le Dim 20 Aoû 2017 - 11:17

Up, on aimerait beaucoup résoudre ce problème !
avatar

Mathildenst
*

Féminin
Messages : 30
Inscrit(e) le : 06/12/2015

http://school-graph.forumactif.org/
Mathildenst a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Neptunia le Dim 20 Aoû 2017 - 13:23

Pourrions nous avoir le code complet (html/css) d'un exemple d'iframe ne fonctionnant pas ?
avatar

Neptunia
Membre actif

Féminin
Messages : 12200
Inscrit(e) le : 08/08/2010

https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Mathildenst le Dim 20 Aoû 2017 - 13:50

Tous les iframes ne fonctionnent pas partie partenaires, c'est que des iframes partenaires donc je me permet de mettre les codes qui ne s'affichent pas mais ils ne sont pas hébergés sur notre forum bien entendu, ce sont des fiches publicités externes qui sont nos fiches partenaires
Notre iframe publicité hébergée dans nos propres modules dans le PA de School Graph marche très bien chez nous et s'affiche cependant, c'est peut-être un bon indice pour trouver le soucis !
Il n'y a que les iframes externes qui ne s'affichent pas :/

Code:
[center]<iframe name="Fiche_pub_SA" src="http://sweet-art.forumactif.com/h5-fiche-publicite-sweet-art" scrolling="no" height="760" width="600" FRAMEBORDER="no"></iframe>[/center]

Code:
<iframe src="http://dark-and-cold.forumactif.com/h3-seconde-fiche-partenariat-par-chaton" height="1100" width="650" frameborder="0" scrolling="no"></iframe>

et plusieurs autres iframes partenaires, chose très embêtante pour l'affichage des partenaires qui se retrouvent sans leur forum affiché chez nous dû à ce soucis ! Merci
avatar

Mathildenst
*

Féminin
Messages : 30
Inscrit(e) le : 06/12/2015

http://school-graph.forumactif.org/
Mathildenst a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Neptunia le Dim 20 Aoû 2017 - 14:21

Mathildenst a écrit:Notre iframe publicité hébergée dans nos propres modules dans le PA de School Graph marche très bien chez nous et s'affiche cependant, c'est peut-être un bon indice pour trouver le soucis !
Il n'y a que les iframes externes qui ne s'affichent pas :/

Bah cela n'a rien d'anormal que votre iframe interne s'affiche puisqu'elle est sur un forum en https, l'iframe est appelée en https (même si le code que vous utilisez est en http, le système place une redirection transparente de vos pages http vers https.

Je reproduis toutefois le problème sur mon forum. Les iframes de forums Forumactif en http ne passent pas sur mon forum quelque soit le réglage retenu à l'option Forcer la compatibilité HTTPS alors qu'à mon humble avis, elles devraient être ignorées en mode HTTPS forcé (y-compris leur taille) et tolérées en mode HTTPS non forcé.

Un test intéressant serait de savoir si une iframe HTTP vraiment externe (donc pas sur un Forumactif) serait acceptée ou non.

La seule solution provisoire étant de choisir le protocole http et de perdre le bénéfice du cadenas.

Je vous suggère de remonter régulièrement ce sujet (minimum une fois par période de 7 jours) tant qu'un membre du staff n'y sera pas intervenu.




Edité :

Précision pour le staff pro.
En mode https non forcé l'iframe s'affiche. C'est uniquement son contenu qui ne s'affiche pas. L'iframe est bien là mais sa balise body est entièrement vide.
avatar

Neptunia
Membre actif

Féminin
Messages : 12200
Inscrit(e) le : 08/08/2010

https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Mathildenst le Dim 20 Aoû 2017 - 14:39

Merci de votre réponse @Neptunia,
Vous m'avez dit précédemment de ne pas forcer l'https, chose faite donc à ce moment nous avons les paramétrages suivants :


Mettre notre forum en http serait dépenser nos crédits pour ne pas pouvoir profiter de la mention sécurisée, chose inutile à nos yeux car nous pensions avoir un avantage...je vais mettre ça de façon provisoire en effet en attendant une réponse mais j'avoue être embêtée. En effet, si on ne force pas l'https les iframes devraient être affichés, je ne comprend pas pourquoi ils ne sont pas pris en compte pour un HTTP !

J'ai fait la comparaison demandée. Voici le résultat : j'ai pris un iframe venant de youtube, donc site sécurisé en https, l'iframe s'affiche bien. Une page de chez 20 minutes, non sécurisé en http donc, ne fonctionne pas, avec le même iframe que pour Youtube, juste la redirection lien qui change (http/https), voyez-vous même sur ma capture d'écran : https://i.goopics.net/dvDjL.png

Donc forumactif ou non, les iframes HTTP ne fonctionnent pas sur un forum sécurisé...
Il serait impossible de mettre tous les sites et iframes d'autres forums en HTTPS pour notre forum ! Certains ne veulent pas d'https, et on ne peut pas résoudre ça en modifiant les liens ! ^^
avatar

Mathildenst
*

Féminin
Messages : 30
Inscrit(e) le : 06/12/2015

http://school-graph.forumactif.org/
Mathildenst a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Neptunia le Dim 20 Aoû 2017 - 14:47

Mettre notre forum en http serait dépenser nos crédits pour ne pas pouvoir profiter de la mention sécurisée, chose inutile à nos yeux car nous pensions avoir un avantage...

Même si je suis moi même passée au https, j'ai dit assez souvent ici ce que je pensais du https mais je répéterais tout de même qu'à mes yeux le https est avant tout une source de nombreux inconvénients.

Et je suis d'accord avec vous. Acheter un certificat SSL pour ne pas l'activer est une aberration. Voilà pourquoi j'avais insisté sur le mot provisoire.
Plus qu'à patienter et vous ne devriez pas avoir à attendre longtemps si je me fie à mon flair.
avatar

Neptunia
Membre actif

Féminin
Messages : 12200
Inscrit(e) le : 08/08/2010

https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Mathildenst le Mar 22 Aoû 2017 - 10:29

Oui exactement... Le https ne fait que nous provoquer des inconvénients hélas :c
Merci Neptunia Smile
avatar

Mathildenst
*

Féminin
Messages : 30
Inscrit(e) le : 06/12/2015

http://school-graph.forumactif.org/
Mathildenst a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Chacha le Ven 25 Aoû 2017 - 11:19

Bonjour,

Renseignements pris, voici la réponse des techniciens Wink


Concernant ce problème, c'est normal :

Ces options lui permettent aussi de forcer le forum à être compatible avec le protocole HTTPS (label "Sécurisé" sur toutes les pages mais certaines ressources seront ignorées) ou encore de passer en HTTPS de façon entièrement automatisée tous les liens des ressources de base sur Forumactif ainsi que les services les plus utilisés sur les forums. Donc plus aucun besoin de faire des remplacements de liens de façon manuelle pour ces ressources Very Happy

http://forum.forumactif.com/t389989p150-nouveau-possibilite-de-passer-son-forum-forumactif-en-https

Certaines ressources ne passent pas, et nos techniciens ne peuvent hélas rien y faire... Sad


Cordialement.
avatar

Chacha
Modéractif
Modéractif

Masculin
Messages : 54597
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Neptunia le Ven 25 Aoû 2017 - 11:30

Bonjour Chacha

[quote]
Concernant ce problème, c'est normal :

Certaines ressources ne passent pas, et nos techniciens ne peuvent hélas rien y faire... Sad

Cordialement.

En dehors des iframes, quelles sont les autres ressources ne passant pas ?

J'imagine <embed>, <object> ?
avatar

Neptunia
Membre actif

Féminin
Messages : 12200
Inscrit(e) le : 08/08/2010

https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Chacha le Ven 25 Aoû 2017 - 11:35

Bonjour Neptunia,

La question est transmise Wink


Cordialement.
avatar

Chacha
Modéractif
Modéractif

Masculin
Messages : 54597
Inscrit(e) le : 21/08/2010

http://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Mathildenst le Ven 25 Aoû 2017 - 12:35

Merci de votre réponse,
Il n'y a donc aucun moyen de mettre des iframes sur un forum https ?
Si c'est le cas alors je ne renouvellerai pas le SSL l'année prochaine, ça n'apporte pas grand chose de plus, mis à part des soucis depuis que nous l'obtenons.
avatar

Mathildenst
*

Féminin
Messages : 30
Inscrit(e) le : 06/12/2015

http://school-graph.forumactif.org/
Mathildenst a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Walt le Ven 25 Aoû 2017 - 12:47

Bonjour,

Une iframe affichant un contenu HTTPS s'affichera sur un forum en HTTPS. C'est le contenu mixte qui pose problème. A terme néanmoins, de plus en plus de sites passeront vers le HTTPS, il faudra donc voir comment évoluent les choses.

Cordialement,
Walt
avatar

Walt
Modéractif
Modéractif

Masculin
Messages : 3283
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Mathildenst le Ven 25 Aoû 2017 - 13:24

Je pense que beaucoup de forums resteront en http car forumactif est un service gratuit qui leur permet de créer leur forum sans payer, certains voudront payer pour obtenir ces bénéfices, d'autres non. À ce jour si je regarde parmi les forums partenaires du mien, 3/4 forums sont restés pour le moment en http. Ça m'empêche d'ailleurs d'afficher leurs fiches publicité http, les partenariats étant un des moyens supplémentaires de gagner des membres et de la visibilité, si je perd mes partenaires à cause d'une mauvaise visibilité je ne peux pas avoir ma visibilité dont j'ai besoin pour mettre en valeur mon forum de manière externe. Donc le soucis de non-affichage de l'http et surtout les iframes http dans mon cas nous embête beaucoup. J'ai acheté un certificat de sécurité et au final cela nous empêche de donner de la visibilité donc au final c'est perdant pour nous. Par ailleurs, si on force les ressources https les images hébergées par nos membres en http, les images ne s'affichent plus (chacun a encore le droit de choisir son hébergeur hélas et nous n'allons pas en imposer à qui que ce soit), donc au final notre forum n'est pas HTTPS. Je considère que les images comme les avatars ou les signatures appartiennent aux membres et je ne me réserve aucun droit de les re-héberger.
Donc au final, si on force l'https on a des soucis d'affichage partout, si on ne le force pas on aura toujours plus d'images mais toujours pas d'iframes visibles...
avatar

Mathildenst
*

Féminin
Messages : 30
Inscrit(e) le : 06/12/2015

http://school-graph.forumactif.org/
Mathildenst a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Walt le Ven 25 Aoû 2017 - 13:43

Je pense que beaucoup de forums resteront en http car forumactif est un service gratuit qui leur permet de créer leur forum sans payer, certains voudront payer pour obtenir ces bénéfices, d'autres non.
C'est une position que vous prenez aujourd'hui, en ayant à l'esprit le fonctionnement actuel du Net. Il faut voir dans quel sens évoluent les restrictions imposées par les navigateurs pour les sites n'arborant pas de certificat SSL. En quelques mois, la situation a déjà pas mal évolué :
  1. absence de cadenas vert
  2. présence d'un cadenas rouge
  3. présence d'un cadenas rouge + avertissement au clic sur un champ de type password
Rien n'indique que ces exigences n'augmentent pas encore dans les mois à venir, sans que ni vous ni moi n'ayons une quelconque possibilité de les éviter. Avec la conséquence potentielle de devoir réviser sa position sur le SSL.

Par ailleurs, si on force les ressources https les images hébergées par nos membres en http, les images ne s'affichent plus
C'est ce que j'entendais par "de plus en plus de sites passeront vers le HTTPS". Un hébergeur d'images qui d'ici la fin de l'année ne serait pas en HTTPS verrait son avenir, à mon sens, fortement compromis... En outre, Forumactif passe automatiquement en HTTPS les images (et autres ressources) hébergées sur les services externes suivants :
archive-host.com
gyazo.com
hostingpics.net
i.imgur.com
imgup.net
imgur.com
photobucket.com
postimg.org
servimg.com

Deux observations :
  1. cette liste me semble être suffisamment étoffée pour permettre un choix raisonnable à vos membres,
  2. lorsque nous avons établi cette liste, j'ai pu échanger avec de nombreux services d'hébergement et les 3/4 envisageaient un passage au HTTPS à plus ou moins long terme. Elle est donc appelée à s'étoffer davantage

Cordialement,
Walt
avatar

Walt
Modéractif
Modéractif

Masculin
Messages : 3283
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Iframes qui ne s'affichent plus sur notre forum, problème SSL

Message par Mathildenst le Ven 25 Aoû 2017 - 14:52

Si la liste s'étoffe ça ne pourrait qu'être bénéfique en effet. Pour ma part j'utilise goopics, déjà en https et cela s'affiche correctement sur mon forum donc, aucun besoin de redirection. J'utilisais hostingpics auparavant, mais l'envoie d'images (surtout pour chaque nouveau thème à installer, étant un forum graphique) était trop lent ^^ Cependant les membres utilisant zupimages, noelshack etc. qui sont pratiques et également réputés ne sont pas en https (il y en a tellement que la liste est longue, passer les ressources http en https de tous les hébergeurs doit être compliqué en effet).
Vous avez raison, il faut voir l'évolution de l'https sur le web.
Cependant notre forum va continuer à n'afficher que le https sans le cadenas vert pendant 1 an avec en supplément certaines images hébergées par nos membres sur des sites ne figurant pas dans votre liste et donc en http (si je force l'https rien n'apparaîtra plus) et à ne pas afficher les iframes de nos partenaires qui ont donc hébergé leur code dans les modules sur Forumactif quand même et qui ont pris un iframe pour relier sur des forums externes (pub,partenaires etc.) Ce n'est pas normal que même sans forcer l'https, les iframes http ne s'affichent pas, ne pourraient-ils pas être redirigé en https non plus ?
avatar

Mathildenst
*

Féminin
Messages : 30
Inscrit(e) le : 06/12/2015

http://school-graph.forumactif.org/
Mathildenst a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum