Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

3 participants

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Futuroscophile Mer 07 Fév 2018, 10:26

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome, Safari
Personnes concernées par le problème : Moi uniquement
Problème apparu depuis : mercredi 07/02/2018
Lien du forum : http://www.forum-futuroscope.net

Description du problème

Bonjour, j'ouvre ce sujet pour vous demander secours :

Je constate depuis ce matin qu'il est impossible pour moi de me connecter au compte fondateur de mon forum (dernière connexion lundi 5 février).

Je connais pourtant les identifiants par cœur.

Je soupçonne que le souci est lié à l'encodage en UTF-8 que j'ai demandé ces derniers jours. Mon mot de passe contient lui-même une lettre avec diacritique …

J'ai constaté en même temps que plusieurs pages HTML du forum affichent mal beaucoup de caractères, alors que je n'avais jamais rencontré de souci de ce type …
Mad

Est-ce normal, est-ce temporaire ? La conversion en UTF-8 est-elle en cours ou a t-elle échoué ? Cela impacte-t-il effectivement les identifiants des utilisateurs ? confused Dans quel délai pourrai-je me reconnecter, ou suis-je bloqué ????

(Je précise que je n'ai pas accès la boîte mail du fondateur … je suis administrateur et le fondateur m'avait légué ses identifiants il y a des années en quittant le forum).

Si un modéractif ou un aidactif peut m'aider … Merci !
Futuroscophile

Futuroscophile
***

Masculin
Messages : 152
Inscrit(e) le : 09/02/2008

Voir le profil de l'utilisateur http://www.forum-futuroscope.net
Futuroscophile a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Chapo Mer 07 Fév 2018, 10:43

Bonjour,

tout d'abord pour votre problème principal (la connexion au PA) il est possible que la présence d'un signe diacritique joue sur la connexion même si les mots de passe ne sont pas stockés en clair et bien que nos différents tests n'aient rien relevés de tel jusqu'à présent. Quoiqu'il en soit, et même si vous n'avez pas accès au compte fondateur nous pouvons vous régénérer un mot de passe (juste pour que vous accédiez au PA, vous pourrez par la suite redéfinir le mot de passe tel que cela vous convient).

Pour ce qui est des symboles apparaissant sur le forum nous allons bien évidemment vous aider à résoudre ces problèmes, n'hésitez pas à nous tenir informé (pour les pages que vous appelez en iframe par exemple la cause est simple: elle sont désormais en UTF-8 alors que vous forcez l'encodage en Windows-1252)
Chapo

Chapo
Dévactif
Dévactif

Masculin
Messages : 5155
Inscrit(e) le : 02/05/2006

Voir le profil de l'utilisateur
Chapo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Futuroscophile Mer 07 Fév 2018, 10:48

Merci pour la réponse rapide @Chapo
Quelle est la marche à suivre pour régénérer le mdp ?
Futuroscophile

Futuroscophile
***

Masculin
Messages : 152
Inscrit(e) le : 09/02/2008

Voir le profil de l'utilisateur http://www.forum-futuroscope.net
Futuroscophile a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Chapo Mer 07 Fév 2018, 10:58

J'ai besoin de votre nom d'utilisateur sur le forum.

Pour ce qui est des signes qui apparaissent de façon incorrecte, j'ai jusqu'à présent trouvé 2x le caractère
Code:
& #65533;
(dans index_body et dans overall_footer_end) mais ce dernier ne semble pas être un caractère affichable car je l'ai testé sous Firefox et Chrome sur d'autres pages et j'ai toujours le symbole de caractère "cassé"
Chapo

Chapo
Dévactif
Dévactif

Masculin
Messages : 5155
Inscrit(e) le : 02/05/2006

Voir le profil de l'utilisateur
Chapo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Futuroscophile Mer 07 Fév 2018, 11:01

Compte fondateur concerné par le problème : fondateuroscope
Futuroscophile

Futuroscophile
***

Masculin
Messages : 152
Inscrit(e) le : 09/02/2008

Voir le profil de l'utilisateur http://www.forum-futuroscope.net
Futuroscophile a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Chapo Mer 07 Fév 2018, 11:12

le compte fondateuroscope est le compte fondateur du forum.

Si vous souhaitez modifier le mot de passe de votre compte personnel, rendez-vous à cette URL: http://www.forum-futuroscope.net/profile?mode=sendpassword

Si c'est le compte fondateur que vous souhaitez modifier, je vous laisse voir avec le staff.
Chapo

Chapo
Dévactif
Dévactif

Masculin
Messages : 5155
Inscrit(e) le : 02/05/2006

Voir le profil de l'utilisateur
Chapo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Futuroscophile Mer 07 Fév 2018, 11:21

C'est effectivement avec le compte fondateur que j'utilise, que j'ai le souci.
(mon compte perso : TCJ)
Que dois-je faire ?
(nb : le lien Récupération ou Passation d'un Compte Fondateur dans votre signature ne fonctionne pas)

[EDIT]
Chapo a écrit:Pour ce qui est des signes qui apparaissent de façon incorrecte, j'ai jusqu'à présent trouvé 2x le caractère
Code:
& #65533;
(dans index_body et dans overall_footer_end) mais ce dernier ne semble pas être un caractère affichable car je l'ai testé sous Firefox et Chrome sur d'autres pages et j'ai toujours le symbole de caractère "cassé"
Ce caractère est un point d'interrogation dans un losange, pour moi cela s'affiche parfaitement (icône que j'utilise pour "à propos"). https://apps.timwhitlock.info/unicode/inspect?s=%EF%BF%BD
Je constate que les différentes pages HTML qui posaient problèmes affichent tout correctement désormais. Yes
Mais toujours le problème de connexion au compte fondateur.
Futuroscophile

Futuroscophile
***

Masculin
Messages : 152
Inscrit(e) le : 09/02/2008

Voir le profil de l'utilisateur http://www.forum-futuroscope.net
Futuroscophile a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Chapo Mer 07 Fév 2018, 11:34

Futuroscophile a écrit:C'est effectivement avec le compte fondateur que j'utilise, que j'ai le souci.
Que dois-je faire ?
Voir avec le staff bénévole, ils sont plus au courant que moi des procédures pour redéfinir les mots de passe fondateur

Si je peux me permettre, je vous conseille vivement, une fois votre accès au PA rétabli, de modifier l'adresse email de sorte que vous puissiez être contacté par mail.
Sauf erreur de ma part le "subaddressing" est fonctionnel chez votre prestataire de mail, ce qui fait qu'avec un email actuel user@provider.tld vous pouvez renseigner une adresse mail pour le fondateur sous la forme user+label@provider.tld (par exemple user+forum@provider.tld) pour recevoir vos messages sur une seule et même boîte tout en vous laissant la possibilité de les trier facilement sur cette boîte.

Futuroscophile a écrit:(nb : le lien Récupération ou Passation d'un Compte Fondateur dans votre signature ne fonctionne pas)
Vous avez raison, lorsque j'ai repris ce compte il y a quelques années la signature était déjà en place et j'avoue n'y avoir jamais fait attention, je vais donc dès à présent en supprimer les liens invalides avant qu'ils n'induisent en erreur d'autres utilisateurs
Chapo

Chapo
Dévactif
Dévactif

Masculin
Messages : 5155
Inscrit(e) le : 02/05/2006

Voir le profil de l'utilisateur
Chapo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Walt Mer 07 Fév 2018, 11:43

Bonjour,
Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?) A5LKuPuSi vous êtes le fondateur du forum, pour récupérer un mot de passe afin d'accéder aux outils réservés au fondateur, et à votre forum, il suffit d'envoyer un message privé à une seule personne : soit un Modéractif ou un Aidactif avec les informations suivantes :
  • L'adresse email ayant servie à la création du forum,
  • Le lien de votre forum.
Pour plus d'explications, merci de lire ce sujet.

Cordialement,
Walt
Walt

Walt
Modéractif
Modéractif

Masculin
Messages : 6022
Inscrit(e) le : 08/09/2015

Voir le profil de l'utilisateur
Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Futuroscophile Mer 07 Fév 2018, 11:54

Merci @Walt pour la précision. Je viens vers vous en MP.

@Chapo Je n'ai pas bien compris pour le subaddressing. Mais si je peux effectivement changer l'e-mail fondateur c'est une bonne chose, j'ignorais que c'était possible.

Merci à vous deux pour votre aide thumright Je mettrai le sujet en Résolu une fois tout réglé.
Futuroscophile

Futuroscophile
***

Masculin
Messages : 152
Inscrit(e) le : 09/02/2008

Voir le profil de l'utilisateur http://www.forum-futuroscope.net
Futuroscophile a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Chapo Mer 07 Fév 2018, 11:59

Le subaddressing permet de rajouter un "+" suivi d'un label à la fin de votre nom d'utilisateur et lorsque vous recevrez un email à cette adresse le serveur de mail ne tient pas compte de la partie ajoutée. Ainsi vous pouvez vous affranchir des limitations sur un mail unique (puisque vous pouvez créer autant de labels que nécessaire) et côté boîte mail vous pouvez ajouter des critères de filtre pour classer les emails automatiquement en fonction des labels.
Chapo

Chapo
Dévactif
Dévactif

Masculin
Messages : 5155
Inscrit(e) le : 02/05/2006

Voir le profil de l'utilisateur
Chapo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Connexion impossible, mot de passe non reconnu ! (Lié à l'encodage UTF-8 ?)

Message par Futuroscophile Mer 07 Fév 2018, 17:02

Sauvé, merci !
Futuroscophile

Futuroscophile
***

Masculin
Messages : 152
Inscrit(e) le : 09/02/2008

Voir le profil de l'utilisateur http://www.forum-futuroscope.net
Futuroscophile a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum