Suppression d'un compte et SSL ?

3 participants

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Suppression d'un compte et SSL ?

Message par Cloo Sam 19 Mai 2018 - 0:16

Bonjour,

A priori, cela n'a rien à voir, je sais... mais je vous explique:

Contexte: j'ai installé le certificat SSL il y a quelques semaines, après l'acquisition du package Premium.

Ce matin, un des membres de mon forum me contacte: il voulait supprimer son compte via la case à cocher dans son profil, mais il recevait le message d'erreur suivant:
Suppression d'un compte et SSL ? Suppre10

Je lui ai indiqué le lien suivant pour se désinscrire:
https://www.forumactif.com/unscribe

Quand il indiquait ceci comme adresse du forum --> https://accrosjardin.forumactif.com/
Adresse qu'il a copiée-collée du champ Adresse de son navigateur... cela ne fonctionnait pas.

mais avec --> http://accrosjardin.forumactif.com/
cela a fonctionné!

Quelqu'un peut m'expliquer? Pourquoi ça ne fonctionnait pas avec https ?
Et est-ce que le fait que, en essayant de détruire son compte via la case dans son profil, il ait eu le message que l'utilisateur n'existait plus, serait dû aussi au https au lieu du http ?
Cloo

Cloo
Membre habitué

Féminin
Messages : 1006
Inscrit(e) le : 09/07/2008

http://accrosjardin.forumactif.com/
Cloo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par Cloo Dim 20 Mai 2018 - 1:04

Je remonte le sujet! Smile
Cloo

Cloo
Membre habitué

Féminin
Messages : 1006
Inscrit(e) le : 09/07/2008

http://accrosjardin.forumactif.com/
Cloo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par Cloo Lun 21 Mai 2018 - 1:47

Je re-remonte! Very Happy
Cloo

Cloo
Membre habitué

Féminin
Messages : 1006
Inscrit(e) le : 09/07/2008

http://accrosjardin.forumactif.com/
Cloo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par w00tw00t Lun 21 Mai 2018 - 14:24

Bonjour Cloo,

Je pense qu'il est souhaitable d'attendre demain le retour de congés des salariés d'eToxic (FA) pour que vous puissiez avoir une réponse plus complète, car ils sont les seuls à avoir le code source sous les yeux.

Néanmoins, d'après mes constations, je pense que vous avez mis le doigt sur deux petits defect en effet. Je m'explique.

1) Lorsque l'on s'inscrit, vous remarquerez que la notion d' "adresse" fait en fait référence à un nom d'hôte, et non à une adresse URL (qui elle inclus le protocole HTTP ou HTTPS) :
Suppression d'un compte et SSL ? JWs9cbX

Donc lorsque l'on se désinscrit, il est certainement attendu un nom d'hôte également tel que "accrosjardin.forumactif.com", sans le protocole HTTP ou HTTPS. D'ailleurs si on raisonne en termes de base de données normalisée, il est peut probable qu'une URL soit présente en tant que telle, mais plutôt ses composantes stockées indépendamment.

Autrement dit, FA retire le protocole lorsque vous soumettez une URL plutôt qu'un nom d'hôte avant de le rechercher en base, mais a probablement oublié de le faire pour ce qui est d'HTTPS. En attendant, rien ne vous empêche de fournir un nom d'hôte sans protocole, ou en effet une URL (composée du nom d'hôte et le protocole HTTP, et ce même si votre site est en HTTPS), dont le nom d'hôte sans protocole sera donc également extrait.

2) Pour ce qui est maintenant du "Désolé, cet utilisateur n'existe pas", il est possible que ce soit à cause du lien envoyé par email qui contient un point au bout :
Code:
https://test.forumactif.com/act-411-7c74?del=user.

Je viens de faire le test et en effet, en supprimant le point final, ça fonctionne ! Donc pour ce dernier point (c'est le cas de le dire!) il n'y a pas de lien avec le HTTPS, car le test a été réalisé avec un forum HTTP.

Par ailleurs, gardez à l'idée aussi que les suppressions n'auront pas lieu si votre utilisateur est trop récent (moins de 7 jours).

Pour conclure, je vous ai proposé des solutions de contournement pour chaque cas, mais vous avez bien fait de reporter ces petits soucis à FA pour qu'une vraie correction puisse être mise en œuvre.

Cordialement,
w00tw00t
w00tw00t

w00tw00t
***

Messages : 118
Inscrit(e) le : 09/05/2018

http://forum.forumactif.org
w00tw00t a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par Invité Lun 21 Mai 2018 - 14:35

Bonjour Cloo,
est-ce que votre membre s'est enregistré sur votre forum, il y a 7 jours ?
car sans ce délai de 7 jours qui suivent l'inscription, un membre ne peut pas supprimer son compte et reçoit ce message justement.
Anonymous

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par Cloo Lun 21 Mai 2018 - 14:39

Merci pour ta réponse... et oui, j'attends les explications de FA. L'utilisateur ayant réussi à supprimer son compte, ce n'est pas une urgence, je veux juste comprendre, et pouvoir donner une solution, une explication, si le cas se représente dans le futur.

Une petite précision... le message "Désolé, cet utilisateur n'existe pas" a été obtenu quand le membre a essayé de supprimer son compte via la case à cocher en bas de la page dans son profil. N'ayant jamais essayé moi-même de détruire mon compte où que ce soit, je ne sais pas ce qui se passe par la suite (mais je pourrais essayer sur mon forum test). J'en conclus que cette opération envoie un courriel, et il faut cliquer sur le lien envoyé pour confirmer? Et il y a donc un point de trop... ou le point final de la phrase est collé au lien...

Pour le délai de 7 jours, oui, je savais.
Cloo

Cloo
Membre habitué

Féminin
Messages : 1006
Inscrit(e) le : 09/07/2008

http://accrosjardin.forumactif.com/
Cloo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par Cloo Lun 21 Mai 2018 - 14:40

Barbalala62 a écrit:Bonjour Cloo,
est-ce que votre membre s'est enregistré sur votre forum, il y a 7 jours ?
car sans ce délai de 7 jours qui suivent l'inscription, un membre ne peut pas supprimer son compte et reçoit  ce message justement.
Non, ce n'est pas du tout ce cas-là... et je connais très bien ce délai de 7 jours.
Cloo

Cloo
Membre habitué

Féminin
Messages : 1006
Inscrit(e) le : 09/07/2008

http://accrosjardin.forumactif.com/
Cloo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par w00tw00t Lun 21 Mai 2018 - 14:43

Bonjour Cloo,

J'en conclus que cette opération envoie un courriel, et il faut cliquer sur le lien envoyé pour confirmer? Et il y a donc un point de trop... ou le point final de la phrase est collé au lien...

C'est exactement ça. Avec cette méthode de suppression (via le profil), il semble y avoir un point en trop au bout du lien de confirmation de suppression envoyé par email, ce qui empêche la bonne compréhension de la requête de suppression par les serveurs FA.

Cordialement,
w00tw00t
w00tw00t

w00tw00t
***

Messages : 118
Inscrit(e) le : 09/05/2018

http://forum.forumactif.org
w00tw00t a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par Walt Lun 21 Mai 2018 - 15:10

Bonjour,

Les deux problèmes ont été remontés pour correction, merci de les avoir signalés.

Cordialement,
Walt
Walt

Walt
Modéractif
Modéractif

Masculin
Messages : 6083
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par Cloo Lun 21 Mai 2018 - 15:21

Merci pour le suivi, Walt! Smile
Cloo

Cloo
Membre habitué

Féminin
Messages : 1006
Inscrit(e) le : 09/07/2008

http://accrosjardin.forumactif.com/
Cloo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Suppression d'un compte et SSL ?

Message par Walt Sam 18 Aoû 2018 - 12:41

Bonjour,

Ce problème a été corrigé il y a plusieurs semaines.

Cordialement,
Walt
Walt

Walt
Modéractif
Modéractif

Masculin
Messages : 6083
Inscrit(e) le : 08/09/2015

Walt a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum