Sous forums à l'horizontal dans l'affichage d'un forum

Voir le sujet précédent Voir le sujet suivant Aller en bas

Sous forums à l'horizontal dans l'affichage d'un forum

Message par Sveglia le Lun 4 Juin 2018 - 14:01

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Tous les utilisateurs
Lien du forum :

Description du problème

Bonjour,

Je viens de modifier les catégories dans mon index-box, jusque là tout allait bien, mais en allant sur l'un des forums des dites catégories, j'ai réalisé qu'à l'intérieur des forums, donc dans l'affichage des sous-forums, ça se barrait littéralement en steak et les sous forums sont décalés sur une ligne horizontale, hors je veux qu'ils s'affichent normalement, comme le codage des catégories sur l'index.

Cela fait un petit moment que je n'ai pas codé, et je ne me souviens plus si cela concerne bien un problème avec l'index box ou si cela en concerne une autre template, j'ai tenté de chercher une solution mais je n'ai rien trouvé

Merci d'avance
avatar

Sveglia
Nouveau membre

Messages : 2
Inscrit(e) le : 04/06/2018

Sveglia a été remercié(e) par l'auteur de ce sujet.

Re: Sous forums à l'horizontal dans l'affichage d'un forum

Message par Shazam le Mar 5 Juin 2018 - 10:05

Bonjour Sveglia,

Bienvenue sur le Forum des Forums Smile

Je ne sais pas si je suis en mesure de vous aidez, mais pouvez-vous nous fournir le code de votre Template Index_box ?

Merci Smile


Ou sinon, vous pouvez aller voir ce   tutoriel ?
avatar

Shazam
*

Masculin
Messages : 40
Inscrit(e) le : 03/07/2016

http://lhsv.forum-canada.com/
Shazam a été remercié(e) par l'auteur de ce sujet.

Re: Sous forums à l'horizontal dans l'affichage d'un forum

Message par Sveglia le Mar 5 Juin 2018 - 10:52

Merci !

La template a été pas mal modifiée en suivant divers tutoriels et mes propres connaissances (rouillées je l'admets) en codage, en soit sur l'index ça s'affiche bien donc j'arrive pas à situer le problème vu que l'affichage se barre en steak à l'intérieur du forum

Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
   <tr>
      <td valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall">{LAST_VISIT_DATE}<br />
         {CURRENT_TIME}<br />
         </span>
         <!-- END switch_user_logged_in -->
         <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
         <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
         <!-- END switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
   </tr>
</table>

<!-- BEGIN catrow --><!-- BEGIN tablehead -->
 <table class="modifcat" width="100%" border="0" cellspacing="0" cellpadding="0" align="center">
    <tr>
      <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle"> {catrow.tablehead.L_FORUM} </th>
   </tr>
   <!-- END tablehead -->
   <!-- BEGIN cathead -->
<table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
<tr></table>
          <!-- END cathead -->
      <!-- BEGIN forumrow -->
       <!-- BEGIN inc -->
            <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
            <!-- END inc -->

            <td align="left" valign="top">
              
                
              <table width="100%" cellpadding="0" cellspacing="0"><br />

          <tr>
  <td valign="top"><div style="margin-top: 17px; margin-left:4px;"><div class="statdescrip">
    
    <table width="100"><tr><td width="70%"><div class="forumtitre">
                              <a href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a></div>
                          
                              <div class="description">
                                {catrow.forumrow.FORUM_DESC}</td><td <width="30%"></div>
                            </td></tr></table>
                                      
                          <td align="center" valign="top"><div class="sousforums">                            
    <span class="gensmall" id="subforums"><br>{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span><script type="text/javascript">
                          jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'<br /> ')).removeAttr('id');
</script>
            
                               <span class="genmed"> <td valign="top"><div class="cadrestatistiques">
                                       <div class="iconederniermessage"><img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></div>
                                 <span class="genmed"><div class="derniermessage">
                                                           <a href="{catrow.forumrow.U_LATEST_TOPIC}" title="{catrow.forumrow.LATEST_TOPIC_TITLE}">{catrow.forumrow.LATEST_TOPIC_NAME}</a></div>
                                      <div class="nbsujets">{catrow.forumrow.POSTS} MESSAGES DANS {catrow.forumrow.TOPICS} SUJETS</div>{catrow.forumrow.USER_LAST_POST}  </td>
                                 <td><div style="width: 10px;" align="top"></div>
                                   <div class="avatarcatégorie">
                                   <!-- BEGIN avatar --><span class="lastpost-avatar">{catrow.forumrow.avatar.LAST_POST_AVATAR}</span>
                            <!-- END avatar --></div> </td><td valign="top">
                </td>
                

                <!-- END forumrow -->
   <!-- BEGIN catfoot -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
   </tr>
   <!-- END catfoot -->
   <!-- BEGIN tablefoot -->
</table><!-- END tablefoot --><!-- END catrow -->
avatar

Sveglia
Nouveau membre

Messages : 2
Inscrit(e) le : 04/06/2018

Sveglia a été remercié(e) par l'auteur de ce sujet.

Re: Sous forums à l'horizontal dans l'affichage d'un forum

Message par Shazam le Ven 8 Juin 2018 - 9:53

Bonjour Sveglia, désolé de ma réponse tardive.

Je me penche sur votre code aujourd'hui ou demain pour voir si je peux trouver quelque chose. Mais sinon il est possible que l'erreur d'affichage provient d'un code Html ou Javascript qui vient perturber l'affichage.. (je penche plus vers cet option, que de trouver un erreur dans le Template)
avatar

Shazam
*

Masculin
Messages : 40
Inscrit(e) le : 03/07/2016

http://lhsv.forum-canada.com/
Shazam a été remercié(e) par l'auteur de ce sujet.

Re: Sous forums à l'horizontal dans l'affichage d'un forum

Message par Chacha le Mer 13 Juin 2018 - 9:37

Bienvenue sur le forum de support de Forumactif

Puisque vous êtes nouveau, voici quelques sujets susceptibles de vous intéresser :
N'hésitez pas à ouvrir un nouveau sujet si vous ne trouvez pas votre réponse.
Bonjour,

Nous n'avons plus de nouvelle de l'auteur de ce sujet depuis plus de 8 jours. Nous considérons donc ce problème comme résolu ou abandonné. La prochaine fois, merci de nous tenir au courant de l'évolution de votre problème, ou pensez à faire un UP régulièrement !

Ce sujet est déplacé à la corbeille, merci d'ouvrir un nouveau sujet si nécessaire, en respectant les Règles générales du forum.
avatar

Chacha
Modéractif
Modéractif

Masculin
Messages : 56780
Inscrit(e) le : 21/08/2010

https://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum