Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Catégories qui ne s'affichent pas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Catégories qui ne s'affichent pas

Message par foxies le Mer 13 Juin 2018 - 15:34

Détails techniques

Version du forum : ModernBB
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome
Personnes concernées par le problème : Tous les utilisateurs
Lien du forum : (lien masqué, vous devez poster pour le voir)

Description du problème

Bonjour à tous ! Je suis en train de travailler sur l'apparence de mes catégories et en en créant une nouvelle (ainsi que des forums tests à l'intérieur) via Général > Catégories et forums, je me suis rendue compte que seule la première catégorie et ses forums associés s'affichaient sur mon forum.

Voici mon template :


Code:
<!-- BEGIN catrow -->
 <!-- BEGIN tablehead -->
<div class="cat">
 
  <div class="cat-title">{catrow.tablehead.L_FORUM}</div>
            


  
                  <!-- END tablehead -->
                      <!-- BEGIN forumrow -->
<div class="cat-forum"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forum-title">{catrow.forumrow.FORUM_NAME}</a></div>
  <!-- END forumrow -->
                  
                  
 
 

 <!-- BEGIN tablefoot -->
</div>  
 <!-- END tablefoot -->
              
<!-- END catrow -->
            
<script type="text/javascript">
if( window.location.pathname === '/' || window.location.pathname.indexOf('/forum') === 0 )
$(function() {
  $('#container .cat').remove();
});
</script>

Vous constaterez qu'un script a été ajouté à la fin pour que les catégories ne soient visibles que par le biais d'un lien qui se trouve dans la barre de navigation (merci encore à @w00tw00t, qui m'a aidé ici). Le script fait en sorte qu'en page d'accueil, aucune catégorie ne s'affiche.

Merci de votre aide et bonne journée I love you

Edit : Je viens de comprendre d'où vient le soucis... Le lien (que j'ai ajouté manuellement dans ma barre de navigation) qui est censé amener aux catégories de mon forum comme je le voudrais, ne peut renvoyer seulement qu'à une catégorie (en l'occurrence, la première) What a Face Je ne sais pas si c'est clair, mais du coup je me demande si il est réellement possible de faire apparaître l'ensemble de mes catégories en cliquant sur un seul et même lien...
avatar

foxies
*****

Féminin
Messages : 529
Inscrit(e) le : 02/05/2010

http://hawkeyeriver.forumgratuit.org/
foxies a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum