formulaire de diaporama en panne?

2 participants

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu formulaire de diaporama en panne?

Message par 1bernard1 Sam 1 Sep 2018 - 18:12

Bonjour

Le formulaire de diaporama ne fonctionne pas bien.
https://forum.forumactif.com/h11-formulaire-diaporama

Il génère bien un code, mais la prévisualisation est déficiente et le code essayé sur le site donne un drôle de résultat
formulaire de diaporama en panne? Captur22

le code
Code:
<style type="text/css">#rotator1535817739380 {height:230px;} #rotator1535817739380 a{position:absolute;background:#FFFFFF;border:1px solid #CCCCCC;padding:4px;} #rotator1535817739380 img { height:220px;width:300px; }</style><div id="rotator1535817739380"><a id="itemActif1535817739380" style="z-index:999" href="#" title="" target="_blank"><img src="[url=http://ze-bistro.forumactif.com/gallery/Album-personnel-de-HOLAF/Pierre-Morel-004-pic_7.htm][img]http://ze-bistro.forumactif.com/users/3814/36/26/18/album/dscn8510.jpg[/img][/url]" alt="" /></a><a  href="#" title="" target="_blank"><img src="[url=http://ze-bistro.forumactif.com/gallery/Album-personnel-de-HOLAF/Fleur-virgin-AAA-pic_128.htm][img]http://ze-bistro.forumactif.com/users/3814/36/26/18/album/12189810.jpg[/img][/url]" alt="" /></a></div><script type="text/javascript">(function(){var r = document.getElementById("rotator1535817739380"), l = r.getElementsByTagName("A"), rotate = window.setInterval(function() {var a = document.getElementById("itemActif1535817739380"), n = jQuery(a).next()[0] || l[0]; if (!a) return window.clearInterval(rotate); n.style.opacity = 1;n.style.zIndex = 998;jQuery(a).animate({"opacity":0},800,"linear",function() {a.id = "";a.style.zIndex = "";n.id = "itemActif1535817739380";n.style.zIndex = 999})},3500)})();</script>
1bernard1

1bernard1
***

Messages : 106
Inscrit(e) le : 04/05/2017

Voir le profil de l'utilisateur http://ze-bistro.forumactif.com/
1bernard1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: formulaire de diaporama en panne?

Message par Bipo Dim 9 Sep 2018 - 0:09

Bonsoir 1bernard1,

Je viens de vérifier le générateur de diaporama sur Forumactif et il fonctionne très bien.

Votre code contient des erreurs... mais qui ne proviennent pas du générateur. Il y a du BBcode avec du HTML, un beau mélange.

Voici votre code corrigé :

Code:
<style type="text/css">
  #rotator1535817739380 {height:230px;}
  #rotator1535817739380 a{position:absolute;background:#FFFFFF;border:1px solid #CCCCCC;padding:4px;}
  #rotator1535817739380 img { height:220px;width:300px; }</style>
<div id="rotator1535817739380"><a id="itemActif1535817739380" style="z-index:999" href="#" title="" target="_blank">
  <a href="http://ze-bistro.forumactif.com/gallery/Album-personnel-de-HOLAF/Pierre-Morel-004-pic_7.htm" title="" target="_blank"><img src="http://ze-bistro.forumactif.com/users/3814/36/26/18/album/dscn8510.jpg" alt="" /></a>
  <a href="http://ze-bistro.forumactif.com/gallery/Album-personnel-de-HOLAF/Fleur-virgin-AAA-pic_128.htm" title="" target="_blank"><img src="http://ze-bistro.forumactif.com/users/3814/36/26/18/album/12189810.jpg" alt="" /></a>
  </a></div>
  <script type="text/javascript">(function(){var r = document.getElementById("rotator1535817739380"), l = r.getElementsByTagName("A"), rotate = window.setInterval(function() {var a = document.getElementById("itemActif1535817739380"), n = jQuery(a).next()[0] || l[0]; if (!a) return window.clearInterval(rotate); n.style.opacity = 1;n.style.zIndex = 998;jQuery(a).animate({"opacity":0},800,"linear",function() {a.id = "";a.style.zIndex = "";n.id = "itemActif1535817739380";n.style.zIndex = 999})},3500)})();</script>

A noter que ce code ne peut être utilisé que sur une page HTML, message d'acueil ou un widget.

Si vous souhaitez mettre un diaporama dans un message, il faut prévoir une modification du code.

Bonne soirée sur Forumactif.
Bipo.
Bipo

Bipo
Rédactif
Rédactif

Messages : 2714
Inscrit(e) le : 23/09/2010

Voir le profil de l'utilisateur
Bipo a été remercié(e) par l'auteur de ce sujet.

Résolu Re: formulaire de diaporama en panne?

Message par 1bernard1 Dim 9 Sep 2018 - 3:07

Je ne comprends pas, je n'ai fait que recopier le code reçu du générateur pourtant!!! Étrange....


En tout cas, Merci beaucoup pour cette réponse.
1bernard1

1bernard1
***

Messages : 106
Inscrit(e) le : 04/05/2017

Voir le profil de l'utilisateur http://ze-bistro.forumactif.com/
1bernard1 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum