Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Problème avec la variable FORUMLASTUSERLINK

Voir le sujet précédent Voir le sujet suivant Aller en bas

  • 0

Résolu Problème avec la variable FORUMLASTUSERLINK

Message par Fallen Leaves le Jeu 8 Nov 2018 - 19:37

Détails techniques

Version du forum : ModernBB
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : depuis le bug des variables
Lien du forum : http://seoulmates.forumactif.com/

Description du problème

Bonsoir à tous  I love you

Je vois que le topic concernant le bug de la variable USERLINK a été archivé dans le sous forum des dévactifs mais j'ai de mon côté un petit problème avec la variable FORUMLASTUSERLINK. En effet, avant, lorsque j'utilisais cette variable sur ma fiche de pub, cela affichait un lien avec le pseudo du dernier membre inscrit (par exemple : Fallen Leaves ) Mais depuis que la correction semble avoir été effectué après le bug rencontré pour l'affichage de certaines variables, ce n'est plus le lien avec le pseudo du dernier inscrit qui s'affiche mais tout simplement le lien... (j'ai maintenant ceci : https://forum.forumactif.com/u165956 )

(Petit exemple avec ma fiche de pub par --> ici <--)

Ma question est donc de savoir quelle manipulation est à faire pour que ce soit le pseudo qui apparaisse et non le lien ?

Voilà le code utilisé dans ma fiche de pub :

Code:
Mr le Ministre accueille la dernière recrue les deux bras ouverts : il s'agirait, semble-t-il, de  <strong><span class="FORUMLASTUSERLINK" style="color:#000;"></span></strong>.

Merci pour votre aide thumright


Dernière édition par Fallen Leaves le Lun 12 Nov 2018 - 6:40, édité 1 fois
avatar

Fallen Leaves
***

Messages : 103
Inscrit(e) le : 16/08/2015

http://seoulmates.forumactif.com/
Fallen Leaves a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la variable FORUMLASTUSERLINK

Message par Milouze14 le Ven 9 Nov 2018 - 7:54

Hello Fallen Leaves,

en attendant une correction sur cette variable et comme tu utilises une page html,
on va ajouter la bibliothèque jQuery dans ta page.

Édites cette dernière et ajoutes après ceci:

Code:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

Ceci:
Code:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js" type="text/javascript">

Remplaces cette partie:
Code:
<strong><span class="FORUMLASTUSERLINK" style="color:#000;"></span></strong>.

Par:
Code:
<strong class="M14_lastUser"></strong>

Puis tout en bas de cette page ajoutes ceci:
Code:
 <script>
$(function(){
var $this=$('strong[class="M14_lastUser"]');
$.get('/statistics', function(data){
var b=$(data).find('table.forumline.values:eq(1)').find('tr:eq(6)').find('td:last').find('.gen a').text();
var c=$(data).find('table.forumline.values:eq(1)').find('tr:eq(6)').find('td:last').find('.gen a').attr('href');
         if(b)
          {
          $this.html('<a href="'+c+'"style="color:#000;">'+b+'</a>');    
          }
          else
          {
          $this.html('<a href="/login">Merci de vous connecter</a>');
          }
});});

</script>

Mais pour cela, il faut activer les statistiques pour les membres:
Général/Statistiques/Statistiques du forum/Autorisations

Qui est autorisé à voir les statistiques en ligne ?
Cocher  Utilisateur enregistré  



Et voilou  Wink  .

Edit, si tu veux avoir la même chose sur toutes les variables, merci de me donner la totalité de ta page HTML.

a++
avatar

Milouze14
Membre actif

Masculin
Messages : 5244
Inscrit(e) le : 18/04/2005

https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la variable FORUMLASTUSERLINK

Message par Fallen Leaves le Dim 11 Nov 2018 - 16:25

Bonjour Milouze ::fleur::

Ta technique fonctionne parfaitement ! C'est bien le nom du dernier utilisateur qui s'affiche. Je te file le code (sous hide) pour que tu puisses m'aider pour les autres variables (nombres de messages et nombre de membres) qui, du coup, ne s'affichent plus. (aperçu du rendu de la fiche sur mon fo de test : http://enjoythetest2.forumactif.com/h4-fichedepub )



Encore merci pour ton aide précieuse, tu me sauves souvent I love you
avatar

Fallen Leaves
***

Messages : 103
Inscrit(e) le : 16/08/2015

http://seoulmates.forumactif.com/
Fallen Leaves a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problème avec la variable FORUMLASTUSERLINK

Message par Milouze14 le Dim 11 Nov 2018 - 18:29

Hello Fallen Leaves,

j'avais déjà préparé la page html en cas ou ..

Tu peux remplacer la totalité par ce contenu stp:



a++
avatar

Milouze14
Membre actif

Masculin
Messages : 5244
Inscrit(e) le : 18/04/2005

https://www.milouze14.com/
Milouze14 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problème avec la variable FORUMLASTUSERLINK

Message par Fallen Leaves le Lun 12 Nov 2018 - 6:40

C'est juste parfait I love you

Merci encore Milouze ! Passe une bonne semaine cheers

résolu merci
avatar

Fallen Leaves
***

Messages : 103
Inscrit(e) le : 16/08/2015

http://seoulmates.forumactif.com/
Fallen Leaves a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec la variable FORUMLASTUSERLINK

Message par PHOENIX_VINCENT le Lun 12 Nov 2018 - 7:39

Yes Yes
avatar

PHOENIX_VINCENT
Nouveau membre

Masculin
Messages : 21
Inscrit(e) le : 10/08/2018

http://straight-six.forumactif.com/
PHOENIX_VINCENT a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum