Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Problème tag (Bouton mention)

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème tag (Bouton mention)

Message par katia26 Mar 1 Jan 2019 - 16:48

Détails techniques

Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome, Internet Explorer, Opera, Safari, Autre
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : Depuis le début
Lien du forum : http://sassyw-boo.forumactif.com

Description du problème

Bonjour à tous,

Je viens vous demander de l'aide concernant l'option Tag @ disponible sur forumactif. Je le vois sur beaucoup de forum et j'aimerai l'installer aussi. Seulement, gros problème, tous les tutos disponibles ne fonctionnent pas sur mon forum Rolling Eyes

J'ai suivi ce sujet : https://forum.forumactif.com/t378492-rendre-le-systeme-de-mentions-plus-facile-a-utiliser mais aucun des deux scripts ne fonctionne. Rien n’apparaît, que ce soit le @ à coté du pseudo que le bouton mentionner.

Quelqu'un peut me dire pourquoi ? Ou m'aider à trouver la solution ?

J'aimerai utiliser la seconde option, avec ce script :

Mentionner dans les messages:

Code:
/* FORUM VERSIONS
 * 0 = PHPBB2
 * 1 = PHPBB3
 * 2 = PUNBB
 * 3 = INVISION
 * 4 = MODERNBB
 */
$(function() {
  var version = 4,
      image = 'http://i19.servimg.com/u/f19/18/21/60/73/mentio10.png';
 
  if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
    document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
    my_setcookie('fa_mention','');
  } if (!/\/t\d+/.test(window.location.pathname)) return;
 
  for (var a = $(['.post-options', '.profile-icons', '.post-options', '.posting-icons', '.profile-icons'][version]), b, c, d = ['.name strong a', '.author a', '.username a', '.author a', '.postprofile-name a'][version], e, i = 0, j = a.length, t = document.getElementById('text_editor_textarea'), l = version == 1 || version == 3 || version == 4; i<j; i++) {
    b = document.createElement('IMG');
    b.src = image;
    b.alt = 'Mentionner';
    b.title = 'Mentionner ' + $(a[i]).closest('.post').find(d + ':not(.fa-mention)').text();
    b.className = 'i_icon_mention';
    b.onclick = function() {
      var n = this.title.replace(/^.*?\s/,'');
    
      if ($.sceditor) t.insertText('@"' + n + '" ');
      else {
        my_setcookie('fa_mention', n);
        window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
      }
    };
 
    if (l) {
      c = document.createElement('LI');
      c.appendChild(b);
    }
  
    a[i].insertBefore(l ? c : b, a[i].firstChild);
  }
 
  $(function(){
    if (!$.sceditor) return;
    t=$(t).sceditor('instance');
  });
});

Merci d'avance et surtout bonne année What a Face


Dernière édition par katia26 le Mar 1 Jan 2019 - 21:55, édité 1 fois
avatar

katia26
Nouveau membre

Messages : 25
Inscrit(e) le : 12/01/2010

Voir le profil de l'utilisateur http://dominion.forumpro.fr/
katia26 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par *Splash* Mar 1 Jan 2019 - 17:26

Hi,

Le script proposé dans le tuto est pour une version ModernBB, il faut changer la valeur ici :
Code:
$(function() {
  var version = 4,

4 = ModernBB
0 = phpBB2

Pour faire apparaître le bouton "Mention" dans les messages

Sinon sans cela le système de mention fonctionne tout seul, il suffit de l'écrire ainsi dans le cas d'un pseudo simple
Code:
@pseudo

Et ainsi si le pseudo est composé
Code:
@"pseudo composé"

Problème tag (Bouton mention) Mentio10

Problème tag (Bouton mention) Mentio11
*Splash*

*Splash*
Membre actif

Masculin
Messages : 3798
Inscrit(e) le : 25/02/2018

Voir le profil de l'utilisateur https://caforum.fr
*Splash* a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par katia26 Mar 1 Jan 2019 - 19:08

Alors je comprend pas j'ai pas du mettre le bon code parce que j'ai bien 0 chez moi pardon Embarassed

Code:
/* FORUM VERSIONS
 * 0 = PHPBB2
 * 1 = PHPBB3
 * 2 = PUNBB
 * 3 = INVISION
 */
$(function() {
  var version = 0;
 
  if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
      document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
      my_setcookie('fa_mention','');
  } if (!/\/t\d+/.test(window.location.pathname)) return;
 
  for (var a = $(['.name a', '.postprofile dt a', '.username a', '.postprofile dt a ~ a', '.namePOST a'][version]), b, i = 0, j = a.length, t = document.getElementById('text_editor_textarea'); i<j; i++) {
      b = document.createElement('A');
      b.title = 'Mentionner ' + $(a[i]).text();
      b.style.marginRight = '3px';
      b.className = 'fa-mention';
      b.innerHTML = '@';
      b.href = '#';
      b.onclick = function() {
        var n = this.title.replace(/^.*?\s/,'');
   
        if ($.sceditor) t.insertText('@"' + n + '" ');
        else {
            my_setcookie('fa_mention', n);
            window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
        }
   
        return false;
      };
 
      a[i].parentNode.insertBefore(b, a[i]);
  }
 
  $(function(){
      if (!$.sceditor) return;
      t=$(t).sceditor('instance');
  });
});
avatar

katia26
Nouveau membre

Messages : 25
Inscrit(e) le : 12/01/2010

Voir le profil de l'utilisateur http://dominion.forumpro.fr/
katia26 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par *Splash* Mar 1 Jan 2019 - 19:11

Ce code ci c'est pour avoir l'@ devant les pseudos dans le profil, moi je parle du code pour ajouter un bouton "Mention" dans les sujets
Cette partie là du tuto

Problème tag (Bouton mention) Code10
*Splash*

*Splash*
Membre actif

Masculin
Messages : 3798
Inscrit(e) le : 25/02/2018

Voir le profil de l'utilisateur https://caforum.fr
*Splash* a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par katia26 Mar 1 Jan 2019 - 19:30

Roh décidément, je fais n'importe quoi Rolling Eyes Désolé je suis un peu fatiguée, j'ai tenté tellement de codes que je me suis mélangé silent

Donc, j'ai bien mis le bon code avec var 0 et toujours rien ...
avatar

katia26
Nouveau membre

Messages : 25
Inscrit(e) le : 12/01/2010

Voir le profil de l'utilisateur http://dominion.forumpro.fr/
katia26 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par Neptunia Mar 1 Jan 2019 - 19:53

Bonjour ^^


Pourrions nous avoir le lien d'un sujet accessible aux invités ?
Neptunia

Neptunia
Membre actif

Féminin
Messages : 17160
Inscrit(e) le : 08/08/2010

Voir le profil de l'utilisateur https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par katia26 Mar 1 Jan 2019 - 20:28

Oui voilà Smile
avatar

katia26
Nouveau membre

Messages : 25
Inscrit(e) le : 12/01/2010

Voir le profil de l'utilisateur http://dominion.forumpro.fr/
katia26 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par *Splash* Mar 1 Jan 2019 - 20:32

@katia26 a écrit:Oui voilà Smile
Voilà quoi ?
*Splash*

*Splash*
Membre actif

Masculin
Messages : 3798
Inscrit(e) le : 25/02/2018

Voir le profil de l'utilisateur https://caforum.fr
*Splash* a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par katia26 Mar 1 Jan 2019 - 20:38

J'ai mis un sujet en visible pour que vous puissiez regarder Smile
avatar

katia26
Nouveau membre

Messages : 25
Inscrit(e) le : 12/01/2010

Voir le profil de l'utilisateur http://dominion.forumpro.fr/
katia26 a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problème tag (Bouton mention)

Message par *Splash* Mar 1 Jan 2019 - 20:42

@katia26 a écrit:J'ai mis un sujet en visible pour que vous puissiez regarder Smile
Et donc c'est à nous de chercher et trouver ce sujet ?
À la bonne heure !
*Splash*

*Splash*
Membre actif

Masculin
Messages : 3798
Inscrit(e) le : 25/02/2018

Voir le profil de l'utilisateur https://caforum.fr
*Splash* a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par katia26 Mar 1 Jan 2019 - 20:43

Excusez moi je pensais que vous étiez déjà sur le forum en fait.

http://sassyw-boo.forumactif.com/t7-note-pour-katia
avatar

katia26
Nouveau membre

Messages : 25
Inscrit(e) le : 12/01/2010

Voir le profil de l'utilisateur http://dominion.forumpro.fr/
katia26 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par *Splash* Mar 1 Jan 2019 - 20:45

@katia26 a écrit:Excusez moi je pensais que vous étiez déjà sur le forum en fait.

http://sassyw-boo.forumactif.com/t7-note-pour-katia
Alors il ne faut pas t'étonner si rien n'apparaît sur ton forum, tes templates sont entièrement modifié donc les scripts du tuto ne peuvent s'appliquer

voir ici pour faire une mention manuel : https://forum.forumactif.com/t399107-probleme-tag-bouton-mention#3333041
*Splash*

*Splash*
Membre actif

Masculin
Messages : 3798
Inscrit(e) le : 25/02/2018

Voir le profil de l'utilisateur https://caforum.fr
*Splash* a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par Neptunia Mar 1 Jan 2019 - 20:59

Toutes les astuces de ce forum sont garanties pour fonctionner sur un forum dont les templates ne sont pas modifiés, ou du moins dont la structure est préservée.

Hors sur votre forum les class d'origine ont disparu.

A la ligne 17 du script, il vous faudra remplacer '.name strong a' par '.namePOST a' -> Correspond au pseudo dans le profil

En tant qu'invitée je ne peux pas voir les boutons Citer, éditer etc etc mais il vous faudra de la même façon remplacer (toujours à la ligne 17) '.post-options' par la nouvelle class où se trouvent vos boutons Citer / Editer.

Ceci pour le script fourni dans le premier message de ce sujet.

Edité : N'ayant pas vu de lien dans votre message (quand je l'ai lu) je suis retournée sur votre forum et vu le sujet sur l'index.
Neptunia

Neptunia
Membre actif

Féminin
Messages : 17160
Inscrit(e) le : 08/08/2010

Voir le profil de l'utilisateur https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par katia26 Mar 1 Jan 2019 - 21:04

@*Splash* a écrit:
@katia26 a écrit:Excusez moi je pensais que vous étiez déjà sur le forum en fait.

http://sassyw-boo.forumactif.com/t7-note-pour-katia
Alors il ne faut pas t'étonner si rien n'apparaît sur ton forum, tes templates sont entièrement modifié donc les scripts du tuto ne peuvent s'appliquer

voir ici pour faire une mention manuel : https://forum.forumactif.com/t399107-probleme-tag-bouton-mention#3333041

Donc du coup pas de script pour les forums où les templates sont personnalisés ?

@Neptunia a écrit:Toutes les astuces de ce forum sont garanties pour fonctionner sur un forum dont les templates ne sont pas modifiés, ou du moins dont la structure est préservée.

Hors sur votre forum les class d'origine ont disparu.

A la ligne 17 du script, il vous faudra remplacer '.name strong a' par '.namePOST a' -> Correspond au pseudo dans le profil

En tant qu'invitée je ne peux pas voir les boutons Citer, éditer etc etc mais il vous faudra de la même façon remplacer (toujours à la ligne 17) '.post-options' par la nouvelle class où se trouvent vos boutons Citer / Editer.

Ceci pour le script fourni dans le premier message de ce sujet.

Edité : N'ayant pas vu de lien dans votre message (quand je l'ai lu) je suis retournée sur votre forum et vu le sujet sur l'index.

Ok je vais essayer Smile
avatar

katia26
Nouveau membre

Messages : 25
Inscrit(e) le : 12/01/2010

Voir le profil de l'utilisateur http://dominion.forumpro.fr/
katia26 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par Neptunia Mar 1 Jan 2019 - 21:08

@katia26 a écrit:Donc du coup pas de script pour les forums où les templates sont personnalisés ?

Il n'est pas possible de concevoir un script qui puisse prendre en compte toutes les personnalisations possibles de templates mais les scripts peuvent dans la plupart des cas s'adapter à une nouvelle structure.

Mais il est préférable quand on touche aux templates de conserver au maximum les sélecteurs de base.

P.S. Et quand on vous demande un lien, effectivement c'est à vous de nous en fournir un et non à nous de le chercher.
Neptunia

Neptunia
Membre actif

Féminin
Messages : 17160
Inscrit(e) le : 08/08/2010

Voir le profil de l'utilisateur https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par katia26 Mar 1 Jan 2019 - 21:15

D'accord merci. Du coup, je viens de modifier pour la partie .namePOST a de la ligne 17 par contre je n'ai aucune class concernant les boutons de citation etc.  Je vous mets mon template pour que vous puissiez voir.

Spoiler:

Code:
<script type="text/javascript">
//<![CDATA[
var multiquote_img_off = '{JS_MULTIQUOTE_IMG_OFF}', multiquote_img_on = '{JS_MULTIQUOTE_IMG_ON}', _atr = '{JS_DIR}addthis/', _ati = '{PATH_IMG_FA}addthis/'{ADDTHIS_LANG}, addthis_localize = { share_caption: "{L_SHARE_CAPTION}", email: "{L_EMAIL}", email_caption: "{L_EMAIL_CAPTION}", favorites: "{L_SHARE_BOOKMARKS}", print: "{L_PRINT}", more: "{L_MORE}" };
$(function(){

    if(typeof(_atc) == "undefined") {
        _atc = { };
    }
    
    _atc.cwait = 0;
    $('.addthis_button').mouseup(function(){
        if ($('#at15s').css('display') == 'block') {
            addthis_close();
        }
    });
});

var hiddenMsgLabel = { visible:'{JS_HIDE_HIDDEN_MESSAGE}', hidden:'{JS_SHOW_HIDDEN_MESSAGE}' };
showHiddenMessage = function(id)
{
    try
    {
        var regId = parseInt(id, 10);
        if( isNaN(regId) ) { regId = 0; }
        
        if( regId > 0)
        {
            $('.post--' + id).toggle(0, function()
 {
 if( $(this).is(":visible") )
 {
 $('#hidden-title--' + id).html(hiddenMsgLabel.visible);
 }
 else
 {
 $('#hidden-title--' + id).html(hiddenMsgLabel.hidden);
 }
 });
        }
    }
    catch(e) { }
    
 return false;
};

//]]>
</script>


<table width="100%" align="center" border="0" cellspacing="0" cellpadding="0" style="max-width:750px !important;">
<tr><td align="left" valign="bottom"><span class="nav"><!-- BEGIN switch_user_authpost --><a href="{U_POST_NEW_TOPIC}" rel="nofollow"><img src="{POST_IMG}" id="{POST_IMG_ID}one" alt="{L_POST_NEW_TOPIC}" align="middle" border="0" /></a> <!-- END switch_user_authpost --><!-- BEGIN switch_user_authreply --><a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" id="i_reply" alt="{L_POST_REPLY_TOPIC}" align="middle" border="0" /></a><!-- END switch_user_authreply --></span></td>
<td align="right" valign="middle"><!-- BEGIN switch_user_logged_in --><!-- BEGIN watchtopic --><span class="gensmall">{S_WATCH_TOPIC}</span><!-- END watchtopic --><!-- END switch_user_logged_in --> <a href="{U_VIEW_OLDER_TOPIC}">{L_VIEW_PREVIOUS_TOPIC}</a> <a href="{U_VIEW_NEWER_TOPIC}">{L_VIEW_NEXT_TOPIC}</a> <a href="#bottom">{L_GOTO_DOWN}</a></td>
</tr>
<tr><td colspan="2"><div id="tlePOST"><h1 class="cattitle">{TOPIC_TITLE}</h1><span class="navPOST" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a class="nav" href="{U_INDEX}" itemprop="url"><span itemprop="title">{L_INDEX}</span></a><!--{NAV_SEP}<a class="nav" href="{U_ALBUM}" itemprop="url"><span itemprop="title">{L_ALBUM}</span></a>-->{NAV_CAT_DESC_SECOND}</span></div>
</td></tr>
</table>

<table class="forumline" width="750px" align="center" border="0" cellspacing="0" cellpadding="0" style="max-width:750px !important;">
 <!-- BEGIN topicpagination -->
 <tr><td class="pagination" align="right" valign="top"><span class="gensmall">{PAGINATION}</span></td></tr>
 <!-- END topicpagination -->
 {POLL_DISPLAY}
 <!-- BEGIN postrow -->
 <!-- BEGIN hidden -->
 <tr><td class="postdetails" align="center">{postrow.hidden.MESSAGE}</td></tr>
 <!-- END hidden -->
 <!-- BEGIN displayed -->
 
 <tr class="post post--{postrow.displayed.U_POST_ID}" id="p{postrow.displayed.U_POST_ID}" style="{postrow.displayed.DISPLAYABLE_STATE}">
 <td {postrow.displayed.THANK_BGCOLOR} valign="top" width="100%" height="28">
 <table width="100%" border="0" cellspacing="0" cellpadding="0">
 <tr><div class="datePOST"><span style="display:inline-block; vertical-align:middle; width:50%;"><img src="{postrow.displayed.MINI_TIME_IMG}" border="0" />{postrow.displayed.POST_DATE}</span><span style="display:inline-block; vertical-align:middle; width:50%; text-align:right; line-height:0;">{postrow.displayed.THANK_IMG} {postrow.displayed.MULTIQUOTE_IMG} {postrow.displayed.QUOTE_IMG} {postrow.displayed.EDIT_IMG} {postrow.displayed.DELETE_IMG} {postrow.displayed.IP_IMG} {postrow.displayed.REPORT_IMG}</span></div>

 <td colspan="2">
 <!-- BEGIN switch_vote_active -->
 <div class="vote gensmall">
 <!-- BEGIN switch_vote --><div class="vote-button"><a href="{postrow.displayed.switch_vote_active.switch_vote.U_VOTE_PLUS}">+</a></div><!-- END switch_vote -->

 <!-- BEGIN switch_bar -->
 <div class="vote-bar" title="{postrow.displayed.switch_vote_active.L_VOTE_TITLE}">
 <!-- BEGIN switch_vote_plus --><div class="vote-bar-plus" style="height:{postrow.displayed.switch_vote_active.switch_bar.switch_vote_plus.HEIGHT_PLUS}px;"></div><!-- END switch_vote_plus -->

 <!-- BEGIN switch_vote_minus --><div class="vote-bar-minus" style="height:{postrow.displayed.switch_vote_active.switch_bar.switch_vote_minus.HEIGHT_MINUS}px;"></div><!-- END switch_vote_minus -->
 </div>
 <!-- END switch_bar -->

 <!-- BEGIN switch_no_bar --><div title="{postrow.displayed.switch_vote_active.L_VOTE_TITLE}" class="vote-no-bar">----</div><!-- END switch_no_bar -->

 <!-- BEGIN switch_vote --><div class="vote-button"><a href="{postrow.displayed.switch_vote_active.switch_vote.U_VOTE_MINUS}">-</a></div><!-- END switch_vote -->
 </div>
 <!-- END switch_vote_active --><div style="height:5px;"></div>
</td></tr>
    
<tr><td valign="top" width="220px"><div id="boxPOST"><div class="namePOST">{postrow.displayed.POSTER_NAME}<div class="rankPOST">{postrow.displayed.POSTER_RANK}</div></div>
 <div class="boxPOST"><div class="avaPOST">{postrow.displayed.POSTER_AVATAR}</div><div class="ktactPOST"><div style="display:none;">{postrow.displayed.POSTER_NAME}</div>{postrow.displayed.PROFILE_IMG}{postrow.displayed.PM_IMG}<!-- BEGIN contact_field -->{postrow.displayed.contact_field.CONTENT}<!-- END contact_field --></div>
 <div class="systab">
<div class="selected">
    <span>PERSO</span>
  <!-- BEGIN profile_field -->   <div class="M14_ProfilPerso"><div class="champprofil">{postrow.displayed.profile_field.LABEL} <span class="M14_profilContent"> {postrow.displayed.profile_field.CONTENT}</span></div>{postrow.displayed.profile_field.SEPARATOR}</div>
            <!-- END profile_field --></div>
   <div>
    <span>More</span>
    <div class="onglet1"></div>  </div>
    <div>
    <span>IRL</span>
    <div class="onglet"></div>  </div>
</div></div></div>
  </td>
  <td valign="top" align="right">
 <div class="postbody"><a name="{postrow.displayed.U_POST_ID}" style="position:relative; top:30px; width:1px;" id="{postrow.displayed.U_POST_ID}"></a>
 <div>{postrow.displayed.MESSAGE}</div>

 <!-- BEGIN switch_attachments -->
 <dl class="attachbox">
 <dt>{postrow.displayed.switch_attachments.L_ATTACHMENTS}</dt>
 <dd>
 <!-- BEGIN switch_post_attachments -->
 <dl class="file">
 <dt><img src="{postrow.displayed.switch_attachments.switch_post_attachments.U_IMG}" alt="" />

 <!-- BEGIN switch_dl_att -->
 <a class="postlink" href="{postrow.displayed.switch_attachments.switch_post_attachments.switch_dl_att.U_ATTACHMENT}">{postrow.displayed.switch_attachments.switch_post_attachments.switch_dl_att.ATTACHMENT}</a> {postrow.displayed.switch_attachments.switch_post_attachments.switch_dl_att.ATTACHMENT_DEL}
 <!-- END switch_dl_att -->

 <!-- BEGIN switch_no_dl_att -->{postrow.displayed.switch_attachments.switch_post_attachments.switch_no_dl_att.ATTACHMENT} {postrow.displayed.switch_attachments.switch_post_attachments.switch_no_dl_att.ATTACHMENT_DEL}<!-- END switch_no_dl_att -->
 </dt>

 <!-- BEGIN switch_no_comment --><dd><em>{postrow.displayed.switch_attachments.switch_post_attachments.switch_no_comment.ATTACHMENT_COMMENT}</em></dd><!-- END switch_no_comment -->

 <!-- BEGIN switch_no_dl_att --><dd><em><strong>{postrow.displayed.switch_attachments.switch_post_attachments.switch_no_dl_att.TEXT_NO_DL}</strong></em></dd><!-- END switch_no_dl_att -->

 <dd>({postrow.displayed.switch_attachments.switch_post_attachments.FILE_SIZE}) {postrow.displayed.switch_attachments.switch_post_attachments.NB_DL}</dd>
 </dl>
 <!-- END switch_post_attachments -->
 </dd></dl>
 <!-- END switch_attachments -->

 <div class="clear"></div>
 <!-- BEGIN switch_signature -->
 <div class="signPOST">{postrow.displayed.SIGNATURE}</div>
 <!-- END switch_signature -->
 </div>
 </td></tr>
 
 <tr class="post--{postrow.displayed.U_POST_ID}" style="{postrow.displayed.DISPLAYABLE_STATE}">
 <td class="browse-arrows"{postrow.displayed.THANK_BGCOLOR} align="center" valign="middle">
 <a href="#top">{L_BACK_TO_TOP}</a> <a href="#bottom">{L_GOTO_DOWN}</a>
 </td>
 </tr></table></td>
 
 </tr>
 <!-- BEGIN first_post_br -->
</table>

<table class="forumline" width="100%" border="0" cellspacing="0" cellpadding="0">
 <!-- END first_post_br -->
 <!-- END displayed -->
 <!-- END postrow -->
 <!-- BEGIN no_post -->
 <tr align="center"><td colspan="3" height="28"><span class="genmed">{no_post.L_NO_POST}</span></td></tr>
 <!-- END no_post -->
</table>

<table class="forumline noprint" width="100%" border="0" cellspacing="0" cellpadding="0" style="margin:auto; max-width:750px !important;">
<tr>
<td valign="top" {COLSPAN_PAGINATION} width="150"><span class="gensmall">{PAGE_NUMBER}</span></td>
<!-- BEGIN topicpagination --><td align="right" valign="top" ><span class="gensmall">{PAGINATION}</span></td><!-- END topicpagination -->
</tr>
</table>

    <!-- BEGIN switch_forum_rules -->
    <table id="forum_rules" width="100%" style="max-width:750px !important;" border="0" cellspacing="0" cellpadding="0">
    <tr><td valign="top" colspan="2"><div class="cattitle">{L_FORUM_RULES}</div></td></tr>
    <tr>
    <td class="clearfix">
    <table>
    <tr>
    <!-- BEGIN switch_forum_rule_image -->
    <td class="logo"><img src="{RULE_IMG_URL}" /></td>
    <!-- END switch_forum_rule_image -->
    <td class="rules postbody">{RULE_MSG}</td>
    </tr>
    </table>
    </td>
    </tr>
    </table>
    <!-- END switch_forum_rules -->

    <form action="{S_JUMPBOX_ACTION}" method="get" name="jumpbox" onsubmit="if(document.jumpbox.f.value == -1){return false;}">
    <table width="100%" style="margin-top:5px; max-width:750px !important;" border="0" cellspacing="0" cellpadding="0" align="center">
    <tr><td align="left" valign="middle" {WIDTH_GALLERY}><span class="nav"><!-- BEGIN switch_user_authpost --><a href="{U_POST_NEW_TOPIC}" rel="nofollow"><img src="{POST_IMG}" id="{POST_IMG_ID}Newtopic" alt="{L_POST_NEW_TOPIC}" align="middle" border="0" /></a><!-- END switch_user_authpost --> <!-- BEGIN switch_user_authreply --><a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" alt="{L_POST_REPLY_TOPIC}" align="middle" border="0" /></a><!-- END switch_user_authreply --></span></td>

    <td align="right" nowrap="nowrap"><span class="gensmall">{L_JUMP_TO}: {S_JUMPBOX_SELECT} <input class="liteoption" type="submit" value="{L_GO}" /></span></td>

    <!-- BEGIN moderation_panel -->
    <td align="center"><span class="gensmall">{moderation_panel.U_YOUR_PERSONAL_MODERATE}</span></td>
    <td align="center" width="250"><span class="gensmall"> </span></td>
 <!-- END moderation_panel -->
    </tr>
    </table>
    </form>
 
    <!-- BEGIN viewtopic_bottom -->
    <table class="noprint" width="100%" style="max-width:750px !important;" border="0" cellspacing="0" cellpadding="0" align="center">
    <tr><td colspan="2" align="right" valign="top" nowrap="nowrap"><span style="display:inline-block; vertical-align:middle;">{S_TOPIC_ADMIN}</span>
    <form name="action" method="get" action="{S_FORM_MOD_ACTION}" style="display:inline-block; vertical-align:middle;">
    <input type="hidden" name="t" value="{TOPIC_ID}" />
    <!-- <input type="hidden" name="sid" value="{S_SID}" /> -->
    <input type="hidden" name="{SECURE_ID_NAME}" value="{SECURE_ID_VALUE}" />
    <span class="gen">{S_SELECT_MOD}&nbsp;<input class="liteoption" type="submit" value="{L_GO}" /></span>
    </form>
    </td></tr>
    </table>
    <!-- END viewtopic_bottom -->
 
    <table class="forumline noprint" style="max-width:750px !important;" align="center" width="100%" border="0" cellspacing="0" cellpadding="0">
    <tr><td colspan="2" align="center" style="padding:0px;">
    <!-- BEGIN switch_user_logged_in --><a name="quickreply"></a>{QUICK_REPLY_FORM}<!-- END switch_user_logged_in -->
    </td></tr>
    </table>
 
    <!-- BEGIN switch_image_resize -->
    <script type="text/javascript">
    //<![CDATA[
    $(resize_images({ 'selector' : '.postbody', 'max_width' : {switch_image_resize.IMG_RESIZE_WIDTH}, 'max_height' : {switch_image_resize.IMG_RESIZE_HEIGHT} }));
    //]]>
    </script>
    <!-- END switch_image_resize -->
    <script src="{JS_DIR}addthis/addthis_widget.js" type="text/javascript"></script>
avatar

katia26
Nouveau membre

Messages : 25
Inscrit(e) le : 12/01/2010

Voir le profil de l'utilisateur http://dominion.forumpro.fr/
katia26 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par Neptunia Mar 1 Jan 2019 - 21:45

Essayez de remplacer :

Code:
<span style="display:inline-block; vertical-align:middle; width:50%; text-align:right; line-height:0;">{postrow.displayed.THANK_IMG} {postrow.displayed.MULTIQUOTE_IMG} {postrow.displayed.QUOTE_IMG} {postrow.displayed.EDIT_IMG} {postrow.displayed.DELETE_IMG} {postrow.displayed.IP_IMG} {postrow.displayed.REPORT_IMG}</span>

par :

Code:
<span class="post-options" style="display:inline-block; vertical-align:middle; width:50%; text-align:right; line-height:0;">{postrow.displayed.THANK_IMG} {postrow.displayed.MULTIQUOTE_IMG} {postrow.displayed.QUOTE_IMG} {postrow.displayed.EDIT_IMG} {postrow.displayed.DELETE_IMG} {postrow.displayed.IP_IMG} {postrow.displayed.REPORT_IMG}</span>

C'est d'ailleurs l'illustration parfaite de ma précédente remarque :
@Neptunia a écrit:Mais il est préférable quand on touche aux templates de conserver au maximum les sélecteurs de base.
Nativement le conteneur est un td, même en plaçant les boutons dans un span de même identifiant, le tutoriel aurait fonctionné sans la moindre modification.
Neptunia

Neptunia
Membre actif

Féminin
Messages : 17160
Inscrit(e) le : 08/08/2010

Voir le profil de l'utilisateur https://www.galaxie-series.net/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème tag (Bouton mention)

Message par katia26 Mar 1 Jan 2019 - 21:49

Super ça fonctionne merci beaucoup ! Je ferai attention la prochaine fois Smile
avatar

katia26
Nouveau membre

Messages : 25
Inscrit(e) le : 12/01/2010

Voir le profil de l'utilisateur http://dominion.forumpro.fr/
katia26 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum