Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Page HTML qui ne s'affiche pas dans un message

Voir le sujet précédent Voir le sujet suivant Aller en bas

Page HTML qui ne s'affiche pas dans un message Empty Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Lun 28 Jan 2019 - 13:57

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome
Capture d'écran du problème :
Voir l'image:
Page HTML qui ne s'affiche pas dans un message S6gr

Personnes concernées par le problème : Plusieurs utilisateurs
Problème apparu depuis : Depuis pas mal de temps en fait, je pensais que ça allait se résoudre avec le temps mais non. On va dire au moins 6 mois.
Lien du forum : http://repellomuggletum.forumactif.com/

Description du problème

Bonjour à tous.

Il y a environ 6 mois j'ai changé le code de ma fiche de partenariat, que vous pouvez retrouver ici : http://repellomuggletum.forumactif.com/t63-notre-fiche-nos-boutons
Quand elle a été installée, une admin m'a fait remonter qu'elle ne voyait pas le code. Puisqu'elle était la seule qui avait ce problème, je ne l'ai pas relevé et lui ai précisé que ça viendrait avec le temps.
A noter que cette fiche de partenariat est donc une page HTML, mis en place grâce à un iframe, chose identique à notre page d'accueil, que cette membre peut voir.

Puisqu'elle m'a signalé que le problème était toujours présent et touchait aussi d'autres personnes, je me tourne vers vous aujourd'hui pour connaître le problème et ainsi régler ça au plus vite, puisque notre nouvelle version ouvre Jeudi ^^

Merci d'avance à ceux qui se pencheront sur le sujet !
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Adam_sfp le Mar 29 Jan 2019 - 20:35

Bonsoir

Vous avez un soucis sur la page HTML

Peut être la  balise <center>qui n'est pas fermée dans cette partie de code de votre page html.
Code:
<center>
      <div class="pubfond">
        <div class="pubcontenu">
          <div class="pubforum">
            <a href="http://mondeandmagiev5.forumactif.org/" target="_blank">Ϟ Repello Muggletum Ϟ</a>
          </div>
          <br/>
          <center>

il est préférable  de mettre ceci
Code:
  <link href="https://fonts.googleapis.com/css?family=Arvo|Satisfy" rel="stylesheet" />

dans la partie
Code:
<head></head>
de votre page HTML.

cdt
Adam_sfp

Adam_sfp
Membre actif

Masculin
Messages : 4461
Inscrit(e) le : 18/04/2008

Voir le profil de l'utilisateur http://antonyadam.kanak.fr
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Ven 1 Fév 2019 - 9:17

Bonjour et merci pour votre réponse.
La balise center est bien fermée.
J'ai changé le lien du font pour le mettre dans le head.
Malheureusement ça n'a rien changé, ma camarade ne voit toujours pas la fiche HTML.
En tout cas merci d'avoir tenté de m'aider !

Quelqu'un d'autre ^^ ?
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Adam_sfp le Ven 1 Fév 2019 - 14:23

Bonjour

Apparemment vous n'avez pas fait la modification et vous avez toujours la balise
Code:
<center>
qui n'est pas fermée comme ceci
Code:
</center>

Si on accède à votre page HTML ici
http://repellomuggletum.forumactif.com/h2-

Celle ci n’apparaît pas ... mais on a accès au code source et on voit bien que la balise n'est pas fermé et la modification non effective.
Page HTML qui ne s'affiche pas dans un message Demo10

Cdt.
Adam_sfp

Adam_sfp
Membre actif

Masculin
Messages : 4461
Inscrit(e) le : 18/04/2008

Voir le profil de l'utilisateur http://antonyadam.kanak.fr
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Sam 2 Fév 2019 - 21:18

Voici mon code :

La balise center est bel et bien fermée dans mon code ^^
Je l'ai ai toutes comptées et normalement quand j'ai un problème ça se met en rouge pour dire que la balise n'est pas fermée. Hors là tout est en vert, donc tout est bien fermé.

Après je ne pense pas que ce soit cette balise qui face que ma page HTML ne soit pas visible.
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Adam_sfp le Lun 4 Fév 2019 - 17:06

Bonjour

Je voulais dire par la que parfois un balise mal fermé ou fermé au mauvais endroit peut engendrer ce soucis et la page n’apparaît pas ( même si le nombre de balise ouverte et fermée est bon) et du coup ça ne se met pas en rouge..

Je n'ai pas regardé votre code en détails votre soucis vient peut être d'ailleurs dans le code...

Vous pouvez voir sur ce lien votre code tel qu'il est
https://codepen.io/anon/pen/qgjGjw
la page n’apparaît pas...

sur celui ci en fermant la deuxième balise <center>
https://codepen.io/anon/pen/aXwrLX
on à déjà des choses qui apparaissent...



Regardez du coté de
Code:
 <div class="pubfond">
peut être...idem si on supprime cette partie du code ou en la déplaçant des éléments apparaissent...

Cdt.
Adam_sfp

Adam_sfp
Membre actif

Masculin
Messages : 4461
Inscrit(e) le : 18/04/2008

Voir le profil de l'utilisateur http://antonyadam.kanak.fr
Adam_sfp a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Scoubifitz le Mar 5 Fév 2019 - 16:05

@Illiana a écrit:

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome
Capture d'écran du problème :
Voir l'image:
Page HTML qui ne s'affiche pas dans un message S6gr

Personnes concernées par le problème : Plusieurs utilisateurs
Problème apparu depuis : Depuis pas mal de temps en fait, je pensais que ça allait se résoudre avec le temps mais non. On va dire au moins 6 mois.
Lien du forum : http://repellomuggletum.forumactif.com/

Description du problème


Bonjour à tous.

Il y a environ 6 mois j'ai changé le code de ma fiche de partenariat, que vous pouvez retrouver ici : http://repellomuggletum.forumactif.com/t63-notre-fiche-nos-boutons
Quand elle a été installée, une admin m'a fait remonter qu'elle ne voyait pas le code. Puisqu'elle était la seule qui avait ce problème, je ne l'ai pas relevé et lui ai précisé que ça viendrait avec le temps.
A noter que cette fiche de partenariat est donc une page HTML, mis en place grâce à un iframe, chose identique à notre page d'accueil, que cette membre peut voir.

Puisqu'elle m'a signalé que le problème était toujours présent et touchait aussi d'autres personnes, je me tourne vers vous aujourd'hui pour connaître le problème et ainsi régler ça au plus vite, puisque notre nouvelle version ouvre Jeudi ^^

Merci d'avance à ceux qui se pencheront sur le sujet !

Bonjour,

Le problème que rencontrent vos membres n'en est pas un .
Certains navigateurs interprètent différemment la balise < center > , surtout dans une fenêtre < iframe > ...
La balise < center > est un cadre qui prend toute la largeur de la page . Cette page est dans une < iframe > .
En regardant votre page : http://repellomuggletum.forumactif.com/h2-fiche-de-partenariat , on s'aperçoit qu'il y a du blanc sur les 2 cotés , ce que voient vos membres dans l'iframe !

Supprimez le premier et dernier < center > de votre code pour rétablir le contenu dans l'iframe .

La balise center est dépréciée depuis HTML4 et obsolète depuis HTML5 . Utilisez plutôt du CSS pour centrer vos cadres (text-align:center;margin:auto).

Votre doctype est <!DOCTYPE html> , donc de type HTML5 ...

study
Scoubifitz

Scoubifitz
Membre actif

Masculin
Messages : 3652
Inscrit(e) le : 18/03/2008

Voir le profil de l'utilisateur http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Mer 6 Fév 2019 - 12:35

Adam_sfp
Oui, mais du coup je n'ai absolument plus le rendu que je désirais. Dans le cas de ton 1er code j'obtiens ça : https://nsm09.casimages.com/img/2019/02/06//1902061236128388816109585.jpg soit le rendu que je désire, et sur ton second code j'obtiens ça : https://nsm09.casimages.com/img/2019/02/06//1902061236128388816109584.jpg

Scoubifitz
Euh... j'ai pas tout compris Laughing Mais j'ai compris l'histoire des bandes blanches et du coup j'ai viré ce qui permettait de mettre la fiche au centre.
Je vais demander à ma membre si elle voit la fiche correctement du coup... Je vous tiens au courant.

Merci à vous deux.
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Mer 6 Fév 2019 - 18:45

Désolée du DP. Juste pour signaler que le soucis est toujours présent.

Membre a écrit:Non toujours pas... Mais je crois que c'est un problème avec Chrome parce que je la vois avec explorer et sur mon téléphone où j'utilise une autre appli d'internet
Sauf que j'utilise chrome aussi et je n'ai pas ce soucis.
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Tite-May le Dim 10 Fév 2019 - 17:18

Bonjour,

Je pense que le souci vient de la scrollbar personnalisée. Je vois qu'il y a des modif's dans la CSS. Vous avez installé un Javascript en plus pour l'installer non ?
Si oui, désactivez temporairement ce script, afin de vérifier que le souci est bien situé à cet endroit.

Bonne journée.
PS : il y a pas mal d'erreur de sémantiques dans votre code qui finira par créer d'autres soucis. N'hésitez pas à dire si vous avez besoin d'un coup de main pour le rafraichir.
avatar

Tite-May
****

Féminin
Messages : 206
Inscrit(e) le : 13/08/2012

Voir le profil de l'utilisateur http://tambouille-raleuses.forumactif.com/
Tite-May a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Lun 11 Fév 2019 - 16:48

Bonjour Tite-May,

Non, je n'ai que le code suivant pour la scrollbar :
Code:
/*scrollbar*/

::-webkit-scrollbar {
  width: 10px;
  height: 5px;
  background-color: #f9f9f9;
}

::-webkit-scrollbar-track {
  background-color: #f9f9f9; /*couleur du fond */
}

::-webkit-scrollbar-thumb {
  background-color: #c0c0c0; /*couleur de l'ascenseur*/
}
Il n'y a aucun javascript supplémentaire. Les seuls java que j'ai sont :
¤ Barre de navigation
¤ Sélectionner code
¤ Correcteur d'éditeur



Après, c'est quoi les erreurs sémantiques ?
J'avoue que je code pour le plaisir, donc mes codes ne sont pas parfait mais je m'en fiche tant que le rendu est celui que je veux X)
Mais je suis pas contre une correction pour tenter de m'améliorer Very Happy
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Tite-May le Mar 12 Fév 2019 - 11:35

Bonjour,

Il faudrait essayer de désactiver temporairement tous les JS afin de vérifier si le problème persiste ou non. Ca peut être n'importe laquelle des bibliothèques qui pose le souci. J'ai déjà eu le cas et j'avais mit longtemps à trouver la cause Wink

Même en codant pour le plaisir, si on ne respecte pas certaines choses le code va buguer sur certains navigateurs. Wink
Je verrai pour faire la correction dans les prochains jours.
avatar

Tite-May
****

Féminin
Messages : 206
Inscrit(e) le : 13/08/2012

Voir le profil de l'utilisateur http://tambouille-raleuses.forumactif.com/
Tite-May a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Jeu 14 Fév 2019 - 13:25

Bonjour,

Je vais demander à mon admin de tester ça de son côté, pour pas désactiver les java trop longtemps.
Je te tiens au courant dès que je sais.

Et je veux bien une correction avec des explications pour ne plus faire ces erreurs par la suite Wink
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Tite-May le Jeu 14 Fév 2019 - 20:33

Ok je te prépare la correction Smile Et j'attends ton retour pour le test
avatar

Tite-May
****

Féminin
Messages : 206
Inscrit(e) le : 13/08/2012

Voir le profil de l'utilisateur http://tambouille-raleuses.forumactif.com/
Tite-May a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Ven 15 Fév 2019 - 16:53

Coucou

en effet, le soucis vient des Java ! est-ce que tu as besoin que je te donne les codes de chacun des Java ?
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Tite-May le Ven 15 Fév 2019 - 19:45

Le mieux est de les désactiver un par un, pour voir lequel fait planter.
Une fois qu'il sera repérer, je veux bien que tu me le donne pour que je regarde si j'arrive à débugguer.
avatar

Tite-May
****

Féminin
Messages : 206
Inscrit(e) le : 13/08/2012

Voir le profil de l'utilisateur http://tambouille-raleuses.forumactif.com/
Tite-May a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Sam 16 Fév 2019 - 9:24

Ok, je vais demander à mon admin de le faire (mais avant je vais les enregistrer sinon je sens la catastrophe XD)
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Dim 17 Fév 2019 - 22:19

Désolé du DP, mais voici les nouvelles de mon admin.
Elle a testé en enlevant 1 java à la fois et elle m'a retourné ça :
@Admin a écrit:Alors je viens de le faire, et à chaque fois ça clignotait deux ou trois secondes et puis plus rien

Dois-je te donner les codes des 3 javas ? Puisqu'on a pas su déterminer lequel était fautif...
Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Tite-May le Mar 19 Fév 2019 - 9:17

Oui on peut essayer comme ça. Je te laisse me les donner, en hide Wink
avatar

Tite-May
****

Féminin
Messages : 206
Inscrit(e) le : 13/08/2012

Voir le profil de l'utilisateur http://tambouille-raleuses.forumactif.com/
Tite-May a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Illiana le Mar 19 Fév 2019 - 9:49

Et j'avais une question aussi...
J'utilise le même code pour ma PA et mon message dans les annonces du forum et... ça mon admin les voit. Alors je trouve ça vraiment trop étrange O.O

Illiana

Illiana
***

Féminin
Messages : 117
Inscrit(e) le : 19/05/2011

Voir le profil de l'utilisateur http://cophirende-academie.forumactif.com/
Illiana a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Chacha le Lun 25 Fév 2019 - 9:51

Page HTML qui ne s'affiche pas dans un message UmaslZ4Bonjour,

Attention, cela fait 6 jours que nous n'avons pas de nouvelles concernant votre demande, si vous ne voulez pas voir votre sujet déplacé à la corbeille, merci de poster dans les 24h qui suivent ce message.

Si votre sujet est résolu, merci d'éditer votre premier message et de cocher l'icône « résolu »
Chacha

Chacha
Modéractif
Modéractif

Masculin
Messages : 62217
Inscrit(e) le : 21/08/2010

Voir le profil de l'utilisateur https://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Page HTML qui ne s'affiche pas dans un message Empty Re: Page HTML qui ne s'affiche pas dans un message

Message par Chacha le Mar 26 Fév 2019 - 9:56

Page HTML qui ne s'affiche pas dans un message 8djze9qBonjour,

Nous n'avons plus de nouvelle de l'auteur de ce sujet depuis plus de 7 jours. Nous considérons donc ce problème comme résolu ou abandonné. La prochaine fois, merci de nous tenir au courant de l'évolution de votre problème, ou pensez à faire un UP régulièrement !

Ce sujet est déplacé à la corbeille, merci d'ouvrir un nouveau sujet si nécessaire, en respectant les Règles générales du forum.
Chacha

Chacha
Modéractif
Modéractif

Masculin
Messages : 62217
Inscrit(e) le : 21/08/2010

Voir le profil de l'utilisateur https://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum