bouton mention qui ne fonctionne pas

3 participants

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu bouton mention qui ne fonctionne pas

Message par shotgun Ven 10 Avr 2020 - 15:52

Détails techniques


Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome, Safari
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : depuis toujours.
Lien du forum : https://bloodinthewater.forumactif.com

Description du problème

bonjour,
je viens vers vous aujourd'hui car j'ai un soucis avec le bouton mention. en effet, au lieu d'affiche @"pseudodumembre", il m'affiche @"". je pense que le problème vient de mon template, sachant qu'il a été modifier. mais j'avoue qu'à ce niveau là, je bloque un peu.
template:

script:
shotgun

shotgun
Nouveau membre

Messages : 10
Inscrit(e) le : 26/01/2019

Voir le profil de l'utilisateur http://murphyslaw.forumactif.com
shotgun a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Invité Ven 10 Avr 2020 - 19:58

hello shotgun,
il faudrait peut-être mentionner le lien de l'astuce non Wink .

Remplaces le script par celui-ci.
A priori , il devrait fonctionner.

Code:
/* FORUM VERSIONS
 * 0 = PHPBB2
 * 1 = PHPBB3
 * 2 = PUNBB
 * 3 = INVISION
 * 4 = MODERNBB
 */
$(function() {
  var version = 0,
      image = 'https://i.servimg.com/u/f19/18/21/60/73/mentio10.png';
 
  if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
    document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
    my_setcookie('fa_mention',''); 
  } if (!/\/t\d+/.test(window.location.pathname)) return;
 
  for (var a = $(['.post-options', '.profile-icons', '.post-options', '.posting-icons', '.profile-icons'][version]), b, c, d = ['#pseudo a', '.author a', '.username a', '.author a', '.postprofile-name a'][version], e, i = 0, j = a.length, t = document.getElementById('text_editor_textarea'), l = version == 1 || version == 3 || version == 4; i<j; i++) {
    b = document.createElement('IMG');
    b.src = image;
    b.alt = 'Mentionner';
    b.title = 'Mentionner ' + $(a[i]).closest('.post').find(d + ':not(.fa-mention)').text();
    b.className = 'i_icon_mention';
    b.onclick = function() {
      var n = this.title.replace(/^.*?\s/,'');
     
      if ($.sceditor) t.insertText('@"' + n + '" ');
      else {
        my_setcookie('fa_mention', n);
        window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
      }
    };
 
    if (l) {
      c = document.createElement('LI');
      c.appendChild(b);
    }
   
    a[i].insertBefore(l ? c : b, a[i].firstChild);
  }
 
  $(function(){
    if (!$.sceditor) return;
    t=$(t).sceditor('instance');
  });
});

a++
Anonymous

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Chacha Jeu 16 Avr 2020 - 10:12

bouton mention qui ne fonctionne pas UmaslZ4Bonjour,

Attention, cela fait 6 jours que nous n'avons pas de nouvelles concernant votre demande, si vous ne voulez pas voir votre sujet déplacé à la corbeille, merci de poster dans les 24h qui suivent ce message.

Si votre sujet est résolu, merci d'éditer votre premier message et de cocher l'icône « résolu »
Chacha

Chacha
Modéractif
Modéractif

Masculin
Messages : 66945
Inscrit(e) le : 21/08/2010

Voir le profil de l'utilisateur https://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Rivendell. Jeu 16 Avr 2020 - 16:39

@"shotgun" / Je me permets d'intervenir pour te prévenir pour un autre forum ou quoi, mais en fait le JS fonctionne avec la valise de FA
Code:
<span class="name"></span>
qui entour {postrow.displayed.POSTER_NAME}. Du coup forcément, si tu la retires, le JS ne saura pas retrouver cette balise. C'est pourquoi soit il faut la laisser soit alors comme Milouze14 l'a fait, modifié ton JS à la ligne 17 en changeant .namePOST a par ta balise qui est
Code:
[i]#pseudo a[/i]
. Le plus simple c'est de laisser la balise, et de l'entourer par une autre par exemple moi je fais :

Code:
<div class="psdo"><span class="name"><strong>{postrow.displayed.POSTER_NAME}</strong></span></div>
I love you
Rivendell.

Rivendell.
**

Messages : 54
Inscrit(e) le : 05/01/2018

Voir le profil de l'utilisateur https://coldcoffee.forumactif.com/
Rivendell. a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Chacha Ven 17 Avr 2020 - 10:08

bouton mention qui ne fonctionne pas 8djze9qBonjour,

Nous n'avons plus de nouvelle de l'auteur de ce sujet depuis plus de 7 jours. Nous considérons donc ce problème comme résolu ou abandonné. La prochaine fois, merci de nous tenir au courant de l'évolution de votre problème, ou pensez à faire un UP régulièrement !

Ce sujet est archivé afin de ne pas perdre les réponses apportées.
Chacha

Chacha
Modéractif
Modéractif

Masculin
Messages : 66945
Inscrit(e) le : 21/08/2010

Voir le profil de l'utilisateur https://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum