bouton mention qui ne fonctionne pas

4 participants

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu bouton mention qui ne fonctionne pas

Message par tearsflight Mer 15 Avr 2020 - 14:13

Détails techniques

Version du forum : ModernBB
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Google Chrome
Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : depuis l'installation du script
Lien du forum : (lien masqué, vous devez poster pour le voir)

Description du problème

Bonjour,

J'ai voulu installer le bouton mention sur mon forum. J'ai donc suivi ce sujet, en mettant bien le bon numéro de version.

Code:
/* FORUM VERSIONS
 * 0 = PHPBB2
 * 1 = PHPBB3
 * 2 = PUNBB
 * 3 = INVISION
 * 4 = MODERNBB
 */
$(function() {
  var version = 4,
      image = 'https://i.imgur.com/fqq2tNP.png';

 
  if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
    document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
    my_setcookie('fa_mention','');
  } if (!/\/t\d+/.test(window.location.pathname)) return;
 
  for (var a = $(['.post-options', '.profile-icons', '.post-options', '.posting-icons', '.profile-icons'][version]), b, c, d = ['.name strong a', '.author a', '.username a', '.author a', '.postprofile-name a'][version], e, i = 0, j = a.length, t = document.getElementById('text_editor_textarea'), l = version == 1 || version == 3 || version == 4; i<j; i++) {
    b = document.createElement('IMG');
    b.src = image;
    b.alt = 'Mentionner';
    b.title = 'Mentionner ' + $(a[i]).closest('.post').find(d + ':not(.fa-mention)').text();
    b.className = 'i_icon_mention';
    b.onclick = function() {
      var n = this.title.replace(/^.*?\s/,'');
    
      if ($.sceditor) t.insertText('@"' + n + '" ');
      else {
        my_setcookie('fa_mention', n);
        window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
      }
    };
 
    if (l) {
      c = document.createElement('LI');
      c.appendChild(b);
    }
  
    a[i].insertBefore(l ? c : b, a[i].firstChild);
  }
 
  $(function(){
    if (!$.sceditor) return;
    t=$(t).sceditor('instance');
  });
});

Le @ s'affiche, mais ne renvoie à rien du tout quand on clique dessus.
Je suppose que le problème vient du codage des sujets et profils, donc je joins le template  viewtopic_body :
Code:
<script type="text/javascript">
//<![CDATA[
var multiquote_img_off = '{JS_MULTIQUOTE_IMG_OFF}', multiquote_img_on = '{JS_MULTIQUOTE_IMG_ON}', _atr = '{JS_DIR}addthis/', _ati = '{PATH_IMG_FA}addthis/'{ADDTHIS_LANG}, addthis_localize = { share_caption: "{L_SHARE_CAPTION}", email: "{L_EMAIL}", email_caption: "{L_EMAIL_CAPTION}", favorites: "{L_SHARE_BOOKMARKS}", print: "{L_PRINT}", more: "{L_MORE}" };

$(function(){
    if(typeof(_atc) == "undefined") {
        _atc = {  };
    }
});

var hiddenMsgLabel = { visible:'{JS_HIDE_HIDDEN_MESSAGE}', hidden:'{JS_SHOW_HIDDEN_MESSAGE}' };
showHiddenMessage = function(id) {
    try {
        var regId = parseInt(id, 10);
        if( isNaN(regId) ) { regId = 0; }

        if( regId > 0) {
            $('.post--' + id).toggle(0, function() {
 if( $(this).is(":visible") ) {
 $('#hidden-title--' + id).html(hiddenMsgLabel.visible);
 } else {
 $('#hidden-title--' + id).html(hiddenMsgLabel.hidden);
 }
 });
        }
    } catch(e) { }

 return false;
};

//]]>
</script>

<div class="sub-header">
 <div class="sub-header-info">
 <h1 class="page-title">
 <a href="{TOPIC_URL}">{TOPIC_TITLE}</a>
 </h1>
 <div class="sub-header-path">
 <a class="nav" href="{U_INDEX}"><span>{L_INDEX}</span></a>
 {NAV_CAT_DESC}
 </div>
 </div>

 <div class="sub-header-buttons">
 <!-- BEGIN switch_user_authpost -->
 <a href="{U_POST_NEW_TOPIC}" rel="nofollow"><img src="{POST_IMG}" id="{POST_IMG_ID}one" alt="{L_POST_NEW_TOPIC}" align="middle" border="0" /></a>&nbsp;&nbsp;&nbsp;
 <!-- END switch_user_authpost -->
 <!-- BEGIN switch_user_authreply -->
 <a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" id="i_reply" alt="{L_POST_REPLY_TOPIC}" align="middle" border="0" /></a>
 <!-- END switch_user_authreply -->
 </div>
</div>

<div class="topic-actions">
 <!-- BEGIN topicpagination -->
 <div class="pagination">
 {PAGINATION}
 </div>
 <!-- END topicpagination -->

 <div class="topic-actions-buttons">
 <!-- BEGIN switch_twitter_btn -->
 <span>
 <a href="https://twitter.com/share" class="twitter-share-button" data-via="{TWITTER}">Tweet</a>
 <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
 </span>
 <!-- END switch_twitter_btn -->

 <!-- BEGIN switch_fb_likebtn -->
 <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "https://connect.facebook.net/{LANGUAGE}/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
 }(document, 'script', 'facebook-jssdk'));</script>
 <span class="fb-like" data-href="{FORUM_URL}{TOPIC_URL}" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></span>
 <!-- END switch_fb_likebtn -->

 <a class="addthis_button">{L_SHARE}</a>
 <!-- BEGIN switch_plus_menu -->
 <script type="text/javascript">//<![CDATA[
 var url_favourite = '{U_FAVOURITE_JS_PLUS_MENU}';
 var url_newposts = '{U_NEWPOSTS_JS_PLUS_MENU}';
 var url_egosearch = '{U_EGOSEARCH_JS_PLUS_MENU}';
 var url_unanswered = '{U_UNANSWERED_JS_PLUS_MENU}';
 var url_watchsearch = '{U_WATCHSEARCH_JS_PLUS_MENU}';
 insert_plus_menu_new('f{FORUM_ID}&amp;t={TOPIC_ID}','{JS_SESSION_ID}', {JS_AUTH_FAVOURITES});
 //]]>
 </script>
 <!-- END switch_plus_menu -->
 </div>
</div>

<div class="quick-nav-topics">
    <!-- BEGIN switch_isconnect -->
 <a href="{U_VIEW_OLDER_TOPIC}">{L_VIEW_PREVIOUS_TOPIC}</a>
    <!-- END switch_isconnect -->
    <a href="#bottom">{L_GOTO_DOWN}</a>
    <!-- BEGIN switch_isconnect -->
 <a href="{U_VIEW_NEWER_TOPIC}">{L_VIEW_NEXT_TOPIC}</a>
    <!-- END switch_isconnect -->
</div>

{POLL_DISPLAY}

<!-- BEGIN postrow -->
 <!-- BEGIN hidden -->
 <div class="post {postrow.hidden.ROW_COUNT}">
 <p style="text-align:center">{postrow.hidden.MESSAGE}</p>
 </div>
 <!-- END hidden -->
 <!-- BEGIN displayed -->
 <div id="p{postrow.displayed.U_POST_ID}" class="post {postrow.displayed.ROW_COUNT} post--{postrow.displayed.U_POST_ID}"{postrow.displayed.THANK_BGCOLOR} style="{postrow.displayed.DISPLAYABLE_STATE}">
            <div style="position: relative; top: -30px; width: 1px;" id="{postrow.displayed.U_POST_ID}"></div>
 <div class="postprofile" id="profile{postrow.displayed.U_POST_ID}">
 <div class="online2"> {postrow.displayed.ONLINE_IMG}</div>
 <dl><div class="fondprofil">
 <dt>
 <div id="profil">

 <div class="avatar">{postrow.displayed.POSTER_AVATAR}</div>
 <div class="base"></div>
 
                                          
                                          <div class="container"><div class="icon">     <div class="infos-supp"></div></div>
                                            
                                            <div class="prof3"><i class="fa fa-pencil"></i><div class="infos4"></div></div>
                                            <div class="prof4"> <i class="fa fa-thumbs-up"></i><div class="infos5"></div></div>
                                            <div class="profilirl"><div class="irl"><div class="infosirl1"></div></div>
                                        <div class="irl">      <div class="infosirl2"></div></div>
                                          <div class="irl">    <div class="infosirl3"></div></div>
                                          <div class="irl">    <div class="infosirl4"></div></div>
                                          <div class="irl">    <div class="infosirl5"></div></div>
                                               <div class="irl">    <div class="infosirl6"></div></div>
                                           </div>
                                            
            </div>
 
                                     </div><div class="title-bg">
   <div class="postprofile-name">
 {postrow.displayed.POSTER_NAME}
</div>
                                          </div>
 <div class="postprofile-rank">
 {postrow.displayed.POSTER_RANK_NEW}{postrow.displayed.RANK_IMAGE}
                                          </div>
 </dt>
                               <div class="prof1">    <span class="fa fa-birthday-cake"> </span> <br/><div class="infos2"></div></div>
                          <div class="prof2">      <i class="fa fa-calendar"></i><br/> <div class="infos3"></div></div>
                                  <div class="cadreprofil">                                  
                           <div class="gifig"></div> <!-- BEGIN profile_field -->
<div class="champsprofilfond">  {postrow.displayed.profile_field.LABEL} {postrow.displayed.profile_field.CONTENT}{postrow.displayed.profile_field.SEPARATOR}</div>
                                    <!-- END profile_field -->  
                                  </div> </div>
 </dl>
 </div>
<dd class="postprofile-contact">
 {postrow.displayed.PM_IMG}
 <!-- BEGIN contact_field -->
 {postrow.displayed.contact_field.CONTENT}
 <!-- END contact_field -->
 </dd>
 <div class="post-head">
 <ul class="profile-icons">
 <li class="btn-thank">
 <a href="{postrow.displayed.THANK_URL}">
 <i class="ion-heart"></i>
 </a>
 </li>
 <li class="btn-quote-multi">
 <span onclick="{postrow.displayed.MULTIQUOTE_URL}" id="post_mq{TOPIC_ID}_{postrow.displayed.U_POST_ID}">
 <i class="ion-quote"></i>
 <i class="ion-ios-plus-empty"></i>
 </span>
 </li>
 <li class="btn-quote">
 <a href="{postrow.displayed.QUOTE_URL}">
 <i class="ion-quote"></i>
 </a>
 </li>
 <li class="btn-edit">
 <a href="{postrow.displayed.EDIT_URL}">
 <i class="ion-edit"></i>
 </a>
 </li>
 <li class="btn-delete">
 <a href="{postrow.displayed.DELETE_URL}">
 <i class="ion-trash-a"></i>
 </a>
 </li>
 <li class="btn-ip">
 <a href="{postrow.displayed.IP_URL}">
 <i class="ion-ios-information"></i>
 </a>
 </li>
 <li class="btn-report">
 {postrow.displayed.REPORT_IMG}
 </li>
 </ul>

 <h2 class="topic-title">{postrow.displayed.ICON} <a href="{postrow.displayed.POST_URL}">{postrow.displayed.POST_SUBJECT}</a></h2>
 <div class="topic-date">
 {postrow.displayed.POST_DATE_NEW}

 <!-- BEGIN switch_vote_active -->
 <div class="vote">
 <!-- BEGIN switch_vote -->
 <a href="{postrow.displayed.switch_vote_active.switch_vote.U_VOTE_PLUS}" class="ion-thumbsup"></a>
 <!-- END switch_vote -->

 <!-- BEGIN switch_vote -->
 <a href="{postrow.displayed.switch_vote_active.switch_vote.U_VOTE_MINUS}" class="ion-thumbsdown"></a>
 <!-- END switch_vote -->

 <!-- BEGIN switch_bar -->
 <div class="vote-bar" title="{postrow.displayed.switch_vote_active.L_VOTE_TITLE}">
 <div class="vote-bar-desc">
 {postrow.displayed.switch_vote_active.L_VOTE_TITLE}
 </div>

 <div class="vote-bars">
 <!-- BEGIN switch_vote_plus -->
 <div class="vote-bar-plus" style="width:{postrow.displayed.switch_vote_active.switch_bar.switch_vote_plus.HEIGHT_PLUS}px;"></div>
 <!-- END switch_vote_plus -->

 <!-- BEGIN switch_vote_minus -->
 <div class="vote-bar-minus" style="width:{postrow.displayed.switch_vote_active.switch_bar.switch_vote_minus.HEIGHT_MINUS}px;"></div>
 <!-- END switch_vote_minus -->
 </div>
 </div>
 <!-- END switch_bar -->

 <!-- BEGIN switch_no_bar -->
 <div title="{postrow.displayed.switch_vote_active.L_VOTE_TITLE}" class="vote-bar-empty"></div>
 <!-- END switch_no_bar -->
 </div>
 <!-- END switch_vote_active -->
 </div>
 </div>

 <div class="postbody">
 <div class="content">
 <div>{postrow.displayed.MESSAGE}</div>
 <!-- BEGIN switch_attachments -->
 <dl class="attachbox">
 <dt>{postrow.displayed.switch_attachments.L_ATTACHMENTS}</dt>
 <dd class="attachments">
 <!-- BEGIN switch_post_attachments -->
 <dl class="file">
 <dt>
 <img src="{postrow.displayed.switch_attachments.switch_post_attachments.U_IMG}" alt=""/>
 </dt>
 <dd>
 <!-- BEGIN switch_dl_att -->
 <span><a class="postlink" href="{postrow.displayed.switch_attachments.switch_post_attachments.switch_dl_att.U_ATTACHMENT}">{postrow.displayed.switch_attachments.switch_post_attachments.switch_dl_att.ATTACHMENT}</a> {postrow.displayed.switch_attachments.switch_post_attachments.switch_dl_att.ATTACHMENT_DEL}</span>
 <!-- END switch_dl_att -->

 <!-- BEGIN switch_no_dl_att -->
 <span>{postrow.displayed.switch_attachments.switch_post_attachments.switch_no_dl_att.ATTACHMENT} {postrow.displayed.switch_attachments.switch_post_attachments.switch_no_dl_att.ATTACHMENT_DEL}</span>
 <!-- END switch_no_dl_att -->

 <!-- BEGIN switch_no_comment -->
 <span>{postrow.displayed.switch_attachments.switch_post_attachments.switch_no_comment.ATTACHMENT_COMMENT}</span>
 <!-- END switch_no_comment -->

 <!-- BEGIN switch_no_dl_att -->
 <span><strong>{postrow.displayed.switch_attachments.switch_post_attachments.switch_no_dl_att.TEXT_NO_DL}</strong></span>
 <!-- END switch_no_dl_att -->

 <span>({postrow.displayed.switch_attachments.switch_post_attachments.FILE_SIZE}) {postrow.displayed.switch_attachments.switch_post_attachments.NB_DL}</span>
 </dd>
 </dl>
 <!-- END switch_post_attachments -->
 </dd>
 </dl>
 <!-- END switch_attachments -->
 </div>
 
 <!-- BEGIN switch_signature -->
 <div class="signature_div" id="sig{postrow.displayed.U_POST_ID}">{postrow.displayed.SIGNATURE_NEW}</div>
 <!-- END switch_signature -->
 </div>
 </div>
 <!-- BEGIN first_post_br -->
 <hr id="first-post-br" />
 <!-- END first_post_br -->
 <!-- END displayed -->
<!-- END postrow -->

<a name="bottomtitle"></a>


<div class="topic-actions bottom">
 <!-- BEGIN topicpagination -->
 <div class="pagination">
 {PAGINATION}
 </div>
 <!-- END topicpagination -->

 <div class="topic-actions-buttons">
 <!-- BEGIN switch_user_logged_in -->
 <!-- BEGIN watchtopic -->
 {S_WATCH_TOPIC}
 <!-- END watchtopic -->
 <!-- END switch_user_logged_in -->

 <!-- BEGIN switch_user_authpost -->
 <a href="{U_POST_NEW_TOPIC}" rel="nofollow"><img src="{POST_IMG}" id="{POST_IMG_ID}one" alt="{L_POST_NEW_TOPIC}" align="middle" border="0" /></a>&nbsp;&nbsp;&nbsp;
 <!-- END switch_user_authpost -->
 <!-- BEGIN switch_user_authreply -->
 <a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" id="i_reply" alt="{L_POST_REPLY_TOPIC}" align="middle" border="0" /></a>
 <!-- END switch_user_authreply -->
 </div>
</div>

<!-- BEGIN promot_trafic -->
 <div class="block" id="ptrafic_close" style="display: none;">
 <div class="h3"><a href="javascript:ShowHideLayer('ptrafic_open','ptrafic_close');"><i class="ion-ios-plus-outline"></i></a>{PROMOT_TRAFIC_TITLE}</div>
 </div>
 <div class="block" id="ptrafic_open" style="display:'';">
 <div class="h3"><a href="javascript:ShowHideLayer('ptrafic_open','ptrafic_close');"><i class="ion-ios-minus-outline"></i></a>{PROMOT_TRAFIC_TITLE}</div>
 <ul class="ptrafic">
 <!-- BEGIN link -->
 <li>
 <a href="{promot_trafic.link.U_HREF}" target="_blank" title="{promot_trafic.link.TITLE}" rel="nofollow">
 <i class="ion-ios-chatbubble-outline"></i>{promot_trafic.link.TITLE}
 </a>
 </li>
 <!-- END link -->
 </ul>
 </div>
<!-- END promot_trafic -->

<!-- BEGIN switch_forum_rules -->
<div class="post row1" id="forum_rules">
 <div class="h3">{L_FORUM_RULES}</div>
 <div class="clear"></div>
 <table class="postbody">
 <tr>
 <!-- BEGIN switch_forum_rule_image -->
 <td class="logo">
 <img src="{RULE_IMG_URL}" alt="" />
 </td>
 <!-- END switch_forum_rule_image -->
 <td class="rules content">
 {RULE_MSG}
 </td>
 </tr>
 </table>
</div>
<!-- END switch_forum_rules -->

<!-- BEGIN switch_user_logged_in -->
 <a name="quickreply"></a>
 {QUICK_REPLY_FORM}
<!-- END switch_user_logged_in -->

<form action="{S_JUMPBOX_ACTION}" method="get" onsubmit="if(document.jumpbox.f.value == -1){return false;}">
 <fieldset class="jumpbox">
 <label>{L_JUMP_TO}:</label>
 {S_JUMPBOX_SELECT}
 <input class="button2" type="submit" value="{L_GO}" />
 </fieldset>
</form>

<!-- BEGIN viewtopic_bottom -->
<form method="get" action="{S_FORM_MOD_ACTION}">
 <fieldset class="quickmod">
 <input type="hidden" name="t" value="{TOPIC_ID}" />

 <!-- <input type="hidden" name="sid" value="{S_SID}" /> -->
 <input type="hidden" name="{SECURE_ID_NAME}" value="{SECURE_ID_VALUE}" />
 <label>{L_MOD_TOOLS}:</label>
 {S_SELECT_MOD}
 <input class="button2" type="submit" value="{L_GO}" />
 </fieldset>
</form>

<div class="sub-header-path">
 <a class="nav" href="{U_INDEX}"><span>{L_INDEX}</span></a>
 {NAV_CAT_DESC}
 </div>

<p class="right">{S_TOPIC_ADMIN}</p>
<!-- END viewtopic_bottom -->

<!-- BEGIN show_permissions -->
 <div class="block">
 <div class="h3">{L_TABS_PERMISSIONS}</div>
 {S_AUTH_LIST}
 </div>
<!-- END show_permissions -->

<!-- BEGIN switch_image_resize -->
<script type="text/javascript">
//<![CDATA[
$(resize_images({ 'selector' : '.postbody .content', 'max_width' : {switch_image_resize.IMG_RESIZE_WIDTH}, 'max_height' : {switch_image_resize.IMG_RESIZE_HEIGHT} }));
//]]>
</script>
<!-- END switch_image_resize -->

<script src="//s7.addthis.com/js/300/addthis_widget.js#pubid=forumotion" type="text/javascript"></script>
<link rel="stylesheet" href="//cdnjs.cloudflare.com/ajax/libs/highlight.js/9.9.0/styles/github-gist.min.css">
<script src="//cdnjs.cloudflare.com/ajax/libs/highlight.js/9.9.0/highlight.min.js"></script>
<script src="//cdnjs.cloudflare.com/ajax/libs/highlight.js/9.9.0/languages/go.min.js"></script>
<script>
$(document).ready(function() {
 $('pre, code').each(function(i, block) {
 hljs.highlightBlock(block);
 });

 $('.post').each(function() {
 if (!$(this).find('.postprofile-avatar').html().length) {
 $(this).find('.postprofile-rank').css('border-bottom', 'none');
 $(this).find('.postprofile > dl > dt').css('min-height', $(this).find('.post-head').innerHeight());
 }
 });
});
</script>

merci d'avaaaance I love you
tearsflight

tearsflight
Nouveau membre

Messages : 22
Inscrit(e) le : 18/10/2016

Voir le profil de l'utilisateur https://madeinsilvercreek.forumactif.com/
tearsflight a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Rivendell. Jeu 16 Avr 2020 - 16:42

Hello. I love you
Essaye ceci :

Code:
/* FORUM VERSIONS
 * 0 = PHPBB2
 * 1 = PHPBB3
 * 2 = PUNBB
 * 3 = INVISION
 * 4 = MODERNBB
 */
$(function() {
  var version = 4,
      image = 'https://i.imgur.com/fqq2tNP.png';
 
 
  if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
    document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
    my_setcookie('fa_mention','');
  } if (!/\/t\d+/.test(window.location.pathname)) return;
 
  for (var a = $(['.post-options', '.profile-icons', '.post-options', '.posting-icons', '.profile-icons'][version]), b, c, d = ['.postprofile-name a', '.author a', '.username a', '.author a', '.postprofile-name a'][version], e, i = 0, j = a.length, t = document.getElementById('text_editor_textarea'), l = version == 1 || version == 3 || version == 4; i<j; i++) {
    b = document.createElement('IMG');
    b.src = image;
    b.alt = 'Mentionner';
    b.title = 'Mentionner ' + $(a[i]).closest('.post').find(d + ':not(.fa-mention)').text();
    b.className = 'i_icon_mention';
    b.onclick = function() {
      var n = this.title.replace(/^.*?\s/,'');
    
      if ($.sceditor) t.insertText('@"' + n + '" ');
      else {
        my_setcookie('fa_mention', n);
        window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
      }
    };
 
    if (l) {
      c = document.createElement('LI');
      c.appendChild(b);
    }
  
    a[i].insertBefore(l ? c : b, a[i].firstChild);
  }
 
  $(function(){
    if (!$.sceditor) return;
    t=$(t).sceditor('instance');
  });
});

Si jamais, j'ai expliqué la raison ici : https://forum.forumactif.com/t402791-bouton-mention-qui-ne-fonctionne-pas
Rivendell.

Rivendell.
**

Messages : 54
Inscrit(e) le : 05/01/2018

Voir le profil de l'utilisateur https://coldcoffee.forumactif.com/
Rivendell. a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par tearsflight Jeu 16 Avr 2020 - 17:05

hey I love you
merci de ton aide, j'ai essayé les 2 solutions que tu as données, mais ça ne fonctionne toujours pas
j'ai donc ça dans mon template maintenant :
Code:
<div class="title-bg">
  <div class="postprofile-name">   
                  <span class="name"><strong>{postrow.displayed.POSTER_NAME}</strong></span>   
</div>
                                          </div>
tearsflight

tearsflight
Nouveau membre

Messages : 22
Inscrit(e) le : 18/10/2016

Voir le profil de l'utilisateur https://madeinsilvercreek.forumactif.com/
tearsflight a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Rivendell. Jeu 16 Avr 2020 - 17:59

En toute logique, si tu essayes avec le js que tu as posté
Code:
/* FORUM VERSIONS
 * 0 = PHPBB2
 * 1 = PHPBB3
 * 2 = PUNBB
 * 3 = INVISION
 * 4 = MODERNBB
 */
$(function() {
  var version = 4,
      image = 'https://i.imgur.com/fqq2tNP.png';
 
 
  if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
    document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
    my_setcookie('fa_mention','');
  } if (!/\/t\d+/.test(window.location.pathname)) return;
 
  for (var a = $(['.post-options'][version]), b, c, d = ['.name a'][version], e, i = 0, j = a.length, t = document.getElementById('text_editor_textarea'), l = version == 1 || version == 3 || version == 4; i<j; i++) {
    b = document.createElement('IMG');
    b.src = image;
    b.alt = 'Mentionner';
    b.title = 'Mentionner ' + $(a[i]).closest('.post').find(d + ':not(.fa-mention)').text();
    b.className = 'i_icon_mention';
    b.onclick = function() {
      var n = this.title.replace(/^.*?\s/,'');
    
      if ($.sceditor) t.insertText('@"' + n + '" ');
      else {
        my_setcookie('fa_mention', n);
        window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
      }
    };
 
    if (l) {
      c = document.createElement('LI');
      c.appendChild(b);
    }
  
    a[i].insertBefore(l ? c : b, a[i].firstChild);
  }
 
  $(function(){
    if (!$.sceditor) return;
    t=$(t).sceditor('instance');
  });
});

Ca devrait fonctionner. Sinon, essaye dans ton template de mettre:

Code:
<div class="title-bg">
  <div class="postprofile-name">  
                  <span class="name">
                            <a name="{postrow.displayed.U_POST_ID}" style="position: relative; top: -30px; width: 1px;" id="{postrow.displayed.U_POST_ID}"></a><strong>{postrow.displayed.POSTER_NAME}</strong></span>  
</div>
                                          </div>

Au sinon, ce que personnellement je fais, je code le mise en page du pseudo en .name strong dans le css et je ne retire jamais ça du template de base de FA.

Code:
<span class="name">
                            <a name="{postrow.displayed.U_POST_ID}" style="position: relative; top: -30px; width: 1px;" id="{postrow.displayed.U_POST_ID}"></a><strong>{postrow.displayed.POSTER_NAME}</strong></span>

Du coup si tu suis ça, dans ton template tu devrais avoir

Code:
<div class="title-bg">  
                  <span class="name">
                            <a name="{postrow.displayed.U_POST_ID}" style="position: relative; top: -30px; width: 1px;" id="{postrow.displayed.U_POST_ID}"></a><strong>{postrow.displayed.POSTER_NAME}</strong></span>
                                          </div>

Dans ton css tu remplaces .postprofile-name par .name strong et là dis-moi si ça fonctionne. reflexion
Rivendell.

Rivendell.
**

Messages : 54
Inscrit(e) le : 05/01/2018

Voir le profil de l'utilisateur https://coldcoffee.forumactif.com/
Rivendell. a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par tearsflight Jeu 16 Avr 2020 - 18:12

toujours pas Mais oui
j'ai mis le code que tu m'as donné dans le template (sans l'enregistrer, parce qu'il faudra que j'adapte mon css du coup) et ça fait toujours pareil.
Par contre, si je mets le JS que tu as un peu réduit (je crois), le bouton ne s'affiche même plus
tearsflight

tearsflight
Nouveau membre

Messages : 22
Inscrit(e) le : 18/10/2016

Voir le profil de l'utilisateur https://madeinsilvercreek.forumactif.com/
tearsflight a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Rivendell. Jeu 16 Avr 2020 - 20:47

C'est trop bizarre car j'utilise ça sur mon forum depuis des années et je n'ai jamais eu de soucis, du coup je sais pas désolée. ::moitimide:: Après si tu n'as pas adapté ton css aux templates c'est normal ..
Rivendell.

Rivendell.
**

Messages : 54
Inscrit(e) le : 05/01/2018

Voir le profil de l'utilisateur https://coldcoffee.forumactif.com/
Rivendell. a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par tearsflight Jeu 16 Avr 2020 - 20:59

je l'ai fait là du coup, pour le css... après pour certaines choses, je bricole pas mal, je suis loin de m'y connaître et le JS fait clairement partie de mes points faibles
merci de ton aide quand même, j'espère que quelqu'un d'autre verra où est le problème, sinon on fera sans ce bouton
tearsflight

tearsflight
Nouveau membre

Messages : 22
Inscrit(e) le : 18/10/2016

Voir le profil de l'utilisateur https://madeinsilvercreek.forumactif.com/
tearsflight a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Chacha Mer 22 Avr 2020 - 9:56

bouton mention qui ne fonctionne pas UmaslZ4Bonjour,

Attention, cela fait 6 jours que nous n'avons pas de nouvelles concernant votre demande, si vous ne voulez pas voir votre sujet déplacé à la corbeille, merci de poster dans les 24h qui suivent ce message.

Si votre sujet est résolu, merci d'éditer votre premier message et de cocher l'icône « résolu »
Chacha

Chacha
Modéractif
Modéractif

Masculin
Messages : 66945
Inscrit(e) le : 21/08/2010

Voir le profil de l'utilisateur https://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par tearsflight Mer 22 Avr 2020 - 9:58

la question est toujours d'actualité, le bouton ne fonctionne toujours pas
tearsflight

tearsflight
Nouveau membre

Messages : 22
Inscrit(e) le : 18/10/2016

Voir le profil de l'utilisateur https://madeinsilvercreek.forumactif.com/
tearsflight a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Self Mer 22 Avr 2020 - 22:26

Bonjour,

J'avoue j'ai essayé sur AwesomeBB et adapté les class à votre version et forum mais je pense que quelque chose comme ça (pour le javascript) devrait fonctionner ? :
Code:
$(function(){
   var image = 'https://i.imgur.com/fqq2tNP.png', t = document.getElementById('text_editor_textarea');
   if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
      document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
      my_setcookie('fa_mention','');
   } if (!/\/t\d+/.test(window.location.pathname)) return;

   $('.post').each(function(i){
      var name = $(this).find('.name strong a').text();
      $(this).find('.profile-icons ul').prepend('<li><img class="i_icon_mention" src="'+image+'" alt="Mentionner" title="Mentionner '+name+'" /></li>');
      $(this).find('.i_icon_mention').on('click', function(){
         if (t.length != 0) t.value = t.value+' '+('@"' + name + '" ');
         else {
            my_setcookie('fa_mention', name);
            window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
         }
      });
   });
   
}, jQuery);
Self

Self
Membre actif

Masculin
Messages : 3827
Inscrit(e) le : 13/06/2013

Voir le profil de l'utilisateur https://selfback.forumactif.com/
Self a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par tearsflight Jeu 23 Avr 2020 - 7:04

bonjour,

merci de ton aide, mais le bouton ne s'affiche plus une fois que je mets ce java malheureusement...
tearsflight

tearsflight
Nouveau membre

Messages : 22
Inscrit(e) le : 18/10/2016

Voir le profil de l'utilisateur https://madeinsilvercreek.forumactif.com/
tearsflight a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Self Jeu 23 Avr 2020 - 11:04

Bonjour,

J'avais oublié de supprimer deux lettres Mr. Green ! Essaie comme ça :

Code:
$(function(){
   var image = 'https://i.imgur.com/fqq2tNP.png', t = document.getElementById('text_editor_textarea');
   if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
      document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
      my_setcookie('fa_mention','');
   } if (!/\/t\d+/.test(window.location.pathname)) return;

   $('.post').each(function(i){
      var name = $(this).find('.name strong a').text();
      $(this).find('.profile-icons').prepend('<li><img class="i_icon_mention" src="'+image+'" alt="Mentionner" title="Mentionner '+name+'" /></li>');
      $(this).find('.i_icon_mention').on('click', function(){
         if (t.length != 0) t.value = t.value+' '+('@"' + name + '" ');
         else {
            my_setcookie('fa_mention', name);
            window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
         }
      });
   });
   
}, jQuery);
Self

Self
Membre actif

Masculin
Messages : 3827
Inscrit(e) le : 13/06/2013

Voir le profil de l'utilisateur https://selfback.forumactif.com/
Self a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par tearsflight Jeu 23 Avr 2020 - 11:17

le bouton est visible à nouveau, mais ne fait toujours rien... je crois qu'il est maudit Sorry
tearsflight

tearsflight
Nouveau membre

Messages : 22
Inscrit(e) le : 18/10/2016

Voir le profil de l'utilisateur https://madeinsilvercreek.forumactif.com/
tearsflight a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Self Jeu 23 Avr 2020 - 11:45

Effectivement, après des tests complémentaires sur votre forum et celui-ci le code suivant semble fonctionner :
Code:
$(function(){
   var image = 'https://i.imgur.com/fqq2tNP.png', t = document.getElementById('textarea_content').querySelectorAll('textarea')[1];
   if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
      document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
      my_setcookie('fa_mention','');
   } if (!/\/t\d+/.test(window.location.pathname)) return;

   $('.post').each(function(i){
      var name = $(this).find('.name strong a').text();
      $(this).find('.profile-icons').prepend('<li><img class="i_icon_mention" src="'+image+'" alt="Mentionner" title="Mentionner '+name+'" /></li>');
      $(this).find('.i_icon_mention').on('click', function(){
         if (t.length != 0) t.value = t.value+' '+('@"' + name + '" ');
         else {
            my_setcookie('fa_mention', name);
            window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
         }
      });
   });
   
}, jQuery);
Self

Self
Membre actif

Masculin
Messages : 3827
Inscrit(e) le : 13/06/2013

Voir le profil de l'utilisateur https://selfback.forumactif.com/
Self a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par tearsflight Jeu 23 Avr 2020 - 11:58

merci pour tes efforts et recherches, mais ça ne fonctionne toujours pas Mince
tearsflight

tearsflight
Nouveau membre

Messages : 22
Inscrit(e) le : 18/10/2016

Voir le profil de l'utilisateur https://madeinsilvercreek.forumactif.com/
tearsflight a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par Self Jeu 23 Avr 2020 - 12:45

Je suis désolé, c'est moi qui n'avais pas le courage de créer un nouvelle adresse mail pour créer un nouveau forum.
Il y avait en effet un problème que ne me donnait pas la console, avec votre template actuel et le code suivant j'obtiens le comportement voulu :
Code:
$(function(){
   var image = 'https://i.imgur.com/fqq2tNP.png';
   if (/mode=reply/.test(window.location.search) && my_getcookie('fa_mention')) {
      document.post.message.value += '@"' + my_getcookie('fa_mention') + '" ';
      my_setcookie('fa_mention','');
   } if (!/\/t\d+/.test(window.location.pathname)) return;

   $('.post').each(function(i){
      if(!$(this).find('.name strong a')) return;
      var name = $(this).find('.name strong a').text();
      $(this).find('.profile-icons').prepend('<li><img class="i_icon_mention" src="'+image+'" alt="Mentionner" title="Mentionner '+name+'" /></li>');
      $(this).find('.i_icon_mention').on('click', function(){
         t = document.getElementById('textarea_content').querySelectorAll('textarea')[1];
         if (t.length != 0) t.value = t.value+' '+('@"' + name + '" ');
         else {
            my_setcookie('fa_mention', name);
            window.location.href = '/post?t=' + window.location.pathname.replace(/\/t(\d+)-.*/,'$1') + '&mode=reply';
         }
      });
   });
   
}, jQuery);

Est-ce pareil pour vous ?
Self

Self
Membre actif

Masculin
Messages : 3827
Inscrit(e) le : 13/06/2013

Voir le profil de l'utilisateur https://selfback.forumactif.com/
Self a été remercié(e) par l'auteur de ce sujet.

Résolu Re: bouton mention qui ne fonctionne pas

Message par tearsflight Jeu 23 Avr 2020 - 13:44

oooh oui, ça marche enfin, un grand MERCI à toi merci
j'ai cru que ça n'était toujours pas bon, parce que d'habitude, il descend la page jusqu'à l'éditeur mais là, il ne le fait pas mais le nom tagué y apparaît bien
merci à toi pour le temps que tu y as passé *-*
tearsflight

tearsflight
Nouveau membre

Messages : 22
Inscrit(e) le : 18/10/2016

Voir le profil de l'utilisateur https://madeinsilvercreek.forumactif.com/
tearsflight a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum