Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Balise code : colorisation du contenu ne fonctionne plus

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Balise code : colorisation du contenu ne fonctionne plus

Message par Chevakine le Lun 14 Sep 2020 - 20:40

Détails techniques

Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome
Capture d'écran du problème :
Voir l'image:
Balise code : colorisation du contenu ne fonctionne plus Rq7q

Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : 14/09/2020
Lien du forum : https://herviefaye.com/

Description du problème

Bonjour,

Hier j'ai suivi ce tuto pour coloriser le contenu de ma balise de code : https://forum.forumactif.com/t287569-coloriser-les-balises-de-code#2538388

J'ai installé le JS (sur toutes les pages) + ce CSS personnalisé : https://github.com/highlightjs/highlight.js/blob/master/src/styles/monokai-sublime.css

Tout fonctionnait bien et puis je me suis aperçue aujourd'hui que ce n'est plus la cas. J'ai l'impression que c'est depuis que j'ai changé le nom de domaine de mon forum (car d'ailleurs, le navigateur met une alerte comme quoi c'est un site dangereux).

Voici mon JS + mon CSS en place concernant l'ensemble des balises et ma tambouille pour tenter de régler le problème :

Code:
$(function(){var a=$("dl.codebox dd").find("code, div.cont_code");0!=a.length&&$.ajax({url:"http://yandex.st/highlightjs/8.0/highlight.min.js",cache:!0,dataType:"script",success:function(){hljs.configure({useBR:!0});a.each(function(a,b){hljs.highlightBlock(b)})}})});

Code:
/* BALISES */

/* balise code */

.hljs {
  display: block;
  overflow-x: auto;
  padding: 0.5em;
  background: #23241f;
}

.hljs,
.hljs-tag,
.hljs-subst {
  color: #f8f8f2;
}

.hljs-strong,
.hljs-emphasis {
  color: #a8a8a2;
}

.hljs-bullet,
.hljs-quote,
.hljs-number,
.hljs-regexp,
.hljs-literal,
.hljs-link {
  color: #ae81ff;
}

.hljs-code,
.hljs-title,
.hljs-section,
.hljs-selector-class {
  color: #a6e22e;
}

.hljs-strong {
  font-weight: bold;
}

.hljs-emphasis {
  font-style: italic;
}

.hljs-keyword,
.hljs-selector-tag,
.hljs-name,
.hljs-attr {
  color: #f92672;
}

.hljs-symbol,
.hljs-attribute {
  color: #66d9ef;
}

.hljs-params,
.hljs-class .hljs-title {
  color: #f8f8f2;
}

.hljs-string,
.hljs-type,
.hljs-built_in,
.hljs-builtin-name,
.hljs-selector-id,
.hljs-selector-attr,
.hljs-selector-pseudo,
.hljs-addition,
.hljs-variable,
.hljs-template-variable {
  color: #e6db74;
}

.hljs-comment,
.hljs-deletion,
.hljs-meta {
  color: #75715e;
}


/* Contenu code */
.code {
  background: #23241f;
  font-size: 12px;
  border-radius : 5px!important;
  border: none!important;
  border: 2px solid #0a9acf!important;
  box-shadow: 0px 0px 2px #000000;
}


/*Titre de CODE, SPOILER ET QUOTE*/
.codebox > dt .genmed, .spoiler > dt {
  font-family: calibri;
  color: #0a9acf;
  text-shadow:1px 1px 2px #000000;
  text-transform: uppercase;  
}

/*Contenu de QUOTE et SPOILER */
.quote, .spoiler_closed, .spoiler_content {
  background-color: rgba(16, 34, 54, 0.8);
  padding: 10px;
  border: none;
}

/*Contenu de HIDE*/
.hidecode > dd:first-of-type {
  background-color: rgba(16, 34, 54, 0.8);
  padding: 10px;
  border: none;
}

/* largeur "code", "citation", "spoiler" et "hide" */
.codebox {
  width: 90%;
  margin-top: 20px!important;
}
.cont_code {
  max-height: 300px!important;
  scrollbar-width: thin;
  padding-left: 25px!important;
}

/* Ajout du "sélectionner le contenu" */
.selectCode {
  float: right;
  text-transform: uppercase;
  cursor: pointer;
  font-family: calibri;
  color: #0a9acf;
  text-shadow:1px 1px 2px #000000;
  font-size: 14px;
}
div.cont_code {
  clear: right;
}

/* Ajout de la numérotation */
.cont_code {
  display: block;
  position: relative;
  padding-left: 28px;
  padding: 1em;
}
.bloclignes {
  position: absolute;
  width: 24px;
  top: 0px;
  left: 0px;
  background-color: #23241f;
  color: ##f8f8f2;
  text-align: right;
  box-shadow: 0px 0px 2px #000000;
}

Merci par avance !
Chevakine

Chevakine
Nouveau membre

Féminin
Messages : 10
Inscrit(e) le : 28/08/2020

Voir le profil de l'utilisateur https://herviefaye.forumactif.com/
Chevakine a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Balise code : colorisation du contenu ne fonctionne plus

Message par 'Christa le Mer 16 Sep 2020 - 4:34

Hello!

Quand je vais sur le lien que tu as fourni, mon inspecteur de code n'affiche pas le javascript que tu es supposé.e avoir ajouté, du coup dans le doute, je me permets de te demander... est-ce que les scripts javascript sont activés?
'Christa

'Christa
**

Féminin
Messages : 62
Inscrit(e) le : 04/06/2009

Voir le profil de l'utilisateur https://lostmindy-test.forumactif.com/
'Christa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise code : colorisation du contenu ne fonctionne plus

Message par Chevakine le Mer 16 Sep 2020 - 10:25

Bonjour,

Merci pour ta réponse rapide.

C'est étrange... C'est bien activé oui :
Spoiler:
Balise code : colorisation du contenu ne fonctionne plus Captur12

Et le code est bien là...
Spoiler:
Balise code : colorisation du contenu ne fonctionne plus Captur13

Est-ce qu'il y a une activation ailleurs ?
Chevakine

Chevakine
Nouveau membre

Féminin
Messages : 10
Inscrit(e) le : 28/08/2020

Voir le profil de l'utilisateur https://herviefaye.forumactif.com/
Chevakine a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise code : colorisation du contenu ne fonctionne plus

Message par 'Christa le Mer 16 Sep 2020 - 17:30

Hello Smile

Je suis repartie vérifier, je suis juste une andouille qui devrait éviter de faire du debug à 4h du matin, c'est juste moi qui avais oublié d'activer le javascript provenant de cette adresse sur mon navigateur (du coup, dans le doute, si tu utilises noscript... c'est p'têt une solution XD). J'ai vérifié aussi si l'hébergeur du javascript (le yandex.st dans le code) était toujours fonctionnel, et ça en a l'air.

Du coup ce que je vais dire ne va pas faire avancer le schmilblick, malheureusement, mais peut-être que quelqu'un de passage aura une idée à partir de mes observations.

Quand je vais sur ton forum et que je checke la console de l'outil de développement de firefox, je vois ceci apparaitre :
Balise code : colorisation du contenu ne fonctionne plus L89Rd
(ça donne sur ce lien)
J'ai été vérifier sur Never Utopia, qui a approximativement le même code pour sa coloration syntaxique, et le message n'apparait pas, et la coloration fonctionne très bien.

Du coup, je ne sais pas du tout ce qui cloche. Un souci de DNS relatif au changement de nom de domaine? Un truc qui coince quelque part? Je suggèrerais peut-être de remplacer l'adresse http://yandex.st/highlightjs/8.0/highlight.min.js du script par https://yandex.st/highlightjs/8.0/highlight.min.js (le seul changement est le https au début XD) mais comme j'ai dit, ça marche sur Never Utopia tel quel, donc je ne sais vraiment pas, désolée !

Notons que la console mentionne également une erreur dans la page /t27-libre-service que je vérifiais pour voir, on dirait qu'une balise </script> est mal fermée quelque part dans l'en-tête du document HTML mais je ne comprends pas trop ce qui se passe. L'erreur apparait dans tous les topics, mais ils contiennent tous du code, donc je ne sais pas si c'est lié à ça, ou bien à une erreur dans ton template viewtopic_body.

Voilà voilà, j'espère avoir potentiellement aidé à trouver le potentiel caillou dans le potage, bon courage!
'Christa

'Christa
**

Féminin
Messages : 62
Inscrit(e) le : 04/06/2009

Voir le profil de l'utilisateur https://lostmindy-test.forumactif.com/
'Christa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise code : colorisation du contenu ne fonctionne plus

Message par Chevakine le Mer 16 Sep 2020 - 19:51

D'accord ! Tu me donnes pas mal de piste à fouiller.

Je vais regarder ça et je reviendrai vous dire ce qu'il en est.
Chevakine

Chevakine
Nouveau membre

Féminin
Messages : 10
Inscrit(e) le : 28/08/2020

Voir le profil de l'utilisateur https://herviefaye.forumactif.com/
Chevakine a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise code : colorisation du contenu ne fonctionne plus

Message par Chevakine le Mer 16 Sep 2020 - 19:59

Oh génial !
En ajoutant le "s", tout est revenu.

Merci beaucoup ! Je n'aurai jamais pu trouver ça, je ne sais d'ailleurs même par regarder ce genre d'anomalie.

Est-ce qu'il y a toujours des erreurs qui sont détectées ? J'ai jeté un coup d’œil à mon template mais j'ai tellement fait de modif que j'ai du mal à m'y retrouver, au premier coup d’œil je n'ai rien vu. Je regarderai à nouveau posément pour voir s'il n'y a pas d'erreur de balise malgré tout cas ça peut poser problème.
Chevakine

Chevakine
Nouveau membre

Féminin
Messages : 10
Inscrit(e) le : 28/08/2020

Voir le profil de l'utilisateur https://herviefaye.forumactif.com/
Chevakine a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise code : colorisation du contenu ne fonctionne plus

Message par 'Christa le Mer 16 Sep 2020 - 20:15

Ah, cool si le s était la seule chose nécessaire. Je vois toujours l'autre erreur, mais uniquement à l'intérieur d'un topic, donc la source de l'erreur est soit un problème dans le template viewtopic_body, soit dans un script qui n'est utilisé que dans les sujets. Bon courage pour la trouver Surprised
Balise code : colorisation du contenu ne fonctionne plus OxXaR
'Christa

'Christa
**

Féminin
Messages : 62
Inscrit(e) le : 04/06/2009

Voir le profil de l'utilisateur https://lostmindy-test.forumactif.com/
'Christa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise code : colorisation du contenu ne fonctionne plus

Message par Chacha le Mar 22 Sep 2020 - 9:09

Balise code : colorisation du contenu ne fonctionne plus UmaslZ4Bonjour,

Attention, cela fait 6 jours que nous n'avons pas de nouvelles concernant votre demande, si vous ne voulez pas voir votre sujet déplacé à la corbeille, merci de poster dans les 24h qui suivent ce message.

Si votre sujet est résolu, merci d'éditer votre premier message et de cocher l'icône « résolu »
Chacha

Chacha
Modéractif
Modéractif

Masculin
Messages : 63812
Inscrit(e) le : 21/08/2010

Voir le profil de l'utilisateur https://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise code : colorisation du contenu ne fonctionne plus

Message par Chevakine le Mar 22 Sep 2020 - 10:31

Oui pardon c'est résolu.
Petite précision concernant les erreurs détectées, une amie est allée vérifié et m'a dit qu'elle n'a plus d'erreur une fois qu'elle paramètre bien sa console.
Chevakine

Chevakine
Nouveau membre

Féminin
Messages : 10
Inscrit(e) le : 28/08/2020

Voir le profil de l'utilisateur https://herviefaye.forumactif.com/
Chevakine a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum