Vérifiez vos informations

Il semblerait que les informations techniques de votre profil n'aient pas été actualisées depuis un certain temps... Pour que l'aide apportée vous soit efficace, il est important que ces informations soient à jour : prenez quelques secondes pour confirmer ou compléter les informations suivantes.


Lien de votre forum
Version de ce forum
Vous êtes le fondateur de ce forum
Vous avez modifié le CSS de ce forum
Vous avez modifié les templates de ce forum
Votre navigateur

Forum qui rame et problème de chargement d'image

Voir le sujet précédent Voir le sujet suivant Aller en bas

En cours Forum qui rame et problème de chargement d'image

Message par Me00w le Lun 5 Oct 2020 - 19:02

Détails techniques

Version du forum : phpBB2
Poste occupé : Fondateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome, Opera, Safari, Autre
Personnes concernées par le problème : Plusieurs utilisateurs
Lien du forum : https://brocart.forumactif.com/

Description du problème

Bonjour,
Plusieurs membres de notre forum nouvellement ouvert (le 25 septembre), nous rapportent rencontrer des lenteurs sur le forum.
Il nous est reporté que certaines pages mettent un temps astronomique à charger principalement visiblement dû au fait que toutes les images sur les pages doivent être affichés en même temps sinon on n'en voit aucune.
J'ai un instant pensé au bug lié à AdBlock, mais visiblement les membres n'ont ce problème que sur notre forum et pas sur d'autres.
Du coup j'aimerai savoir si vous avez une idée quelconque de ce qu'il pourrait se passer, parce que j'avoue que là je sèche un peu.

Par avance merci
Me00w

Me00w
Nouveau membre

Messages : 2
Inscrit(e) le : 04/08/2019

Voir le profil de l'utilisateur https://brocart.forumactif.com/
Me00w a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pinguino le Mar 6 Oct 2020 - 9:38

Bonjour,

Voici le classement des ressources les plus longues à charger sur votre forum :

Forum qui rame et problème de chargement d'image Ress11

Comme vous pouvez le constater, 95% de ces ressources concernent vos images. La plus longue étant https://cdn.discordapp.com/attachments/745575255711416322/758052722816843948/pabrocart2.jpg car elle pèse presque 8 Mo. Le poids moyen d'une page web est de 1,8 Mo ... Rien que l'image est 4 / 5 fois plus lourde.

Si vous voulez que votre forum se charge rapidement :


  1. Vous enregistrez vos images sur votre PC.
  2. Vous les optimiser via un logiciel photo ou sur https://tinypng.com/.
  3. Vous hébergez l'image sur Servimg et non sur cdn.discordapp.com (requête externe qui prend du temps).
  4. Même constat pour les autres images mais rien que la première sera déjà une nette amélioration.
Pinguino

Pinguino
Adminactif
Adminactif

Masculin
Messages : 11863
Inscrit(e) le : 02/05/2004

Voir le profil de l'utilisateur
Pinguino a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pinguino le Jeu 8 Oct 2020 - 17:31

Bonjour,

Avez-vous pu regarder les points évoqués dans mon précédent message ?
Pinguino

Pinguino
Adminactif
Adminactif

Masculin
Messages : 11863
Inscrit(e) le : 02/05/2004

Voir le profil de l'utilisateur
Pinguino a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Chacha le Dim 11 Oct 2020 - 9:42

Forum qui rame et problème de chargement d'image 4qhGdLE
Bienvenue sur le forum de support de Forumactif

Puisque vous êtes nouveau, voici quelques sujets susceptibles de vous intéresser :
N'hésitez pas à ouvrir un nouveau sujet si vous ne trouvez pas votre réponse.
Forum qui rame et problème de chargement d'image UmaslZ4Bonjour,

Attention, cela fait 6 jours que nous n'avons pas de nouvelles concernant votre demande, si vous ne voulez pas voir votre sujet déplacé à la corbeille, merci de poster dans les 24h qui suivent ce message.

Si votre sujet est résolu, merci d'éditer votre premier message et de cocher l'icône « résolu »
Chacha

Chacha
Modéractif
Modéractif

Masculin
Messages : 63913
Inscrit(e) le : 21/08/2010

Voir le profil de l'utilisateur https://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Juux24 le Lun 12 Oct 2020 - 21:12

@Pinguino a écrit:Bonjour,

Voici le classement des ressources les plus longues à charger sur votre forum :

Forum qui rame et problème de chargement d'image Ress11

Comme vous pouvez le constater, 95% de ces ressources concernent vos images. La plus longue étant https://cdn.discordapp.com/attachments/745575255711416322/758052722816843948/pabrocart2.jpg car elle pèse presque 8 Mo. Le poids moyen d'une page web est de 1,8 Mo ... Rien que l'image est 4 / 5 fois plus lourde.

Si vous voulez que votre forum se charge rapidement :


  1. Vous enregistrez vos images sur votre PC.
  2. Vous les optimiser via un logiciel photo ou sur https://tinypng.com/.
  3. Vous hébergez l'image sur Servimg et non sur cdn.discordapp.com (requête externe qui prend du temps).
  4. Même constat pour les autres images mais rien que la première sera déjà une nette amélioration.


Bonsoir !

Je suis également administratrice sur le forum en question donc je me permets de répondre pour Me00w. Alors nous avons réhébergé l'image en question et nous avons pu voir une petite amélioration. Cependant, sur certaines pages où il y a beaucoup d'avatars (puisque nous sommes un forum de ressources), le chargement est vraiment très long (plusieurs minutes) et les images s'affichent toutes en même temps, elles n'arrivent pas progressivement. Ce qui est assez embêtant et rend l'utilisation de notre forum de ressources bancales...
Certaines images viennent de tumblr par exemple et peuvent être lourdes, j'imagine, sauf que nous avons quasiment 1000 membres et que nous ne pouvons pas vérifier que chacun de nos membres utilisent un bon hébergeur. De plus, j'ai regardé aujourd'hui sur un autre forum de ressources où ils ont 10x plus de membres et d'images et ça n'est pas lent à ce point (voire pas du tout). Alors qu'est-ce qui peut expliquer ce ralentissement ? Du codage ?

Merci d'avance pour votre réponse et pour du temps apporté à notre problème Smile
Juux24

Juux24
****

Féminin
Messages : 286
Inscrit(e) le : 07/02/2010

Voir le profil de l'utilisateur http://www.aa-retro.com/
Juux24 a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pinguino le Mar 13 Oct 2020 - 11:01

Je viens de vérifier la page https://www.aa-retro.com/t20751p30-recensement-du-mois-d-octobre-jusqu-au-13-10 :

Forum qui rame et problème de chargement d'image Img18

Il s'agit majoritairement de GIFs animés dans les signatures qui sont appelées en CSS. Malheureusement, certains hébergeurs les délivrent très lentement (voir les temps de chargement dans "Time"). De ce fait, je ne vois pas trop ce que nous pourrions faire de notre côté malheureusement.

Nous avions implémenté la technologie lazyload à l'époque pour les avatars et images dans les messages insérés via une balise <IMG>. Mais cette technologie n'était pas compatible avec de nombreux scripts d'utilisateurs (images déformées).

Par contre, si vous avez un peu de temps, est-il possible de tester sur la version mobile + sur la version classique mais en forçant les templates par défaut ?
Pinguino

Pinguino
Adminactif
Adminactif

Masculin
Messages : 11863
Inscrit(e) le : 02/05/2004

Voir le profil de l'utilisateur
Pinguino a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Juux24 le Mar 13 Oct 2020 - 20:08

D'accord, merci de votre réponse ! Je viens de tester la version classique ainsi que la mobile et en effet, le temps de chargement est bien moins long, les images s'affichent quasiment de suite. Cela veut donc dire que nos templates ralentissent le chargement de la page (en + du grand nombre d'images) ?

EDIT : Par contre je viens de voir que sur votre dernière image, il s'agit de mon autre forum et pas celui annoncé par Me00w plus haut à savoir celui-ci : https://brocart.forumactif.com
Juux24

Juux24
****

Féminin
Messages : 286
Inscrit(e) le : 07/02/2010

Voir le profil de l'utilisateur http://www.aa-retro.com/
Juux24 a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pinguino le Jeu 15 Oct 2020 - 14:49

Concernant Broc'Art, l'analyse du chargement de la page montre qu'il y a une forte latence à cause de cette image. Sur ma capture d'écran, vous pouvez voir que l'image a mis 17 secondes pour s'afficher créant une latence pour d'autres ressources :

Code:
https://images2.imgbox.com/86/49/CiRRG2ne_o.jpg

Forum qui rame et problème de chargement d'image Rame10

Pour le coup, je vous conseille 3 choses :

1) Déjà plus de 7 Mo pour une image JPG si petite, je ne comprends même pas comment c'est possible. En l'enregistrant sur Photoshop en qualité maximum, j'obtiens une image de 160 Ko ... Voici le lien au besoin : https://i.servimg.com/u/f73/19/83/20/22/test10.jpg
2) Ensuite, les images les plus longues proviennent de ce domaine images2.imgbox.com. Peut-être voir pour les ré-héberger sur Servimg ou un autre hébergeur plus rapide.
3) Enfin, n'hésitez pas à ajouter un attribut loading="lazy" à l'intérieur des balises IMG. Par exemple :

Code:
<img src="https://i.imgur.com/O1bteho.png" loading="lazy" id="i_logo" border="0" alt="Broc'Art" vspace="1">
Pinguino

Pinguino
Adminactif
Adminactif

Masculin
Messages : 11863
Inscrit(e) le : 02/05/2004

Voir le profil de l'utilisateur
Pinguino a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Juux24 le Dim 18 Oct 2020 - 11:57

Merci beaucoup pour votre réponse !

Nous avons changé l'image de la page d'accueil et mise celle que vous avez proposé, merci. Nous allons en effet regarder pour changer l'hébergeur imgbox même si beaucoup de nos membres l'utilisent déjà...

Et dernière question, est-il possible d'appliquer l'attribut loading="lazy" à toutes les images du forum via le css par exemple ?

Merci d'avance
Bon dimanche.
Juux24

Juux24
****

Féminin
Messages : 286
Inscrit(e) le : 07/02/2010

Voir le profil de l'utilisateur http://www.aa-retro.com/
Juux24 a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pluktoo le Dim 18 Oct 2020 - 19:03

Bonjour,

Je constate depuis ce matin que mon forum rame énormément, et en venant en parler ici je constate que c'est pareil pour le Forum des forums, les pages sont nettement plus longues à s'afficher que d'habitude.
S'agit-il d'un problème de serveur ?
Je n'ai pas ce problème de lenteur sur d'autres sites.
avatar

Pluktoo
*

Masculin
Messages : 43
Inscrit(e) le : 04/06/2008

Voir le profil de l'utilisateur http://noustous.forumpro.fr
Pluktoo a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pinguino le Lun 19 Oct 2020 - 9:03

Bonjour,

@Juux24 : malheureusement, l'attribut loading="lazy" n'est compatible qu'avec les balises IMG et IFRAME. Sur les forums, cet attributs est déjà en place sur les avatars et les vidéos Youtube par exemple. Il n'est pas possible de l'ajouter quand on affiche une image via CSS donc.

@Pluktoo : avez-vous Adblock ?
Pinguino

Pinguino
Adminactif
Adminactif

Masculin
Messages : 11863
Inscrit(e) le : 02/05/2004

Voir le profil de l'utilisateur
Pinguino a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pluktoo le Lun 19 Oct 2020 - 9:27

Je n'ai pas Adblock mais un autre bloqueur de pub intégré dans Opéra sans que je l'aie installé.
Néanmoins je ne crois pas que ce bloqueur de pub soit la cause de la lenteur du forum car je n'ai rien changé et ça fonctionnait très bien, même avec lui.
De plus sur d'autres sites je n'ai pas de problème de lenteur alors que le bloqueur de pub est activé aussi.
Et ce matin je constate que les choses semblent revenues à la normale, plus de lenteurs ni sur mon forum ni ici.
Le mystère restera donc entier...
avatar

Pluktoo
*

Masculin
Messages : 43
Inscrit(e) le : 04/06/2008

Voir le profil de l'utilisateur http://noustous.forumpro.fr
Pluktoo a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pinguino le Lun 19 Oct 2020 - 17:20

@Pluktoo : les problèmes de chargement rencontrés notamment hier ne viennent pas de Adblock mais d'un problème que nous venons d'identifier au niveau des proxies. La vitesse de chargement devrait être de retour à la normale d'ici quelques minutes et de façon stable.
Pinguino

Pinguino
Adminactif
Adminactif

Masculin
Messages : 11863
Inscrit(e) le : 02/05/2004

Voir le profil de l'utilisateur
Pinguino a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pluktoo le Lun 19 Oct 2020 - 17:44

Merci beaucoup ! Smile
avatar

Pluktoo
*

Masculin
Messages : 43
Inscrit(e) le : 04/06/2008

Voir le profil de l'utilisateur http://noustous.forumpro.fr
Pluktoo a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Pinguino le Mar 20 Oct 2020 - 10:02

@Juux24 : avez-vous vu des améliorations concernant le temps de chargement du forum Broc'Art ?
Pinguino

Pinguino
Adminactif
Adminactif

Masculin
Messages : 11863
Inscrit(e) le : 02/05/2004

Voir le profil de l'utilisateur
Pinguino a été remercié(e) par l'auteur de ce sujet.

En cours Re: Forum qui rame et problème de chargement d'image

Message par Me00w Aujourd'hui à 13:20

Je me permet de répondre à sa place.
On a essayé de mettre en place l'attribut lazy ainsi que de mettre une image moins lourde pour la PA.
Mais visiblement ça ne résoud pas le problème, sur certains sujets c'est toujours très long à charger

EDIT : par exemple les images de ce sujet https://brocart.forumactif.com/t217-adelaide-kane prennent un temps interminable à charger alors que normalement la PA n'entre pas en ligne de compte vu qu'on est dans un sujet
Me00w

Me00w
Nouveau membre

Messages : 2
Inscrit(e) le : 04/08/2019

Voir le profil de l'utilisateur https://brocart.forumactif.com/
Me00w a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum