Problèmes d'affichage version web sur mobile

3 participants

Voir le sujet précédent Voir le sujet suivant Aller en bas

En cours Problèmes d'affichage version web sur mobile

Message par Destin01 Sam 14 Mai 2022 - 12:00

Détails techniques


Version du forum : ModernBB
Poste occupé : Administrateur
Navigateur(s) concerné(s) : Mozilla Firefox, Google Chrome
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Tous les utilisateurs
Lien du forum : https://v2-test-fauves.forumactif.com/

Description du problème

Bonjour à tous.tes !

Grâce à MlleAlys, je me suis rendue compte que le forum avait des soucis d'affichage en version mobile.

Premier problème, visible sur la capture d'écran : le rectangle blanc/gris sur tout le côté droit du forum.
Suivant son conseil, j'ai tenté d'activer et de désactiver les feuilles JS une à une sans que cela change quoi que ce soit.

Deuxième problème : l'application des couleurs sur la barre de navigation et sur le fond lorsqu'on ouvre l'application. J’ai bien modifié dans l'app mobile du panneau d'administration, mais elles ne s'appliquent pas (elles restent sur le bleu de base) ...

Si quelqu'un a une idée d'où peuvent venir ces bugs, je suis preneuse ! reflexion

Merci d'avance !

EDIT : grâce aux indications de chatigré, il se trouve que le souci vient de la version web sur mobile, et non de la version mobile !


Dernière édition par Destin01 le Dim 22 Mai 2022 - 13:19, édité 1 fois
avatar

Destin01
Nouveau membre

Messages : 19
Inscrit(e) le : 07/04/2013

Voir le profil de l'utilisateur https://v2-test-fauves.forumactif.com/
Destin01 a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par Destin01 Lun 16 Mai 2022 - 19:16

Up !
avatar

Destin01
Nouveau membre

Messages : 19
Inscrit(e) le : 07/04/2013

Voir le profil de l'utilisateur https://v2-test-fauves.forumactif.com/
Destin01 a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par chattigre Lun 16 Mai 2022 - 20:15

Bonjour,

Déjà, ce que vous montrez sur votre capture n'est pas la version mobile ^^ :
Problèmes d'affichage version web sur mobile Tfv2mo10
Ensuite, vos liens étant en noir, le menu de la version mobile est invisible en noir sur noir.

Pour corriger cela ajoutez à votre CSS :
Code:
#mpage-body-modern #header a {
  color: inherit;
}

De plus ce script devrait être désactivé sur mobile car le conteneur recherché n'existe pas et cela fait planter le reste du JS de la page :
Code:
$(function () {
  $.get($('#dernier_membre a[href^=\'/u\']') [0].href, function (d) {
    (a = $('#avatar_membre img', $(d))).length && $('#avatar_dernier_membre').html(a)
  })
});

Vous pouvez remplacer par ceci pour le désactiver sur la version mobile :
Code:
$(function () {
  if($("#mpage-body-modern").length) return;
  $.get($('#dernier_membre a[href^=\'/u\']') [0].href, function (d) {
    (a = $('#avatar_membre img', $(d))).length && $('#avatar_dernier_membre').html(a)
  })
});

Bonne journée
chattigre

chattigre
Membre habitué

Masculin
Messages : 1848
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par chattigre Lun 16 Mai 2022 - 20:20

Re,

Je réponds au 2e problème ^^

1- Tous les navigateurs ne sont pas compatibles avec ces paramètres et le paramétrage ne changera donc rien si le navigateur n'est pas compatible.

2- Si vous aviez déjà installé la PWA le navigateur peut se montrer très capricieux à changer les couleurs. Essayez de la retirer de votre mobile, de vider votre cache, de redémarrer votre téléphone et de remettre l'app PWA...
Si ça ne résout pas le problème pour vous vérifiez avec un autre utilisateur / appareil vierge de la PWA auparavant.
Vous concernant il faudra patienter quelques jours selon les navigateurs et/ou refaire la réinstallation avec un délai après désinstallation.
Cela dépend des appareils et des navigateurs, on n'y peut hélas pas grand chose.

Bonne journée
chattigre

chattigre
Membre habitué

Masculin
Messages : 1848
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par Destin01 Lun 16 Mai 2022 - 23:21

Bonjour et merci pour ta réponse !

Concernant les soucis de couleurs pour la toolbar et le fond, si c'est un problème d'OS/appareil capricieux, je ne vais effectivement pas me battre avec ça Rolling Eyes (j'ai désinstallé l'appli, il m'a mis à jour ... sur l'ancienne version du forum ahah).

Et à propos du script, j'ai changé pour celui que tu m'as donné. Mais sur la version application et navigateur téléphone (chrome pour Android du coup), le rectangle gris subsiste ... J'ai aussi ajouté ton code CSS.
Ce que je ne comprends pas, c'est que sur la précédente version du forum, il n'y avait pas de conflit avec le JS de la toolbar. Par contre, je l'ai recodé dans le CSS. Est-ce que ça pourrait avoir un rapport ? reflexion
avatar

Destin01
Nouveau membre

Messages : 19
Inscrit(e) le : 07/04/2013

Voir le profil de l'utilisateur https://v2-test-fauves.forumactif.com/
Destin01 a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par chattigre Lun 16 Mai 2022 - 23:38

Bonjour
Comme indiqué dans mon premier message, ce que je vois sur la capture de ton premier post c'est la version PC.
Affichée sur un mobile certes mais ce n'est pas la version mobile (voir ma capture) Smile
Sur mobile et avec la version mobile je ne rencontre pas de problème de carré gris que ce soit avant ou après correction.
En revanche l'erreur JS est logique puisque l'organisation de la version mobile est totalement différente.
De plus s'agit-il bien du forum https://v2-test-fauves.forumactif.com/ ?

Bonne journée
chattigre

chattigre
Membre habitué

Masculin
Messages : 1848
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par Chacha Dim 22 Mai 2022 - 9:35

Problèmes d'affichage version web sur mobile UmaslZ4Bonjour,

Attention, cela fait 6 jours que nous n'avons pas de nouvelles concernant votre demande, si vous ne voulez pas voir votre sujet déplacé à la corbeille, merci de poster dans les 24h qui suivent ce message.

Si votre sujet est résolu, merci d'éditer votre premier message et de cocher l'icône « résolu »
Chacha

Chacha
Modéractif
Modéractif

Masculin
Messages : 66694
Inscrit(e) le : 21/08/2010

Voir le profil de l'utilisateur https://forum.forumactif.com/
Chacha a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par Destin01 Dim 22 Mai 2022 - 12:30

Bonjour chattigre et avec mes excuses pour le délai de réponse ! Le sujet est toujours d'actu !

Alors oui, il s'agit bien de l'adresse https://v2-test-fauves.forumactif.com/ !

Je vois ce que tu veux dire pour la version mobile. Normalement, je devrais avoir un petit carré à droite qui me permettrait de choisir la "version mobile" (comme tu as sur ton screen). Or, là, je n'arrive pas à y accéder (le carré gris est à ce niveau sur toutes les pages). J'ai vidé le cache de mon navigateur de téléphone etc., mais cela me ramène toujours à cette version "ordinateur" (qui ne l'est pas vraiment).

J'ai donc soit :
- la version application (mon tout premier screen)
- la version navigateur (et comme tu peux le voir sur ces deux images : https://zupimages.net/up/22/20/vwxu.jpg et https://zupimages.net/up/22/20/n6fu.jpg, elle est "décochée"). En revanche, si je coche "version pour ordinateur", le carré gris disparaît ... Mais ça ne s'applique pas sur l'application de mon téléphone.

Je ne sais pas si je suis très claire Neutral
avatar

Destin01
Nouveau membre

Messages : 19
Inscrit(e) le : 07/04/2013

Voir le profil de l'utilisateur https://v2-test-fauves.forumactif.com/
Destin01 a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par chattigre Dim 22 Mai 2022 - 12:39

Bonjour,

En version "ordinateur", sur mobile, tu dois avoir un lien "Version mobile" dans le bas de page à côté des liens de Copyrights et autres.
Pour un utilisateur lambda, il devrait arriver directement sur la "vraie" version mobile...

Les paramètres de ton navigateur ne sont-ils pas configurés pour afficher par défaut la version "ordinateur" des sites ?
Il doit y avoir un paramètre site par site dans la barre d'outils pour passer d'une version à l'autre indépendamment de FA.
Si on force par le navigateur l'affichage de la version PC, la version mobile n'est pas proposée en bas de page, car notre appareil n'est pas "un mobile qui veut la version PC" mais "un PC"...

Quant à la version "appli", elle ne change rien à l'affichage du forum lui-même par rapport à l'affichage direct dans le navigateur.

Bonne journée
chattigre

chattigre
Membre habitué

Masculin
Messages : 1848
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par Destin01 Dim 22 Mai 2022 - 13:22

Rebonjour !

Je pense que je n'avais tout simplement pas compris la différence entre version mobile et version web SUR mobile ...
J'ai pu accéder à la version mobile en allant cliquer sur le lien en bas de page et effectivement, tout roule en version mobile.
C'est donc bien la version web sur mobile qui a ce souci de carré gris (de fait, j'ai modifié le titre du post d'origine et fait un edit).

Le souci est donc le suivant, puisque nous utilisons la version web : d'où vient ce carré gris qui remplace la toolbar et comment le régler ?

Merci d'avance !
avatar

Destin01
Nouveau membre

Messages : 19
Inscrit(e) le : 07/04/2013

Voir le profil de l'utilisateur https://v2-test-fauves.forumactif.com/
Destin01 a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par chattigre Dim 22 Mai 2022 - 13:45

chattigre a écrit:Ce script devrait être désactivé sur mobile car le conteneur recherché n'existe pas et cela fait planter le reste du JS de la page :
Code:
$(function () {
  $.get($('#dernier_membre a[href^=\'/u\']') [0].href, function (d) {
    (a = $('#avatar_membre img', $(d))).length && $('#avatar_dernier_membre').html(a)
  })
});

Vous pouvez remplacer par ceci pour le désactiver sur la version mobile :
Code:
$(function () {
  if($("#mpage-body-modern").length) return;
  $.get($('#dernier_membre a[href^=\'/u\']') [0].href, function (d) {
    (a = $('#avatar_membre img', $(d))).length && $('#avatar_dernier_membre').html(a)
  })
});

Bonne journée

Si tu pouvais déjà mettre en œuvre cette modification que je récupère un menu mobile fonctionnel, ce sera bien plus pratique pour tester Very Happy

Merci ^^
chattigre

chattigre
Membre habitué

Masculin
Messages : 1848
Inscrit(e) le : 17/04/2019

Voir le profil de l'utilisateur https://test1-chattigre.forumactif.fr
chattigre a été remercié(e) par l'auteur de ce sujet.

En cours Re: Problèmes d'affichage version web sur mobile

Message par Destin01 Dim 22 Mai 2022 - 13:58

chattigre a écrit:

Si tu pouvais déjà mettre en œuvre cette modification que je récupère un menu mobile fonctionnel, ce sera bien plus pratique pour tester Very Happy

Merci ^^

Oh purée désolée, je m'étais trompée de feuille JS ... -_-
J'ai fait la modif au bon endroit normalement !
avatar

Destin01
Nouveau membre

Messages : 19
Inscrit(e) le : 07/04/2013

Voir le profil de l'utilisateur https://v2-test-fauves.forumactif.com/
Destin01 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum