Problème avec code image reactive

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 17:09

Bonjour,

Après plusieurs jours de recherche sur le forum, je me décide à poster mon problème.

Alors, comme dit dans le titre, je viens de refaire mon design, et j'ai mis une bannière sur laquelle je voudrais mettre des liens vers plusieurs pages du forum.

J'ai trouvé un tuto, pour faire une image réactive.

N'y connaissant pas grand chose, j'ai essayer de me debrouiller en j'en suis arrivée à ça :

Code:
<img usemap="#index" src="http://www.picdo.net/fichiers/2010/11/2/cce691fb-2b89-4e4b-931c-7d328f49d9ab_bann-3.png" width="750" height="350" border="0">
<map name="index">
<area shape="rect" title="Réglement" coords="19.65,5.47,22.79,6.17" href=http://graphparadise.forumgratuit.org/reglement-f1/reglement-gp-t1.htm">
<area shape="rect" title="Commandes" coords="19.58,6.60,23.35,7.16" href=http://graphparadise.forumgratuit.org/commandes-f5/">
<area shape="rect" title="Tutoriels" coords="19.33,7.55,22.65,8.15" href="http://graphparadise.forumgratuit.org/tutoriels-f13/">
<area shape="rect" title="Recrutement" coords="19.40,8.47,23.67,9.17" href="http://graphparadise.forumgratuit.org/recrutement-f4/">
<area shape="rect" title="Galeries" coords="19.47,9.56,22.26,10.23" href="http://graphparadise.forumgratuit.org/galeries-f10/">
<area shape="rect" title="SOTW" coords="14.15,1.76,18.41,2.40" href="http://graphparadise.forumgratuit.org/sotw-f32/">
</map>

Comme il n'y avait pas d'indication sur le tuto sur l'emplacement ou mettre ce code, je l'ai coller dans le template, index body.
Malheureusement, ça ne fonctionne pas Sad

Donc, de une, je ne sais pas si mon code est bon et de deux, si je l'ai mis à la bonne place Interrog

Une âme généreuse pourrait-elle me venir en aide ?

Lien vers mon fofo : http://graphparadise.forumgratuit.org/

Merci d'avance,
Jess.


Dernière édition par Oo-jess-oO le Lun 15 Nov 2010 - 9:58, édité 1 fois

Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Arlem le Mer 3 Nov 2010 - 18:17

Bonsoir,

A première vue ton code n'a pas l'air faux et de toute façon si tu as suivi le tutoriel à la lettre il n'y a pas de raisons que ça ne fonctionne pas. Smile
Pour le mettre à la place de ta bannière, dans le Overall_header, cherche et remplace par ton code ceci :
Code:
<a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a>


Arlem
+ Hyperactif +

Messages : 2550
Inscrit(e) le : 30/06/2009

Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 18:44

Bonsoir,

J'ai donc retiré le code que tu m'as donné et je l'ai remplacé par celui donné dans mon premier message et ... ben non toujours pas !! Sad

Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Arlem le Mer 3 Nov 2010 - 18:57

L'image ne se met pas au bon endroit où le code ne fonctionne pas ?

Arlem
+ Hyperactif +

Messages : 2550
Inscrit(e) le : 30/06/2009

Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 19:02

L'image est au bon endroit mais toujours pas de liens dessus.


Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Arlem le Mer 3 Nov 2010 - 19:35

Essaie en mettant des coordonnées sans virgules, seulement avec des nombres entiers.
coords="19.65,5.47,22.79,6.17" => coords="19,5,23,6"

Arlem
+ Hyperactif +

Messages : 2550
Inscrit(e) le : 30/06/2009

Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 19:52

fait et toujours pas, je ne comprends pas

je ne vois pas ou peut etre l'erreur !!

Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Arlem le Mer 3 Nov 2010 - 20:17

Tu as oublié deux ouvertures de guillemets après les premiers href mais apparemment ça ne règle toujours pas le problème...

Arlem
+ Hyperactif +

Messages : 2550
Inscrit(e) le : 30/06/2009

Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 20:27

Hinus a écrit:
Code:
<a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a>

Il fallait bien que je l'enlève ça?? et que je mette mon code à la place ?

Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Problème avec code image reactive

Message par Scoubifitz le Mer 3 Nov 2010 - 20:32

bonsoir,

le code avec l'emplacement correct de vos liens ...

Code:
<img usemap="#index"
 src="http://www.picdo.net/fichiers/2010/11/2/cce691fb-2b89-4e4b-931c-7d328f49d9ab_bann-3.png"
 border="0" height="350" width="750">
<map name="index">
<area shape="rect" title="Réglement"
 coords="555,155,650,180"
 href="http://graphparadise.forumgratuit.org/reglement-f1/reglement-gp-t1.htm%22">
<area shape="rect" title="Commandes"
 coords="555,180,655,205"
 href="http://graphparadise.forumgratuit.org/commandes-f5/%22">
<area shape="rect" title="Tutoriels"
 coords="555,210,640,235"
 href="http://graphparadise.forumgratuit.org/tutoriels-f13/">
<area shape="rect" title="Recrutement"
 coords="555,240,670,265"
 href="http://graphparadise.forumgratuit.org/recrutement-f4/">
<area shape="rect" title="Galeries"
 coords="555,270,630,295"
 href="http://graphparadise.forumgratuit.org/galeries-f10/">
<area shape="rect" title="SOTW" coords="430,50,492,68"
 href="http://graphparadise.forumgratuit.org/sotw-f32/">
</map>

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 20:42

Bonsoir,

Merci mais je dois vraiment avoir un pb, car ça ne fonctionne toujours pas Sad

Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Scoubifitz le Mer 3 Nov 2010 - 21:07

je viens de voir le souci ...

dans le Template "overall header" , repérez cette partie :

<!-- BEGIN switch_logo_center -->
<a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a>

<br />
<!-- END switch_logo_center -->

et remplacez le par :

<!-- BEGIN switch_logo_center -->

<img usemap="#index"
src="http://www.picdo.net/fichiers/2010/11/2/cce691fb-2b89-4e4b-931c-7d328f49d9ab_bann-3.png"
border="0" height="350" width="750">
<map name="index">
<area shape="rect" title="Réglement"
coords="555,155,650,180"
href="http://graphparadise.forumgratuit.org/reglement-f1/reglement-gp-t1.htm%22">
<area shape="rect" title="Commandes"
coords="555,180,655,205"
href="http://graphparadise.forumgratuit.org/commandes-f5/%22">
<area shape="rect" title="Tutoriels"
coords="555,210,640,235"
href="http://graphparadise.forumgratuit.org/tutoriels-f13/">
<area shape="rect" title="Recrutement"
coords="555,240,670,265"
href="http://graphparadise.forumgratuit.org/recrutement-f4/">
<area shape="rect" title="Galeries"
coords="555,270,630,295"
href="http://graphparadise.forumgratuit.org/galeries-f10/">
<area shape="rect" title="SOTW" coords="430,50,492,68"
href="http://graphparadise.forumgratuit.org/sotw-f32/">
</map>

<br />
<!-- END switch_logo_center -->

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 21:29

Alors il y a du mieux, sauf que maintenant quand je clique sur les liens de mon image, ça me marque :

You can return to the index

Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Scoubifitz le Mer 3 Nov 2010 - 21:35

ma faute ...

je n'ai pas vérifié les liens ... il reste des erreurs dans "Réglement" et "commandes" ( %22 )...

<!-- BEGIN switch_logo_center -->

<img usemap="#index"
src="http://www.picdo.net/fichiers/2010/11/2/cce691fb-2b89-4e4b-931c-7d328f49d9ab_bann-3.png"
border="0" height="350" width="750">
<map name="index">
<area shape="rect" title="Réglement"
coords="555,155,650,180"
href="http://graphparadise.forumgratuit.org/reglement-f1/reglement-gp-t1.htm">
<area shape="rect" title="Commandes"
coords="555,180,655,205"
href="http://graphparadise.forumgratuit.org/commandes-f5/">
<area shape="rect" title="Tutoriels"
coords="555,210,640,235"
href="http://graphparadise.forumgratuit.org/tutoriels-f13/">
<area shape="rect" title="Recrutement"
coords="555,240,670,265"
href="http://graphparadise.forumgratuit.org/recrutement-f4/">
<area shape="rect" title="Galeries"
coords="555,270,630,295"
href="http://graphparadise.forumgratuit.org/galeries-f10/">
<area shape="rect" title="SOTW" coords="430,50,492,68"
href="http://graphparadise.forumgratuit.org/sotw-f32/">
</map>


<!-- END switch_logo_center -->

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 21:40

hannnnnnnn merciiiiiiiiiii Very Happy

j'avoues que je commençais à desesperer !!

Merci beaucoup pour ces precieux codes ^^

maintenant que ça fonctionne vais potasser dessus histoire de comprendre Wink

Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Scoubifitz le Mer 3 Nov 2010 - 21:44

petit plus ...

les coords="555,180,655,205" sont en pixels ...

555,180 de la gauche et du haut de l'image pour commencer

le rectangle de lien ( shape="rect" ) ; 655,205 pour finir le rectangle ...

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 21:48

ok merci et comment on trouve ces coordonnées?

Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Scoubifitz le Mer 3 Nov 2010 - 22:05

j'ouvre l'image avec Photofiltre ,

et je place ma sélection à l'endroit voulu ...

et en bas , sur la barre de description se trouvent les valeurs du cadre ...


Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 22:09

hannnnnnn ben oui forcement, n'ayant pas fait ça, je ne pouvais pas trouver les bonnes coordonnées.

Merci beaucoup pour ces renseignements.

Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Scoubifitz le Mer 3 Nov 2010 - 22:11

si vous n'avez pas d'autres questions ...

résolu ?

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Oo-jess-oO le Mer 3 Nov 2010 - 22:12

ouép resoluuuu ^^


Oo-jess-oO
Nouveau membre

Messages : 14
Inscrit(e) le : 03/11/2010

http://graphparadise.forumgratuit.org/
Oo-jess-oO a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Invité le Ven 5 Nov 2010 - 23:24

Je me permet de "m'incruster" puisque le sujet est résolu. J'ai un header de fond, pour l'installer j'ai donc du insérer un code CSS et donc considérer cette image comme une image de fond. Je voudrais mettre le code de mon image réactive mais je ne sais pas où le mettre. Quelqu'un pourrait-il m'aider ?

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Arlem le Ven 5 Nov 2010 - 23:29

Bonsoir,

Créé un nouveau sujet, ce sera plus facile pour t'aider, surtout que ton cas n'a pas l'air très simple. Smile

Arlem
+ Hyperactif +

Messages : 2550
Inscrit(e) le : 30/06/2009

Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème avec code image reactive

Message par Invité le Sam 6 Nov 2010 - 21:46

Ok, merci du conseil Hinus!!

Invité
Invité


Invité a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum