Affichage d'un post : décalé vers le bas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Affichage d'un post : décalé vers le bas

Message par Pouss' le Mer 13 Avr 2011 - 22:40

Bonsoir Smile

Alors voilà, cela fait longtemps que j'avais remarqué ce problème, mais jusque là je n'y avais pas vraiment porté attention. Lorsque je clique pour accéder au dernier message posté sur l'accueil, ou même lorsque je clique sur un lien qui doit me mener à un message précis dans un sujet (par exemple le 3ème message du sujet), l'affichage est mauvais : au lieu d'arriver avec le haut du message sur le bord supérieur de mon navigateur comme ceci :



j'arrive avec le milieu de mon message sur le bord supérieur de mon navigateur, ce qui fait que je dois chaque fois remonter pour pouvoir lire.



Ça ne me le fait pas sur d'autres forums, donc je ne sais pas si c'est à cause d'un code dans mon CSS, ou d'un template (car j'en ai modifié plusieurs, mais je ne sais pas lequel pourrait être responsable). J'utilise Mozilla pour tous les forums que j'utilise.

Merci pour votre aide en tout cas !


Dernière édition par Pouss' le Jeu 14 Avr 2011 - 0:04, édité 1 fois

Pouss'
**

Messages : 50
Inscrit(e) le : 01/05/2009

http://angels-breaking-up.forumactif.com/
Pouss' a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Affichage d'un post : décalé vers le bas

Message par Scipion le Mer 13 Avr 2011 - 23:36

Bonsoir !

Pour déterminer l'origine de ce problème, je vous invite à extraire totalement votre feuille CSS et de réinstaller un à un les différents codes de son contenu, sans oublier de valider et de visualiser à chaque fois.

Cordialement


Scipion
+ Hyperactif +

Masculin
Messages : 8655
Inscrit(e) le : 03/02/2010

http://forum.forumactif.com/
Scipion a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Affichage d'un post : décalé vers le bas

Message par Pouss' le Jeu 14 Avr 2011 - 0:03

Merci pour ce conseil. A peine commencé, que je peux déjà dire que ça ne vient pas du CSS. Sans CSS personnalisé du tout, ça me le fait toujours... serait-ce le template des posts ? Ou bien celui concernant le profil ? Je remarque que cela s'ajuste exactement au dessus du pseudo du membre qui a posté le message...

...

Après recherche dans le template cité, celui concernant le profil, j'ai trouvé : ceci figurait au niveau du pseudo du membre, et comme j'ai déplacé ce dernier pour le mettre en dessous de l'avatar, j'ai déplacé ce qui mène au post également, donc il me le mettait au niveau du pseudo du membre.

Code:
<a name="{postrow.displayed.U_POST_ID}"></a>

En le déplaçant juste avant ce qui représente l'avatar dans le template, il me mène au niveau de l'avatar quand je vais voir un sujet Smile

Merci pour votre aide, car ça m'a permis de trouver la solution !

Pouss'
**

Messages : 50
Inscrit(e) le : 01/05/2009

http://angels-breaking-up.forumactif.com/
Pouss' a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum