Je craque... fond blanc sur iFrame avant fond noir

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Je craque... fond blanc sur iFrame avant fond noir

Message par renaudbb le Mar 21 Juin 2011 - 13:43

Bonjour à tous, après avoir parcouru les forums et essayé des solutions, je désespère.

Voici mon souci : mon forum a un fond gris (#282828). Je l'invoque depuis un site web via une iFrame.

Avant d'afficher le forum, mon iFrame affiche un grand rectangle blanc. J'ai essayé : de passer tous les fonds en gris dans le paramétrage, de mettre "background-color:#282828" avec et sans " autour de la valeur, d'utiliser "allowtransparency:true", et qq autres trucs. J'ai aussi essayé de mettre une image de fond grise.

Le code est <iframe background-color:"#282828" width="800" height="1000" frameborder="0" marginheight="0" marginwidth="0" src="http://adrale.forumgratuit.org"></iframe>

et le forum est ici : http://adrale.fr/membres-forum.html

Heeeelp !
Merci

J'avoue que tout coup de main est bienvenu.


Dernière édition par renaudbb le Mar 21 Juin 2011 - 20:10, édité 1 fois

renaudbb
Nouveau membre

Messages : 9
Inscrit(e) le : 21/06/2011

http://iso1965.fr www.rb2-conseil.com
renaudbb a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par SoraNoHime le Mar 21 Juin 2011 - 14:36

Bonjour,

Personnellement, je ne vois pas de tour blanc sur votre forum, mais cela est peut être du au fait que j'utilise forefox et vous un autre navigateur. Ou alors j'ai mal compris où se trouve votre fond, et je n'ai pas vu le problème.

Pourriez-vous me préciser ceci en faisant un scan du souci.

Cordialement.

SoraNoHime
+ Hyperactif +

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par Lord Hinateur le Mar 21 Juin 2011 - 14:56

Apparemment, il appel sur son site (dont nous n’avons pas l'adresse, soit dit en passant) et le problème qu'il rencontre c'est l'iframe se "remplit" de blanc puis affiche enfin le forum. J'ai bon ?

À vu de nez, l'iframe prend son temps pour charger le forum et met donc une couleur par défaut (de là à savoir si c'est modifiable...)

Lord Hinateur
Nouveau membre

Masculin
Messages : 24
Inscrit(e) le : 19/06/2011

http://z-corps2022.rpg-board.net/
Lord Hinateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par renaudbb le Mar 21 Juin 2011 - 14:57

En effet, je m'aperçois que le problème n'existe pas sur FF !

Mais je ne peux pas faire un scan : c'est un phénomène qui se passe très rapidement.

An fait, sous Chrome ou Safari (je suis sur mac) et IE sous Windows, avant que le forum ne s'affiche, l'iFrame s'initialise comme un grand rectangle blanc.

Je suppose que FF attend pour afficher l'iFrame d'avoir chargé (ou compris ou je ne sais quoi) le fond définitif avant d'afficher quoi que ce soit.

renaudbb
Nouveau membre

Messages : 9
Inscrit(e) le : 21/06/2011

http://iso1965.fr www.rb2-conseil.com
renaudbb a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par renaudbb le Mar 21 Juin 2011 - 14:57

@Lord Hinateur a écrit:Apparemment, il appel sur son site (dont nous n’avons pas l'adresse, soit dit en passant) et le problème qu'il rencontre c'est l'iframe se "remplit" de blanc puis affiche enfin le forum. J'ai bon ?

À vu de nez, l'iframe prend son temps pour charger le forum et met donc une couleur par défaut (de là à savoir si c'est modifiable...)


Euh, comment ça pas l'adresse ? elle est dans mon message : http://adrale.fr/membres-forum.html


renaudbb
Nouveau membre

Messages : 9
Inscrit(e) le : 21/06/2011

http://iso1965.fr www.rb2-conseil.com
renaudbb a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par Lord Hinateur le Mar 21 Juin 2011 - 15:03

@renaudbb a écrit:
@Lord Hinateur a écrit:Apparemment, il appel sur son site (dont nous n’avons pas l'adresse, soit dit en passant) et le problème qu'il rencontre c'est l'iframe se "remplit" de blanc puis affiche enfin le forum. J'ai bon ?

À vu de nez, l'iframe prend son temps pour charger le forum et met donc une couleur par défaut (de là à savoir si c'est modifiable...)


Euh, comment ça pas l'adresse ? elle est dans mon message : http://adrale.fr/membres-forum.html


Au temps pour moi, je vous avait mal comprit ^^. Tournant sous firefox également (donc ne voyant pas le phénomène), j'en ait conclus que l'adresse que vous nous donniez était celle de votre forum (et non de votre site, comme c'est effectivement le cas).

Après visualisation sous chrome, le phénomène est effectivement flagrant. Je vais regarder dans mes livres d'HTML si je trouve quelque chose.

Lord Hinateur
Nouveau membre

Masculin
Messages : 24
Inscrit(e) le : 19/06/2011

http://z-corps2022.rpg-board.net/
Lord Hinateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par SoraNoHime le Mar 21 Juin 2011 - 15:08

pourquoi ne pas insérez votre background par la css

Code:
body {background-color:#282828;}

SoraNoHime
+ Hyperactif +

Féminin
Messages : 6218
Inscrit(e) le : 10/06/2010

http://fanasiacodes.bbfr.net/
SoraNoHime a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par Lord Hinateur le Mar 21 Juin 2011 - 15:11

J'ai probablement quelque chose qui correspond à votre cas:

ajouter ceci dans votre balise <iframe>:
Code:
style="visibility:hidden;" onload="this.style.visibility = 'visible';"

Lord Hinateur
Nouveau membre

Masculin
Messages : 24
Inscrit(e) le : 19/06/2011

http://z-corps2022.rpg-board.net/
Lord Hinateur a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par renaudbb le Mar 21 Juin 2011 - 20:08

Macema a écrit:pourquoi ne pas insérez votre background par la css

Code:
body {background-color:#282828;}

oups erreur je voualis quoter l'autre message... je ne sais pas comment on supprime !

renaudbb
Nouveau membre

Messages : 9
Inscrit(e) le : 21/06/2011

http://iso1965.fr www.rb2-conseil.com
renaudbb a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par renaudbb le Mar 21 Juin 2011 - 20:09

@Lord Hinateur a écrit:J'ai probablement quelque chose qui correspond à votre cas:

ajouter ceci dans votre balise <iframe>:
Code:
style="visibility:hidden;" onload="this.style.visibility = 'visible';"

CA MARCHE !!!!! NICKEL !!!

renaudbb
Nouveau membre

Messages : 9
Inscrit(e) le : 21/06/2011

http://iso1965.fr www.rb2-conseil.com
renaudbb a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Je craque... fond blanc sur iFrame avant fond noir

Message par Lord Hinateur le Mar 21 Juin 2011 - 22:37

CSS book rule every time Cool

Au plaisir de t'avoir aidé, n'oublie pas de mettre ton sujet en résolu Wink

Lord Hinateur
Nouveau membre

Masculin
Messages : 24
Inscrit(e) le : 19/06/2011

http://z-corps2022.rpg-board.net/
Lord Hinateur a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum