Un PhP Raiders pour mon Forum

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Un PhP Raiders pour mon Forum

Message par HoShiMayatan le Jeu 7 Juil 2011 - 15:47

Rappel du premier message :

Bonjour,
J'ai récemment tenté l'expérience d'installer un PhP pour mon forum de légion (il s'agit d'un calendrier ou on s'inscrit pour des sorties etc)

N'ayant aucunes connaissances dans le domaine je rencontre beaucoup de difficultés, en tout point, pour la personnalisation notamment (comment faire un template, pour l'installer etc), et à des fins pratiques, je ne sais pas comment faire en sorte que le PhP garde les logs du forum : c'est à dire qu'un membre connecté au forum n'ai pas besoin de se réinscrire en allant sur le php.
D'ailleurs je ne sais pas non plus comment faire apparaitre l'adresse du php dans le menu de mon forum.

J'ai conscience que ce topic regroupe beaucoup de problèmes et si il n'est pas à la bonne place je le déplacerai.

Merci de bien vouloir m'aider, si cela est possible Embarassed

Ps :
L'adresse de mon forum : http://www.legion-madeyes.com/
Ladresse du PhP installé et non personnalisé : http://aion-legion-madeyes.com/phpraid/index.php
Dossier zip phpraiders : Phpraiders v1.0.8a
Pack image : Aion pack


Dernière édition par HoShiMayatan le Dim 10 Juil 2011 - 20:29, édité 2 fois

HoShiMayatan
***

Féminin
Messages : 128
Inscrit(e) le : 29/10/2008

http://madeyes.forumclan.com/
HoShiMayatan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par HoShiMayatan le Ven 8 Juil 2011 - 23:27

Etana a écrit:Vous avez uploadé quelque chose par l'ftp ?


Cordialement.

Oui je l'ai effacé ensuite j'esseye tout ce que je peux T.T

EDIt
le souci est survenu quand j'ai executer le fichier install de cette autre jeu sur phpmyadmin
comment annuler cela ?

HoShiMayatan
***

Féminin
Messages : 128
Inscrit(e) le : 29/10/2008

http://madeyes.forumclan.com/
HoShiMayatan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par Ea le Ven 8 Juil 2011 - 23:46

En cherchant dans les sources, ça à l'air d'être un soucis quand la méthode d'identification n'est pas choisie.

Donc probablement que les configurations ont disparues en installation le truc rune, il faudrait voir dans la table " phpraider_config " si dans l'onglet " Afficher " il y a bien phpraider comme valeur pour authentication ( sinon il faut l'éditer et le mettre ).


Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par HoShiMayatan le Ven 8 Juil 2011 - 23:55

Etana a écrit:En cherchant dans les sources, ça à l'air d'être un soucis quand la méthode d'identification n'est pas choisie.

Donc probablement que les configurations ont disparues en installation le truc rune, il faudrait voir dans la table " phpraider_config " si dans l'onglet " Afficher " il y a bien phpraider comme valeur pour authentication ( sinon il faut l'éditer et le mettre ).


Cordialement.
Merci (Etana Save Me ! XD)

Bon le fait qu'il n'y ai plus le blanc me rassure déja meme si ce n'est pas encore ça ... :/
regardez :s

http://aion-legion-madeyes.com/phpraid/index.php

HoShiMayatan
***

Féminin
Messages : 128
Inscrit(e) le : 29/10/2008

http://madeyes.forumclan.com/
HoShiMayatan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par Ea le Sam 9 Juil 2011 - 0:01

Au même endroit il y a le paramètre template, il faudrait surement le mettre à default ( ou bien au nom du template qu'il faudrait ).

Edit : il y a le paramètre "site_url" qu'il faudrait mettre à http://aion-legion-madeyes.com/phpraid/ probablement.


Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par HoShiMayatan le Sam 9 Juil 2011 - 0:12

Etana a écrit:Au même endroit il y a le paramètre template, il faudrait surement le mettre à default ( ou bien au nom du template qu'il faudrait ).

Edit : il y a le paramètre "site_url" qu'il faudrait mettre à http://aion-legion-madeyes.com/phpraid/ probablement.


Cordialement.
(OWI XD)

Merci merci (j'étais vraiment en déprime après tant d'acharnement avoir tout réduit en pièce ... ><)
Vraiment merci.

Je me remet à l'installation du jeu je vais bien finir par y arriver Mad

Edit :

J'ai un nouveau souci de log > je n'arrive plus à me conecter au phpraider bien que je sois connectée au forum.

HoShiMayatan
***

Féminin
Messages : 128
Inscrit(e) le : 29/10/2008

http://madeyes.forumclan.com/
HoShiMayatan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par Ea le Sam 9 Juil 2011 - 0:45

Il devrait vous suffire de vous déconnecter / reconnecter au forum.


Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par HoShiMayatan le Sam 9 Juil 2011 - 1:03

Je n'arrète pas de le faire justement c'est ce qui me pose problème Sad

HoShiMayatan
***

Féminin
Messages : 128
Inscrit(e) le : 29/10/2008

http://madeyes.forumclan.com/
HoShiMayatan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par Ea le Sam 9 Juil 2011 - 1:09

Dans phpmyadmin > phpraider_profile > afficher, il y a bien un compte avec un profile_id à 1 ?

Edit : ça doit être bon vu que le message "La bienvenue sur le PhpRaiders de la Légion Madeyes ! Il est encore en construction et non fonctionnel pour le moment, il faudra patienter avant de l'utiliser. " doit être écrit avec ce compte là.

Mais donc vous êtes connectée puis déconnectée et ainsi de suite ? Ou jamais connectée ?



Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par HoShiMayatan le Sam 9 Juil 2011 - 1:22

Etana a écrit:Dans phpmyadmin > phpraider_profile > afficher, il y a bien un compte avec un profile_id à 1 ?

Edit : ça doit être bon vu que le message "La bienvenue sur le PhpRaiders de la Légion Madeyes ! Il est encore en construction et non fonctionnel pour le moment, il faudra patienter avant de l'utiliser. " doit être écrit avec ce compte là.

Mais donc vous êtes connectée puis déconnectée et ainsi de suite ? Ou jamais connectée ?



Cordialement.

Oui j'ai aussi vu que le pseudo du message était comme celui du forum. Quand j'ai corrigé le blanc sur phpmyadmin j'étais connectée au php en tant qu'admin, j'ai voulu me déco voir si le pseudo changeait mais impossible de me reconnecter au phpraider.

Vous aviez noter ce lien précédement http://aion-legion-madeyes.com/phpraid/index.php?option=com_members
Grace a lui avant le blanc phpmyadmin, j'avais une case de log en cliquant sur ce lien ("connectez vous pour accéder a cette page); Hors la il n'y a meme plus cette possibilité :s


EDIT

Il y a bien un réel souci pour se log au php.
J'ai remis les anciens fichiers (en retirant les fa_phpraider que vous m'aviez donné).

Le résultat c'est qu'on ne passe plus par le fofo pour se log, mais quand on veut se log directement au php il n'y a toujours aucunes cases pour écrire son pseudo et son mot de passe. est-ce du au fichier install que j'avais mis sur phpmyadmin et qui avaitfait du sphpraiders une page blanche ? Comment réparer cela ?
http://aion-legion-madeyes.com/phpraid/index.php?option=com_login&task=login

Merci pour votre aide.

HoShiMayatan
***

Féminin
Messages : 128
Inscrit(e) le : 29/10/2008

http://madeyes.forumclan.com/
HoShiMayatan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par HoShiMayatan le Dim 10 Juil 2011 - 6:27

(up)
Bonsoir,
Vraiment merci pour tout ce travail que vous fournissez,
je me sens bien inutile de ne pas pouvoir en faire autant Sad

Il me reste la partie concernant l'installation du pack de jeu, depuis le dossier Runes j'ai un peu peur de tout faire sauter x) J'ai néanmoins pu avancer un peu, il semblerait que le pack aion soit partiellement installé ...

Néanmoins sur phpmyadmin il y a toujours un message d'erreur quand j'execute le fichier install.
Sur le phpraider tout n'est pas encore en place même si beaucoup plus de choses fonctionnent ^^


Agrandir cette imageRéduire cette image Cliquez ici pour la voir à sa taille originale.


Par exemple les icones classes n'apparaissent pas sur le phpraider (alors qu'elles sont bien dans le dossier).
Pour ce qui est des attributs j'ai pu trouver la réponse entre temps ^^

-----

J'ai ensuite un autre souci, quand je crée un raid, j'ai un message d'erreur en accueil,
le raid n'est pas visible sur le calendrier il y a ça à la place (accueil):

Agrandir cette imageRéduire cette image Cliquez ici pour la voir à sa taille originale.


Qu'est ce que ça signifie ?

A nouveau merci Smile


EDIT :

J'en reviens aux logs, désolée, cela ne fonctionne pas ou avec beaucoup trop d'insistance ...
je redemanderai à d'autre membres.

Un membre connecté au forum qui clik sur le lien Raids n'est pas connecté au phpraider bien que le script lui ai créé un compte avec son pseudo. Quand le membre clik sur "se connecter" dans phpraider il est renvoyé au forum puis il reclik sur Raids et est toujours invité dur le phpraider .. il reclik donc sur se connecter pour se log phpraider mais est renvoyé au forum... et ainsi de suite sans jamais pouvoir se log au phpraider.

La demande était qu'un membre n'ai pas à se relog au phpraider. Le script a bien joué son role en créant le compte avec le pseudo du forum, mais il ne fonctionne pas quand il s'agit de log le membre au phpraider en passant par le lien Raids.

Est-ce qu'il manque quelque chose ? Au lien "Raids" par exemple ?

Si il n'est pas possible de faire se connecter un membre au phpraider via le forum, j'ai une variante qui m'interresserait aussi et serai peu être plus accessible : toujours garder la création automatique du compte phpraider avec pseudo du forum et mdp, mais faire en sorte que pour se connecter, le phpraider cesse de nous renvoyer sur le forum, pour qu'on puisse se log avec le passe créé par le script sur le phpraider.

J'espère que je me suis bien exprimée Embarassed

A nouveau merci pour le temps que vous passez sur ce souci.

HoShiMayatan
***

Féminin
Messages : 128
Inscrit(e) le : 29/10/2008

http://madeyes.forumclan.com/
HoShiMayatan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par Ea le Dim 10 Juil 2011 - 13:03

Il devrait juste falloir se déconnecter puis reconnecter.

Vu que des membres étaient sur le forum pendant qu'il n'y avait plus les fichiers fa_connect.php et fa_unconnect.php alors qu'il y avait toujours le script faisant la connexion sur le forum, ils ont du etre "cru" connecté sur le forum mais en fait ne le sont pas vraiment.

Il devrait donc suffire d'une seule fois se déconnecter/reconnecter pour que ce soit bon.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par HoShiMayatan le Dim 10 Juil 2011 - 20:04

Bonsoir,
je viens de faire un nouveau teste avec un membre, j'ai assisté en direct à la création de son compte sur phpraider (en actualisant la page) pendant que lui déconnectait/reconnectait. Il a fallu déco reco 2 fois pour que le compte se créé et se déconnecter des 2 sites puis reconnecter au fofo > phpraider pour qu'il soit reconnu avec son pseudo forum.

C'était avant le code que vous m'avez donné
Code:
setcookie('password', md5("start"), time() + 92629743);
Je suis en train de le mettre et je ferais un nouveau teste ^^
Cordialement.


_______________

Pour les images je ne comprend pas :

Etana a écrit:
@HoShiMayatan a écrit:Ben c'est ça que je ne comprend pas, les images existent bien au bon endroit avec le nom exacte des classes sur le phpraider, mais pas d'images qui s'affichent.
Clerc et sorcier n'y sont pas en tout cas :
- http://aion-legion-madeyes.com/phpraid/games/aionetana/images/class/clerc.png
- http://aion-legion-madeyes.com/phpraid/games/aionetana/images/class/sorcier.png

Quand je suis via ftp jusqu'au dossier .../images/class/ les images de toutes les classes sont bien en place :



Je ne regarde peu etre pas au bon endroit ?

_______________

Autre remarque aussi : un membre connecté au phpraider ne vois absolument rien a part le bouton accueil oO
Il ne vois ni le calendrier ni l'option créer un personnage, ni s'inscrire à tel raid du coup...

Un grand merci.

HoShiMayatan
***

Féminin
Messages : 128
Inscrit(e) le : 29/10/2008

http://madeyes.forumclan.com/
HoShiMayatan a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par Ea le Dim 10 Juil 2011 - 20:13

Les noms d'image doivent etre en minuscule sans espace dans le ftp.

@HoShiMayatan a écrit:Autre remarque aussi : un membre connecté au phpraider ne vois absolument rien a part le bouton accueil oO
Il ne vois ni le calendrier ni l'option créer un personnage, ni s'inscrire à tel raid du coup...

Un grand merci.
Là il y a les groupes : http://aion-legion-madeyes.com/phpraid/index.php?option=com_groups

En cliquant sur le nombre de membre d'un groupe on voit qui il y a dedans et on peut rajouter des membres.

Là il y a moyen de changer les permissions de chaque groupe : http://aion-legion-madeyes.com/phpraid/index.php?option=com_permissions

Et là on voit dans quels groupes sont quels membres : http://aion-legion-madeyes.com/phpraid/index.php?option=com_members

Les membres qui ne sont dans aucun groupe n'ont aucune permissions donc ils ne voyent que la page d'accueil.

Cordialement.

Ea
Aidactif
Aidactif

Messages : 23429
Inscrit(e) le : 04/04/2008

Ea a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Un PhP Raiders pour mon Forum

Message par HoShiMayatan le Dim 10 Juil 2011 - 20:27

Ah merciii beaucoup, vraiment ^^
En plus des miniscules j'ai aussi changé le dossier "class" en "classe", les icones ont été correctement affichées après cela !

Merci vraiment pour toute l'aide que vous m'avez apporté, c'était un énorme travail pour moi et ça n'a pa du être facil pour vous Sad

Je vais noter ce topic comme résolu étant donné que toute la partie installation a été faite et que cela fonctionne. Je pense pouvoir me débrouiller pour le reste grace à vos indications.

A nouveau merci.
J'ouvrirai probablement un topic pour la personnalisation (couleur, transparence) du template, vu que je ne m'y connait pas non plus Sad

Bonne soirée à vous.
Amicalement.

HoShiMayatan
***

Féminin
Messages : 128
Inscrit(e) le : 29/10/2008

http://madeyes.forumclan.com/
HoShiMayatan a été remercié(e) par l'auteur de ce sujet.

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum