tableau en codage erreur.

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu tableau en codage erreur.

Message par emc2 le Ven 22 Fév 2013 - 15:12

Etrangement, je viens de coller/copier un tableau d'un forum phpbb2 vers un autre phpbb2

J'ai mis ce script dans le CSS
Code:
/* .systab .tab => les onglet */
.systab .tab {
  padding: 2px 10px;
  margin-right: 1px;
  color: #000;
  background: #b8b885;
  border: 2px solid #000;
  cursor: pointer;
}
/* .systab .tab:hover => les onglets survolés */
.systab .tab:hover {
  background: #b8b885;
  color: #e81e1e;
  border-color: #e81e1e;
}
/* .systab .tab.selected => les onglets sélectionnés */
.systab .tab.selected{
  color: #e81e1e;
  background: #b8b885;
}
/* .systab .contents => les conteneurs des contenus associés aux onglets  */
.systab .contents {
  margin-top: 1px;
  margin-bottom: 1px;
  color: #b8b885;
  background: #b8b885;
  border: 1px solid #b8b885;
  padding: 3px;
}
/* style des onglets si ils sont à gauche ou à droite */
.systab.sfloat .tab,.systab.sfloat .tab {
  display: block;
  margin: 5px;
}
/* flottement des conteneurs si les onglets sont à gauche où à droite */
.systab.sfloat .tabs,.systab.sfloat .contents {
  float: left;
}

Celui-là dans le javascript
Code:
$(function(){
  var d=function(){if($(this).is(".selected")) return;var a=$(this).closest(".systab");a.find(".selected").removeClass("selected").filter(".content")[a.is(".sslide")?"slideUp":a.is(".sfade")?"fadeOut":"hide"](500);$(this).addClass("selected").data("content").addClass("selected").stop(!0,!0)[a.is(".sslide")?"slideDown":a.is(".sfade")?"fadeIn":"show"](500)};$("div.systab").each(function(){var a=$("> div",this).detach(),c=[],b;$(this).html('<div class="'+($(this).is(".sbottom")?"contents":"tabs")+'"></div><div class="'+($(this).is(".sbottom")?
"tabs":"contents")+'"></div>');$(a).each(function(){b=$(this).children(":first");b.is("span")?(c=$(c).add($(b).addClass("tab").data("content",$(this))),$(this).addClass("content").data("tab",b)):$(this).remove()});$("> div.tabs",this).append(c);$("> div.contents",this).append(a);b=$(".content:first,.content.selected",this).last();$(b).addClass("selected").siblings().hide();$(b).data("tab").addClass("selected")}).on("click",".tab",d).filter(".shover").on("mouseenter",".tab",d)
});

Et celui-là dans la description du forum ou je souhaite que le tableau apparaisse.
Code:
<div class="systab s_float">
  <div>
    <span>L'Espadon</span>
    <img src="http://i34.servimg.com/u/f34/16/74/01/20/espado10.jpg" />
  </div>
  <div class="selected">
    <span>Long Sea</span>
    <img src="http://i34.servimg.com/u/f34/16/74/01/20/long_s10.jpg" />
  </div>
  <div>
    <span>La Confiance</span>
    <img src="http://i44.servimg.com/u/f44/16/74/01/20/la_con12.png" />
  </div>
  <div>
    <span>Le Warum</span>
    <img src="http://i34.servimg.com/u/f34/16/74/01/20/warum10.jpg" />
  </div>
  <div>
    <span>La Pinta Bella</span>
    <img src="http://i34.servimg.com/u/f34/16/74/01/20/le_clo10.jpg" />
  </div>
  <div>
    <span>Le Soledad</span>
    <img src="http://uprapide.com/images/invite/soled.jpg" />
  </div>
  <div>
    <span>Elössen</span>
    <img src="http://i44.servimg.com/u/f44/16/74/01/20/elosse10.png" />
  </div>
  <div>
    <span>Le rêveur</span>
    <img src="http://i44.servimg.com/u/f44/16/74/01/20/le_rev11.jpg" />
  </div>
</div>

Et bien dans ce forum, cela fonctionne bien, alors que dans celui-là, les différents tableaux s'affichent les uns en dessous des autres tous en même temps. (De plus, l'onglet des feuilles de jeu ne s'affichent pas non plus sous les avaatrs des membres qui en ont généré une, mais ça c'est secondaire). Et je n'arrive pas à trouver l'origine du problème. Quelqu'un peut-il m'aider ?


Dernière édition par emc2 le Ven 22 Fév 2013 - 19:23, édité 1 fois

emc2
*****

Messages : 518
Inscrit(e) le : 30/09/2011

http://sainte-croix.forumgratuit.org/
emc2 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: tableau en codage erreur.

Message par Ninel le Ven 22 Fév 2013 - 17:33

Votre P.A marche parfaitement sur mon forum de test : http://newtest.topsujet.com/

Pouvez-vous me donner votre CSS en entier pour que je regarde si le problème est de là ?

Ninel
****

Masculin
Messages : 228
Inscrit(e) le : 09/03/2011

Ninel a été remercié(e) par l'auteur de ce sujet.

Résolu Re: tableau en codage erreur.

Message par Scoubifitz le Ven 22 Fév 2013 - 17:50

bonjour,

le javascript est-il activé ?

Activer la gestion des codes Javascript : Oui  Non

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.

Résolu Re: tableau en codage erreur.

Message par emc2 le Ven 22 Fév 2013 - 19:23

autant pour moi ! Je suis une buse. Merci !
je balise en "résolu"

emc2
*****

Messages : 518
Inscrit(e) le : 30/09/2011

http://sainte-croix.forumgratuit.org/
emc2 a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum