Comment retrouve-t-on les erreurs de codages détectés par Markup

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Comment retrouve-t-on les erreurs de codages détectés par Markup

Message par Mikalus le Mer 10 Avr 2013 - 4:10

Bonsoir infomaniac, Razz

En lisant certains appel à l'aide j'ai découvert le site de testage des codes, et combien fut ma surprise vue le peu de choses modifiées de me retrouver avec 9 erreurs et 6 warnings.

Bon, en galérant pas mal, je suis redescendu à 5 erreurs et 0 warning...

Mais comment je fais pour retrouver les passages que l'on m'indique dans ce listing :


Validation Output: 5 Errors

Error there is no attribute X



You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.
Line 12, column 209: there is no attribute "height"

… class="forumline" width="450" height="250" border="0" cellspacing="1" cellpad…

Line 12, column 269: there is no attribute "height"

…pacing="1" cellpadding="0"><tr height="25"><td class="catLeft"><span class="ge…

Error document type does not allow element X here; missing one of Y start-tag



The mentioned element is not allowed to appear in the context in which you've placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you've forgotten to close a previous element.

One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "<a>", "<span>", or "<font>").
Line 12, column 793: document type does not allow element "div" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag

…><span class="genmed"><div align="justify">Bienvenue au duché du Mulheim,<br />

Line 17, column 2270: document type does not allow element "div" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag

…25"><b><div style="text-align:center;">Informations</div></b></th></tr><tr><td…

Line 17, column 2553: document type does not allow element "div" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag

…rimson; text-shadow: 2px 1px 3px grey"><div style="font-size: 14px"><i>_ Le st…


Car à quoi corresponde le "Line 17, columm 2553" ????????????????? pale

J'en suis arrivé à supposer que définir la hauteur d'une ligne dans un tableau, on ne peut pas utiliser "height", mais on fait comment alors ??? pale reflexion aidez moi

Un ch'tit indice !... Very Happy


Dernière édition par Mikalus8764 le Dim 14 Avr 2013 - 6:25, édité 1 fois

Mikalus
**

Masculin
Messages : 50
Inscrit(e) le : 04/01/2013

http://les-temps-oublies.forumgratuit.org/
Mikalus a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment retrouve-t-on les erreurs de codages détectés par Markup

Message par Mikalus le Jeu 11 Avr 2013 - 14:57

Re-bonjour,

Oui, je sais... je peux visiter tous les template, pages en HTML mis sur l'accueil, dans les catégories/forums...etc...

Mais je ne peux croire qu'un petit génie de l'info n'en ai pas eut ras le bol de tous se taper et n'a pas fini par bricoler un 'tit logiciel pour retrouver des morceaux de codes dans toutes les lignes ???...

Allez, soyez sympa... je jure de garder le secret !... salut

Mikalus
**

Masculin
Messages : 50
Inscrit(e) le : 04/01/2013

http://les-temps-oublies.forumgratuit.org/
Mikalus a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Comment retrouve-t-on les erreurs de codages détectés par Markup

Message par Arlem le Jeu 11 Avr 2013 - 16:46

Bonjour Smile

Si vous êtes sous Windows :
Ctrl + U puis Ctrl + F sur l'index de votre forum.

Arlem
+ Hyperactif +

Messages : 2550
Inscrit(e) le : 30/06/2009

Arlem a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Comment retrouve-t-on les erreurs de codages détectés par Markup

Message par Mikalus le Dim 14 Avr 2013 - 5:25

Window 8, pour mon malheur !...

Je vais essayer le truc... je reviens vous donner des nouvelles ... Wink

EDIT

Alors certes, toute la page apparait, mais mon problème demeure car il s'agit des codes générés par les fonctionnalités de la PA d'administration du forum.
Car en fait, la partie est celle que créer le forum à partir du titre du forum donné dans ;
PA > Général > Forum-Configuration > Nom du site

Donc là, j'ose pas trop trifouiller... De plus, pour les autres, il m'affiche "ligne non trouvée"...
Je ne l'ai pourtant pas inventé !...

J'en ai retrouvé trois provenant de la toolbar de Geovisite (elles ne figurait pas dans le listing ci-dessus, j'ai installé cette barre après...), mais là encore il mentionne de ne pas modifié le code...
Alors je pourrais me débarrasser de cette toolbar, les stats c'est pas mon truc...
Mais il y a une fonctionnalité que j'apprécie pas mal, vu que mon forum est quasiment tout le temps en construction pour le moment, c'est le seul moyen pour les internautes de me contacter pour avoir des infos par le biais de la MP-Geovisite, qui fonctionne même avec le forum en mode construction... Sad

Enfin, j'ai eu ma réponse pour retrouvé les codes, le reste c'est le fonctionnement de forumactif, je suppose que ce n'est pas çà qui ralentit le chargement de mes pages.... scratch
Je ne sais plus où chercher un moyen d'accélérer l'affichage !!... d'autant que le poids des images reste correcte...

De toute façon, merci à toi Arlem, thumright

Mikalus
**

Masculin
Messages : 50
Inscrit(e) le : 04/01/2013

http://les-temps-oublies.forumgratuit.org/
Mikalus a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum