Problème de personnalisation de liens de sous-forums

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème de personnalisation de liens de sous-forums

Message par Iezael le Jeu 28 Aoû 2014 - 11:45

Bonjour à tous !

Me voilà avec un nouveau soucis.
J'ai suivi un des tutos disponibles concernant la personnalisation des liens de sous-forums (ceux qu'on trouve juste en dessous des descriptions). Je n'ai eu aucun soucis avec le template, ni le css, mais il y a quand même un truc qui cloche :

Une partie de ce que j'ai mis dans le css ne s'applique pas sur mes liens. Par exemple, j'ai mis l'attribut small-caps qui fonctionne parfaitement dessus, mais, j'ai aussi mis une autre couleur, qui elle n'apparait pas.
(le lien du forum est ici)

Le template index_box
Spoiler:
Code:
        <table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
        <tr>
          <td valign="bottom">
              <!-- BEGIN switch_user_logged_in -->
              <span class="gensmall">{LAST_VISIT_DATE}<br/>
              {CURRENT_TIME}<br/>
              </span>
              <!-- END switch_user_logged_in -->
              <div class="nav">
                <a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}
              </div>
          </td>
          <td class="gensmall" align="right" valign="bottom">
              <!-- BEGIN switch_user_logged_in -->
              <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br/>
              <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br/>
              <!-- END switch_user_logged_in -->
              <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
          </td>
        </tr>
        </table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumline" width="100%" border="0" cellspacing="1" cellpadding="0">
  <tr>
    <th colspan="{catrow.tablehead.INC_SPAN}" nowrap="nowrap" width="100%" class="secondarytitle">{catrow.tablehead.L_FORUM} </th>
      <!--th nowrap="nowrap" width="50">{L_TOPICS}</th>
      <th nowrap="nowrap" width="50">{L_POSTS}</th>
      <th nowrap="nowrap" width="150"><div style="width:150px;">{L_LASTPOST}</div></th-->
  </tr>
  <!-- END tablehead -->
        <!-- BEGIN cathead -->
        <tr>
          <!-- BEGIN inc -->
          <td class="{catrow.cathead.inc.INC_CLASS}" width="46">
              <img src="{SPACER}" height="0" width="46"/>
          </td>
          <!-- END inc -->
          <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
              <h{catrow.cathead.level} class="hierarchy">
              <span class="cattitle">
              <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
              </span>
              </h{catrow.cathead.level}>
          </td>
          <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right">
              &nbsp;
          </td>
        </tr>
        <!-- END cathead -->
        <!-- BEGIN forumrow -->
        <tr>
          <!-- BEGIN inc -->
          <td class="{catrow.forumrow.inc.INC_CLASS}" width="46">
              <img src="{SPACER}" height="0" width="46" alt="."/>
          </td>
          <!-- END inc -->
          <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
              <h{catrow.forumrow.level} class="hierarchy">
              <span class="forumlink">
              <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}"><span class="titreforum">{catrow.forumrow.FORUM_NAME}</span></a></a><br/>
              </span>
              </h>{catrow.forumrow.level}
              <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
              <span class="gensmall">
              <span class="gensmall">
        <!-- BEGIN switch_moderators_links -->
        {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
        <!-- END switch_moderators_links -->
</span>
        <div class="sousforums">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</div>
          </td>
          <td class="row3 over" align="center" valign="middle" height="50">
              <!-- BEGIN avatar -->
              <div style="width: 200px;">
              </div>
              <span class="lastpost-avatar">{catrow.forumrow.avatar.LAST_POST_AVATAR}</span>
              <!-- END avatar -->
              <div class="gensmall sujets_messages">
                {catrow.forumrow.POSTS} messages & {catrow.forumrow.TOPICS} sujets
            </div>        <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /><br />
<span class="gensmall">{catrow.forumrow.LAST_POST}</span>            <!--td class="row3 over" align="center" valign="middle" height="50">
  <span class="gensmall">{catrow.forumrow.LAST_POST}</span>
</td-->
          </td>
        </tr>
        <!-- END forumrow -->
        <!-- BEGIN catfoot -->
        <tr>
          <!-- BEGIN inc -->
          <td class="{catrow.catfoot.inc.INC_CLASS}" width="46">
              <img src="{SPACER}" height="0" width="46"/>
          </td>
          <!-- END inc -->
          <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1">
              <img src="{SPACER}" alt="" height="1" width="1"/>
          </td>
        </tr>
        <!-- END catfoot -->
        <!-- BEGIN tablefoot -->
        </table>
        <img src="{SPACER}" alt="" height="5" width="1"/>
        <!-- END tablefoot -->
        <!-- END catrow -->

Et la partie CSS concernée
Spoiler:
Code:
.sousforums {
    font-family: Trebuchet, sans-serif;
    text-align: center;
  font-size: 15px;
  margin-top: -18px;
  color:#33633b;
          -webkit-transition:All 1s ease;
  -moz-transition:All 1s ease;
  -o-transition:All 1s ease;
    font-variant: small-caps;
}

.sousforums:hover {
    font-family: Trebuchet, sans-serif;
    text-align: center;
  font-size: 15px;
  margin-top: -18px;
  color:#eaedea;
          -webkit-transition:All 1s ease;
  -moz-transition:All 1s ease;
  -o-transition:All 1s ease;
    font-variant: small-caps;
}

Aussi, comme vous pouvez le voir sur le forum, la transition n'est pas pris en compte, ni la taille de la police, ni tout ce qui est mis dans la partie hover.

Je coince un peu du coup x3
Merci pour votre aide !


Dernière édition par Iezael le Jeu 28 Aoû 2014 - 12:17, édité 1 fois

Iezael
Nouveau membre

Messages : 11
Inscrit(e) le : 25/08/2014

http://fear-the-spartans.forumactif.ord
Iezael a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de personnalisation de liens de sous-forums

Message par MlleAlys le Jeu 28 Aoû 2014 - 12:05

Bonjour,
visez directement les liens des sous forums dans votre css ^^ :
Code:

.sousforums {
  margin-top: -18px;
  text-align: center;
}

.sousforums a {
  font-family: Trebuchet, sans-serif;
  font-size: 15px;
  color:#33633b;
  -webkit-transition:All 1s ease;
  -moz-transition:All 1s ease;
  -o-transition:All 1s ease;
  transition:All 1s ease;
  font-variant: small-caps;
}
 
.sousforums a:hover {
  color:#eaedea;
}

(inutile de remettre ce qui ne change pas au passage de la souris, préciser juste ce qui est modifié Wink )


Dernière édition par MlleAlys le Jeu 28 Aoû 2014 - 12:25, édité 1 fois

MlleAlys
+ Hyperactif +

Messages : 4340
Inscrit(e) le : 12/09/2012

MlleAlys a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de personnalisation de liens de sous-forums

Message par Iezael le Jeu 28 Aoû 2014 - 12:17

aaaaah mais oui x_x Qu'est-ce que je suis bête parfois xD

Merci beaucoup pour votre aide et la rapidité de votre réponse !

Bonne journée!

Iezael
Nouveau membre

Messages : 11
Inscrit(e) le : 25/08/2014

http://fear-the-spartans.forumactif.ord
Iezael a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum