Problème de Liste de sous-catégorie

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème de Liste de sous-catégorie

Message par Vhawa le Mar 9 Déc 2014 - 8:56

Détails techniques


Version du forum : phpBB2
Poste occupé : Administrateur
Navigateur(s) concerné(s) : Google Chrome
Capture d'écran du problème :
Voir l'image:

Personnes concernées par le problème : Tous les utilisateurs
Problème apparu depuis : Hier quand j'ai mis en place le code
Lien du forum : http://confidence.forumactif.org/

Description du problème

Bonjour !

Je viens vous voir parce que j'ai un petit problème concernant l'alignement des sous catégorie, au lieux d'être verticale, donc les une en dessous des autres, certaines se mettent a la suite séparée par des virgules.
J'aimerais qu'elle soit toute en colonne et pas en ligne.

Pour faire cette mise en page j'ai suivit ces consignes : http://forum.forumactif.com/t331410-mise-en-forme-des-categories

Merci d'avance et bonne journée !

Vhawa
Nouveau membre

Messages : 4
Inscrit(e) le : 08/12/2014

http://confidence.forumactif.org/
Vhawa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de Liste de sous-catégorie

Message par Daewyn le Mar 9 Déc 2014 - 12:44

Bonjour, pourrais-je voir votre Template index_box s'il vous plait ? Il semble en effet que le problème ne s'applique pas à tout les liens ce qui est assez étrange. Egalement, avez-vous des scripts qui pourraient rentrer en conflit ?

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

http://dae-test-fantasia.forumactif.org/
Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de Liste de sous-catégorie

Message par Vhawa le Mar 9 Déc 2014 - 23:21

Bonsoir.

Voilà mon template index_box:
Code:
<table width="100%" border="0" cellspacing="1" cellpadding="0" align="center">
   <tr>
      <td valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <span class="gensmall">{LAST_VISIT_DATE}<br />
         {CURRENT_TIME}<br />
         </span>
         <!-- END switch_user_logged_in -->
         <div class="nav"><a class="nav" href="{U_INDEX}">{L_INDEX}</a>{NAV_CAT_DESC}</div>
      </td>
      <td class="gensmall" align="right" valign="bottom">
         <!-- BEGIN switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_NEW}">{L_SEARCH_NEW}</a><br />
         <a class="gensmall" href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a><br />
         <!-- END switch_user_logged_in -->
         <a class="gensmall" href="{U_SEARCH_UNANSWERED}">{L_SEARCH_UNANSWERED}</a>
      </td>
   </tr>
</table>
<!-- BEGIN catrow --><!-- BEGIN tablehead --><table class="forumlineac" width="100%" border="0" cellspacing="0" cellpadding="0">
   <tr>
    <td colspan="3" nowrap="nowrap" width="100%" class="fondhaut"> {catrow.tablehead.L_FORUM} </td>
  </tr>
   <!-- END tablehead -->
   <!-- BEGIN cathead -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.cathead.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="{catrow.cathead.CLASS_CAT}" colspan="{catrow.cathead.INC_SPAN}" width="100%">
         <h{catrow.cathead.LEVEL} class="hierarchy">
            <span class="cattitle">
               <a class="cattitle" title="{catrow.cathead.CAT_DESC}" href="{catrow.cathead.U_VIEWCAT}">{catrow.cathead.CAT_TITLE}</a>
            </span>
         </h{catrow.cathead.LEVEL}>
      </td>
      <td class="{catrow.cathead.CLASS_ROWPIC}" colspan="3" align="right">&nbsp;</td>
   </tr>
   <!-- END cathead -->
   <!-- BEGIN forumrow -->
  <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.forumrow.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" alt="." /></td>
      <!-- END inc -->
      <td class="row1 over" width="5">
                  <div class="liens" id="subforums">
                                  {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}<script type="text/javascript">jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'<br />')).removeAttr('id');</script></div>
            </td>
      <td class="row1 over" colspan="{catrow.forumrow.INC_SPAN}" valign="top" width="100%" height="50">
                  <div class="centrefo"><table width="100%"><tr><td widht="70%">
                   
                    <h{catrow.forumrow.LEVEL} class="hierarchy">
            <span class="forumlink">
              <a class="forumlink" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />
            </span>
                    </h{catrow.forumrow.LEVEL}></td>
                   
                    <div align="right"> <span class="gensmall">{catrow.forumrow.TOPICS} sujets | {catrow.forumrow.POSTS} messages</span></div>
                   
                    <td width="30%"><div class="stats">
                      </div></td>
                    </tr>
                    <tr>
                      <td colspan="2">
                          <span class="genmed">{catrow.forumrow.FORUM_DESC}</span>
        <span class="gensmall">
            <!-- BEGIN switch_moderators_links -->
            {catrow.forumrow.switch_moderators_links.L_MODERATOR}{catrow.forumrow.switch_moderators_links.MODERATORS}
            <!-- END switch_moderators_links -->
                    </span>
                      </td></tr></table></div></td>
   
      <td class="row3 over" align="center" valign="middle" height="50"><div class="lastm">
                  <img title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />
                  <br /><span class="gensmall">{catrow.forumrow.LAST_POST}</span>
        </div>
      </td>
  </tr>
  <!-- END forumrow -->
   <!-- BEGIN catfoot -->
   <tr>
      <!-- BEGIN inc -->
      <td class="{catrow.catfoot.inc.INC_CLASS}" width="46"><img src="{SPACER}" height="0" width="46" /></td>
      <!-- END inc -->
      <td class="spaceRow" colspan="{catrow.catfoot.INC_SPAN}" height="1"><img src="{SPACER}" alt="" height="1" width="1" /></td>
   </tr>
   <!-- END catfoot -->
   <!-- BEGIN tablefoot -->
<tr><td height="30" colspan="3"><div class="fondbas"></div></td></tr>
</table><br /><img src="{SPACER}" alt="" height="5" width="1" /><!-- END tablefoot --><!-- END catrow -->

J'ai deux javaScript, un pour les onglets de ma page d'accueil et un pour ceux de mon QEEL, en avez vous également besoin ?

Vhawa
Nouveau membre

Messages : 4
Inscrit(e) le : 08/12/2014

http://confidence.forumactif.org/
Vhawa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de Liste de sous-catégorie

Message par Daewyn le Mar 9 Déc 2014 - 23:52

Non ça ira, je ne pense pas que ça joue pour ton problème ^^ Alors déjà je n'ai rien remarqué d'anormal dans ton Template, mis à part ce bout là :

Code:
<div align="right"> <span class="gensmall">{catrow.forumrow.TOPICS} sujets | {catrow.forumrow.POSTS} messages</span></div>
                   
                    <td width="30%"><div class="stats">
                    </div></td>

La ligne des sujets / messages est mise entre deux colonnes d'un même tableau, alors qu'elle ne devrait pas. Par ailleurs la colonne d'après (justement) est vide, donc je suppose que ça là qu'elle aurait du être à la base ? Peut être rectifier ça changera quelque chose (mais je ne peux pas garantir).

Au passage tu as une alternative que tu peux tester expliquée ici si jamais : http://forum.forumactif.com/t371637-personnaliser-l-affichage-des-sous-forums

Daewyn
***

Féminin
Messages : 182
Inscrit(e) le : 23/06/2011

http://dae-test-fantasia.forumactif.org/
Daewyn a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de Liste de sous-catégorie

Message par Neptunia le Mer 10 Déc 2014 - 1:36

Bonjour ^^


Le problème surgit à un endroit précis de l'index qui n'est ni le début ni la fin, mais se trouve en plein milieu. Cette configuration exclut d'emblée une origine dans le template. Le template fonctionne en boucle et le souci serait systématique de haut en bas.

Ensuite le problème apparaît à la catégorie Les zones saines (vérifiable facilement en déplaçant la catégorie en bas de page -> En déplaçant la section, on déplace le problème et on le minimise en le plaçant au plus bas)

Le problème est donc à rechercher dans les noms ou descriptions de la catégorie ou de l'un de ses composants.

Le sous-forum L'Europe me semble le candidat idéal vu l'originalité de son nom.

Neptunia
+ Hyperactif +

Féminin
Messages : 10392
Inscrit(e) le : 08/08/2010

http://www.planet-series.com/
Neptunia a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de Liste de sous-catégorie

Message par Vhawa le Mer 10 Déc 2014 - 9:06

Bonjour ^^

J'ai modifier le template, à défaut d'avoir réparer mon problème ça m'as fait progresser un peu en code.

Pour le nom de la sous-catégorie, même si ça me paraissait étrange (je ne vois pas en quoi « L’Europe » est plus étrange que « L’Univers », mais soit) j’ai changé les noms avec ceux des sous-catégories qui ne présentait pas de problème pour se mettre en colonne, ça n’a rien changé. J’ai également essayé de descendre la catégorie « zone saine » et en effet ça a fait descendre le problème avec elle.
Du coup j’ai essayé de la supprimer pour voir si le problème s’en allait avec elle, mais non.

Si il n’y a pas de solution à ce problème tant-pis je laisserais tel-que, c’est moins esthétique certes, mais les sous-catégories sont toujours là au moins.

Merci pour votre aide.

Vhawa
Nouveau membre

Messages : 4
Inscrit(e) le : 08/12/2014

http://confidence.forumactif.org/
Vhawa a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de Liste de sous-catégorie

Message par Henrykiki le Mer 10 Déc 2014 - 11:17

Ce que je remarque, moi, c'est que tes virgules se mettent sur les seuls blocs qui contiennent l'ID "subforums"...



Et je pense qu'il y a quelque chose dans ton code qui parle/fait quelque chose vis à vis des "subforums"... à creuser... scratch


Dernière édition par Henrykiki le Mer 10 Déc 2014 - 11:18, édité 1 fois

Henrykiki
**

Masculin
Messages : 95
Inscrit(e) le : 26/11/2014

http://scoubalou.forumsactifs.com
Henrykiki a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Problème de Liste de sous-catégorie

Message par Vhawa le Mer 10 Déc 2014 - 13:03

Même si je suis une quasi bille en code, j'ai essayer de comprendre et j'ai chercher une autre mise en forme de catégorie qui faisait le même effet de liste de sous-catégorie pour comparer les deux codes.

J'ai réussi a résoudre mon problème en remplaçant :
Code:
<div class="liens" id="subforums">
                                  {catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}<script type="text/javascript">jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'<br />')).removeAttr('id');</script></div>
Provenant du code originellement utilisé, par :
Code:
<div class="liens"><span id="subforums">{catrow.forumrow.L_LINKS}{catrow.forumrow.LINKS}</span>
    <script type="text/javascript">
      jQuery('#subforums').html(jQuery('#subforums').html().replace(/, /g,'<br />')).removeAttr('id');
    </script></div>
Qui lui provient de l'autre code (que j'avais tester avant pour voir si le problème se répétait).

Je ne sais pas en quoi ça à fait bien se réaligner toutes les sous-catégories, mais ça peut peut être vous aider à comprendre.

Mon problème est résolu.
Je vous remercie pour le temps que vous y avez passé ^^

Vhawa
Nouveau membre

Messages : 4
Inscrit(e) le : 08/12/2014

http://confidence.forumactif.org/
Vhawa a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum