Balise "code" Qui ne fonctionne pas

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Balise "code" Qui ne fonctionne pas

Message par Mr.Paste le Ven 17 Avr 2015 - 18:55

Salut Smile
J'ai un petit problème tout simple c'est que dans mes pages html la balise <code> ne fonctionne pas alors que j'ai fais des tests qui fonctionnait très bien avant d'être sur FA :3

( J'ai bien pensé à utiliser un textarea mais je préférerais la balise code si c'est possible )

Merci Mr. Green


Dernière édition par Mr.Paste le Mar 21 Avr 2015 - 15:03, édité 1 fois

Mr.Paste
***

Messages : 154
Inscrit(e) le : 16/08/2014

Mr.Paste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise "code" Qui ne fonctionne pas

Message par Mr.Paste le Dim 19 Avr 2015 - 10:21

Up :p

Mr.Paste
***

Messages : 154
Inscrit(e) le : 16/08/2014

Mr.Paste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise "code" Qui ne fonctionne pas

Message par demeter1 le Dim 19 Avr 2015 - 10:24

Bonjour Mr.Paste,
Strange que cette balise ne fonctionne pas. Je viens de faire un tableau sur une page html contenant cette balise et je n'ai pas rencontré de soucis de cet ordre.

Vous devriez fournir le lien de votre page ou du moins le contenu de celle ci entre les balises code pour voir ce qui cloche.

demeter1
+ Hyperactif +

Masculin
Messages : 8232
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise "code" Qui ne fonctionne pas

Message par Mr.Paste le Dim 19 Avr 2015 - 10:31

Par exemple :
Code:
<!DOCTYPE html>
<html>
<body>
<pre>
  <code>
<button type="button" onclick="alert('Hello world!')">Click Me!</button>
  </code>
  </pre>
</body>
</html>
Quand je fais ça le rendu sur la page html est un bouton "Press" :/

Merci Smile

Edit lien : http://wired-bear.forumactif.org/h26-code-test


Dernière édition par Mr.Paste le Dim 19 Avr 2015 - 10:43, édité 1 fois

Mr.Paste
***

Messages : 154
Inscrit(e) le : 16/08/2014

Mr.Paste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise "code" Qui ne fonctionne pas

Message par demeter1 le Dim 19 Avr 2015 - 10:41

Rien de plus normal, il s'agit d'un bouton d'alerte en js.

Si vous voulez utiliser la balise code en html , il faut utiliser
Code:
<code>le contenu</code>

demeter1
+ Hyperactif +

Masculin
Messages : 8232
Inscrit(e) le : 23/01/2009

http://altitudetropicale.forums-actifs.com/index.forum
demeter1 a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise "code" Qui ne fonctionne pas

Message par Mr.Paste le Dim 19 Avr 2015 - 10:44

Excusez moi, j'ai réussi à oublier la balise code dans un post parlant de la balise code ^^
( J'ai édité )

Mr.Paste
***

Messages : 154
Inscrit(e) le : 16/08/2014

Mr.Paste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise "code" Qui ne fonctionne pas

Message par Mr.Paste le Lun 20 Avr 2015 - 17:00

Rappel

Code:
<!DOCTYPE html>
<html>
<body>
<pre>
  <code>
<button type="button" onclick="alert('Hello world!')">Click Me!</button>
  </code>
  </pre>
</body>
</html>
Quand je fais ça le rendu sur la page html est un bouton "Click Me!" et non "<button type="button" onclick="alert('Hello world!')">Click Me!</button>" qui serait le rendu normal sur une page HTML :p

Merci Smile
-
Lien test : http://wired-bear.forumactif.org/h26-code-test

Mr.Paste
***

Messages : 154
Inscrit(e) le : 16/08/2014

Mr.Paste a été remercié(e) par l'auteur de ce sujet.

Résolu Re: Balise "code" Qui ne fonctionne pas

Message par Scoubifitz le Lun 20 Avr 2015 - 19:51

Bonsoir,

la balise code fait exactement ce qu'on attend d'elle :

https://developer.mozilla.org/fr/docs/Web/HTML/Element/code

on peut mettre des balises à l'intérieur de la balise code , qui fonctionne normalement :

https://developer.mozilla.org/fr/docs/Web/HTML/Cat%C3%A9gorie_de_contenu#Contenu_phras.C3.A9

Si on veut afficher < , on doit écrire " & l t ; " et pour fermer > , " & g t ; " ...

http://www.startyourdev.com/html/tag-html-balise-code

S'il y a beaucoup de < > , on peut utiliser un script , comme pour les forums :

exemple :

Code:
<!DOCTYPE html>
<html>
<head>
<script src="//code.jquery.com/jquery-1.9.1.min.js"></script>
  <meta charset="utf-8">
  <title>test balises code</title>
<style type="text/css">
code{
  display:inline-block;
  background:#ccccff;
  padding:3px 5px;
  font:12px Courier New;
  white-space:pre;
}
</style>
</head>
<body>
  <p>Ceci est une mise en forme à l'aide de balises <code>code</code> :</p>
<code><code>
<div style='line-height: 10px;'>
<span style='font-size: 29px; text-transform: uppercase;'>  Mr.Paste  </span>
<span style='font-size: 29px; font-family: Monotype Corsiva;'> Ma Présentation </span>
</div>
</code>
</code>

<script type="text/javascript">
$(document).ready(function(){
$("code").each(function(){
 var a = $(this),b = a.html();
 b = b.replace(/</g, '&lt;').replace(/>/g, '&gt;');
 a.html(b);
});
});
</script>
</body>
</html>

... même si c'est plus simple de prendre un textarea pour ça ...

Scoubifitz
+ Hyperactif +

Masculin
Messages : 3539
Inscrit(e) le : 18/03/2008

http://scoubidous.superforum.fr/
Scoubifitz a été remercié(e) par l'auteur de ce sujet.
  • 0

Résolu Re: Balise "code" Qui ne fonctionne pas

Message par Mr.Paste le Mar 21 Avr 2015 - 15:03

Merci Very Happy Je suis nul... :3

Mr.Paste
***

Messages : 154
Inscrit(e) le : 16/08/2014

Mr.Paste a été remercié(e) par l'auteur de ce sujet.

Voir le sujet précédent Voir le sujet suivant Revenir en haut


Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum